Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

SSH: Troz änderung in conf ändert sich nichts

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Antworten
NewLin
Member
Member
Beiträge: 52
Registriert: 26. Mär 2004, 19:38
Kontaktdaten:

SSH: Troz änderung in conf ändert sich nichts

Beitrag von NewLin » 8. Aug 2006, 19:26

nabend zusammen
ich hoffe mal das ihr mir helfen könnt ..
aslo mein prob is wen ich

Code: Alles auswählen

3) Aenderung der sshd Konfiguration so dass keys akzeptiert benutzt werden 

a) Im putty Fenster mit C:\Program Files\putty>pscp root@obelix:/etc/ssh/sshd_config sshd_config die sshd Konfigurationsdatei downloaden. 
b) Editieren der Datei mit einem Windows Editor so dass die folgenden Parameter wie folgt gesetzt sind: Code:
PubkeyAuthentication yes 
   RSAAuthentication no 
   PermitRootLogin yes


c) Im putty Fenster mit C:\Program Files\putty>pscp sshd_config root@obelix:/etc/ssh/sshd_config die sshd Konfigurationsdatei uploaden. 
d) Im Server Befehlsfenster welches in 2.a geoffnet wurde rcsshd restart eingeben.

anwende müste ja rein theroteisch mit dem juser ohne pw nur mit dem key einloggen können..

es lief uach bis ich den server neu aufgesetzt habe..
jetz kann ich mich mit beiden anmelden.. also key und pw,

hir mal mien config

Code: Alles auswählen

#	$OpenBSD: sshd_config,v 1.69 2004/05/23 23:59:53 dtucker Exp $

# This is the sshd server system-wide configuration file.  See
# sshd_config(5) for more information.

# This sshd was compiled with PATH=/usr/bin:/bin:/usr/sbin:/sbin

# The strategy used for options in the default sshd_config shipped with
# OpenSSH is to specify options with their default value where
# possible, but leave them commented.  Uncommented options change a
# default value.

#Port 22
#Protocol 2,1
#ListenAddress 0.0.0.0
#ListenAddress ::

# HostKey for protocol version 1

#HostKey /etc/ssh/ssh_host_key
# HostKeys for protocol version 2
#HostKey /etc/ssh/ssh_host_rsa_key
#HostKey /etc/ssh/ssh_host_dsa_key

# Lifetime and size of ephemeral version 1 server key
#KeyRegenerationInterval 1h
#ServerKeyBits 768

# Logging
#obsoletes QuietMode and FascistLogging
#SyslogFacility AUTH
#LogLevel INFO

# Authentication:

#LoginGraceTime 2m
PermitRootLogin yes
#StrictModes yes
#MaxAuthTries 6

RSAAuthentication no 
PubkeyAuthentication yes 
AuthorizedKeysFile	.ssh/authorized_keys

# For this to work you will also need host keys in /etc/ssh/ssh_known_hosts
#RhostsRSAAuthentication no
# similar for protocol version 2
#HostbasedAuthentication no
# Change to yes if you don't trust ~/.ssh/known_hosts for
# RhostsRSAAuthentication and HostbasedAuthentication
#IgnoreUserKnownHosts no
# Don't read the user's ~/.rhosts and ~/.shosts files
#IgnoreRhosts yes

# To disable tunneled clear text passwords, change to no here!
PasswordAuthentication no 
#PermitEmptyPasswords no

# Change to no to disable s/key passwords
#ChallengeResponseAuthentication yes

# Kerberos options
#KerberosAuthentication no
#KerberosOrLocalPasswd yes
#KerberosTicketCleanup yes
#KerberosGetAFSToken no

# GSSAPI options
#GSSAPIAuthentication no
#GSSAPICleanupCredentials yes

# Set this to 'yes' to enable support for the deprecated 'gssapi' authentication
# mechanism to OpenSSH 3.8p1. The newer 'gssapi-with-mic' mechanism is included
# in this release. The use of 'gssapi' is deprecated due to the presence of 
# potential man-in-the-middle attacks, which 'gssapi-with-mic' is not susceptible to.
#GSSAPIEnableMITMAttack no
 

# Set this to 'yes' to enable PAM authentication, account processing, 
# and session processing. If this is enabled, PAM authentication will 
# be allowed through the ChallengeResponseAuthentication mechanism. 
# Depending on your PAM configuration, this may bypass the setting of 
# PasswordAuthentication, PermitEmptyPasswords, and 
# "PermitRootLogin without-password". If you just want the PAM account and 
# session checks to run without PAM authentication, then enable this but set 
# ChallengeResponseAuthentication=no
UsePAM yes

#AllowTcpForwarding yes
#GatewayPorts no
X11Forwarding no
#X11DisplayOffset 10
#X11UseLocalhost yes
#PrintMotd yes
#PrintLastLog yes
#TCPKeepAlive yes
#UseLogin no
#UsePrivilegeSeparation yes
#PermitUserEnvironment no
#Compression yes
#ClientAliveInterval 0
#ClientAliveCountMax 3
#UseDNS yes
#PidFile /var/run/sshd.pid
#MaxStartups 10
#AllowUsers Wurstbrot

# no default banner path
#Banner /some/path

# override default of no subsystems
Subsystem	sftp	/usr/lib/ssh/sftp-server

# This enables accepting locale enviroment variables LC_* LANG, see sshd_config(5).
AcceptEnv LANG LC_CTYPE LC_NUMERIC LC_TIME LC_COLLATE LC_MONETARY LC_MESSAGES 
AcceptEnv LC_PAPER LC_NAME LC_ADDRESS LC_TELEPHONE LC_MEASUREMENT 
AcceptEnv LC_IDENTIFICATION LC_ALL

und was ich ja möchte ist ja nur der key..
bitte um hilfe
Die vergangenheit läst sich nicht ändern!
Ändere die Zukunft

Werbung:
Benutzeravatar
panamajo
Guru
Guru
Beiträge: 2587
Registriert: 12. Feb 2005, 22:45

Beitrag von panamajo » 8. Aug 2006, 19:36

sshd muss (wie jeder andere Service auch) mitbekommen dass die config neu eingelesen werden soll.
Dies geschieht mit

Code: Alles auswählen

# /etc/init.d/sshd reload

NewLin
Member
Member
Beiträge: 52
Registriert: 26. Mär 2004, 19:38
Kontaktdaten:

Beitrag von NewLin » 8. Aug 2006, 19:47

ja das ist mir auch shcon klar .. das mach ich aj .. er restartet sie auch ohne zu murren nur irgendwie aktzeptiert ers nich..

p.s.
da ist noch was .. wenn ich "UserAllow Wurstbrot" aktiviere kann ich mich mit anderen juser nicht mer einlogen.. was auch so soll.. aber dafür kann ich mich wieder per password mit dem acc einlogen was eigentlich nicht sien sol..
Die vergangenheit läst sich nicht ändern!
Ändere die Zukunft

b3ll3roph0n
Moderator
Moderator
Beiträge: 3669
Registriert: 4. Dez 2005, 13:17
Kontaktdaten:

Beitrag von b3ll3roph0n » 8. Aug 2006, 20:12

Code: Alles auswählen

UsePAM no
Gruß b3ll3roph0n
--
Denken hilft!

Ich beantworte keine Support-Anfragen per PN.
Für alle meine Beiträge gelten, außer bei Zitaten, die Creative Commons.

NewLin
Member
Member
Beiträge: 52
Registriert: 26. Mär 2004, 19:38
Kontaktdaten:

Beitrag von NewLin » 8. Aug 2006, 20:18

achjo stimmt.. grml habsch voll verjessen.. thx :) das kommt wenn man zu eilig is :D
Die vergangenheit läst sich nicht ändern!
Ändere die Zukunft

Antworten