Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

Probleme mit VMware Workstation Installation unter OpenSuse

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Antworten
Christian1983
Newbie
Newbie
Beiträge: 39
Registriert: 5. Dez 2005, 15:29
Wohnort: Bremen
Kontaktdaten:

Probleme mit VMware Workstation Installation unter OpenSuse

Beitrag von Christian1983 » 26. Jul 2006, 20:19

Hallo,

ich habe versucht VMware Workstation 5.5.1.19175 unter OpenSuse 10.1 zu installieren. make, gcc und alles ist installiert. Es tritt folgender Fehler bei der Programmausführung von ./vmware-config.pl auf:

linux-yyeg:/usr/bin # ./vmware-config.pl
Making sure services for VMware Workstation are stopped.

Stopping VMware services:
Virtual machine monitor done

Configuring fallback GTK+ 2.4 libraries.

In which directory do you want to install the mime type icons?
[/usr/share/icons]

What directory contains your desktop menu entry files? These files have a
.desktop file extension. [/usr/share/applications]

In which directory do you want to install the application's icon?
[/usr/share/pixmaps]

Trying to find a suitable vmmon module for your running kernel.


None of the pre-built vmmon modules for VMware Workstation is suitable for your
running kernel. Do you want this program to try to build the vmmon module for
your system (you need to have a C compiler installed on your system)? [yes]
Using compiler "/usr/bin/gcc". Use environment variable CC to override.

What is the location of the directory of C header files that match your running
kernel? [/lib/modules/2.6.16.21-0.13-default/build/include]

Extracting the sources of the vmmon module.

Building the vmmon module.

Using 2.6.x kernel build system.
make: Entering directory `/tmp/vmware-config3/vmmon-only'
make -C /lib/modules/2.6.16.21-0.13-default/build/include/.. SUBDIRS=$PWD SRCROOT=$PWD/. modules
make[1]: Entering directory `/usr/src/linux-2.6.16.21-0.13-obj/i386/default'
make -C ../../../linux-2.6.16.21-0.13 O=../linux-2.6.16.21-0.13-obj/i386/default modules
CC [M] /tmp/vmware-config3/vmmon-only/linux/driver.o
In file included from /tmp/vmware-config3/vmmon-only/linux/driver.h:20,
from /tmp/vmware-config3/vmmon-only/linux/driver.c:49:
/tmp/vmware-config3/vmmon-only/./include/compat_wait.h:37:5: warning: "VMW_HAVE_EPOLL" is not defined
/tmp/vmware-config3/vmmon-only/./include/compat_wait.h:43:5: warning: "VMW_HAVE_EPOLL" is not defined
In file included from /tmp/vmware-config3/vmmon-only/linux/driver.h:20,
from /tmp/vmware-config3/vmmon-only/linux/driver.c:49:
/tmp/vmware-config3/vmmon-only/./include/compat_wait.h:60: error: conflicting types for ‘poll_initwait’
/usr/src/linux-2.6.16.21-0.13/include/linux/poll.h:45: error: previous declaration of ‘poll_initwait’ was here
/tmp/vmware-config3/vmmon-only/linux/driver.c:145: warning: initialization from incompatible pointer type
/tmp/vmware-config3/vmmon-only/linux/driver.c:149: warning: initialization from incompatible pointer type
make[4]: *** [/tmp/vmware-config3/vmmon-only/linux/driver.o] Fehler 1
make[3]: *** [_module_/tmp/vmware-config3/vmmon-only] Fehler 2
make[2]: *** [modules] Fehler 2
make[1]: *** [modules] Fehler 2
make[1]: Leaving directory `/usr/src/linux-2.6.16.21-0.13-obj/i386/default'
make: *** [vmmon.ko] Fehler 2
make: Leaving directory `/tmp/vmware-config3/vmmon-only'
Unable to build the vmmon module.

For more information on how to troubleshoot module-related problems, please
visit our Web site at "http://www.vmware.com/download/modules/modules.html" and
"http://www.vmware.com/support/reference ... linux.html".

Execution aborted.


Wer kann mir weiterhelfen ? habe schon die maus auf ein standard modell eingestellt!!! leider ohne erfolg !!!

Gruss
Christian1983

Werbung:
towo
Moderator
Moderator
Beiträge: 3707
Registriert: 15. Feb 2004, 16:42
Wohnort: Nimritz
Kontaktdaten:

Beitrag von towo » 26. Jul 2006, 20:28

Den neuesten any-any-patch hast Du natürlich installiert, gelle?
Signatur nach Diktat spazieren gegangen

Bild

Christian1983
Newbie
Newbie
Beiträge: 39
Registriert: 5. Dez 2005, 15:29
Wohnort: Bremen
Kontaktdaten:

Beitrag von Christian1983 » 26. Jul 2006, 20:48

any-any-patch hab ich nicht installiert

das geht hier eher in die richtung...

http://vmware-forum.de/viewtopic.php?t= ... light=suse

ziehe mir gerade den alten kernel vmlinux-2.6.16.13-4-default.gz und teste das ganze nochmal...

gruss
christian1983

Benutzeravatar
Martin Breidenbach
Ultimate Guru
Ultimate Guru
Beiträge: 5632
Registriert: 26. Mai 2004, 21:33
Wohnort: N 50.17599° E 8.73367°

Beitrag von Martin Breidenbach » 26. Jul 2006, 21:05

Christian1983 hat geschrieben:any-any-patch hab ich nicht installiert
Warum nicht ?

Bei mir läufts damit.

http://www.linux-club.de/ftopic61701.html
Nicht Böse sein ! Der Onkel macht doch nur Spaß !

Christian1983
Newbie
Newbie
Beiträge: 39
Registriert: 5. Dez 2005, 15:29
Wohnort: Bremen
Kontaktdaten:

Beitrag von Christian1983 » 26. Jul 2006, 21:24

hab jetzt den alten kernel installiert mit any-any patch 101... und jetzt folgenden Fehler bekommen:

linux-yyeg:/home/lxuser/Desktop/vmware-any-any-update101 # ./runme.pl
Updating /usr/bin/vmware-config.pl ... now patched
The file /usr/lib/vmware/modules/source/vmmon.tar that this script was about to
install already exists. Overwrite? [yes]

The file /usr/lib/vmware/modules/source/vmnet.tar that this script was about to
install already exists. Overwrite? [yes]

Updating /usr/bin/vmware ... No patch needed/available
Updating /usr/bin/vmnet-bridge ... No patch needed/available
Updating /usr/lib/vmware/bin/vmware-vmx ... No patch needed/available
Updating /usr/lib/vmware/bin-debug/vmware-vmx ... No patch needed/available
VMware modules in "/usr/lib/vmware/modules/source" has been updated.

Before running VMware for the first time after update, you need to configure it
for your running kernel by invoking the following command:
"/usr/bin/vmware-config.pl". Do you want this script to invoke the command for
you now? [yes]

Making sure services for VMware Workstation are stopped.

Stopping VMware services:
Virtual machine monitor done

You must read and accept the End User License Agreement to continue.
Press enter to display it.


Do you accept? (yes/no)

The answer "" is invalid. It must be one of "y" or "n".

Do you accept? (yes/no) yes

Thank you.

Configuring fallback GTK+ 2.4 libraries.

In which directory do you want to install the mime type icons?
[/usr/share/icons]

What directory contains your desktop menu entry files? These files have a
.desktop file extension. [/usr/share/applications]

In which directory do you want to install the application's icon?
[/usr/share/pixmaps]

Trying to find a suitable vmmon module for your running kernel.

None of the pre-built vmmon modules for VMware Workstation is suitable for your
running kernel. Do you want this program to try to build the vmmon module for
your system (you need to have a C compiler installed on your system)? [yes]

Using compiler "/usr/bin/gcc". Use environment variable CC to override.

What is the location of the directory of C header files that match your running
kernel? [/lib/modules/2.6.16.13-4-default/build/include]

Extracting the sources of the vmmon module.

Building the vmmon module.

Building for VMware Workstation 5.5.x.
Using 2.6.x kernel build system.
make: Entering directory `/tmp/vmware-config7/vmmon-only'
make -C /lib/modules/2.6.16.13-4-default/build/include/.. SUBDIRS=$PWD SRCROOT=$PWD/. modules
make[1]: Entering directory `/usr/src/linux-2.6.16.13-4-obj/i386/default'
make -C ../../../linux-2.6.16.13-4 O=../linux-2.6.16.13-4-obj/i386/default modules
CC [M] /tmp/vmware-config7/vmmon-only/linux/driver.o
CC [M] /tmp/vmware-config7/vmmon-only/linux/hostif.o
CC [M] /tmp/vmware-config7/vmmon-only/common/cpuid.o
CC [M] /tmp/vmware-config7/vmmon-only/common/hash.o
CC [M] /tmp/vmware-config7/vmmon-only/common/memtrack.o
CC [M] /tmp/vmware-config7/vmmon-only/common/phystrack.o
CC [M] /tmp/vmware-config7/vmmon-only/common/task.o
gcc: error trying to exec 'cc1plus': execvp: Datei oder Verzeichnis nicht gefunden
make[4]: *** [/tmp/vmware-config7/vmmon-only/common/task.o] Fehler 1
make[3]: *** [_module_/tmp/vmware-config7/vmmon-only] Fehler 2
make[2]: *** [modules] Fehler 2
make[1]: *** [modules] Fehler 2
make[1]: Leaving directory `/usr/src/linux-2.6.16.13-4-obj/i386/default'
make: *** [vmmon.ko] Fehler 2
make: Leaving directory `/tmp/vmware-config7/vmmon-only'
Unable to build the vmmon module.

For more information on how to troubleshoot module-related problems, please
visit our Web site at "http://www.vmware.com/download/modules/modules.html" and
"http://www.vmware.com/support/reference ... linux.html".

Execution aborted.

@ Martin Breidenbach: welchen kernel benutzt du ???

kernel-default:
Installiert: 2.6.16.13-4
Kandidat: 2.6.16.21-0.13
Versionstabelle:
2.6.16.21-0.13 0
500 ftp://ftp.gwdg.de SuSE/10.1-i386/security pkglist
500 ftp://ftp.gwdg.de 10.1/ repomd
*** 2.6.16.13-4 0
500 ftp://ftp.gwdg.de SuSE/10.1-i386/base pkglist
100 RPM Database

Gruss
Christian1983

Benutzeravatar
Martin Breidenbach
Ultimate Guru
Ultimate Guru
Beiträge: 5632
Registriert: 26. Mai 2004, 21:33
Wohnort: N 50.17599° E 8.73367°

Beitrag von Martin Breidenbach » 26. Jul 2006, 21:36

Christian1983 hat geschrieben:gcc: error trying to exec 'cc1plus': execvp: Datei oder Verzeichnis nicht gefunden
Da fehlt wohl gc++
Christian1983 hat geschrieben:@ Martin Breidenbach: welchen kernel benutzt du ???

Code: Alles auswählen

2.6.16.21-0.13-default 
... wobei auf DIESEM SuSE 10.1 Rechner VMware nur zu 'wissenschaftlichen Zwecken' drauf ist (um sowas hier eben testen zu können) - das ist ein PIII-600 384 MB und ich bin eigentlich KEIN Masochist. Habe trotzdem eben mal zur Sicherheit eine kleine VM mit Win98 gestartet. Für VMware habe ich einen P4 3GHz 2GB RAM aber der hat SuSE 10 drauf (läuft...wozu updaten).
Nicht Böse sein ! Der Onkel macht doch nur Spaß !

Christian1983
Newbie
Newbie
Beiträge: 39
Registriert: 5. Dez 2005, 15:29
Wohnort: Bremen
Kontaktdaten:

Beitrag von Christian1983 » 26. Jul 2006, 21:52

hab gc++ nachinstalliert aber immer noch den gleich fehler

gcc: error trying to exec 'cc1plus': execvp: Datei oder Verzeichnis nicht gefunden

gruss
christian

Benutzeravatar
Martin Breidenbach
Ultimate Guru
Ultimate Guru
Beiträge: 5632
Registriert: 26. Mai 2004, 21:33
Wohnort: N 50.17599° E 8.73367°

Beitrag von Martin Breidenbach » 26. Jul 2006, 22:06

Wenn das Paket gcc-c++ installiert ist dann sollte das in /usr/lib/gcc/i586-suse-linux/4.1.0/cc1plus liegen:

rpm -q --filesbypkg gcc-c++ ergibt:

gcc-c++ /usr/bin/c++
gcc-c++ /usr/bin/g++
gcc-c++ /usr/lib/gcc
gcc-c++ /usr/lib/gcc/i586-suse-linux
gcc-c++ /usr/lib/gcc/i586-suse-linux/4.1.0
gcc-c++ /usr/lib/gcc/i586-suse-linux/4.1.0/cc1plus
gcc-c++ /usr/share/man/man1/g++.1.gz

Ich habe bei mir wie im o.g. Link beschrieben die ganze Paketgruppe 'C/C++ Compiler und Werkzeuge' installiert.
Nicht Böse sein ! Der Onkel macht doch nur Spaß !

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 3 Gäste