Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

keyboard-umstellung bei freenx geht nicht mehr

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Antworten
linuxn00b
Newbie
Newbie
Beiträge: 30
Registriert: 21. Jan 2005, 20:03

keyboard-umstellung bei freenx geht nicht mehr

Beitrag von linuxn00b » 21. Jul 2006, 15:18

Hallo beisammen.
Nach einem Update geht bei meinem Debian nicht mehr das Tastaturlayout zu wechseln.
Das Ganze sieht so aus: man loggt sich per FreeNX auf dem Server ein. FreeNX wählt dabei jedoch per default leider das englische (amerikanische) Layout, obwohl es in der xorg.conf auf "de" gestellt ist. Wenn ich mich per VNC einlogge, geht es. Soweit, so schlimm. Da ich aber xfce4 als Oberfläche nutze, habe ich mir ein Script gebastelt, dass automatisch beim anmelden ausgeführt wird. Das tat auch bisher immer, aber nach dem Update geht "/usr/bin/X11/setxkbmap -v 9 -rules xorg -model pc105 -layout de" nicht mehr. Das "v 9" dient dem ausspucken von mehr Infos. Als Ouptut erhalte ich folgendes:
IW /home/testuser/blub.txt Row 1 Col 1 3:05 Ctrl-K H for help
Setting verbose level to 9
locale is C
Warning! Multiple definitions of rules file
Using command line, ignoring X server
Applied rules from xorg:
model: pc105
layout: de
Trying to build keymap using the following components:
keycodes: xfree86+aliases(qwertz)
types: complete
compat: complete
symbols: pc(pc105)+de
geometry: pc(pc105)
Error loading new keyboard description


Was läuft denn hier falsch?

Danke für eure Hilfe

--n00b

Werbung:
thomas67
Newbie
Newbie
Beiträge: 3
Registriert: 31. Aug 2006, 19:42

Beitrag von thomas67 » 4. Sep 2006, 11:03

Hallo,

ich leide unter dem gleichen Problem! Hast Du schon eine Lösung?

Viele Grüße

THomas

mechanicus
Hacker
Hacker
Beiträge: 299
Registriert: 14. Jan 2005, 22:26

Re: keyboard-umstellung bei freenx geht nicht mehr

Beitrag von mechanicus » 4. Sep 2006, 17:44

linuxn00b hat geschrieben:Nach einem Update geht bei meinem Debian nicht mehr das Tastaturlayout zu wechseln.
Das Ganze sieht so aus: man loggt sich per FreeNX auf dem Server ein. FreeNX wählt dabei jedoch per default leider das englische (amerikanische) Layout, ...
Das kannst Du doch im NX-Client einstellen...

M.f.G. mechanicus

Antworten