Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

[gelöst] Modul advansys unter SuSE 10.1?

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Antworten
Alarich
Newbie
Newbie
Beiträge: 33
Registriert: 19. Jul 2006, 16:51

[gelöst] Modul advansys unter SuSE 10.1?

Beitrag von Alarich » 19. Jul 2006, 17:01

Hallo zusammen,

ich betreibe eine Advansys-SCSI Karte unter SuSE 10.1. Unter SuSE 9.2 konnte ich das nötige Treiber-Modul advansys noch selbst bauen. Unter "make menuconfig" war in den Low-Level-Treibern ein Treiber für advansys auswählbar. Dann make modules, make modules_install und ein modprobe advansys. Dann liefs.
Unter SuSE 10.1 wollte ich jetzt genauso vorgehen, doch findet sich keine Option mehr, mit der man das Modul auswählen kann.
Die Source-Dateien sind jedenfalls in den Kernel-Sources mit dabei. Also müßte sich das Modul doch kompilieren lassen, denke ich. Oder liege ich da falsch?
Welche Möglichkeiten habe ich denn jetzt, das Modul zu bauen? Oder ist das Modul überhaupt nicht mehr zum Laufen zu bringen? Ach ja, ich verwende den Kernel 2.6.16.13-4.

Bin für alle Vorschläge dankbar. Langsam wirds frustrierend...

Danke schon mal für alle Eure Bemühungen im voraus,

Alarich

\EDIT:
Ich habe es zwischenzeitlich mit folgendem Code geschafft, das Modul zu kompilieren:

Code: Alles auswählen

make menuconfig # Kernel konfigurieren, ohne auf advansys zu achten
make                       # kernel und Module bauen
make CONFIG_SCSI_ADVANSYS=m drivers/scsi/advansys.ko
Anschließend noch ein depmod -A und ein modprobe advansys. Schon lief die Karte.

CU,

Alarich

Werbung:
Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast