Probleme bei build/install von ATI Treiber Modul

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Antworten
Midnight
Newbie
Newbie
Beiträge: 5
Registriert: 22. Apr 2004, 17:55

Probleme bei build/install von ATI Treiber Modul

Beitrag von Midnight » 5. Mai 2004, 15:32

Da ich große Probleme mit dem xserver habe, habe ich mich entschlossen zu versuchen die Linux Grafiktreiber von ATI zu installieren. Beim installieren des rpm Packets habe ich dann zunächst die Fehlermeldung
*** Trying to install a precompiled kernel module.
*** WARNING ***
Tailored kernel module for fglrx not present in your system.
You must go to /lib/modules/fglrx/build_mod subdir
and execute './make.sh' to build a fully customed kernel module.
Afterwards go to /lib/modules/fglrx and run './make_install.sh'
in order to install the module into your kernel's module repository.
(see readme.txt for more details.)

As of now you can still run your XServer in 2D, but hardware acclerated
OpenGL will not work and 2D graphics will lack performance.

failed.
*** Error: no kernel module build environment - please consult readme.
bekommen. Soweit ich das verstanden habe ist also der Versuch ein precompiled kernel module zu installieren gescheitert und da keine kernel module build environment installiert war konnte auch kein Versuch gestartet werden ein neues Modul zu compilieren.
Nach der Nachinstallation der Kernel Sourcen war ich dann einen Schritt weiter und die Meldung
*** Found kernel module build environment, generating kernel module now.
erschien.
Leider hat der Versuch das Module neu zu compilieren dann aber auch mit der Meldung
- trying a sample load of the kernel module
Warning: loading /lib/modules/2.4.21-99-default/kernel/drivers/char/drm/fglrx.o will taint the kernel: non-GPL license - Proprietary. (C) 2002 - ATI Technologies, Starnberg, GERMANY
See http://www.tux.org/lkml/#export-tainted for information about tainted modules
/lib/modules/2.4.21-99-default/kernel/drivers/char/drm/fglrx.o: init_module: No such device
Hint: insmod errors can be caused by incorrect module parameters, including invalid IO or IRQ parameters.
You may find more information in syslog or the output from dmesg
/lib/modules/2.4.21-99-default/kernel/drivers/char/drm/fglrx.o: insmod /lib/modules/2.4.21-99-default/kernel/drivers/char/drm/fglrx.o failed
/lib/modules/2.4.21-99-default/kernel/drivers/char/drm/fglrx.o: insmod fglrx failed
failed.
abgebrochen.
Weiss jemand was ich falsch mache?

Werbung:
deekay
Newbie
Newbie
Beiträge: 1
Registriert: 6. Mai 2004, 12:20
Wohnort: Braunschweig
Kontaktdaten:

SuSe 9.1 und FGLRX - So gehts!!!

Beitrag von deekay » 7. Mai 2004, 11:05

Da ich immer mehr anfragen bekomme, wie ich nu das Problem gelöst habe. Hab ich meine Lösung auf meiner Website gepostet.

Die Lösung liegt hier:
http://www.deekay.org/suse91_fglrx.html

Bei Fragen einfach anschreiben.

Gast

Re: SuSe 9.1 und FGLRX - So gehts!!!

Beitrag von Gast » 19. Mai 2004, 08:11

deekay hat geschrieben:Da ich immer mehr anfragen bekomme, wie ich nu das Problem gelöst habe. Hab ich meine Lösung auf meiner Website gepostet.

Die Lösung liegt hier:
http://www.deekay.org/suse91_fglrx.html

Bei Fragen einfach anschreiben.
Hallo,

Sie habe das fur die 2.6 kernel, das fur die 2.4 wie gebraucht ist here: ftp://ftp.suse.com/pub/suse/i386/supple ... lrx/3.7.0/.

Verzeihung fur meine Deutsch, :oops:

Benutzeravatar
taz
Newbie
Newbie
Beiträge: 2
Registriert: 16. Apr 2004, 11:35
Wohnort: Hanau

Re: SuSe 9.1 und FGLRX - So gehts!!!

Beitrag von taz » 19. Mai 2004, 08:16

Anonymous hat geschrieben:
deekay hat geschrieben:Da ich immer mehr anfragen bekomme, wie ich nu das Problem gelöst habe. Hab ich meine Lösung auf meiner Website gepostet.

Die Lösung liegt hier:
http://www.deekay.org/suse91_fglrx.html

Bei Fragen einfach anschreiben.
Hallo,

Sie habe das fur die 2.6 kernel, das fur die 2.4 wie gebraucht ist here: ftp://ftp.suse.com/pub/suse/i386/supple ... lrx/3.7.0/.

Verzeihung fur meine Deutsch, :oops:
Sorry, forgot to login! :(
Taz

"Zeit ist gelt und ich habe zu wenig von beiden!"

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 5 Gäste