Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

Azureus Java Fehler

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

SimGeh
Newbie
Newbie
Beiträge: 2
Registriert: 21. Jun 2006, 00:36

Azureus Java Fehler

Beitrag von SimGeh » 22. Jun 2006, 17:28

Hi
wenn ich Azureus im Konsole Modus starten möchte gebe ich den Befehl:
java -jar Azureus2.jar --ui=console ein.

Als Root ist das alles kein Problem und Azureus startet sich. Sobald ich mich aber als User einlogge und den Befehl eingebe kommt folgender Fehler:
Exception in thread "main" java.lang.NoClassDefFoundError: org/apache/log7j/Layout

Kann mir jemand sagen warum das als Root kein Problem ist aber als user nicht geht!

Danke SimGeh

Werbung:
Jazz
Member
Member
Beiträge: 71
Registriert: 30. Mai 2004, 15:13

Beitrag von Jazz » 2. Jul 2006, 20:58

hab das gleiche problem kann auch nur als root starten und nicht als user.
hat jemand inzwischen eine lösung. wäre sehr dankbar. LG jazz

Jazz
Member
Member
Beiträge: 71
Registriert: 30. Mai 2004, 15:13

Beitrag von Jazz » 2. Jul 2006, 21:07

hab jetzt die lösung man muss 2 dateien in das verzeicnis des azureus tun.
einmal log4j.jar und einmal die commons-cli.jar dann gehts auch als user. :wink:

Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus » 21. Jul 2006, 10:47

oder das RPM Azureus-console installieren :mrgreen:
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

EagleFox
Member
Member
Beiträge: 115
Registriert: 12. Mai 2005, 18:43

Beitrag von EagleFox » 22. Jul 2006, 20:56

Hallo oc2pus,

ich habe gestern auch mal wieder ein update gemacht und kann seitdem den azureus auch nicht mehr starten. In der Konsole:

Code: Alles auswählen

eaglefox:/etc # azureus
java virtual machine used: /usr/lib64/jvm/jre/bin/java
classpath used: /usr/share/java/Azureus/Azureus2.jar:/usr/share/java/Azureus/swt.jar
main class used: org.gudy.azureus2.ui.swt.Main
flags used:
options used: -Xms16m -Xmx128m -Djava.library.path=/usr/lib/Azureus
arguments used:
eaglefox:/etc #  
..und nichts passiert.

Sonst habe ich als user einfach über das K-Menü den Azureus gestartet, aber da tut sich auch nichts mehr.

Ich habe folgende Pakete:

Code: Alles auswählen

Azureus-2.4.0.3-B65.oc2pus.1
Azureus-libswt3-gtk2-I20060620_1010-0.oc2pus.1
Azureus-console-2.4.0.3-B65.oc2pus.1
Leider gibt es weder in den "messages" noch in der "warn" eine Systemmeldung dazu. Wie und wo kann ich herausfinden, was da schief läuft? Ich habe SuSE 10.1 64-bit.
Ich hoffe Du hast da nen Tip für mich!

Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus » 22. Jul 2006, 21:18

das Azureus log steht in /tmp/Azureus.log

und wieso startest du das als root ??
und bei 64bit kann es sein, das du ein anderes swt benötigst ... aber schau erst mal ins log

Code: Alles auswählen

#! /bin/bash

# source the jpackage helpers
VERBOSE=1
. /usr/share/java-utils/java-functions

# set JAVA_* environment variables
set_javacmd
check_java_env
set_jvm_dirs

CLASSPATH=`build-classpath Azureus/Azureus2 Azureus/swt`
MAIN_CLASS="org.gudy.azureus2.ui.swt.Main"
set_options "-Xms16m -Xmx128m -Djava.library.path="/usr/lib/Azureus""

run "$@" 2> /tmp/Azureus.log
evtl musst du den java.library.path anpassen für die 64bit Welt.
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

EagleFox
Member
Member
Beiträge: 115
Registriert: 12. Mai 2005, 18:43

Beitrag von EagleFox » 22. Jul 2006, 21:28

Ähm, als root habe ich nur versucht, weil es als user aus der Konsole auch nicht ging. Selbe Ausgabe wie unter root. Das letztere habe ich dann nur gepostet! Ich starte das sont niemals nie als root!

Also die /tmp/Azureus.log sagt:

Code: Alles auswählen

Exception in thread "main" java.lang.UnsatisfiedLinkError: /usr/lib/Azureus/libswt-pi-gtk-3301.so: /usr/lib/Azureus/libswt-pi-gtk-3301.so:
wrong ELF class: ELFCLASS32
        at java.lang.ClassLoader$NativeLibrary.load(Native Method)
        at java.lang.ClassLoader.loadLibrary0(ClassLoader.java:1751)
        at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1676)
        at java.lang.Runtime.loadLibrary0(Runtime.java:822)
        at java.lang.System.loadLibrary(System.java:992)
        at org.eclipse.swt.internal.Library.loadLibrary(Library.java:123)
        at org.eclipse.swt.internal.gtk.OS.<clinit>(OS.java:22)
        at org.eclipse.swt.internal.Converter.wcsToMbcs(Converter.java:63)
        at org.eclipse.swt.internal.Converter.wcsToMbcs(Converter.java:54)
        at org.eclipse.swt.widgets.Display.<clinit>(Display.java:126)
        at org.gudy.azureus2.ui.swt.mainwindow.SWTThread.<init>(SWTThread.java:80)
        at org.gudy.azureus2.ui.swt.mainwindow.SWTThread.createInstance(SWTThread.java:61)
        at org.gudy.azureus2.ui.swt.mainwindow.Initializer.<init>(Initializer.java:109)
        at org.gudy.azureus2.ui.swt.Main.<init>(Main.java:147)
        at org.gudy.azureus2.ui.swt.Main.main(Main.java:162)
Scheint, als wäre es nur noch unter 32-bit lauffähig, oder???

Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus » 22. Jul 2006, 21:34

aha, jetzt kommen wir der Sache näher :)

du verwendest eine 64bit JVM und mischst nun aus meinem Azureus-libswt3-gtk2 Paket 32bit dazu... das kann nicht gehen.

Du musst dir also ein 64bit SWT besorgen und dieses installieren. Dann sollte das auch klappen.

Es sind dann nur ein paar kleinere Anpassungen im Startscript erforderlich für die 64bit SWT.

==> gibt es hier:
http://download3.eclipse.org/eclipse/downloads/
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

EagleFox
Member
Member
Beiträge: 115
Registriert: 12. Mai 2005, 18:43

Beitrag von EagleFox » 22. Jul 2006, 21:39

Hmm, aber es ging doch auch vor dem update, was ich gestern gemacht habe!
Mal sehen, was ich bezüglich der 64bit SWT machen kan.

Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus » 22. Jul 2006, 21:40

EagleFox hat geschrieben:Hmm, aber es ging doch auch vor dem update, was ich gestern gemacht habe!
Mal sehen, was ich bezüglich der 64bit SWT machen kan.
rpm -qa --last
==> alle Pakete in Installationsreihenfolge auflisten, schauen welche du gestern eingespielt hast ... vielleicht kommen wir so dahinter
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

EagleFox
Member
Member
Beiträge: 115
Registriert: 12. Mai 2005, 18:43

Beitrag von EagleFox » 22. Jul 2006, 21:47

Ok, also hier die Pakete von gestern und heute!

Code: Alles auswählen

Azureus-console-2.4.0.3-B65.oc2pus.1          Sa 22 Jul 2006 20:47:42 CEST
log4j-1.2.13-2jpp                             Sa 22 Jul 2006 20:47:41 CEST
jakarta-commons-lang-2.1-4jpp                 Sa 22 Jul 2006 20:47:41 CEST
jakarta-commons-cli-1.0-7jpp                  Sa 22 Jul 2006 20:47:41 CEST
amarok-xmms-1.4.1_1.0-1.guru.suse101          Sa 22 Jul 2006 20:23:09 CEST
amarok-xine-1.4.1_1.0-1.guru.suse101          Sa 22 Jul 2006 20:23:09 CEST
amarok-libvisual-1.4.1_1.0-1.guru.suse101     Sa 22 Jul 2006 20:23:09 CEST
kpowersave-0.6.2-3.3                          Sa 22 Jul 2006 20:23:08 CEST
amarok-1.4.1_1.0-1.guru.suse101               Sa 22 Jul 2006 20:22:59 CEST
libwnck-32bit-2.12.2-28.7                     Sa 22 Jul 2006 20:22:53 CEST
Azureus-2.4.0.3-B65.oc2pus.1                  Sa 22 Jul 2006 20:22:53 CEST
powersave-0.12.20-0.3                         Sa 22 Jul 2006 20:22:46 CEST
kopete-0.12.1-2.1                             Sa 22 Jul 2006 20:22:42 CEST
dejavu-fonts-ttf-2.8-1.guru.suse101           Sa 22 Jul 2006 20:22:08 CEST
Mesa-devel-6.4.2-19.7                         Sa 22 Jul 2006 20:22:05 CEST
hal-32bit-0.5.6-33.11                         Sa 22 Jul 2006 20:22:05 CEST
hal-0.5.6-33.11                               Sa 22 Jul 2006 20:22:01 CEST
xorg-x11-libs-6.9.0-50.17                     Sa 22 Jul 2006 20:21:35 CEST
sax2-tools-2.7-125.19                         Sa 22 Jul 2006 20:21:34 CEST
Mesa-6.4.2-19.7                               Sa 22 Jul 2006 20:21:33 CEST
xorg-x11-server-6.9.0-50.17                   Sa 22 Jul 2006 20:21:29 CEST
xorg-x11-driver-video-nvidia-6.9.0-46.15      Sa 22 Jul 2006 20:21:28 CEST
xorg-x11-driver-video-6.9.0-46.15             Sa 22 Jul 2006 20:21:28 CEST
Mesa-32bit-6.4.2-19.7                         Sa 22 Jul 2006 20:21:27 CEST
xorg-x11-server-glx-6.9.0-50.17               Sa 22 Jul 2006 20:21:23 CEST
sax2-ident-1.7-125.19                         Sa 22 Jul 2006 20:21:23 CEST
powersave-libs-0.12.20-0.3                    Sa 22 Jul 2006 20:21:22 CEST
sax2-7.1-125.19                               Sa 22 Jul 2006 20:21:21 CEST
xorg-x11-libs-32bit-6.9.0-50.17               Sa 22 Jul 2006 20:21:20 CEST
xkeyboard-config-0.7-19.7                     Sa 22 Jul 2006 20:21:19 CEST
sax2-libsax-7.1-125.19                        Sa 22 Jul 2006 20:21:16 CEST
3ddiag-0.735-1.6                              Sa 22 Jul 2006 20:21:15 CEST
powersave-libs-32bit-0.12.20-0.3              Sa 22 Jul 2006 20:21:14 CEST
lftp-3.5.1-1.guru.suse101                     Sa 22 Jul 2006 20:21:13 CEST
yast2-backup-2.13.2-3.3                       Sa 22 Jul 2006 20:21:11 CEST
sax2-libsax-perl-7.1-125.19                   Sa 22 Jul 2006 20:21:11 CEST
ktorrent-2.0_0.2-1.guru.suse101               Sa 22 Jul 2006 20:21:09 CEST
sax2-gui-1.7-125.19                           Sa 22 Jul 2006 20:21:06 CEST
xorg-x11-6.9.0-50.17                          Sa 22 Jul 2006 20:20:51 CEST
yast2-packager-2.13.139-1.3                   Fr 21 Jul 2006 09:41:01 CEST
xen-devel-3.0.2_09749-0.7                     Fr 21 Jul 2006 09:41:00 CEST
autoyast2-2.13.69-0.3                         Fr 21 Jul 2006 09:40:59 CEST
audit-1.1.3-23.3                              Fr 21 Jul 2006 09:40:58 CEST
yast2-installation-2.13.132.4-0.3             Fr 21 Jul 2006 09:40:54 CEST
yast2-online-update-2.13.43-1.3               Fr 21 Jul 2006 09:40:51 CEST
yast2-2.13.64.2-0.2                           Fr 21 Jul 2006 09:40:48 CEST
zmd-7.1.1.0-39.50                             Fr 21 Jul 2006 09:40:46 CEST
novfs-kmp-default-1.2.0_2.6.16.21_0.13-9.2    Fr 21 Jul 2006 09:40:39 CEST
zaptel-kmp-default-1.2.4_2.6.16.21_0.13-10.3  Fr 21 Jul 2006 09:40:21 CEST
xen-libs-3.0.2_09749-0.7                      Fr 21 Jul 2006 09:40:21 CEST
udev-085-30.11                                Fr 21 Jul 2006 09:40:20 CEST
gtk2-2.8.10-49                                Fr 21 Jul 2006 09:40:15 CEST
apparmor-profiles-2.0-34.9                    Fr 21 Jul 2006 09:40:08 CEST
autoyast2-installation-2.13.69-0.3            Fr 21 Jul 2006 09:40:07 CEST
libzypp-1.2.0-1.27                            Fr 21 Jul 2006 09:40:06 CEST
audit-libs-1.1.3-23.3                         Fr 21 Jul 2006 09:40:03 CEST
suseRegister-1.0-63.9                         Fr 21 Jul 2006 09:40:02 CEST
yast2-pkg-bindings-2.13.88-1.3                Fr 21 Jul 2006 09:40:01 CEST
mozilla-nss-32bit-3.11.2-1.1                  Fr 21 Jul 2006 09:40:01 CEST
kdesvn-svnqt-0.9.0-0.pm.0                     Fr 21 Jul 2006 09:40:00 CEST
apparmor-docs-2.0-17.5                        Fr 21 Jul 2006 09:40:00 CEST
mkinitrd-1.2-106.15                           Fr 21 Jul 2006 09:39:59 CEST
yast2-security-2.13.4-0.3                     Fr 21 Jul 2006 09:39:56 CEST
digikamimageplugins-0.8.2-2.1                 Fr 21 Jul 2006 09:39:44 CEST
kdesvn-0.9.0-3.1                              Fr 21 Jul 2006 09:39:35 CEST
apparmor-utils-2.0-23.5                       Fr 21 Jul 2006 09:39:28 CEST
zen-updater-7.1.0-51.29                       Fr 21 Jul 2006 09:39:27 CEST
yast2-apparmor-2.0-27.5                       Fr 21 Jul 2006 09:39:26 CEST
gwenview-1.3.92-2.1                           Fr 21 Jul 2006 09:39:18 CEST
yast2-online-update-frontend-2.13.43-1.3      Fr 21 Jul 2006 09:39:17 CEST
yast2-qt-2.13.60-0.4                          Fr 21 Jul 2006 09:38:25 CEST
libzypp-zmd-backend-7.1.1.0-42.46             Fr 21 Jul 2006 09:38:23 CEST
kernel-default-2.6.16.21-0.13                 Fr 21 Jul 2006 09:37:31 CEST
rug-7.1.1.0-18.24                             Fr 21 Jul 2006 09:37:24 CEST
yast2-ncurses-2.13.40-1.3                     Fr 21 Jul 2006 09:37:22 CEST
kdesvn-svnqt-devel-0.9.0-0.pm.0               Fr 21 Jul 2006 09:37:22 CEST
apparmor-parser-2.0-21.5                      Fr 21 Jul 2006 09:37:21 CEST
yast2-perl-bindings-2.13.5-1.3                Fr 21 Jul 2006 09:37:20 CEST
xen-3.0.2_09749-0.7                           Fr 21 Jul 2006 09:37:18 CEST
digikam-0.8.2-6.1                             Fr 21 Jul 2006 09:36:24 CEST
kernel-source-2.6.16.21-0.13                  Fr 21 Jul 2006 09:35:54 CEST

Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus » 23. Jul 2006, 10:40

EagleFox hat geschrieben:Hmm, aber es ging doch auch vor dem update, was ich gestern gemacht habe!
Mal sehen, was ich bezüglich der 64bit SWT machen kan.
kann es sein, da du dir das Azureus Paket vorher selber erstellt hattest (aus dem Workshop)?
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

EagleFox
Member
Member
Beiträge: 115
Registriert: 12. Mai 2005, 18:43

Beitrag von EagleFox » 23. Jul 2006, 12:21

:roll: Hab ich das??? Also ich kann mich nicht wirklich daran erinnert das getan zu haben. Ich habe mir jetzt die 64-bit Version von sourceforge gezogen, jetzt läuft es wieder. Ist nur seltsam, weil das Azureus von sourceforge ja garnicht als rpm installiert wird. Irgendwie muss ich das von Dir installiert haben, sonst wäre es ja nicht als rpm im System gewesen.
Naja, es läuft und alles wird gut! :wink:
Dennoch Danke für Deine Bemühungen!

Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus » 23. Jul 2006, 12:32

EagleFox hat geschrieben::roll: Hab ich das??? Also ich kann mich nicht wirklich daran erinnert das getan zu haben.
falls du das getan hättest, wäre es nämlich erklärbar warum es mal funktioniert hat:
durch den rebuild auf deinem System wurden durchgängig die richtigen "64bit lib-Pfade" für die Macros verwendet. ...
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

EagleFox
Member
Member
Beiträge: 115
Registriert: 12. Mai 2005, 18:43

Beitrag von EagleFox » 23. Jul 2006, 12:41

Ja, das sehe ich ein! Mich wundert es ja auch.
Dann muss ich aber irgendwie verhindern, dass es mit geupdatet wird, weil ich das ja jedes mal wieder selbst neu kompilieren muss. Da ist der Weg über ein einfaches "download" und in ein bestimmtes Verzeichnis entpacken wohl weniger aufwendig. So groß wird der Unterschied zwischen Deinem Paket und dem von Sourceforge wohl nicht sein, oder?

Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus » 23. Jul 2006, 12:50

EagleFox hat geschrieben:Ja, das sehe ich ein! Mich wundert es ja auch.
Dann muss ich aber irgendwie verhindern, dass es mit geupdatet wird, weil ich das ja jedes mal wieder selbst neu kompilieren muss. Da ist der Weg über ein einfaches "download" und in ein bestimmtes Verzeichnis entpacken wohl weniger aufwendig. So groß wird der Unterschied zwischen Deinem Paket und dem von Sourceforge wohl nicht sein, oder?
:)
naja, mein RPM installiert es (SuSE-)Linux-konform, für alle User auf einem System nutzbar, es sind einige Azurues-Plugins gleich mitinstalliert, es wird ein Menu-Eintrag erstellt und die Abhängigkeiten zu anderen SuSE-Paketen werden berücksichtigt....

Es wurde ja auch nur veröffentlicht weil viele User Schwierigkeiten haben Azureus ans fliegen zu bekommen ...
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

EagleFox
Member
Member
Beiträge: 115
Registriert: 12. Mai 2005, 18:43

Beitrag von EagleFox » 23. Jul 2006, 13:02

:D Achso, naja, da ich es ja ans fliegen gebracht habe, so schwer war es ja nicht, komme ich wohl mit der "abgespeckten" sourceforge-Version klar. Da ich alleiniger Herrscher über meine Rechner bin, brauche ich mir auch kein Bein auszureissen, dass da mehrere User mit hantieren dürfen! Und solange ich weiss, wo ich das Paket stecken habe, kann ich wohl nochmal ein Auge zudrücken, dass es nicht SuSE-konform installiert ist. Dass die Abhängigkeiten noch korrekt sind kann ja bei jedem Start erneut raten! :D

xandl12
Member
Member
Beiträge: 53
Registriert: 17. Sep 2005, 03:32

Azureus-console -problem

Beitrag von xandl12 » 8. Sep 2006, 16:38

Hi!

Ich wollte Azureus von der Konsole aus benützen und hab mir mit smart
das RPM "Azureus-console" und die abhängigen Pakete installiert!

Wenn ich jetzt aber Azureus-console.sh starte, öffnet sich das normale GUI und versucht die Datei "--ui=console" zu öffnen!

Code: Alles auswählen

alex@linux:/usr/share/java/Azureus> Azureus-console.sh
java virtual machine used: /usr/lib/jvm/jre/bin/java
classpath used: /usr/share/java/Azureus/Azureus2.jar:/usr/share/java/Azureus/swt.jar:/usr/share/java/log4j.jar:/usr/share/java/jakarta-commons-cli.jar
main class used: org.gudy.azureus2.ui.swt.Main
flags used:
options used: -Xms16m -Xmx128m -Djava.library.path=/usr/lib/Azureus
arguments used: --ui=console

Dann hab ich versucht

Code: Alles auswählen

alex@linux:/usr/share/java/Azureus> java -jar Azureus2.jar --ui=console
Exception in thread "main" java.lang.NoClassDefFoundError: org/apache/commons/cli/CommandLine
Kann mir wer sagen was da nicht stimmt? :?:


lg
xandl12

-----------------
SuSe 10.0 KDE 3.5.4

Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Re: Azureus-console -problem

Beitrag von oc2pus » 8. Sep 2006, 16:59

xandl12 hat geschrieben:Wenn ich jetzt aber Azureus-console.sh starte, öffnet sich das normale GUI und versucht die Datei "--ui=console" zu öffnen!

Code: Alles auswählen

alex@linux:/usr/share/java/Azureus> Azureus-console.sh
java virtual machine used: /usr/lib/jvm/jre/bin/java
classpath used: /usr/share/java/Azureus/Azureus2.jar:/usr/share/java/Azureus/swt.jar:/usr/share/java/log4j.jar:/usr/share/java/jakarta-commons-cli.jar
main class used: org.gudy.azureus2.ui.swt.Main
flags used:
options used: -Xms16m -Xmx128m -Djava.library.path=/usr/lib/Azureus
arguments used: --ui=console
poste mal den Inhalt von Azureus-console.sh, evtl ist da ein "kleiner" Bug drin.
xandl12 hat geschrieben:Dann hab ich versucht

Code: Alles auswählen

alex@linux:/usr/share/java/Azureus> java -jar Azureus2.jar --ui=console
Exception in thread "main" java.lang.NoClassDefFoundError: org/apache/commons/cli/CommandLine
Kann mir wer sagen was da nicht stimmt? :?:
dein Aufruf funktioniert nicht weil du log4j und swt nicht im Classpath hast.
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

xandl12
Member
Member
Beiträge: 53
Registriert: 17. Sep 2005, 03:32

Beitrag von xandl12 » 8. Sep 2006, 17:22

Inhalt von Azureus-console.sh

Code: Alles auswählen

#! /bin/bash

# source the jpackage helpers
VERBOSE=1
. /usr/share/java-utils/java-functions

# set JAVA_* environment variables
set_javacmd
check_java_env
set_jvm_dirs

CLASSPATH=`build-classpath Azureus/Azureus2 Azureus/swt log4j jakarta-commons-cli`
MAIN_CLASS="org.gudy.azureus2.ui.swt.Main"
set_options "-Xms16m -Xmx128m -Djava.library.path="/usr/lib/Azureus""

run --ui=console "$@" 2> /tmp/Azureus-console.log
im /tmp/Azureus-console.log steht "nur"

Code: Alles auswählen

SWT:13907): Gtk-WARNING **: gtk_widget_size_allocate(): attempt to allocate widget with width 250 and height -1

Antworten

Wer ist online?

Mitglieder in diesem Forum: Bing [Bot] und 5 Gäste