ltsp 3 - SuSE 9.x

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Gesperrt
Benutzeravatar
kroe
Member
Member
Beiträge: 87
Registriert: 11. Sep 2003, 19:38

ltsp 3 - SuSE 9.x

Beitrag von kroe » 2. Mai 2004, 11:04

Hallo,

alle, die noch LTSP 3 installieren möchten (mit LTSP 4 habe ich es noch nicht ausprobiert) und SuSE 9.x einsetzen:

Die tgz-Pakete herunterladen und entpacken, dann in den Ordner ltsp-core wechseln und einen symlink ergänzen:

Code: Alles auswählen

ln -s suse.sh  suse-9.x.sh
wobei natürlich 9.x durch die entsprechende Version ersetzt werden muss, also z.B: durch 9.1

und schon funktioniert es wie gewohnt :-)

Btw. auch hier müssen für den dhcp-Server die Einträge in der /etc/sysconfig/dhcp entsprechend geändert werden --> siehe www.linux-schulen.de -> ltsp

Viele Grüße
kroe
Zuletzt geändert von kroe am 8. Jun 2004, 00:12, insgesamt 1-mal geändert.
Dokumentation für LTSP-SuSE-icewm, insbesondere für den Einsatz in Schulen:
--> http://www.linux-schulen.de

Werbung:
Rolf-Werner
Hacker
Hacker
Beiträge: 338
Registriert: 23. Jan 2004, 09:34

Ging bei mir anders

Beitrag von Rolf-Werner » 5. Mai 2004, 12:37

Hallo,

danke für den Tip - aber bei mir lief es anders: Ich habe den Eintrag in der /etc/SuSErelease geändert. Da steht Version 9.1, daraus hab ich 9.0 gemacht. Danach lief alles problemlos, jedenfalls mit den fertigen Paketen von linux-schulen.

Hab ich jetzt was falsch gemacht?

Grüße
Rolf
Wissen ist Macht.
Wir wissen nichts.
Macht nichts.

schweer
Hacker
Hacker
Beiträge: 268
Registriert: 2. Jan 2004, 23:40
Wohnort: Bochum

Re: Ging bei mir anders

Beitrag von schweer » 5. Mai 2004, 21:08

Rolf-Werner hat geschrieben:Ich habe den Eintrag in der /etc/SuSErelease geändert. Da steht Version 9.1, daraus hab ich 9.0 gemacht. Danach lief alles problemlos, jedenfalls mit den fertigen Paketen von linux-schulen.
Hab ich jetzt was falsch gemacht?
Natürlich nicht. Aber den Eintrag besser wieder auf 9.1 setzen, sonst kommt SuSEs Yast eventuell durcheinander. LTSP braucht das nach der Installation nicht mehr.

wolfgang

MToth
Newbie
Newbie
Beiträge: 10
Registriert: 28. Feb 2004, 12:33

Beitrag von MToth » 11. Jul 2004, 14:18

Hallo..
Ich habe deinen Tip zur config auf der Schulserver Seite gesehen. Aber irgendwie bekomme ich den DHCP nicht gestartet, folgender Fehler (9.1 Pro):

/etc/init.d/dhcpd start gab 1 (Fehler nicht spezifiziert) zurück:
Starting DHCP server Internet Software Consortium DHCP Server V3.0.1rc13
Copyright 1995-2003 Internet Software Consortium.
All rights reserved.
For info, please visit http://www.isc.org/products/DHCP
/var/lib/dhcp///etc/dhcpd.conf line 10: subnet 192.168.0.254 netmask 255.255.255.0: bad subnet number/mask combination.
subnet 192.168.0.254 netmask 255.255.255.0
^
/var/lib/dhcp///etc/dhcpd.conf line 12: empty shared-network decl
}
^
Configuration file errors encountered -- exiting

-------------------------
-------------------------

meine dhcpd.conf sieht so aus:

option subnet-mask 255.255.255.0;
option broadcast-address 192.168.0.255;
option routers 192.168.0.254;
option domain-name-servers 192.168.0.254;
option domain-name "yourdomain.com";
option root-path "192.168.1.254:/opt/ltsp/i386";
default-lease-time 21600;
max-lease-time 21600;
shared-network WORKSTATIONS {
subnet 192.168.0.254 netmask 255.255.255.0 {
}
}
group {
option log-servers 192.168.1.254;
use-host-decl-names on;
host ws001 {
hardware ethernet 00:02:3F:BB:3B:E8;
fixed-address 192.168.0.2;
filename "/lts/vmlinuz-2.4.18-ltsp-1/pxelinux.0";
}
}


--------------------
--------------------

Für einen Tip wäre ich dankbar...

Benutzeravatar
kroe
Member
Member
Beiträge: 87
Registriert: 11. Sep 2003, 19:38

Beitrag von kroe » 11. Jul 2004, 14:50

Hi,
MToth hat geschrieben: ...
shared-network WORKSTATIONS {
subnet 192.168.0.254 netmask 255.255.255.0 {
}
}
...
Die letzte von mir zititierte Klammer darf erst ganz am Ende (nach den group-einträgen) zugemacht werden.

also:

shared-network WORKSTATIONS {
subnet 192.168.0.254 netmask 255.255.255.0 {
}
group {
option log-servers 192.168.1.254;
use-host-decl-names on;
host ws001 {
hardware ethernet 00:02:3F:BB:3B:E8;
fixed-address 192.168.0.2;
filename "/lts/vmlinuz-2.4.18-ltsp-1/pxelinux.0";
}
}
}

Ich hoffe jetzt funktioniert es.

viele Grüße
kroe
Dokumentation für LTSP-SuSE-icewm, insbesondere für den Einsatz in Schulen:
--> http://www.linux-schulen.de

Gast

Beitrag von Gast » 11. Jul 2004, 21:49

MToth hat geschrieben:/var/lib/dhcp///etc/dhcpd.conf line 10: subnet 192.168.0.254 netmask 255.255.255.0: bad subnet number/mask combination.
Du hast als Subnetz-Adresse die Deines Nameservers angegeben, das kann nicht hinhauen, wie die Fehlermeldung besagt.
Andreas

MToth
Newbie
Newbie
Beiträge: 10
Registriert: 28. Feb 2004, 12:33

Beitrag von MToth » 12. Jul 2004, 20:25

Aaaalso,

ich mußte jetzt erstmal einen Tag Kräfte sammeln, trotz der Klammer-Sache wollte es nicht funzen -- der DHCP verweigerte immer wieder den Start. Als ich eben boote, gibt es ein Update für den DHCP, nachdem dieses installiert ist, läuft auch der Server ohne weitere Änderung an der DHCP Config. So weit so gut. Als Client habe ich hier einen Fuji Laptop, auf dem auch 9.1 von Platte läuft. Die Grafik ist eine ATI, die in der (Laptop-) Conf als Treiber "radeon" eingetragen ist. Der Client bootet vom LAN, bis der X Server gestartet werden soll, dann kommt die Meldung, ich solle in lts.conf den richtigen X Server einstellen. Ich habe dort dann von auto auf ati auf radeon gewechselt, aber es geht nicht. Drücke ich Return, um trotz X Server Fehlermeldung fortzufahren, kommt eine Meldung mit SIGHUP und das war's dann.

Ich habe leider keine weiteren Netzwerk-Boot - fähigen Rechner, daher kann ich das auch nicht für Nvidia o.ä. ausprobieren.

zu:

http://www.linux-schulen.de/~lnxl0001/l ... p#prozesse

Hier funktioniert die "touch tmp/mice ..." Sache nicht -- es gibt das Verzeichnis nicht. Ich war mir nicht sicher, ob es das mit (Inhalt) schon hätte geben sollen -- ist das überhaupt für 9.1 gültig oder nur für 9.0?

Vielen Dank schon mal....

Benutzeravatar
kroe
Member
Member
Beiträge: 87
Registriert: 11. Sep 2003, 19:38

Beitrag von kroe » 24. Jul 2004, 14:07

MToth hat geschrieben:
zu:

http://www.linux-schulen.de/~lnxl0001/l ... p#prozesse

Hier funktioniert die "touch tmp/mice ..." Sache nicht -- es gibt das Verzeichnis nicht. Ich war mir nicht sicher, ob es das mit (Inhalt) schon hätte geben sollen -- ist das überhaupt für 9.1 gültig oder nur für 9.0?
Du hast anscheindend die Zeile zuvor nicht gelesen: change to /opt/ltsp/

Dort gibt es sicherlich das Verzeichnis tmp und damit müsste auch der touch Befehl funktionieren.

Gruß
kroe
Dokumentation für LTSP-SuSE-icewm, insbesondere für den Einsatz in Schulen:
--> http://www.linux-schulen.de

Gesperrt

Wer ist online?

Mitglieder in diesem Forum: Bing [Bot] und 2 Gäste