Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

[gelöst] lspci - Befehl nicht gefunden

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Antworten
b2890x
Member
Member
Beiträge: 85
Registriert: 15. Jan 2006, 10:11
Wohnort: 3.OG.mi.

[gelöst] lspci - Befehl nicht gefunden

Beitrag von b2890x » 4. Jun 2006, 22:54

Hm mein Problem:

lspci gibts nicht mehr (habs seit 10.1-installation auch noch nicht gebraucht)

paar infos:

pciutils 2.2.1-14
lspci liegt auch in /sbin
ja ich habs auch als root ausgeführt
hm Rest siehe Signatur


Hoffe jemand kann mir helfen? :?

Liebe Grüsse
Zuletzt geändert von b2890x am 4. Jun 2006, 23:24, insgesamt 1-mal geändert.

Werbung:
Freecoffee
Guru
Guru
Beiträge: 1750
Registriert: 29. Sep 2004, 17:00
Wohnort: Bayern

Beitrag von Freecoffee » 4. Jun 2006, 23:03

lspci liegt wie du auch schreibst in /sbin. Ich verstehe nicht, wo dein Problem liegt... :roll:
Gruß, Freecoffee

b2890x
Member
Member
Beiträge: 85
Registriert: 15. Jan 2006, 10:11
Wohnort: 3.OG.mi.

Beitrag von b2890x » 4. Jun 2006, 23:05

Nabend, das ist mein Problem:

Code: Alles auswählen

maik@linux:/sbin> lspci
bash: lspci: command not found

hm edit: ok Dummheit ./lspci geht - nur wieso geht das nicht mehr auf die "normale" Art und Weise ohne das aus dem Verzeichnis aufzurufen

Grothesk
Ultimate Guru
Ultimate Guru
Beiträge: 14662
Registriert: 26. Okt 2003, 11:52
Wohnort: Köln

Beitrag von Grothesk » 4. Jun 2006, 23:10

Wie hast du dich als root angemeldet?
Mit 'su' oder mit 'su -'?
Das macht nämlich einen Unterschied bei den Pfaden aus.
"Die Rechtschreibung ist Freeware, du darfst sie kostenlos nutzen. Allerdings ist sie nicht OpenSource, d.h. du sollst sie nicht verändern oder in veränderter Form veröffentlichen."

b2890x
Member
Member
Beiträge: 85
Registriert: 15. Jan 2006, 10:11
Wohnort: 3.OG.mi.

Beitrag von b2890x » 4. Jun 2006, 23:15

Ich habs mit 'sudo' gemacht - scheint nicht zu gehen, warum eigentlich nicht? Hab ich wohl ein falsches verständniss vom Befehl!? Mit 'su' und 'su-' ging das jeweils.

Tut mir leid wenn ich mal wieder voreilig meinen Verstand verworfen hab - aber das mit 'sudo' koenntet ihr mir vielleicht noch erklären?

Freecoffee
Guru
Guru
Beiträge: 1750
Registriert: 29. Sep 2004, 17:00
Wohnort: Bayern

Beitrag von Freecoffee » 4. Jun 2006, 23:19

sudo führt ein Programm mit root-Rechten in deiner Umgebung aus, su schaltet in die Umgebung des Nutzers root um. In deiner PATH-Variablen sind naturgemäß /sbin und /usr/sbin nicht enthalten, wohl aber in der vom Nutzer root. :)
Gruß, Freecoffee

b2890x
Member
Member
Beiträge: 85
Registriert: 15. Jan 2006, 10:11
Wohnort: 3.OG.mi.

Beitrag von b2890x » 4. Jun 2006, 23:24

Oh alles klar, vielen Dank. Gute Nacht wünsch ich. :wink:

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 2 Gäste