Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

MBR durch Grub total verändert - DriveCrypt-Abfrage weg!

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Gesperrt
Oli-nux
Hacker
Hacker
Beiträge: 500
Registriert: 28. Mai 2004, 17:05

MBR durch Grub total verändert - DriveCrypt-Abfrage weg!

Beitrag von Oli-nux » 19. Mai 2006, 15:44

Hi,

es war so, dass ich bisher immer Suse 9.0 neben Windows installiert hatte.
Grub war auch nicht aktiv, d.h. ich konnte Suse nur immer über die DVD starten - was ich auch so wollte.
Es ist so, dass ich Partitionen unter Windows mittels DriveCrypt Plus Pack verschlüsselt habe und über dieses DriveCrpyt in den MBR eine Anmeldung aktiviert habe.
Man kann Windows also nur starten, wenn man das Passwort für diese DriveCrypt-Anmeldung kennt (Linux war ja unsichtbar).
Heute habe ich mir Suse 10.0 drauf installiert (9.0 Partition gelöscht) und logischerweise hat der Grub sich eingetragen.
Nun wenn ich den Rechner starte erscheint Grub, doch wenn ich den Eintrag Windows auswähle, dann startet er ohne die DriveCrypt-Abfrage mein Windows.:?
Wie kann ich das wieder so hinbiegen, dass die DriveCrypt-Abfrage, wenn man Windows starten will, wieder erscheint?
Muss ich den Grub evtl. irgendwie auf Diskette machen und somit wieder aus den MBR entfernen?

Ist sehr wichtig!!!!
http://mainschleifen-angler.de.vu Textilen- & Geschenke-Shop

Werbung:
towo
Moderator
Moderator
Beiträge: 3708
Registriert: 15. Feb 2004, 16:42
Wohnort: Nimritz
Kontaktdaten:

Beitrag von towo » 19. Mai 2006, 18:18

Muss ich den Grub evtl. irgendwie auf Diskette machen und somit wieder aus den MBR entfernen?
Vermutlich.
Ist sehr wichtig!!!!
Ja,ja.
Signatur nach Diktat spazieren gegangen

Bild

Benutzeravatar
geb-tm
Member
Member
Beiträge: 73
Registriert: 23. Feb 2006, 14:20
Wohnort: 04229
Kontaktdaten:

Beitrag von geb-tm » 20. Mai 2006, 09:30

Als stinkschnöder Anwender habe ich nicht wirklich Ahnung, nur soviel das mir klar ist, das der Verweis auf den Cryptographen durch den Verweis auf GURB ersetzt wurde. Ich glaube mal gelesen zu haben das der MBR-Inhalt vorher gesichert wird, mglw. hab ich das aber auch nur falsch verstanden.
Gibt es nicht auch eine Art MBR am Anfang einer Patition? Dort könnte man dann doch alternativ die Crypt-Abfrage platzieren.
Du siehst, ich habe nicht so recht den Durchblick, vielleicht taugt's aber wenigstens für einen neuen Gedankenansatz.
openSuSE 13.1 / KDE 4.11.5
Linux 3.11.10.-7 auf:
ASRock N68-VS3 FX CPU: AMD AII X3/450,
8GB RAM usw.

JohnDoe82
Newbie
Newbie
Beiträge: 1
Registriert: 20. Mär 2007, 12:48

Beitrag von JohnDoe82 » 20. Mär 2007, 18:22

DCPP (Drivecrypt Plus Pack von SecurStar) mit Linux zum laufen zu bringen bei verschlüsselter Windows Bootpartition ist nicht so leicht, aber es geht.

Da ich gerade mal wieder gekämpft habe und es wieder mal geschafft habe, hier direkt mal ein kleines Tutorial:

Zunächst die Partitionierung:
Partition Mount-Point Größe/Anm.
------------------------------------------------
hda1 /boot ca. 50-100 MB (am ANFANG der Festplatte!!!!!)
hda2 C: WINDOWS Boot (nachher verschlüsselt)

dies sind zunächst die primären Partitionen.
Nun erstelle man eine "Erweiterte Partition"
in die kommt dann noch:

hda3 D: WINDOWS Daten (nachher verschlüsselt)
hda4 SWAP ab 128 - 512 MB bis zum 1,5fachen des eingebauten RAM
hda5 / Linux Partition

Nun Windose mit allem Kram auf C: und D: installieren und verschlüsseln.
Bootauth installieren.
Gucken ob alles danach ordentlich läuft.

Nun Linux installieren.
Bei Ende der Installation, aber VOR Installation des Bootloaders geht man am besten in ein Konsolenfenster (bspw. STRG+ALT+F2)

Die Grub/Linux-Bootpartition mounten:

mkdir /mnt/boot
mount /dev/hda1 /mnt/boot

cd /mnt/boot

nun mit dd den aktuellen BOOTAUTH MBR sichern:

dd if=/dev/hda of=winxp.mbr bs=512 count=1

nun müssten wir in unserem /boot-Verzeichnis eine Datei "winxp.mbr" haben mit der Dateigröße 512 Bytes.

das ist unser bootauth-MBR.

nun weiter bei der Linux-Installation den Bootloader GRUB installieren.

einen Chainloader Eintrag bspw. mit dem Namen "Windows XP" vorsehen,
aber außer dem Namen nicht groß konfigurieren...

GRUB schön ordentlich in den MBR, die Bootpartition und /dev/hda oder /dev/hda1 installieren.
Aber das funzt leider nicht.

Vor dem ersten Neustarten (um weiter zu installieren) müssen wir dann noch die menu.lst im ordner /boot/grub bearbeiten (z.B. mit vi).

irgendwo da drin steht "title Windows XP" für unseren vorher eingetragenen Bootmenüeintrag für Windose.
wenn wir die Stelle gefunden haben, dann muß dort folgendes eingestellt sein:
rootnoverify (hd0,1) ###///--->>> das setzt C: als aktive Partition, damit Bootauth auch gefunden wird
chainloader (hd0,0)/winxp.mbr ###///--->>> hier wird nun der alte Drive Crypt MBR gebootet


Wenn man danach das Setup fertig hat und Linux neu booten will, dann kommt in der Regel ERST der BOOTAUTH - Screen und danach GRUB.
Was ja falsch ist...

wenn wir nun im GRUB angelangt sind, dann müssen wechsele man noch mit ESC in den Textmode und dann mit "c" in die Konsole von GRUB.

jetzt mit dem Befehl
setup (hd0)
den MBR überschreiben.

und mit "reboot" neustarten

danach hab ich nochmal mit der Installations-CD1/DVD über die Installation/Reparatur den Bootloader mit dem Expertenwerkzeug repariert.
Dann wieder die menu.lst anpassen, denn die wird da immer wieder falsch umgeschrieben.

Und fertig.
Demnächst gibts mal nen besseres Tutorial.
Aber bitte meldet euch einfach bei Probleme hier oder per PN oder Mail.

VG JD.

towo
Moderator
Moderator
Beiträge: 3708
Registriert: 15. Feb 2004, 16:42
Wohnort: Nimritz
Kontaktdaten:

Beitrag von towo » 20. Mär 2007, 18:25

Sehr schön.

Aber

1. solltest Du sowas ins Wiki schreiben
und
2. solltest Du mal auf das Datum des letzten Postes gucken!

Sowas nennt man Leichefledderei.

Closed
Signatur nach Diktat spazieren gegangen

Bild

Gesperrt

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast