Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

Error activating XKB mit NX

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Antworten
linuxn00b
Newbie
Newbie
Beiträge: 30
Registriert: 21. Jan 2005, 20:03

Error activating XKB mit NX

Beitrag von linuxn00b » 17. Mär 2006, 10:23

Hallo zusammen.
Ich habe einen FreeNX-Server laufen, bekomme aber beim Starten von Gnome folgende Meldung: "Error activating XKB configuration".
Dies lässt sich beheben, wenn man nachher als eingeloggter user "/usr/bin/X11/setxkbmap -rules xfree86 -model pc104 -layout us -option "" " eingibt. Dies soll aber immer gestartet werden. Wie kann ich denn ein default-x-script ausführen lassen? Oder noch besser: gibt es eine generelle Lösung für das Problem?

Danke
n00b

Werbung:
linuxn00b
Newbie
Newbie
Beiträge: 30
Registriert: 21. Jan 2005, 20:03

Beitrag von linuxn00b » 17. Mär 2006, 10:56

Was ich noch hinzufügen sollte: er meldet mir beim Fehler, dass Xfree86 das Problem hervorrufen würde, aber das benutze ich garnicht mehr, ich nutze jetzt Xorg.

linuxn00b
Newbie
Newbie
Beiträge: 30
Registriert: 21. Jan 2005, 20:03

Beitrag von linuxn00b » 21. Mär 2006, 10:14

Kann man denn nirgendwo ein startup-script erstellen, dass dann automatisch beim einloggen gestartet wird?

linuxn00b
Newbie
Newbie
Beiträge: 30
Registriert: 21. Jan 2005, 20:03

Beitrag von linuxn00b » 21. Mär 2006, 12:49

Ich formuliere es am besten nochmal neu:
Also, ich möchte per Freenx ein gnome starten. Das klappt auch. Aber ich bekomme eine Fehlermeldung " "Error activating XKB configuration"." Das Tastaturlayout ist dann auf englisch umgestellt. Wenn ich, wie hier angegeben (http://openfacts.berlios.de/index-en.ph ... FAQ/Server) " /usr/bin/X11/setxkbmap -rules xfree86 -model pc104 -layout us -option """, allerdings mit de statt us, eingebe, dann habe ich wieder ein deutsches layout. Das möchte ich aber gern automatisieren. Geht sowas? Ich habe schon für den user eine .Xsession und eine .xinitrc erstellt, wo "#!/bin/bash" und oben genannter Befehl eingetragen ist, aber das hilft nicht.
Ich bin echt am verzweifeln...

rolle
Guru
Guru
Beiträge: 3724
Registriert: 4. Mai 2004, 21:50
Kontaktdaten:

Beitrag von rolle » 21. Mär 2006, 19:00

http://www.linux-club.de/viewtopic.php?t=56303
Sieh Dir mal diese Lösung an.
Horrido, Roland

Für meine Postings gilt außer bei Zitaten hier im Linux-Club die Creative Commons.

linuxn00b
Newbie
Newbie
Beiträge: 30
Registriert: 21. Jan 2005, 20:03

Beitrag von linuxn00b » 22. Mär 2006, 10:59

Ich bin jetzt auf XFCE4 umgestiegen. Dort kann man scripts in ~./Desktop/Autostart setzen, die dann automatisch ausgeführt werden. Trotzdem danke

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 3 Gäste