Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

powersave ERROR

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Antworten
cc
Member
Member
Beiträge: 56
Registriert: 17. Jan 2004, 23:44

powersave ERROR

Beitrag von cc » 13. Mär 2006, 10:31

hallo

habe opensuse 10.0:

Code: Alles auswählen

linux:~ # uname -a
Linux linux 2.6.13-15.8-default #1 Tue Feb 7 11:07:24 UTC 2006 i686 i686 i386 GNU/Linux
und bekomme solche Fehlermeldungen:

Code: Alles auswählen

linux:~ # cat /var/log/messages
Mar 12 01:13:39 linux kernel: ACPI: PCI Interrupt Link [LNKA] enabled at IRQ 5
Mar 12 01:13:39 linux kernel: PCI: setting IRQ 5 as level-triggered
Mar 12 01:13:39 linux kernel: ACPI: PCI Interrupt 0000:00:10.0[A] -> Link [LNKA] -> GSI 5 (level, low) -> IRQ 5
Mar 12 01:13:39 linux [powersave]: ERROR (CPUFreq_Kernel:21) Can not set ondemand governor, maybe your cpufreq driver is too slow.
Mar 12 01:13:39 linux kernel: uhci_hcd 0000:00:10.0: UHCI Host Controller
Mar 12 01:13:39 linux [powersave]: ERROR (CPUFreq_Kernel:23) Try CPUFREQ_CONTROL=userspace in /etc/sysconfig/powersave/cpufreq.
Mar 12 01:13:39 linux kernel: uhci_hcd 0000:00:10.0: new USB bus registered, assigned bus number 1
Mar 12 01:13:39 linux [powersave]: ERROR (PM_Interface:231) Cannot create cpufreq objects
Mar 12 01:13:39 linux kernel: uhci_hcd 0000:00:10.0: irq 5, io base 0x0000e000
Mar 12 01:13:39 linux kernel: hub 1-0:1.0: USB hub found
Mar 12 01:13:39 linux kernel: hub 1-0:1.0: 2 ports detected
Mar 12 01:13:39 linux kernel:     ACPI-0212: *** Warning: Device is not power manageable
Mar 12 01:13:39 linux kernel: ACPI: PCI Interrupt 0000:00:10.1[B] -> Link [LNKB] -> GSI 11 (level, low) -> IRQ 11
die kiste hängt sich auch ab und zu auf mit der powersave error, vor allem nach dem aufstarten.
was ist da faul ?
Zuletzt geändert von cc am 15. Mär 2006, 14:23, insgesamt 2-mal geändert.

Werbung:
Grothesk
Ultimate Guru
Ultimate Guru
Beiträge: 14662
Registriert: 26. Okt 2003, 11:52
Wohnort: Köln

Beitrag von Grothesk » 13. Mär 2006, 10:38

Nichts.


Bzw. es ist dann etwas faul, wenn dein Prozessor das eigentlich können solle. Aber den hast du uns ja vorenthalten...
"Die Rechtschreibung ist Freeware, du darfst sie kostenlos nutzen. Allerdings ist sie nicht OpenSource, d.h. du sollst sie nicht verändern oder in veränderter Form veröffentlichen."

cc
Member
Member
Beiträge: 56
Registriert: 17. Jan 2004, 23:44

Beitrag von cc » 15. Mär 2006, 14:21

Grothesk hat geschrieben:Nichts.


Bzw. es ist dann etwas faul, wenn dein Prozessor das eigentlich können solle. Aber den hast du uns ja vorenthalten...
und wie kann ich überprüfen, ob mein processor dies wirklich kann ?


habe etwas zu diesem thema gefunden:

http://de.opensuse.org/SDB:ACPI_Suspend ... powersaved

bei mir läuft wirklich beides: acpid und powersaved

wollte acpid vom startup deaktivieren, aber bekomme folgende Meldung:

Code: Alles auswählen

linux:~ # insserv -r acpid
insserv: Service acpid has to be enabled for service haldaemon
insserv: exiting now!
soll ich haldaemon ebenfalls ausser gefecht setzen ?

flo41
Hacker
Hacker
Beiträge: 290
Registriert: 9. Feb 2005, 11:47

Beitrag von flo41 » 15. Mär 2006, 15:31

herausfinden welchen Prozessor du hast und was er alles kann:

Code: Alles auswählen

/cat/cpuinfo

cc
Member
Member
Beiträge: 56
Registriert: 17. Jan 2004, 23:44

Beitrag von cc » 15. Mär 2006, 15:52

Code: Alles auswählen

linux:/proc # cd /proc
linux:/proc # cat cpuinfo
processor       : 0
vendor_id       : GenuineIntel
cpu family      : 15
model           : 2
model name      : Intel(R) Pentium(R) 4 CPU 2.00GHz
stepping        : 4
cpu MHz         : 2000.161
cache size      : 512 KB
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 2
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm
bogomips        : 4003.83

cc
Member
Member
Beiträge: 56
Registriert: 17. Jan 2004, 23:44

Beitrag von cc » 15. Mär 2006, 20:56

wenn ich versuche powersaved in yast zu deaktivieren, dann bekomme ich folgende Meldung:

Code: Alles auswählen

to disable service acpid in all runlevels,
these service must be additionally disabled,
because the deped on it:
powersaved, haldaemon
und nach dem restart bekomme sehr viele probleme.
es scheint bei suse 10 man kann nicht einfach acpid deaktivieren, ohne powesaved auch zu deaktivieren.

cc
Member
Member
Beiträge: 56
Registriert: 17. Jan 2004, 23:44

Beitrag von cc » 17. Mär 2006, 16:36

habe sogar BIOS updatet, aber es hilft nicht weiter.

meine Power Management BIOS settings sehen folgendermassen aus:

Code: Alles auswählen

ACPI AWARE O/S                   YES
POWER MANAGEMENT                 ENABLED
SUSPEND TIME OUT (MIN.)          DISABLED
HARD DISK TIME OUT (MIN.)        DISABLED
PWR BUTTON < 4 SEC               INSTANT OFF
RESTORE ON AC/POWER LOSS         POWER OFF
RESUME ON RTC ALARM              DISABLED
RTC ALARM DATE                   15
RTC ALARM HOUR                   12
RTC ALARM MINUTE                 30
RTC ALARM SECOND                 30
LAN / RING POWER ON              DISABLED


vielleicht handelt sich um einen BUG in verbindung mit gewisser hardware ?

flo41
Hacker
Hacker
Beiträge: 290
Registriert: 9. Feb 2005, 11:47

Beitrag von flo41 » 17. Mär 2006, 21:00

hast du dir die Fehlermelung ueberhaupt durchgelesen???
Da steht doch ganz eindeutig das wenn du acpi deaktivierst (was du anscheinend versucht hast) auch noch powersaved und haldaemon deaktiviert werden muessen ....
wer lesen kann ist klar im vorteil :roll:

cc
Member
Member
Beiträge: 56
Registriert: 17. Jan 2004, 23:44

Beitrag von cc » 17. Mär 2006, 21:12

flo41 hat geschrieben:hast du dir die Fehlermelung ueberhaupt durchgelesen???
Da steht doch ganz eindeutig das wenn du acpi deaktivierst (was du anscheinend versucht hast) auch noch powersaved und haldaemon deaktiviert werden muessen ....
wer lesen kann ist klar im vorteil :roll:
hast du meine postings genau gelesen ?

die Fehlermeldung habe genau gelesen, aber wollte nur ausprobieren,

was suse auf seiner support seite behauptet:

http://de.opensuse.org/SDB:ACPI_Suspend ... powersaved

cc
Member
Member
Beiträge: 56
Registriert: 17. Jan 2004, 23:44

Beitrag von cc » 15. Aug 2006, 00:05

Dieses problem ist immer noch nicht behoben !
Jedesmal nach dem Aufstarten verfolgt mich diese Fehlermeldung:

Code: Alles auswählen

Der powersave-Daemon läuft nicht.
Durch Starten desselben verbessert sich die Leistung: /usr/sbin/rcpowersaved start
Alle Online Updates helfen bis jetzt nicht.

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast