Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

[gelöst]MySql 4.1.13

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Antworten
Benutzeravatar
pertincoion
Newbie
Newbie
Beiträge: 15
Registriert: 26. Okt 2005, 07:05

[gelöst]MySql 4.1.13

Beitrag von pertincoion » 8. Feb 2006, 11:50

Hallo!

Habe schon Onkel Google gefragt und einige Foren besucht und dort gesucht, aber leider keine Lösung gefunden, die mir hilft.

Ich habe Cao-Faktura über Wine zum laufen gebracht jedoch habe ich ein Problem mit der Anmeldung in meine MySQL. Wenn ich richtig liege, hat dass was mit 'old_passwords' zu tun. Wenn ich versuche mich einzuloggen, dann sagt er mir:
Der Server ist nicht erreichbar!!
Client does not support authentication protocol requested by server; consider upgrading MySQL client
Dies ist, wenn ich das Passwort mit eingebe.
Ohne Passwort ist der Server erreichbar
Der Server ist erreichbar, jedoch wurde der Zugriff verweigert!
Ich habe schon im MySQL-Administrator die Einstellung auf old_passwords eingestellt. Leider kein Ergebnis (nach restart von MySQL).

In der my.cnf habe ich dann gesehen, dass der Admistrator 'old_passwords' eingetragen hat, habe ich geändert auf 'old_passwords', kein Ergebnis.

Wie kann ich zu einem Ergebnis kommen?

Ich benutze SuSE 10.0 und MySQL 4.1.13-Max.

Gruss Sven
Zuletzt geändert von pertincoion am 9. Feb 2006, 07:01, insgesamt 1-mal geändert.

Werbung:
Benutzeravatar
whois
Administrator
Administrator
Beiträge: 16599
Registriert: 11. Okt 2004, 08:50
Wohnort: Aachen
Kontaktdaten:

Beitrag von whois » 8. Feb 2006, 12:04

Hi

Vielleicht hilft dir der Link.

SQL TUTORITAL

Ich habe noch nie mit Cao-Faktura gearbeitet und weiss daher auch nicht wie die Anbindung funktioniert.

Benutzeravatar
panamajo
Guru
Guru
Beiträge: 2585
Registriert: 12. Feb 2005, 22:45

Re: MySql 4.1.13

Beitrag von panamajo » 8. Feb 2006, 12:21

pertincoion hat geschrieben: Ich habe Cao-Faktura über Wine zum laufen gebracht jedoch habe ich ein Problem mit der Anmeldung in meine MySQL. Wenn ich richtig liege, hat dass was mit 'old_passwords' zu tun. Wenn ich versuche mich einzuloggen, dann sagt er mir:
Der Server ist nicht erreichbar!!
Client does not support authentication protocol requested by server; consider upgrading MySQL client
[...]
Ich habe schon im MySQL-Administrator die Einstellung auf old_passwords eingestellt. Leider kein Ergebnis (nach restart von MySQL).
Ich nehme an du verwendest einen ODBC Treiber? Leider verschweigt die Doku dass die aktuelle stable Version 3.* sich wie ein 3.* Client verhält - deine Vermutung eines Zusammenhangs mit old_passwords ist IMO korrekt.

Aber: das setzen von old_passwords in my.cnf bewirkt nur, das neue Passwörter nach einem Neustart des Dienstes im alten Format angelegt werden. Also nicht, dass bestehende Passwörter funktionieren.

Man kann das alte Format mit der Funktion OLD_PASSWORD erzwingen:

Code: Alles auswählen

mysql> USE mysql;
mysql> UPDATE user SET Password=OLD_PASSOWD('klartext') WHERE user='benutzer';
MySQL Privileges danach neu laden.

Benutzeravatar
pertincoion
Newbie
Newbie
Beiträge: 15
Registriert: 26. Okt 2005, 07:05

Beitrag von pertincoion » 8. Feb 2006, 13:47

Danke!

Habe MySQL deinstalliert und wieder installiert, jetzt funzt Cao soweit (muss erstmal testen). Aber fragt mich bitte nicht wieso dass jetzt funtioniert, ich weiss es leider auch nicht...

Gruss Sven

Benutzeravatar
pertincoion
Newbie
Newbie
Beiträge: 15
Registriert: 26. Okt 2005, 07:05

Beitrag von pertincoion » 9. Feb 2006, 07:00

Hallo!

Habe nochmal darüber nachgedacht, warum es jetzt funktioniert.

Ich hatte den Tip von panamajo ausprobiert, danach konnte ich micht trotz restart von MySQL nicht einloggen (ist aber wohl ein wichtiger Punkt). Nachdem ich 'sauer' war hatte ich MySQL deinstalliert, wieder neu installiert und gestartet und siehe da, ich konnte mich mit dem User/Passwort das ich mit panamajos Hilfe freigeschaltet habe, einloggen (aber auch nur mit diesem, da ich Testweise auch andere in meiner Datenbank befindliche User/Passwörter ausprobiert hatte und die gleiche Fehlermeldung kam).

Nochmals Danke

Sven

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 3 Gäste