Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

RealVNC auflösung umstellen

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Antworten
cyberflyer2002
Newbie
Newbie
Beiträge: 42
Registriert: 6. Jun 2004, 00:37
Kontaktdaten:

RealVNC auflösung umstellen

Beitrag von cyberflyer2002 » 6. Feb 2006, 15:32

Hi Leute,

ich hab RealVNC auf meinem Linux Pc installiert und greife von Windows darauf zu. Es funktioniert auch relativ gut. Nur hab ich leider ein Paar Probleme.

1.) Wie kann man die Auflösung umstellen?
Benutze unter Linux und Windows 1280x1024. Jedoch wenn ich von Windows auf Linux verbinde wird immer nur ein Fenster mit 1024x768 geöffnet. Hab in der /root/.vnc/xstartup die geometry schon auf 1280x1024 gestellt was leider aber nichts geholfen hat.

2.)Wo kann man einstellen das beim Verbinden kein Passwort abgefragt wird ?

3.) Wie kann ich den VNC-Server automatisch beim Starten laden lassen? Geht es auch irgendwie das man einstellt das beim Verbinden der Anmeldebilschirm kommt wo man sich dann am System anmelden kann ?

4.) Nach dem erfolgreichen einloggen kommt immer eine console und vnc config. Kann man das irgendwie deaktivieren?

Danke für die Hilfe

Werbung:
rolle
Guru
Guru
Beiträge: 3724
Registriert: 4. Mai 2004, 21:50
Kontaktdaten:

Beitrag von rolle » 6. Feb 2006, 16:24

Was hast Du für ein Linux, wie startest Du den VNC-Server, hast Du das Howto hier im Forum gelesen?
Horrido, Roland

Für meine Postings gilt außer bei Zitaten hier im Linux-Club die Creative Commons.

cyberflyer2002
Newbie
Newbie
Beiträge: 42
Registriert: 6. Jun 2004, 00:37
Kontaktdaten:

Beitrag von cyberflyer2002 » 6. Feb 2006, 17:22

ich nutze Suse Linux 10.0. Das Howto hab ich noch nicht gelesen, da ich es nicht gefunden habe. Vielleicht kannst mir ja bitte den Link posten.

Der VNC-Server wurde bisher von mir händisch gestartet.

danke

Benutzeravatar
haveaniceday
Hacker
Hacker
Beiträge: 775
Registriert: 7. Jul 2004, 14:09
Wohnort: Paderborn

Beitrag von haveaniceday » 6. Feb 2006, 21:14

Meine VNC-Settings werden dort geholt:

cat /etc/xinetd.d/vnc

Code: Alles auswählen

# default: off
# description: This serves out a VNC connection which starts at a KDM login \
#       prompt. This VNC connection has a resolution of 1024x768, 16bit depth.
service vnc1
{
        disable         = no
        socket_type     = stream
        protocol        = tcp
        wait            = no
        user            = nobody
        server          = /usr/X11R6/bin/Xvnc
        server_args     = :42 -inetd -once -query localhost -geometry 1024x768 -depth 16
        type            = UNLISTED
        port            = 5901
}
# default: off
# description: This serves out a VNC connection which starts at a KDM login \
#       prompt. This VNC connection has a resolution of 1280x1024, 16bit depth.
service vnc2
{
        type            = UNLISTED
        port            = 5902
        socket_type     = stream
        protocol        = tcp
        wait            = no
        user            = nobody
        server          = /usr/X11R6/bin/Xvnc
        server_args     = :42 -inetd -once -query localhost -geometry 1280x1024 -depth 16
        disable         = no
}
# default: off
# description: This serves out a VNC connection which starts at a KDM login \
#       prompt. This VNC connection has a resolution of 1600x1200, 16bit depth.
service vnc3
{
        type            = UNLISTED
        port            = 5903
        socket_type     = stream
        protocol        = tcp
        wait            = no
        user            = nobody
        server          = /usr/X11R6/bin/Xvnc
        server_args     = :42 -inetd -once -query localhost -geometry 1016x744 -depth 16
        disable         = no
}
# default: off
# description: This serves out the vncviewer Java applet for the VNC \
#       server running on port 5901, (vnc port 1).
service vnchttpd1
{
        disable         = yes
        socket_type     = stream
        protocol        = tcp
        wait            = no
        user            = nobody
        server          = /usr/X11R6/bin/vnc_inetd_httpd
        server_args     = 1024 768 5901
        type            = UNLISTED
        port            = 5801
}
# default: off
# description: This serves out the vncviewer Java applet for the VNC \
#       server running on port 5902, (vnc port 2).
service vnchttpd2
{
        type            = UNLISTED
        port            = 5802
        socket_type     = stream
        protocol        = tcp
        wait            = no
        user            = nobody
        server          = /usr/X11R6/bin/vnc_inetd_httpd
        server_args     = 1280 1024 5902
        disable         = yes
}
# default: off
# description: This serves out the vncviewer Java applet for the VNC \
#       server running on port 5902, (vnc port 3).
service vnchttpd3
{
        type            = UNLISTED
        port            = 5803
        socket_type     = stream
        protocol        = tcp
        wait            = no
        user            = nobody
        server          = /usr/X11R6/bin/vnc_inetd_httpd
        server_args     = 1600 1200 5903
        disable         = yes
}
vncviewer :1 1024x768
vncviewer :2 1280x1024


Haveaniceday

PS: + xinetd muss gestartet werden
The gates in my computer are AND,OR and NOT, not Bill.
Wer lesen kann und dann noch die Suche bedienen kann ist klar im Vorteil 8)

cyberflyer2002
Newbie
Newbie
Beiträge: 42
Registriert: 6. Jun 2004, 00:37
Kontaktdaten:

Beitrag von cyberflyer2002 » 6. Feb 2006, 21:28

hi Haveaniceday


was ist bitte xinetd.d ? ich benutze realvnc. ich glaub das ist etwas anderes.

kennst du vielleicht ein programm außer realvnc das ich verwenden könnte ?


gruß

rolle
Guru
Guru
Beiträge: 3724
Registriert: 4. Mai 2004, 21:50
Kontaktdaten:

Beitrag von rolle » 6. Feb 2006, 21:39

http://www.linux-club.de/viewtopic.php?t=41289

edit: Wenn Du SuSE nutzt, dann vergiß den RealVNC und nimm TightVNC, das ist dort schon mit dabei.
Horrido, Roland

Für meine Postings gilt außer bei Zitaten hier im Linux-Club die Creative Commons.

cyberflyer2002
Newbie
Newbie
Beiträge: 42
Registriert: 6. Jun 2004, 00:37
Kontaktdaten:

Beitrag von cyberflyer2002 » 7. Feb 2006, 18:25

Danke rolle.

Ich habe nun diesen TightVNC installiert und wenn ich den Server von hand starte funktioniert es auch mit meiner vorgegebenen Auflösung.

Nur habe ich leider wieder ein Problem und zwar funktioniert es nicht wenn ich den vnc Dienst mit dem xinetd starten lasse. Es kommt zwar das Login Fenster aber leider wieder nur in der 1024x768 Auflösung.

Ich weiß das es drei verschiede Modis gibt einmal 1024x768,1280x1200 und 1600x1200.

Nur wie greife ich auf den zweiten zu ?
Mit 192.168.0.1:2 hat es mal nicht funktioniert


danke

rolle
Guru
Guru
Beiträge: 3724
Registriert: 4. Mai 2004, 21:50
Kontaktdaten:

Beitrag von rolle » 7. Feb 2006, 19:33

Du kannst in YaST-Netzwerkdienste-xinetd auswählen, welche der drei möglichen Auflösungen bzw. welche der Server laufen sollen. Hast Du da auch denjenigen mit der gewünschten Auflösung aktiviert?
Horrido, Roland

Für meine Postings gilt außer bei Zitaten hier im Linux-Club die Creative Commons.

cyberflyer2002
Newbie
Newbie
Beiträge: 42
Registriert: 6. Jun 2004, 00:37
Kontaktdaten:

Beitrag von cyberflyer2002 » 7. Feb 2006, 19:36

ja hab ich gemacht laufen alle drei !

Antworten