Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

xrdp server ( rdesktop-server für Linux ) geht/is working !

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Benutzeravatar
haveaniceday
Hacker
Hacker
Beiträge: 775
Registriert: 7. Jul 2004, 14:09
Wohnort: Paderborn

Beitrag von haveaniceday » 26. Okt 2006, 21:59

Schau mal in den Logdateien. Ist Xvnc richtig eingerichtet und
funktioniert ?

Viele Grüße,

Haveaniceday

PS: Bei mir sieht das sesman log so aus:

Code: Alles auswählen

home:/usr/local/xrdp # more sesman.log
[20060731-18:23:08] [DEBUG] starting sesman with pid 1948
[20060731-18:23:08] [DEBUG] listening...
[20060731-18:24:43] [DEBUG] granted TS access to user me
[20060731-18:25:08] [DEBUG] starting Xvnc session...
[20060731-20:21:44] [DEBUG] shutting down sesman 1
[20060731-20:21:44] [DEBUG] shutting down sesman 1
[20060801-01:03:18] [DEBUG] starting sesman with pid 4601
[20060801-01:03:18] [DEBUG] listening...
[20060801-01:04:26] [DEBUG] granted TS access to user me
[20060801-01:04:26] [DEBUG] starting Xvnc session...
[20060801-01:49:07] [DEBUG] shutting down sesman 1
[20060801-01:49:07] [DEBUG] shutting down sesman 1
The gates in my computer are AND,OR and NOT, not Bill.
Wer lesen kann und dann noch die Suche bedienen kann ist klar im Vorteil 8)

Werbung:
yankee927
Newbie
Newbie
Beiträge: 3
Registriert: 26. Okt 2006, 09:45
Wohnort: zu Hause

Beitrag von yankee927 » 27. Okt 2006, 09:43

Moins,

muss das mit XVNC unbedingt so sein, ich nutz hier RDP und wollt es auch weiter nutzen.

Nun mal ein anderes Problem zum selben Thema *gg* - ich wollte das auch mal bei ner anderen Distrib. ausprobieren, hab Fedora Core 4 auf nen PC geschmissen (nicht wundern, arbeite in nem "Rechenzentrum)...so da geht auch alles wunderbar auf anhieb, wenn PAM, GCC und OpenSSL drauf ist, nur wenn ich verbinde kommt

started connection
connectting to sesman
sending login info to sesman
receiving sesman header
receiving sesman data
sesman started a session <-- ich hatte mich schon gefreut
connectiong to 127.0.0.1 5910 <-- warum auch immer
error - problem connecting

So da es diesen Fehler hier schon mal gibt von >TBT<...würd ich ja auch gerne die Lösung ausprobieren. NUR ICH FIND DIE DATEI
---> DISPLAYMANAGER <--- nicht und
---> SuSEconfig <---gibts bei Fedora glaub ich auch nicht.

Hat jmd. ne Lösung für mich..........?

DANKE

mfg
yankee927

Benutzeravatar
haveaniceday
Hacker
Hacker
Beiträge: 775
Registriert: 7. Jul 2004, 14:09
Wohnort: Paderborn

Beitrag von haveaniceday » 27. Okt 2006, 13:20

connectiong to 127.0.0.1 5910

=> Das ist die Verbindunganfrage an einen VNC-Server mit Display ":10".
Ein virtuellen X-Server wie z.B. Xvnc muss schon da sein.

Edit:
Die SuSE Sachen sollten nur das Konfigurieren des Xvnc vereinfachen.

Bei dir würde ich vorschlagen:
- Xvnc installieren
- vncviewer sollte mit dem Xvnc gehen
- dann xrdp probieren.

Haveaniceday
The gates in my computer are AND,OR and NOT, not Bill.
Wer lesen kann und dann noch die Suche bedienen kann ist klar im Vorteil 8)

yankee927
Newbie
Newbie
Beiträge: 3
Registriert: 26. Okt 2006, 09:45
Wohnort: zu Hause

Beitrag von yankee927 » 30. Okt 2006, 14:29

Moins,

ich werde das mal testen wenn ich wieder auf arbeit bin....nur so viel, auf SuSE 9.3 gehts wieder...ich hatte nur mal neugestartet und dann lief es...keine Ahnung warum.

Mfg
yankee927

GMastaP
Member
Member
Beiträge: 110
Registriert: 4. Mai 2004, 15:14

Beitrag von GMastaP » 11. Jan 2007, 11:42

es gibt mitlerweile nen Patch um das deutsche Tastatur Layout nutzen zu können inclusive Alt-Gr Taste.

um den Patch einzuspielen, muss das Source Packet, imo 0.3.2, geladen und entpackt werden. Anschließend muss der Patch gesaugt werden und im xrdp-0.3.2 verzeichnet geunzipped werden.

make && make install ausführen und fertig.
Play Russian Roulette In Bash, Just Run This Line as root:
# [ $[ $RANDOM % 6 ] == 0 ] && echo "rm -rf / You are busted" || echo "You live"

Be careful, don't do this if you don't know what will happen ......

tonosinai
Newbie
Newbie
Beiträge: 15
Registriert: 12. Jan 2005, 20:03
Wohnort: Mühltal
Kontaktdaten:

Beitrag von tonosinai » 6. Feb 2007, 13:27

:?: Wo bekomme ich den Patch?

Gruss

Stefan

mschmitz
Newbie
Newbie
Beiträge: 4
Registriert: 19. Jun 2007, 15:55

Beitrag von mschmitz » 19. Jun 2007, 16:17

Hallo @all

habe hier ein OpenSuSE 10.2 X64 System mit einem AMD Athlon 64 X2.

Habe xrdp 4.0 installiert und noch folgendes Problem:

ich kann mich nicht einloggen.
Es kommt immer:

Code: Alles auswählen

Jun 19 16:14:10 linux-terminal sesman[6744]: [INFO ] scp thread on sck 6 started successfully
Jun 19 16:14:10 linux-terminal sesman[6744]: pam_unix(sesman:auth): authentication failure; logname= uid=0 euid=0 tty= ruser= rhost=  user=root
Könnt Ihr mir hier helfen ?

hier die sessman.ini

Code: Alles auswählen

[Globals]
ListenAddress=127.0.0.1
ListenPort=3350
EnableUserWindowManager=1
UserWindowManager=startwm.sh
DefaultWindowManager=startwm.sh

[Security]
AllowRootLogin=1
MaxLoginRetry=4
TerminalServerUsers=tsusers
TerminalServerAdmins=tsadmins

[Sessions]
MaxSessions=10
KillDisconnected=0
IdleTimeLimit=0
DisconnectedTimeLimit=0

[Logging]
LogFile=./sesman.log
LogLevel=DEBUG
EnableSyslog=1
SyslogLevel=DEBUG

[X11rdp]
param1=-bs
param2=-ac

[Xvnc]
param1=-bs
param2=-ac
Danke

Gruß

mschmitz

Benutzeravatar
haveaniceday
Hacker
Hacker
Beiträge: 775
Registriert: 7. Jul 2004, 14:09
Wohnort: Paderborn

Beitrag von haveaniceday » 19. Jun 2007, 16:27

Ist vielleicht bei deinem Passwort ein y,z oder Sonderzeichen,
welches durch eine englische oder andere Tastatureinstellung
von xrdp falsch gelesen wird ?

=> Schau mal bei der sichtbaren Usereingabe ob die einzelnen
Zeichen von xrdp richtig angezeigt werden.

Haveaniceday
The gates in my computer are AND,OR and NOT, not Bill.
Wer lesen kann und dann noch die Suche bedienen kann ist klar im Vorteil 8)

Benutzeravatar
tomi-w80
Member
Member
Beiträge: 81
Registriert: 9. Okt 2005, 18:27
Wohnort: Quedlinburg
Kontaktdaten:

Beitrag von tomi-w80 » 7. Jan 2008, 14:18

Hallo zusammen,

habe den xrdp 0.4 installiert. Echt super Sache! Läuft fast alles, außer... Mein Server hängt in einer Windows Domain (ADS) und authentifiziert sich dort, weil Samba mit auf der Kiste läuft. An der Konsole kann ich mich mit DOMAIN\User einloggen, auch per SSH kein Problem. Lokal kann ich mich auch anmelden. Jetzt funktioniert die Authentifizierung per xrdp nicht. Es gibt nur einen lokalen User, das ist root. Mit dem kann ich den xrdp erfolgreich testen, bei anderen Usern kommt eben "Logon failed".

Wie kann ich xrdp überreden, die Authentifizierung von der ADS Domain mit zu nehmen? Ich habe eine Suse 10.2 laufen, bei dem ich im Yast die Authentifizierung per ADS aktiviert habe.

Ich denke, das läuft über Winbind.

Hat jemand eine Idee? Dann kann ich endlich der Geschäftsführung mal ein Suse per RDP zur Verfügung stellen :)

Gruß
Thomas
Suse Linux 11.1

http://www.warnecke-web.de - Meine Tutorialsammlung

hws
Newbie
Newbie
Beiträge: 1
Registriert: 12. Feb 2008, 11:48

Beitrag von hws » 12. Feb 2008, 11:58

Hallo,
ich habe xrdp (mit 6 Clients) installiert und dabei das Problem, dass die Sessions nicht (richtig) geschlossen werden, so dass nach einiger Zeit keine neuen Logins mehr möglich sind. Erst nach einem "/etc/init.d/xrdp_control restart" geht es weiter, ist natürlich keine Dauerlösung. Ich habe die MaxSessions mal auf 20 hochgesetzt, aber die Zahl wird anscheinend auch erreicht.

Hat jemand dazu Tipps??
[Sessions]
In einem anderen Forum hab ich gesehen, dass die Parameter (KillDisconnected), (IdleTimeLimit) und (DisconnectedTimeLimit)
mit Werten versehen waren.
In den Manuals steht aber, dass die letzten 3 Optionen noch nicht wirksam sind. Hat sich das nun geändert?
Danke für alle Antworten.

hws

Meine Sesman.ini:
[Globals]
ListenAddress=127.0.0.1
ListenPort=3350
EnableUserWindowManager=1
UserWindowManager=startwm.sh
DefaultWindowManager=startwm.sh

[Security]
AllowRootLogin=1
MaxLoginRetry=4
TerminalServerUsers=tsusers
TerminalServerAdmins=tsadmins

[Sessions]
MaxSessions=20
KillDisconnected=1
IdleTimeLimit=10
DisconnectedTimeLimit=1

[Logging]
LogFile=./sesman.log
LogLevel=DEBUG
EnableSyslog=0
SyslogLevel=DEBUG

[X11rdp]
param1=-bs
param2=-ac

[Xvnc]
param1=-bs
param2=-ac

Antworten