Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

xrdp server ( rdesktop-server für Linux ) geht/is working !

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Benutzeravatar
haveaniceday
Hacker
Hacker
Beiträge: 775
Registriert: 7. Jul 2004, 14:09
Wohnort: Paderborn

xrdp server ( rdesktop-server für Linux ) geht/is working !

Beitrag von haveaniceday » 3. Feb 2006, 18:20

( Als Keywords: Hab mal ein paar Stichworte und Texte in Englisch und Deutsch eingefügt. Hatte ziemlich mit Google gesucht, um das Projekt zu finden,
Remote Desktop Protocol server für/for Linux: xrdp-0.1.tar.gz works under SuSE 10.0)

Hallo Ihr,

hab gerade erfolgreich unter suse 10.0 http://xrdp.sourceforge.net/ kompiliert
und in Betrieb genommen.

Einzige Änderung:
- startwm.sh
> > #!/bin/sh
> > export PATH=$PATH:/opt/kde3/bin

Hi everybody,

I was able to compile and run http://xrdp.sourceforge.net/ as rdesktop-server for SuSE 10.0.
Only change I made: see above for "PATH" settings for startkde.

Best regards,

Haveaniceday

PS: SuSE 9.1 geht auch. Zu Installieren fürs make : openssl-devel pam-devel
The gates in my computer are AND,OR and NOT, not Bill.
Wer lesen kann und dann noch die Suche bedienen kann ist klar im Vorteil 8)

Werbung:
rolle
Guru
Guru
Beiträge: 3724
Registriert: 4. Mai 2004, 21:50
Kontaktdaten:

Beitrag von rolle » 3. Feb 2006, 23:24

Dankeschön, ich setze das mal als wichtig.
Horrido, Roland

Für meine Postings gilt außer bei Zitaten hier im Linux-Club die Creative Commons.

Benutzeravatar
haveaniceday
Hacker
Hacker
Beiträge: 775
Registriert: 7. Jul 2004, 14:09
Wohnort: Paderborn

Beitrag von haveaniceday » 4. Feb 2006, 00:05

Welche Ehre :oops:

Der Tastatur wird bei "de" nicht korrekt eingebunden. "qwerty" kommt.
Arbeite mal etwas daran..

Haveaniceday
The gates in my computer are AND,OR and NOT, not Bill.
Wer lesen kann und dann noch die Suche bedienen kann ist klar im Vorteil 8)

rolle
Guru
Guru
Beiträge: 3724
Registriert: 4. Mai 2004, 21:50
Kontaktdaten:

Beitrag von rolle » 4. Feb 2006, 00:15

Welche Ehre
Ehre, wem Ehre gebürt. :lol:
Horrido, Roland

Für meine Postings gilt außer bei Zitaten hier im Linux-Club die Creative Commons.

Pumphaus
Member
Member
Beiträge: 152
Registriert: 10. Jul 2005, 13:15
Kontaktdaten:

Beitrag von Pumphaus » 6. Feb 2006, 20:30

Hi,

find ich gut, dass es jetzt einen RDP-Server für Linux gibt. Allerdings wäre vielleicht eine kurze Beschreibung zur Benutzung nicht schlecht. Aus der "Doku" auf der Homepage komme ich irgendwie nich schlau :?:

Benutzeravatar
haveaniceday
Hacker
Hacker
Beiträge: 775
Registriert: 7. Jul 2004, 14:09
Wohnort: Paderborn

Beitrag von haveaniceday » 6. Feb 2006, 20:50

Download hier:

http://sourceforge.net/project/showfile ... _id=112022


1. tar xvzf xrdp-0.1.tar.gz
2. cd xrdp
3. make
4. als root: make install
5. /usr/local/xrdp/startwm.sh anpassen ( siehe oben )
6. Als root: /usr/local/xrdp/xrdpstart.sh

Und dann mit "rdesktop localhost" testen.
( Evtl. englische Tastaturbelegung, => in "User" Feld "y/z" testen
um Passwörter richtig einzugeben. )

Haveaniceday
Zuletzt geändert von haveaniceday am 6. Feb 2006, 21:38, insgesamt 1-mal geändert.
The gates in my computer are AND,OR and NOT, not Bill.
Wer lesen kann und dann noch die Suche bedienen kann ist klar im Vorteil 8)

Pumphaus
Member
Member
Beiträge: 152
Registriert: 10. Jul 2005, 13:15
Kontaktdaten:

Beitrag von Pumphaus » 6. Feb 2006, 21:33

beim ausführen von "rdesktop localhost" bekomm ich das hier (habs auch schon mit krdc probiert, gleiches ergebnis):
[...]~> rdesktop localhost
X Error of failed request: BadMatch (invalid parameter attributes)
Major opcode of failed request: 93 (X_CreateCursor)
Serial number of failed request: 566
Current serial number in output stream: 722

Benutzeravatar
haveaniceday
Hacker
Hacker
Beiträge: 775
Registriert: 7. Jul 2004, 14:09
Wohnort: Paderborn

Beitrag von haveaniceday » 6. Feb 2006, 21:40

Hab's oben mal ergänzt.
Als root: /usr/local/xrdp/xrdpstart.sh

Jetzt:
ps -ef | grep -e xrdp -e sesman

Die beiden Prozesse killen
Start als root und schon sollte es gehen.

Haveaniceday
The gates in my computer are AND,OR and NOT, not Bill.
Wer lesen kann und dann noch die Suche bedienen kann ist klar im Vorteil 8)

Pumphaus
Member
Member
Beiträge: 152
Registriert: 10. Jul 2005, 13:15
Kontaktdaten:

Beitrag von Pumphaus » 7. Feb 2006, 15:40

Das is cool :)
Danke :!:

Benutzeravatar
haveaniceday
Hacker
Hacker
Beiträge: 775
Registriert: 7. Jul 2004, 14:09
Wohnort: Paderborn

Beitrag von haveaniceday » 3. Mär 2006, 00:31

Small update...
Version 0.2 has already a corrected startwm.sh

You need some development packages for the compiling ( suse 10.0 )
openssl-devel
pam-devel

I am not sure if all DISPLAY* settings are required.
Also not sure how big the security whole "Open TCP port 6000" is.
This is just the description made for a secured intranet.

1. install openssl-devel and pam-devel as root
2. Do as regular user
3. tar xvzf xrdp-0.2.tar.gz
4. cd xrdp-0.2
5. make
6. rest to be done as root:
7. make install
8. Edit /etc/sysconfig/displaymanager:
DISPLAYMANAGER_REMOTE_ACCESS="yes"
DISPLAYMANAGER_STARTS_XSERVER="yes"
DISPLAYMANAGER_XSERVER_TCP_PORT_6000_OPEN="yes"
9. SuSEconfig
10. /usr/local/xrdp/xrdpstart.sh
11. log off as root


Test with: rdesktop -k de -g "100%" -a 24 localhost
or just with rdesktop localhost.

Do not forget to start xrdpstart.sh as root.

Haveaniceday

PS: Ich weiss nicht wie groß die Sicherheitslücken durch die "DISPLAY*" settings sind.
Speziell das Open vom port 6000.
Meine Anleitung wurde für ein abgesichertes Intranet geschrieben.
Fragt hier, wenn ihr es "sicherer" wissen wollt. Vielleicht kann jemand
anders diese Frage beantworten !
The gates in my computer are AND,OR and NOT, not Bill.
Wer lesen kann und dann noch die Suche bedienen kann ist klar im Vorteil 8)

tonosinai
Newbie
Newbie
Beiträge: 15
Registriert: 12. Jan 2005, 20:03
Wohnort: Mühltal
Kontaktdaten:

Beitrag von tonosinai » 8. Mär 2006, 13:54

Hi. Ich habe das jetzt mal nach deiner Anleitung installiert. Und was soll ich sagen, es funktioniert wunderbar. Allerdings stört mich, dass ich immer ein englisches Tastaturlayout habe. Kann man das ändern?

Gruss

Stefan

Benutzeravatar
haveaniceday
Hacker
Hacker
Beiträge: 775
Registriert: 7. Jul 2004, 14:09
Wohnort: Paderborn

Beitrag von haveaniceday » 8. Mär 2006, 14:05

Zur Zeit ist mir das nicht bekannt.
Ich wollte mir mal Zeit dafür nehmen, habe es aber noch
nicht geschafft. Kann noch ein paar Wochen dauern..

Haveaniceday
The gates in my computer are AND,OR and NOT, not Bill.
Wer lesen kann und dann noch die Suche bedienen kann ist klar im Vorteil 8)

Benutzeravatar
Maddin/Samurai
Newbie
Newbie
Beiträge: 24
Registriert: 15. Mär 2006, 12:32
Wohnort: treuer M-V Anhänger (Pasewalk)

Beitrag von Maddin/Samurai » 5. Apr 2006, 19:54

kann man nicht die tastatur umstellen mit

Code: Alles auswählen

 alt+Umschalttaste
?

versucht es mal damit.

MFG Maddin
Das glück bevorzugt den, der Vorbereitet ist!

Benutzeravatar
haveaniceday
Hacker
Hacker
Beiträge: 775
Registriert: 7. Jul 2004, 14:09
Wohnort: Paderborn

Beitrag von haveaniceday » 27. Apr 2006, 12:49

@oliverimm

pam-devel für suse 10.0 kann man hier finden:

http://rpmfind.net/linux/RPM/opensuse/1 ... .i586.html

Haveaniceday
The gates in my computer are AND,OR and NOT, not Bill.
Wer lesen kann und dann noch die Suche bedienen kann ist klar im Vorteil 8)

Fried_Chicken
Newbie
Newbie
Beiträge: 33
Registriert: 20. Mär 2006, 18:57

Beitrag von Fried_Chicken » 25. Mai 2006, 14:38

Wo muss ich was einstellen wenn ich mit einem Client auf mein xrdp server zugreiffe, und das Display 0 (sprich lokales GUI) auf meinem entfernten Rechner haben möchte?

SirLD
Newbie
Newbie
Beiträge: 1
Registriert: 8. Jul 2006, 20:22

Beitrag von SirLD » 8. Jul 2006, 20:25

hi, ich hab gentoo und bekomme immer folgende ausgabe, wenn ich rdesktop localhost ausführe:

started connecting
connecting to sesman
sending login info to sesman
receiving sesman header
receiving sesman data
sesman started session
connecting to 127.0.0.1 5910
error - problem connecting

hab ich vergessen, was zu installieren? ich komm nich drauf...

TBT
Newbie
Newbie
Beiträge: 2
Registriert: 17. Jul 2006, 10:54

Beitrag von TBT » 17. Jul 2006, 10:59

ich würde dieses Tool auch gerne nutzen, doch kann ich mich einfach nicht einloggen

bei VNC Verbindung

Code: Alles auswählen

started connecting 
connecting to sesman 
sending login info to sesman 
receiving sesman header 
receiving sesman data 
sesman started session 
connecting to 127.0.0.1 5911
error - problem connecting 
und bei RDP Verbindung

Code: Alles auswählen

started connecting 
connecting to sesman 
sending login info to sesman 
receiving sesman header 
receiving sesman data 
sesman started session 
some error 
jemand einen Hinweis, woran dies liegt?

Ich habe dafür extra einen frischen SuSE 10.1 installiert,
und mich an die in diesem Thread angegebene Installationanweisung
von haveaniceday gehalten.

Danke

Benutzeravatar
haveaniceday
Hacker
Hacker
Beiträge: 775
Registriert: 7. Jul 2004, 14:09
Wohnort: Paderborn

Beitrag von haveaniceday » 1. Aug 2006, 01:11

Ich habe es jetzt mal mit xrdp-0.3 und 10.1 probiert.
( wie am 2006-März-03, 12:31 am "Small update" beschrieben )

Geht bei mir.

pstree -p zeigt:
├─sesman(4601)───sesman(4645)─┬─Xvnc(4647)
│ └─startwm.sh(4646)───startkde(4648)───kwrapper(4696)

Habt Ihr:
- Als root gestartet ?
- Xvnc installiert
- Punkt 8+9 der Anleitung noch mal gecheckt ?

Was sagt diese Logdatei:

Code: Alles auswählen

myhome:/usr/local/xrdp # cat sesman.log
[20060731-18:23:08] [DEBUG] starting sesman with pid 1948
[20060731-18:23:08] [DEBUG] listening...
[20060731-18:24:43] [DEBUG] granted TS access to user haveaniceday
[20060731-18:25:08] [DEBUG] starting Xvnc session...
[20060731-20:21:44] [DEBUG] shutting down sesman 1
[20060731-20:21:44] [DEBUG] shutting down sesman 1
[20060801-01:03:18] [DEBUG] starting sesman with pid 4601
[20060801-01:03:18] [DEBUG] listening...
[20060801-01:04:26] [DEBUG] granted TS access to user haveaniceday
[20060801-01:04:26] [DEBUG] starting Xvnc session...
Haveaniceday
The gates in my computer are AND,OR and NOT, not Bill.
Wer lesen kann und dann noch die Suche bedienen kann ist klar im Vorteil 8)

Mr. Death
Newbie
Newbie
Beiträge: 1
Registriert: 7. Aug 2006, 09:04

Beitrag von Mr. Death » 7. Aug 2006, 09:08

:?

Habe Probleme unter Suse 10.1 mit MAKE. Er durchläuft das MAKE und bringt dann den Fehler "cannot find -lxrdp".

Wer kann mir sagen was hier fehlt oder was ich hier falsch gemacht habe.

Gruss
Markus

yankee927
Newbie
Newbie
Beiträge: 3
Registriert: 26. Okt 2006, 09:45
Wohnort: zu Hause

Problem

Beitrag von yankee927 » 26. Okt 2006, 10:17

Moins,

ich hab ja schon ne Menge ausprobiert, ltsp4.2, PXES usw...

Aber das hier ist klasse, nun hab ich leider doch ein Problem und zwar foglendes: Ich habe nen Server SuSE Linux Enterprise Server 9.3, da wollt ich das installieren. Hab es vorher aber auf nem anderen Linux PC getestet (Linux 9.3 Pro) lief auch - hab den platt gemacht und noch mal ne Grundinstallation von Linux 9.3 drauf installiert und dann das xrdp noch mal installiert ohne Probleme compiliert usw. geht nicht mehr und es kam diese Fehlermeldung, als ich mich von nem Win2000 PC einloggen wollte:

error sesman returned no
error connection failed


Hab ich was vergessen???????

Ich will das auf dem Server dann installieren und nicht den Schrotten...

[/img]

Antworten