Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

kein USB-Disk Zugriff unter Realtimekernel

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Antworten
Susanne
Newbie
Newbie
Beiträge: 40
Registriert: 22. Sep 2005, 19:20
Wohnort: Weiterstadt

kein USB-Disk Zugriff unter Realtimekernel

Beitrag von Susanne » 1. Feb 2006, 20:26

jetzt hab ichs endlich geschafft, in meiner Suse 9.3 den 2.6.11.7-realtime Kernel zu kompilieren und installieren und einen großen Spaß dran zu haben ':D' - da fällt mir doch tatsächlich noch ein Haar in die Suppe: meine USB-Platte IOMEGA wird zwar im Konqueror noch als Ordner /media/IOMEGA angezeigt, aber der Inhalt nicht (ext3). Ich kann aber wohl etwas neues hin speichern, das seh ich dann auch - auf das,was schon drauf ist aber kann icht nicht zugreifen.
Die Konfig ist vom Suse Kernel geklont und nur die im Howto empfohlenen Änderungen gemacht. Auch in var/log/messages kann ich nix erkennen, was da nicht geht:
Feb 1 20:08:40 linux kernel: usb 1-3: new high speed USB device using ehci_hcd and address 4
Feb 1 20:08:41 linux kernel: Initializing USB Mass Storage driver...
Feb 1 20:08:41 linux kernel: scsi0 : SCSI emulation for USB Mass Storage devices
Feb 1 20:08:41 linux kernel: usbcore: registered new driver usb-storage
Feb 1 20:08:41 linux kernel: USB Mass Storage support registered.
Feb 1 20:08:42 linux kernel: usb-storage: device found at 4
Feb 1 20:08:42 linux kernel: usb-storage: waiting for device to settle before scanning
Feb 1 20:08:47 linux kernel: Vendor: HDS72252 Model: 5VLAT80 Rev: V36O
Feb 1 20:08:47 linux kernel: Type: Direct-Access ANSI SCSI revision: 00
Feb 1 20:08:47 linux kernel: SCSI device sda: 488397169 512-byte hdwr sectors (250059 MB)
Feb 1 20:08:47 linux kernel: sda: assuming drive cache: write through
Feb 1 20:08:47 linux kernel: SCSI device sda: 488397169 512-byte hdwr sectors (250059 MB)
Feb 1 20:08:47 linux kernel: sda: assuming drive cache: write through
Feb 1 20:08:47 linux kernel: sda: sda1 sda2
Feb 1 20:08:47 linux kernel: Attached scsi disk sda at scsi0, channel 0, id 0, lun 0
Feb 1 20:08:47 linux kernel: Attached scsi generic sg0 at scsi0, channel 0, id 0, lun 0, type 0
Feb 1 20:08:47 linux kernel: usb-storage: device scan complete
Feb 1 20:08:47 linux /etc/hotplug.d/block/50-hwscan.hotplug[8684]: new block device /block/sda
Feb 1 20:08:47 linux /etc/hotplug.d/block/50-hwscan.hotplug[8747]: new block device /block/sda/sda1
Feb 1 20:08:47 linux /etc/hotplug.d/block/50-hwscan.hotplug[8779]: new block device /block/sda/sda2
Feb 1 20:08:48 linux hal-subfs-mount[8773]: registered at resmgrd and called(8192) /bin/mount -t subfs -o fs=ntfs,sync,nosuid,nodev,exec /dev/sda1 "/media/IOMEGA_HDD"
Feb 1 20:08:48 linux hal-subfs-mount[8797]: registered at resmgrd and called(8192) /bin/mount -t subfs -o fs=ext3,sync,nosuid,nodev,exec /dev/sda2 "/media/usbdisk"

ich kann zwar zur Not damit leben - aber auf meiner Laptopplatte ists schon ein weng eng...
wäre für einen Tip dankbar
Susanne
Thinkpad R61/Intel-T8100/NVIDIA-QUADRO-NVS-140M - openSuse 11.2/11.3/12.1+AVlinux-4.1
Asus A4K/AMD-Athlon64/ATI-Mob.Radeon9700 - openSuse 10.2+10.3

Werbung:
Benutzeravatar
Gimpel
Guru
Guru
Beiträge: 1983
Registriert: 11. Feb 2004, 13:58
Wohnort: Mjunik .... "no a hoibe, resi!"
Kontaktdaten:

Beitrag von Gimpel » 1. Feb 2006, 21:30

Hi susanne! :D

hmmm... subfs... mountet den mit sync option.. *grusel* und das über hal..

Appleonkel: find doch mal raus wie man unter SuSE diesen hal-subfs-mount lahm legt, hehe. Ich kann es leider nicht..

denn ich denke dass es normal funktionieren würde, wenn du die usb-platte auch normal mounten würdest, susanne. aber dazu müsste man das erstmal deaktivieren. OK, das einfachste wäre, natürlich komplett submount lahm zu legen. Macht es dir was aus wenn CDs/DVDs/USB zeug nicht automatisch gemountet wird?
Bild on AMD Athlon64 X2 5600+|64bit|6GB DDR2 800MHz|nVidia GF 8500GT|2.6.29-rc1-moo1|BTRFS|KDE-4.2 SVN trunk + Compiz++|M-Audio Audiophile 2496
----
Bild

Benutzeravatar
Appleonkel
Hacker
Hacker
Beiträge: 794
Registriert: 30. Apr 2004, 12:02
Wohnort: Köln
Kontaktdaten:

Beitrag von Appleonkel » 1. Feb 2006, 21:40

Hi Susann,

versuch doch mal die Platte per hand zu mounten.

Code: Alles auswählen

umount /media/IOMEGA
mount -t ext3 /dev/sda1 /media/IOMEGA
Wenn das nicht hilft muss ich mal schauen. Wie wir das hinbekommen.

P.S.: unter SuSE 10.0 wirds mit USB nicht besser

Appleonkel
"Es gibt anscheinend keine Möglichkeit der Sonde zu antworten." – "Ja, es ist schwierig zu antworten, wenn man die Frage nicht versteht." Star Trek 4

Susanne
Newbie
Newbie
Beiträge: 40
Registriert: 22. Sep 2005, 19:20
Wohnort: Weiterstadt

Beitrag von Susanne » 1. Feb 2006, 22:37

hey vielen Dank Euch beiden! :-)
also: der Versuch, die Platte zu umounten hat nix gebracht, ich krieg gesagt: "...ist nicht eingehängt".
Nein, es würde mir nix ausmachen, von Hand zu mounten.
Was aber passiert mit der USB Maus? (hab wegen ihr mal das USB HID Polling aktiviert gelassen..)
Und meine USB Soundkarte müßt ich dann wohl auch von Hand mounten.
Ist aber kein Problem, kann ich gut mit leben, Hauptsache ich hab ne Lösung! :-)
liebe Grüße
Susanne
Thinkpad R61/Intel-T8100/NVIDIA-QUADRO-NVS-140M - openSuse 11.2/11.3/12.1+AVlinux-4.1
Asus A4K/AMD-Athlon64/ATI-Mob.Radeon9700 - openSuse 10.2+10.3

Benutzeravatar
Appleonkel
Hacker
Hacker
Beiträge: 794
Registriert: 30. Apr 2004, 12:02
Wohnort: Köln
Kontaktdaten:

Beitrag von Appleonkel » 1. Feb 2006, 23:59

Susanne hat geschrieben:also: der Versuch, die Platte zu umounten hat nix gebracht, ich krieg gesagt: "...ist nicht eingehängt".
Ja, dann ist klar das du nix lesen kannst, die Platte wird nicht automtich gemountet oder taucht unter bei der Ausgabe von

Code: Alles auswählen

mount
deine Platte auf?
wenn nein versuch sie mal mir den obigen Befehl zu mounten.
Dann ist sie aber erstmal nur als root beschreibar.

Appleonkel
"Es gibt anscheinend keine Möglichkeit der Sonde zu antworten." – "Ja, es ist schwierig zu antworten, wenn man die Frage nicht versteht." Star Trek 4

Susanne
Newbie
Newbie
Beiträge: 40
Registriert: 22. Sep 2005, 19:20
Wohnort: Weiterstadt

Beitrag von Susanne » 2. Feb 2006, 00:35

das ist die Ausgabe von "mount":
susanne@linux:~> mount
/dev/hda6 on / type ext2 (rw,acl,user_xattr)
proc on /proc type proc (rw)
sysfs on /sys type sysfs (rw)
tmpfs on /dev/shm type tmpfs (rw)
devpts on /dev/pts type devpts (rw,mode=0620,gid=5)
/dev/hda1 on /boot type ext2 (rw,acl,user_xattr)
/dev/hda9 on /home type ext2 (rw,acl,user_xattr)
/dev/hda8 on /tmp type ext2 (rw,acl,user_xattr)
/dev/hda7 on /var type ext2 (rw,acl,user_xattr)
/dev/hda3 on /xfer type vfat (rw,noexec,nosuid,nodev,umask=002,gid=100)
/dev/hda10 on /trans type ext2 (rw,noexec,nosuid,nodev,acl)
usbfs on /proc/bus/usb type usbfs (rw)
susanne@linux:~>

die Platte (bzw deren 2. Partition) ist als /media/usbdisk zu mounten und als root kann ich drauf zugreifen.
damit kann ich erst mal leben , vielen Dank für die freundliche Hilfe :-)
(hoffentlich kann ich auch bald mal was beitragen...) verabschiede mich jetz in die Falle, morgen früh winkt die Broterwerbsarbeit *kotz* ... *g*
bis denne
Susanne
Thinkpad R61/Intel-T8100/NVIDIA-QUADRO-NVS-140M - openSuse 11.2/11.3/12.1+AVlinux-4.1
Asus A4K/AMD-Athlon64/ATI-Mob.Radeon9700 - openSuse 10.2+10.3

Benutzeravatar
Appleonkel
Hacker
Hacker
Beiträge: 794
Registriert: 30. Apr 2004, 12:02
Wohnort: Köln
Kontaktdaten:

Beitrag von Appleonkel » 2. Feb 2006, 00:54

Kein Problem,

wegen Userzugriff schau mal hier

Appleonkel
"Es gibt anscheinend keine Möglichkeit der Sonde zu antworten." – "Ja, es ist schwierig zu antworten, wenn man die Frage nicht versteht." Star Trek 4

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 3 Gäste