Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

probleme mit vmware-config.pl

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Antworten
Christian1983
Newbie
Newbie
Beiträge: 39
Registriert: 5. Dez 2005, 15:29
Wohnort: Bremen
Kontaktdaten:

probleme mit vmware-config.pl

Beitrag von Christian1983 » 30. Jan 2006, 18:45

Hallo,

habe vmware 5.0 workstation installiert und vmware-config.pl ausgeführt, leider startet das Programm nicht... Hat jemand einen Tipp für mich ??? Habe alles auf default eingestellt !!! Danke für eure Antworten !!!

Auszug:

linux:/usr/bin # vmware-config.pl

Making sure services for VMware Workstation are stopped.

Stopping VMware services:
Virtual machine monitor done
Bridged networking on /dev/vmnet0 done
DHCP server on /dev/vmnet1 done
Host-only networking on /dev/vmnet1 done
DHCP server on /dev/vmnet8 done
NAT service on /dev/vmnet8 done
Host-only networking on /dev/vmnet8 done
Virtual ethernet done

Configuring fallback GTK+ 2.4 libraries.

In which directory do you want to install the mime type icons?
[/usr/share/icons]
What directory contains your desktop menu entry files? These files have a
.desktop file extension. [/usr/share/applications]

In which directory do you want to install the application's icon?
[/usr/share/pixmaps]

Trying to find a suitable vmmon module for your running kernel.

None of the pre-built vmmon modules for VMware Workstation is suitable for your
running kernel. Do you want this program to try to build the vmmon module for
your system (you need to have a C compiler installed on your system)? [yes]

Using compiler "/usr/bin/gcc". Use environment variable CC to override.

What is the location of the directory of C header files that match your running
kernel? [/lib/modules/2.6.13-15.7-default/build/include]

Extracting the sources of the vmmon module.

Building the vmmon module.

Using 2.6.x kernel build system.
make: Entering directory `/tmp/vmware-config0/vmmon-only'
make -C /lib/modules/2.6.13-15.7-default/build/include/.. SUBDIRS=$PWD SRCROOT=$PWD/. modules
make[1]: Entering directory `/usr/src/linux-2.6.13-15.7-obj/i386/default'
make -C ../../../linux-2.6.13-15.7 O=../linux-2.6.13-15.7-obj/i386/default modules
CC [M] /tmp/vmware-config0/vmmon-only/linux/driver.o
CC [M] /tmp/vmware-config0/vmmon-only/linux/hostif.o
CC [M] /tmp/vmware-config0/vmmon-only/common/cpuid.o
CC [M] /tmp/vmware-config0/vmmon-only/common/hash.o
CC [M] /tmp/vmware-config0/vmmon-only/common/memtrack.o
CC [M] /tmp/vmware-config0/vmmon-only/common/phystrack.o
CC [M] /tmp/vmware-config0/vmmon-only/common/task.o
CC [M] /tmp/vmware-config0/vmmon-only/common/vmx86.o
CC [M] /tmp/vmware-config0/vmmon-only/vmcore/moduleloop.o
LD [M] /tmp/vmware-config0/vmmon-only/vmmon.o
Building modules, stage 2.
MODPOST
CC /tmp/vmware-config0/vmmon-only/vmmon.mod.o
LD [M] /tmp/vmware-config0/vmmon-only/vmmon.ko
make[1]: Leaving directory `/usr/src/linux-2.6.13-15.7-obj/i386/default'
cp -f vmmon.ko ./../vmmon.o
make: Leaving directory `/tmp/vmware-config0/vmmon-only'
The module loads perfectly in the running kernel.

This program previously created the file /dev/vmnet0, and was about to remove
it. Somebody else apparently did it already.

This program previously created the file /dev/vmnet1, and was about to remove
it. Somebody else apparently did it already.

This program previously created the file /dev/vmnet8, and was about to remove
it. Somebody else apparently did it already.

You have already setup networking.

Would you like to skip networking setup and keep your old settings as they are?
(yes/no) [yes]

Extracting the sources of the vmnet module.

Building the vmnet module.

Using 2.6.x kernel build system.
make: Entering directory `/tmp/vmware-config0/vmnet-only'
make -C /lib/modules/2.6.13-15.7-default/build/include/.. SUBDIRS=$PWD SRCROOT=$PWD/. modules
make[1]: Entering directory `/usr/src/linux-2.6.13-15.7-obj/i386/default'
make -C ../../../linux-2.6.13-15.7 O=../linux-2.6.13-15.7-obj/i386/default modules
CC [M] /tmp/vmware-config0/vmnet-only/driver.o
CC [M] /tmp/vmware-config0/vmnet-only/hub.o
CC [M] /tmp/vmware-config0/vmnet-only/userif.o
CC [M] /tmp/vmware-config0/vmnet-only/netif.o
CC [M] /tmp/vmware-config0/vmnet-only/bridge.o
CC [M] /tmp/vmware-config0/vmnet-only/procfs.o
CC [M] /tmp/vmware-config0/vmnet-only/smac_compat.o
SHIPPED /tmp/vmware-config0/vmnet-only/smac_linux.x386.o
LD [M] /tmp/vmware-config0/vmnet-only/vmnet.o
Building modules, stage 2.
MODPOST
Warning: could not open /tmp/vmware-config0/vmnet-only/includeCheck.h: Invalid argument
CC /tmp/vmware-config0/vmnet-only/vmnet.mod.o
LD [M] /tmp/vmware-config0/vmnet-only/vmnet.ko
make[1]: Leaving directory `/usr/src/linux-2.6.13-15.7-obj/i386/default'
cp -f vmnet.ko ./../vmnet.o
make: Leaving directory `/tmp/vmware-config0/vmnet-only'
The module loads perfectly in the running kernel.

Starting VMware services:
Virtual machine monitor done
Virtual ethernet done
Bridged networking on /dev/vmnet0 done
Host-only networking on /dev/vmnet1 (background) done
Host-only networking on /dev/vmnet8 (background) done
NAT service on /dev/vmnet8 failed

The configuration of VMware Workstation 5.5.1 build-19175 for Linux for this
running kernel completed successfully.

You can now run VMware Workstation by invoking the following command:
"/usr/bin/vmware".

Enjoy,

--the VMware team

linux:/usr/bin # vmware
vmware is installed, but it has not been (correctly) configured
for this system. To (re-)configure it, invoke the following command:
/usr/bin/vmware-config.pl.

**** ENDE ****

Grüsse
Christian1983

Werbung:
towo
Moderator
Moderator
Beiträge: 3709
Registriert: 15. Feb 2004, 16:42
Wohnort: Nimritz
Kontaktdaten:

Beitrag von towo » 30. Jan 2006, 18:46

any-any-update gemacht?
Signatur nach Diktat spazieren gegangen

Bild

Benutzeravatar
Martin Breidenbach
Ultimate Guru
Ultimate Guru
Beiträge: 5632
Registriert: 26. Mai 2004, 21:33
Wohnort: N 50.17599° E 8.73367°

Beitrag von Martin Breidenbach » 30. Jan 2006, 18:49

Ist das SuSE 10.0 mit dem via YOU verfügbaren Kernelupdate ? Bei mir lief das ohne Probleme mit der 5.51. Und zwar ohne any-any.
Nicht Böse sein ! Der Onkel macht doch nur Spaß !

Christian1983
Newbie
Newbie
Beiträge: 39
Registriert: 5. Dez 2005, 15:29
Wohnort: Bremen
Kontaktdaten:

Oh, sorry

Beitrag von Christian1983 » 30. Jan 2006, 18:59

ja, natürlich, also ich verwende SUSE 10.0 und habe kein any-any Update gemacht, ich muss mich da mal schlau machen, was das überhaupt ist und... vielleicht klappt es dann ja...

also ich verwende apt und mache damit ausschließlich alle Updates... auch kernel-default und so...

Grüsse
Christian 1983

Benutzeravatar
Martin Breidenbach
Ultimate Guru
Ultimate Guru
Beiträge: 5632
Registriert: 26. Mai 2004, 21:33
Wohnort: N 50.17599° E 8.73367°

Beitrag von Martin Breidenbach » 30. Jan 2006, 19:05

Das ist ein patch mit dem VMware oftmals auf Kerneln läuft die zum Zeitpunkt des Erscheinens von VMware noch nicht existierten. Infos dazu in dem 'Wichtige Links' Thread hier.

Aber wie gesagt... ich habe den nicht gebraucht.
Nicht Böse sein ! Der Onkel macht doch nur Spaß !

towo
Moderator
Moderator
Beiträge: 3709
Registriert: 15. Feb 2004, 16:42
Wohnort: Nimritz
Kontaktdaten:

Beitrag von towo » 30. Jan 2006, 19:08

Aber wie gesagt... ich habe den nicht gebraucht.
Du redest aber auch von VMWare 5.5, der Threadersteller von 5.0
Signatur nach Diktat spazieren gegangen

Bild

Stefan Staeglich
Advanced Hacker
Advanced Hacker
Beiträge: 960
Registriert: 11. Mai 2004, 10:37

Beitrag von Stefan Staeglich » 30. Jan 2006, 19:09

Der will ja auch vmware 5.0 installieren.

@Christian1983 Wenn du vmware 5.0 besitzt kannst du doch kostenlos auf vmware 5.51 updaten
Gruß Stefan

Benutzeravatar
Martin Breidenbach
Ultimate Guru
Ultimate Guru
Beiträge: 5632
Registriert: 26. Mai 2004, 21:33
Wohnort: N 50.17599° E 8.73367°

Re: probleme mit vmware-config.pl

Beitrag von Martin Breidenbach » 30. Jan 2006, 19:14

Selberlesen bildet:
Christian1983 hat geschrieben:habe vmware 5.0 workstation installiert und vmware-config.pl ausgeführt...

The configuration of VMware Workstation 5.5.1 build-19175 for Linux for this running kernel completed successfully.
Er hat 5.5.1. Sagt jedenfalls seine VMware.
Nicht Böse sein ! Der Onkel macht doch nur Spaß !

towo
Moderator
Moderator
Beiträge: 3709
Registriert: 15. Feb 2004, 16:42
Wohnort: Nimritz
Kontaktdaten:

Re: probleme mit vmware-config.pl

Beitrag von towo » 30. Jan 2006, 20:22

Martin Breidenbach hat geschrieben:Selberlesen bildet:
Christian1983 hat geschrieben:habe vmware 5.0 workstation installiert und vmware-config.pl ausgeführt...

The configuration of VMware Workstation 5.5.1 build-19175 for Linux for this running kernel completed successfully.
Er hat 5.5.1. Sagt jedenfalls seine VMware.
O.k. ich gebe mich geschlagen.
Signatur nach Diktat spazieren gegangen

Bild

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast