Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

Cedega vs. WoW.exe

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Antworten
Neo2k5
Newbie
Newbie
Beiträge: 2
Registriert: 28. Jan 2006, 16:16

Cedega vs. WoW.exe

Beitrag von Neo2k5 » 28. Jan 2006, 16:23

Moisn :)

also hab schon stundenlang gegooglet. und auch hier schon gesucht und nix brauchbares gefunden ...

atm hab ich folgends Problem:

Ich hab Cedega 4.3 drauf gehabt, WoW.exe 1a zum laufen bekommen, soo dann hab ich WoW beendet wollte es am naechsten tag wieder starten, und nun krieg ich folgendes:

sh wow.sh
wine: Unhandled exception, starting debugger...
WineDbg starting on pid 1
No debug information in ELF '/usr/lib/transgaming_cedega//winex/bin/wine' (0x000
00000)
Breakpoint 1 at 0x4000e270
No debug information in ELF '/usr/lib/transgaming_cedega//winex/pthread_lib/libn
tdll.so' (0x4001d000)
No debug information in ELF '/usr/lib/transgaming_cedega//winex/pthread_lib/libw
ine.so' (0x40123000)
No debug information in ELF '/usr/lib/transgaming_cedega//winex/lib/libwine_unic
ode.so' (0x40138000)
No debug information in ELF '/usr/lib/transgaming_cedega//winex/lib/libwine_port
.so' (0x401ff000)
No debug information in ELF '/lib/tls/libm.so.6' (0x4021e000)
No debug information in ELF '/lib/tls/libc.so.6' (0x40246000)
No debug information in ELF '/lib/tls/libpthread.so.0' (0x40365000)
No debug information in ELF '/lib/libdl.so.2' (0x40378000)
No debug information in ELF '/lib/ld-linux.so.2' (0x40000000)
No debug information in ELF '/usr/lib/transgaming_cedega//winex/lib/libcomctl32.
so' (0x40739000)
No debug information in ELF '/usr/lib/transgaming_cedega//winex/lib/libuser32.so
' (0x407be000)
No debug information in ELF '/usr/lib/transgaming_cedega//winex/lib/libgdi32.so'
(0x408e6000)
No debug information in ELF '/usr/lib/transgaming_cedega//winex/lib/libadvapi32.
so' (0x4095d000)
No debug information in ELF '/usr/lib/transgaming_cedega//winex/lib/libshell32.s
o' (0x40984000)
No debug information in ELF '/usr/lib/transgaming_cedega//winex/lib/libpng.so.3'
(0x409f8000)
No debug information in ELF '/usr/lib/libz.so.1' (0x40a24000)
No debug information in ELF '/usr/lib/transgaming_cedega//winex/lib/libole32.so'
(0x40a36000)
No debug information in ELF '/usr/lib/transgaming_cedega//winex/lib/librpcrt4.so
' (0x40a9b000)
No debug information in ELF '/usr/lib/transgaming_cedega//winex/lib/libshlwapi.s
o' (0x40ae1000)
No debug information in ELF '/usr/lib/transgaming_cedega//winex/lib/libwsock32.s
o' (0x40202000)
No debug information in ELF '/usr/lib/transgaming_cedega//winex/lib/libws2_32.so
' (0x40b21000)
No debug information in ELF '/usr/lib/transgaming_cedega//winex/lib/libiphlpapi.
so' (0x4020f000)
No debug information in ELF '/usr/lib/transgaming_cedega//winex/lib/libopengl32.
so' (0x40b3a000)
No debug information in ELF '/usr/lib/transgaming_cedega//winex/lib/libwine_tsx1
1.so' (0x40bc9000)
No debug information in ELF '/usr/X11R6/lib/libSM.so.6' (0x404c3000)
No debug information in ELF '/usr/X11R6/lib/libICE.so.6' (0x40bf7000)
No debug information in ELF '/usr/lib/libGL.so.1' (0x40c0f000)
No debug information in ELF '/usr/lib/transgaming_cedega//winex/lib/libGLU.so.1'
(0x40c8e000)
No debug information in ELF '/usr/X11R6/lib/libXext.so.6' (0x40d49000)
No debug information in ELF '/usr/X11R6/lib/libX11.so.6' (0x40d57000)
No debug information in ELF '/usr/lib/libGLcore.so.1' (0x40e21000)
No debug information in ELF '/usr/lib/tls/libnvidia-tls.so.1' (0x4037d000)
No debug information in ELF '/usr/lib/transgaming_cedega//winex/lib/libddraw.so'
(0x415e5000)
No debug information in ELF '/usr/lib/transgaming_cedega//winex/lib/libimm32.so'
(0x40bdb000)
No debug information in ELF '/usr/lib/transgaming_cedega//winex/lib/libwinmm.so'
(0x4162a000)
No debug information in ELF '/usr/lib/transgaming_cedega//winex/lib/libmsacm32.s
o' (0x41710000)
No debug information in ELF '/usr/lib/transgaming_cedega//winex/lib/libwininet.s
o' (0x41722000)
No debug information in ELF '/usr/lib/transgaming_cedega//winex/lib/libwineserve
r.so' (0x41741000)
No debug information in ELF '/usr/lib/libfreetype.so.6' (0x41cbc000)
No debug information in ELF '/usr/lib/transgaming_cedega//winex/lib/libx11drv.so
' (0x41d29000)
No debug information in ELF '/usr/X11R6/lib/X11/locale/lib/common/xlcDef.so.2' (
0x40bea000)
No debug information in ELF '/usr/X11R6/lib/X11/locale/lib/common/ximcp.so.2' (0
x41daa000)
No debug information in ELF '/usr/lib/gconv/ISO8859-15.so' (0x40bed000)
No debug information in ELF '/usr/X11R6/lib/libXcursor.so.1' (0x41787000)
No debug information in ELF '/usr/X11R6/lib/libXrender.so.1' (0x41dc7000)
No debug information in ELF '/usr/lib/transgaming_cedega//winex/lib/libd3dgl.so'
(0x42110000)
No debug information in ELF '/usr/lib/transgaming_cedega//winex/lib/libwineoss.d
rv.so' (0x42521000)
No debug information in ELF '/usr/lib/transgaming_cedega//winex/lib/libmsacm.drv
.so' (0x4253a000)
No debug information in ELF '/usr/lib/transgaming_cedega//winex/lib/libmidimap.d
rv.so' (0x42542000)
No debug information in ELF '/usr/lib/transgaming_cedega//winex/lib/libmpr.so' (
0x42548000)
No debug information in ELF '/usr/lib/transgaming_cedega//winex/lib/libcomdlg32.
so' (0x43730000)
No debug information in ELF '/usr/lib/transgaming_cedega//winex/lib/libwinspool.
drv.so' (0x43795000)
No debug information in ELF '/usr/lib/transgaming_cedega//winex/lib/libversion.s
o' (0x437aa000)
No debug information in ELF '/usr/lib/transgaming_cedega//winex/lib/liblz32.so'
(0x437b4000)
No debug information in ELF '/usr/lib/transgaming_cedega//winex/lib/liboledlg.so
' (0x42554000)
No debug information in ELF '/usr/lib/transgaming_cedega//winex/lib/libavicap32.
so' (0x437bb000)
No debug information in ELF '/usr/lib/transgaming_cedega//winex/lib/libmsvfw32.s
o' (0x437c0000)
No debug information in 32bit DLL 'D:\.wine\drive_c\World of Warcraft\WoW.exe' (
0x00400000)
No debug information in 32bit DLL 'NTDLL.DLL' (0x4005b000)
No debug information in 32bit DLL 'KERNEL32.DLL' (0x77034000)
No debug information in 32bit DLL 'C:\WINDOWS\SYSTEM32\MSVCRT.DLL' (0x406f3000)
No debug information in 32bit DLL 'ADVAPI32.DLL' (0x4096f000)
No debug information in 32bit DLL 'GDI32.DLL' (0x40905000)
No debug information in 32bit DLL 'USER32.DLL' (0x407f5000)
No debug information in 32bit DLL 'COMCTL32.DLL' (0x40747000)
No debug information in 32bit DLL 'RPCRT4.DLL' (0x40abe000)
No debug information in 32bit DLL 'OLE32.DLL' (0x40a55000)
No debug information in 32bit DLL 'SHLWAPI.DLL' (0x40afe000)
No debug information in 32bit DLL 'SHELL32.DLL' (0x409a7000)
No debug information in 32bit DLL 'IPHLPAPI.DLL' (0x40216000)
No debug information in 32bit DLL 'WS2_32.DLL' (0x40b29000)
No debug information in 32bit DLL 'WSOCK32.DLL' (0x40206000)
No debug information in 32bit DLL 'DDRAW.DLL' (0x415fb000)
No debug information in 32bit DLL 'OPENGL32.DLL' (0x40b81000)
No debug information in 32bit DLL 'IMM32.DLL' (0x40be1000)
No debug information in 32bit DLL 'D:\.WINE\DRIVE_C\WORLD OF WARCRAFT\DIVXDECODE
R.DLL' (0x10000000)
No debug information in 32bit DLL 'WINMM.DLL' (0x41638000)
No debug information in 32bit DLL 'MSACM32.DLL' (0x41715000)
No debug information in 32bit DLL 'D:\.WINE\DRIVE_C\WORLD OF WARCRAFT\FMOD.DLL'
(0x41680000)
No debug information in 32bit DLL 'WININET.DLL' (0x4172d000)
No debug information in 32bit DLL 'X11DRV.DLL' (0x41d48000)
No debug information in 32bit DLL 'D3DGL.DLL' (0x42123000)
No debug information in 32bit DLL 'WINEOSS.DRV' (0x42524000)
No debug information in 32bit DLL 'MSACM.DRV' (0x4253d000)
No debug information in 32bit DLL 'MIDIMAP.DRV' (0x42544000)
No debug information in 32bit DLL 'MPR.DLL' (0x4254e000)
No debug information in 32bit DLL 'WINSPOOL.DRV' (0x4379d000)
No debug information in 32bit DLL 'COMDLG32.DLL' (0x43742000)
No debug information in 32bit DLL 'LZ32.DLL' (0x437b7000)
No debug information in 32bit DLL 'VERSION.DLL' (0x437ad000)
No debug information in 32bit DLL 'OLEDLG.DLL' (0x42557000)
No debug information in 32bit DLL 'AVICAP32.DLL' (0x437bd000)
No debug information in 32bit DLL 'MSVFW32.DLL' (0x437c5000)
No debug information in 32bit DLL 'D:\.WINE\DRIVE_C\WORLD OF WARCRAFT\UNICOWS.DL
L' (0x7f2d0000)
Unhandled exception: page fault on read access to 0xdeadbeef in 32-bit code (0xd
eadbeef).
In 32-bit mode.
Register dump:
CS:0073 SS:007b DS:007b ES:007b FS:003b GS:0033
EIP:deadbeef ESP:406e1f70 EBP:406e21cc EFLAGS:00210202( R- 00 I - - 1 )
EAX:406e1fb0 EBX:00000000 ECX:ffffffff EDX:00100701
ESI:00000014 EDI:406e1f90
Stack dump:
0x406e1f70 (NTDLL.DLL.memcpy+0x430320): 004206fd ffffffff 00000006 80000004
0x406e1f80 (NTDLL.DLL.memcpy+0x430330): 00000000 00000000 406e1fb0 00000000
0x406e1f90 (NTDLL.DLL.memcpy+0x430340): 406e1f98 00000001 00000101 05000000
0x406e1fa0 (NTDLL.DLL.memcpy+0x430350): 00000004 90000000 40380d30 00000000
0x406e1fb0 (NTDLL.DLL.memcpy+0x430360): 02000002 00000002 000c0001 000000fa
0x406e1fc0 (NTDLL.DLL.memcpy+0x430370): 00000101 000c0000 00100701 00000101
0x406e1fd0 (NTDLL.DLL.memcpy+0x430380):

Backtrace:
=>0 0xdeadbeef (UNICOWS.DLL..reloc+0x5f7d2eef) (ebp=406e21cc)
1 0x00403d4b (WoW.exe.EntryPoint+0x2d4b in D:\.wine\drive_c\World of Warcraft\
WoW.exe) (ebp=406e226c)
2 0x400d0dc0 (NTDLL.DLL.wine_server_call+0x20dc in libntdll.so) (ebp=406e2314)
3 0x400d0ed3 (NTDLL.DLL.wine_server_call+0x21ef in libntdll.so) (ebp=406e2448)
4 0x4036a2b0 (NTDLL.DLL.memcpy+0xb8660 in libpthread.so.0) (ebp=406e24b8)
5 0x403047ce (NTDLL.DLL.memcpy+0x52b7e in libc.so.6) (ebp=00000000)

0xdeadbeef (UNICOWS.DLL..reloc+0x5f7d2eef): *** Invalid address 0xdeadbeef (UNIC
OWS.DLL..reloc+0x5f7d2eef)
-- no code --
Modules:
Address Module Name
0x00400000-00c88000 (PE) D:\.wine\drive_c\World of Warcraft\WoW.exe
0x10000000-10069000 (PE) D:\.WINE\DRIVE_C\WORLD OF WARCRAFT\DIVXDECODER.D
LL
0x4005b000-4005d000 (PE) NTDLL.DLL
0x40206000-40208000 (PE) WSOCK32.DLL
0x40216000-40218000 (PE) IPHLPAPI.DLL
0x406f3000-40739000 (PE) C:\WINDOWS\SYSTEM32\MSVCRT.DLL
0x40747000-40749000 (PE) COMCTL32.DLL
0x407f5000-407f7000 (PE) USER32.DLL
0x40905000-40907000 (PE) GDI32.DLL
0x4096f000-40971000 (PE) ADVAPI32.DLL
0x409a7000-409a9000 (PE) SHELL32.DLL
0x40a55000-40a57000 (PE) OLE32.DLL
0x40abe000-40ac0000 (PE) RPCRT4.DLL
0x40afe000-40b00000 (PE) SHLWAPI.DLL
0x40b29000-40b2b000 (PE) WS2_32.DLL
0x40b81000-40b83000 (PE) OPENGL32.DLL
0x40be1000-40be3000 (PE) IMM32.DLL
0x415fb000-415fd000 (PE) DDRAW.DLL
0x41638000-4163a000 (PE) WINMM.DLL
0x41680000-41710000 (PE) D:\.WINE\DRIVE_C\WORLD OF WARCRAFT\FMOD.DLL
0x41715000-41717000 (PE) MSACM32.DLL
0x4172d000-4172f000 (PE) WININET.DLL
0x41d48000-41d4a000 (PE) X11DRV.DLL
0x42123000-42125000 (PE) D3DGL.DLL
0x42524000-42526000 (PE) WINEOSS.DRV
0x4253d000-4253f000 (PE) MSACM.DRV
0x42544000-42546000 (PE) MIDIMAP.DRV
0x4254e000-42550000 (PE) MPR.DLL
0x42557000-42559000 (PE) OLEDLG.DLL
0x43742000-43744000 (PE) COMDLG32.DLL
0x4379d000-4379f000 (PE) WINSPOOL.DRV
0x437ad000-437af000 (PE) VERSION.DLL
0x437b7000-437b9000 (PE) LZ32.DLL
0x437bd000-437bf000 (PE) AVICAP32.DLL
0x437c5000-437c7000 (PE) MSVFW32.DLL
0x77034000-77036000 (PE) KERNEL32.DLL
0x7f2d0000-7f30c800 (PE) D:\.WINE\DRIVE_C\WORLD OF WARCRAFT\UNICOWS.DLL
Threads:
process tid prio
00000001 (D) D:\.wine\drive_c\World of Warcraft\WoW.exe
00000002 0 <==
WineDbg terminated on pid 1

die wow.sh:

cat wow.sh
#!/bin/bash
cd /home/neo2k5/.wine/drive_c/World\ of\ Warcraft/
cedega WoW.exe -opengl

sooo naja ... wenn ich es mit Wine starte anstatt mit Cedega, laueft es wie nen doeppcken ... aber ich kann nich Interagieren (Wine prob, daher Cedega) ...

Nun hab ich Cedega schon von 4.3 auf 5.0.1 geupdatet, aber ich krieg immer noch das gleiche.

Ist halt sehr komisch .. das es von jetzt auf gleich nich mehr lief Oo ...

weis da einer Rat?


Gruss Neo2k5

Werbung:
flo41
Hacker
Hacker
Beiträge: 290
Registriert: 9. Feb 2005, 11:47

Beitrag von flo41 » 28. Jan 2006, 18:41

liegt an wow ver 1.9.2 ... das geht nich mit cedega.... ich hab ver 5.0.irgendwas und geht auch nicht ...

Neo2k5
Newbie
Newbie
Beiträge: 2
Registriert: 28. Jan 2006, 16:16

Beitrag von Neo2k5 » 29. Jan 2006, 05:37

ja das komische ist halt, das ich nachm update halt 1x das wow starten konnte, und es lief halt .. und erst nachdem ich wow geschlossen habe, und nachn paar stunden erneut oeffnen wollte, kam das problem .. und mit wine gehts ja (nur halt ohne interagieren) ..

das ist das was mich stuzig macht!


mfg

flo41
Hacker
Hacker
Beiträge: 290
Registriert: 9. Feb 2005, 11:47

Beitrag von flo41 » 30. Jan 2006, 20:05

also ich bekomm genau den selben fehler seit ich mir die 1.9.2 installiert hab ... habs mit der 1.9.0 probier - da gings .... 1.9.2 - ging wieder nicht .... ich hab auch schonmal versucht sämtliche dlls die er nennt einfach als native zu markieren und von dlldump zu holen, hat dann dazu geführt das ich irgendwann 20 dlls hatte und es immer noch nicht ging.
Also:
Abwarten und Tee trinken und hoffen das Blizz endlich ne native ver rausbringt.

Antworten