Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

[solved] Alsa treiber Intallation - FATAL: Error inserting..

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Antworten
b2890x
Member
Member
Beiträge: 85
Registriert: 15. Jan 2006, 10:11
Wohnort: 3.OG.mi.

[solved] Alsa treiber Intallation - FATAL: Error inserting..

Beitrag von b2890x » 18. Jan 2006, 00:16

Nabend,

ich habe ein Problem mit der Alsa Treiber installation. Hab mich durch unzählige HowTos geschlagen und habe nun folgendes Problem:

"modprobe snd-emu10k1" funktioniert noch wunderbar,
die eingabe von "modprobe snd-pcm-oss" führt dann zu folgendem Fehler:

Error inserting snd_pcm_oss (/lib/modules/2.6.13-15.7-default/kernel/sound/acore/oss/snd-pcm-oss.ko): Unknown symbol in module, or unknown parameter (see dmesg)

Ich habe auch die Lösung des Problems gefunden nur leider weiss ich nicht so richtig wie ich das praktisch umsetzen soll:

The above issue is caused when you switch from alsa-driver to in-kernel ALSA because when you unmerge alsa-driver the module files are config protected and hence get left behind. So, when you switch to in-kernel drivers, running modprobe gives you a mix of alsa-driver and in-kernel modules thus causing the above errors.
The solution is quite easy. We just need to manually remove the problem causing directory after you unmerge alsa-driver. Be sure to remove the correct kernel version and not the current one!

# rm -rf /lib/modules/KERNELVER/alsa-driver


Also füge ich ein: rm -rf /lib/modules/2.6.13-15.7-default/alsa-driver, was mein Problem aber nicht löst.


Ich wäre wirklich sehr dankbar für eure Hilfe, wo ich doch noch ganz am Anfang meiner kleinen Linuxkarriere bin. :oops:

Liebe Grüsse

Werbung:
Benutzeravatar
Gimpel
Guru
Guru
Beiträge: 1983
Registriert: 11. Feb 2004, 13:58
Wohnort: Mjunik .... "no a hoibe, resi!"
Kontaktdaten:

Beitrag von Gimpel » 18. Jan 2006, 01:18

gibts das alsa-driver in dem verzeichnis überhaupt, bzw gab?

weil hier nicht:
/lib/modules/2.6.15-nitro3/*

und modprobe kannste dir sparen. einfach alsaconf ausführen, das macht das schon
Bild on AMD Athlon64 X2 5600+|64bit|6GB DDR2 800MHz|nVidia GF 8500GT|2.6.29-rc1-moo1|BTRFS|KDE-4.2 SVN trunk + Compiz++|M-Audio Audiophile 2496
----
Bild

b2890x
Member
Member
Beiträge: 85
Registriert: 15. Jan 2006, 10:11
Wohnort: 3.OG.mi.

Beitrag von b2890x » 19. Jan 2006, 20:08

Hi, hat soweit geklappt, danke. :)

Benutzeravatar
Gimpel
Guru
Guru
Beiträge: 1983
Registriert: 11. Feb 2004, 13:58
Wohnort: Mjunik .... "no a hoibe, resi!"
Kontaktdaten:

Beitrag von Gimpel » 19. Jan 2006, 22:50

no problemo
Bild on AMD Athlon64 X2 5600+|64bit|6GB DDR2 800MHz|nVidia GF 8500GT|2.6.29-rc1-moo1|BTRFS|KDE-4.2 SVN trunk + Compiz++|M-Audio Audiophile 2496
----
Bild

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 2 Gäste