Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

Dazuko -> Kernel

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Antworten
lbier
Newbie
Newbie
Beiträge: 8
Registriert: 1. Jan 2006, 09:40

Dazuko -> Kernel

Beitrag von lbier » 7. Jan 2006, 23:12

Hallo,
habe Suse 10.0 (32 Bit) und mir die aktuelle Version 2.1.0 ( http://www.dazuko.org/downloads.shtml )von dazuko geladen. Vorab habe ich über YOU mein System aktualisiert.

Anschließend habe ich mit root rpm -q kernel-source und uname -a meine Version verglichen und sind gleich.

Dann die Befehle make cloneconfig und make prepare-all im Verzeichnis /usr/src/linux ausgeführt (aus meiner Sicht soweit i.o.).

In das dazuko Verzeichnis gewechselt ./configure und make ausgeführt.

Anschließend ins /sbin gewechselt und insmod dazuko.ko eingegeben und mit cat /proc/modules
überprüft ob dazuko auftaucht. Tut es auch.

Allerdings wenn ich den Rechner neu starte, werde ich jedes Mal gefragt, ob dazuko geladen werden soll und wenn ich es doch auch für die Zukunft haben möchte bitte den Systemstart anpassen.

Tja, und hier bin ich jetzt am Ende mit meinem Latein ...
Wer kann mir weiterhelfen???

Werbung:
Benutzeravatar
Gimpel
Guru
Guru
Beiträge: 1983
Registriert: 11. Feb 2004, 13:58
Wohnort: Mjunik .... "no a hoibe, resi!"
Kontaktdaten:

Beitrag von Gimpel » 8. Jan 2006, 12:12

hmm...

lösung a)

füge in der /etc/modprobe.conf folgendes hinzu:

Code: Alles auswählen

alias dazuko dazuko
gefolgt von einem

Code: Alles auswählen

depmod -a
lösung b)

wenn das nicht tut (hab gelesen dass dazuko da probs macht), füge es zur initial ramdisk hinzu... weiß nicht die genaue syntax auf SuSE, aber müsste was sein ala

Code: Alles auswählen

mkinitrd --with=dazuko /boot/initrd-`uname -r` `uname -r`
also `uname -r` ist deine kernel version

lösung c)

wenn das auch nicht geht:

Code: Alles auswählen

echo "insmod dazuko.ko" >> /etc/init.d/boot.local
lol ^^^ ...aber geht auch
Bild on AMD Athlon64 X2 5600+|64bit|6GB DDR2 800MHz|nVidia GF 8500GT|2.6.29-rc1-moo1|BTRFS|KDE-4.2 SVN trunk + Compiz++|M-Audio Audiophile 2496
----
Bild

lbier
Newbie
Newbie
Beiträge: 8
Registriert: 1. Jan 2006, 09:40

Beitrag von lbier » 15. Jan 2006, 12:27

Danke für die Antwort :!:
Zu Lösung a.)
Habe wie beschrieben die Datei erweitert, allerdings bekomme ich weiterhin die Meldung.

Zu Lösung b.)
Konnte den Befehl mkinitrd --with nicht unter Suse 10.0 ausführen. Wenn ich unter mkinitrd -h schaue, gibt es dort nicht die with Funktion :(

Zu Lösung c.)
Habe wie beschrieben den Befehl eingegeben, und ... immer noch die Meldung Dazuko manuell starten :cry:

Wolfgang02
Newbie
Newbie
Beiträge: 29
Registriert: 22. Jan 2005, 10:37

Beitrag von Wolfgang02 » 21. Feb 2006, 21:44

Probiers mal so:

Öffne die Datei /etc/sysconfig/kernel und trage in die Option MODULES_LOADED_ON_BOOT das Wort "dazuko" vor dem Wort "capability" ein.

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 3 Gäste