Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

Antivir - Datei /etc/sysconfig/antivir nicht vorhanden

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Antworten
Benutzeravatar
stwe
Newbie
Newbie
Beiträge: 23
Registriert: 18. Dez 2005, 21:47

Antivir - Datei /etc/sysconfig/antivir nicht vorhanden

Beitrag von stwe » 1. Jan 2006, 23:37

Hallo,

ich habe mir die Anleitung bzgl. Antivir und Dazuko durchgelesen. Antivir habe ich direkt von der Anbieter-HP. Dazuko läuft laut lsmod als Modul.

Ich kann auch /etc/init.d/avguard.sh mittels start und stop starten und stoppen.

Allerdings habe ich keine Datei avguard in /etc/sysconfig und auf die Testviren von http://eicar.com/anti_virus_test_file.htm reagiert antivir nicht.

Meine Fragen sind nun:

1) Was mache wegen der fehlenden Datei antivir in /etc/sysconfig. Ich kann ohne das Dingen nicht dem Howto dieses Forums folgen.

2) Läuft bei mir nun das Echtzeitscanning oder nicht? Immerhin läuft doch dakuzo als Modul und ich kann avguard.sh starten und stoppen. Vielleicht kann mich da mal jemand aufklären.

...Bitte nicht wieder gleich mein Posting löschen, bin Linux Newbie...

Steffen

Werbung:
Benutzeravatar
Waschbaer
Member
Member
Beiträge: 114
Registriert: 12. Nov 2005, 10:00
Wohnort: Germany

Beitrag von Waschbaer » 2. Jan 2006, 09:50

In /etc/sysconfig muss es auch keine Datei avguard geben. Bei mir gibt es dort nur die Datei Antivir.

Die Testviren hat er bei mir erkannt, allerdings nur die nicht gepackten, gepackte Dateien scannt avguard nämlich nicht.

Hast du avguard schon konfiguriert? Dort musst du nämlich die Pfade angeben, in denen er scannen soll. Am leichtesten geht das wohl mit:

Code: Alles auswählen

antivir-gui
Man kann nie so kompliziert denken, wie es plötzlich kommt

Opensuse 10.1, Ubuntu 6.06

http://petition.eurolinux.org/

Benutzeravatar
stwe
Newbie
Newbie
Beiträge: 23
Registriert: 18. Dez 2005, 21:47

Beitrag von stwe » 2. Jan 2006, 21:11

Hallo,
In /etc/sysconfig muss es auch keine Datei avguard geben. Bei mir gibt es dort nur die Datei Antivir.
Also bei mir gibt es in /ect/sysconfig keine Datei mit Namen antivir oder avguard. Genau das ist ja das Problem, weshalb ich das Howto nicht nachvollziehen kann.

Wenn ich apt starte, sagt er mir, dass dass km-dazuko nicht installiert ist. Trotzdem läuft dazuko laut lsmod als Modul.

Code: Alles auswählen

antivir-gui
...habe ich ausgeführt. Ich kann auch updaten und die Verzeichnisse scannen. Also ich blicke da nicht mehr durch mit dem Echtzeitscannen.

Steffen[/code]

Argon
Newbie
Newbie
Beiträge: 23
Registriert: 10. Sep 2004, 23:10

Re: Antivir - Datei /etc/sysconfig/antivir nicht vorhanden

Beitrag von Argon » 2. Jan 2006, 22:32

stwe hat geschrieben:Dazuko läuft laut lsmod als Modul
Wie erkenne ich, dass z.B. bei mir Dazuko als Modul läuft?
Wenn ich in der Textkonsole lsmod eingebe, sehe ich eine große Liste u.a. das hier.

Code: Alles auswählen

dazuko                 53360                          0
Läuft das jetzt bei mir einwandfrei oder nicht?
Epox - AMD 2,2 GHz - 1GB RAM - 9800pro - 120 GB HDD
Suse Linux 10 und Windows XP Prof.

Benutzeravatar
stwe
Newbie
Newbie
Beiträge: 23
Registriert: 18. Dez 2005, 21:47

Beitrag von stwe » 2. Jan 2006, 23:58

Hallo,

also wenn lsmod Dir den dazuko anzeigt, ist das Kernelmodul geladen. Ob das nun bei Dir läuft oder nicht weiß ich nicht (woher auch).

Meine Frage, warum denn nun sich keine antivir-Datei in /etc/sysconfig befindet, konnte mir keiner beantworten. Schade. Trotzdem Danke für die zahlreichen Antworten.

Steffen

Benutzeravatar
Spankmaster79
Newbie
Newbie
Beiträge: 31
Registriert: 19. Nov 2005, 07:39

Beitrag von Spankmaster79 » 7. Jan 2006, 09:42

Dieselbe Frage stell ich mir auch grad.

Das how-to ist nicht gerade sehr hilfreich. Vorallem wenn man yast nicht benutzen will um die neusten Versionen zu benutzen.....oder die DVD als Installationsquelle entfernt hat.

dazuko läuft bei mir als Kernel-Modul

Datein in /etc/sysconfig finde ich auch nicht. Aber in /etc ist die avguard.conf und auch die Antivir.conf aber da sind keine Einträge drin wie im How-to beschriebe......

Das gui startet bei mir nicht weil angeblich keine java runtime installiert ist. Die gui verlangt nach Version 1.4.x ich hab aber 1.5.0.....

Alles wiedermal nicht so prickelnd....

Gruß
Spanky
Die Welt ist rund, drum spring ich im Viereck ;-)

Benutzeravatar
stwe
Newbie
Newbie
Beiträge: 23
Registriert: 18. Dez 2005, 21:47

Beitrag von stwe » 7. Jan 2006, 16:47

Hallo

Datein in /etc/sysconfig finde ich auch nicht. Aber in /etc ist die avguard.conf und auch die Antivir.conf aber da sind keine Einträge drin wie im How-to beschriebe......
Genau das ist mein Problem. Vielleicht kann sich der Howto-Autor dazu mal äußeren.
Das gui startet bei mir nicht weil angeblich keine java runtime installiert ist. Die gui verlangt nach Version 1.4.x ich hab aber 1.5.0.....
Ich habe die neueste JRE 1.5 und es läuft das Gui - wenigstens etwas.

Steffen

mexoticom
Member
Member
Beiträge: 65
Registriert: 2. Dez 2007, 14:29
Kontaktdaten:

Beitrag von mexoticom » 6. Dez 2007, 18:18

Hallo!
Muss das Thema noch mal ausgraben.
Will mir Antivir draufpacken und bin nach dieser Anleitung gegangen
http://www.linux-club.de/ftopic48455.html
und habe folgende Pakete installiert:
antivir(2.1.10.15)
dazuko-kmp-bigsmp(2.3.3.4_2.6.22.5_31)
dazuko(2.3.3.4)
Nun stehe ich bei dem Punkt, an dem ich die antivir.conf ändern soll.
Die Datei ist nirgends zu finden.
Habe es mit der Suchfunktion im Startmenü und und dem
Konsolenbefehl "find" versucht.
Kann mir bitte jemand weiterhelfen?
OpenSuse 10.3 Kernel 2.6.22.17-0.1-default i686 KDE 4.0.1 (KDE 4.0.x >=20080201) "release 12.4"
Jeder so wie er es verdient

mexoticom
Member
Member
Beiträge: 65
Registriert: 2. Dez 2007, 14:29
Kontaktdaten:

Beitrag von mexoticom » 7. Dez 2007, 02:03

Hat denn niemand eine Idee?
OpenSuse 10.3 Kernel 2.6.22.17-0.1-default i686 KDE 4.0.1 (KDE 4.0.x >=20080201) "release 12.4"
Jeder so wie er es verdient

Benutzeravatar
spezi
Hacker
Hacker
Beiträge: 769
Registriert: 19. Mai 2004, 12:24
Wohnort: die Stadt im Wald

Beitrag von spezi » 9. Dez 2007, 21:48

Guten Abend,

Code: Alles auswählen

 ...an dem ich die antivir.conf ändern soll
die gibt es nicht mehr. Heisst jetzt avguard.conf und liegt in /etc.

Das Howto bezieht sich auf eine ältere Version von antivir. Da hat sich etliches geändert.

mfg
spezi
Intel Pentium G2020 - MSI H61I-E35 B3, LG-32MP58, Samsung RV720, BR MFC-J4420DW, FRITZ!Box 7490, Syynology DS215j, oS 42.3, Raucher

mexoticom
Member
Member
Beiträge: 65
Registriert: 2. Dez 2007, 14:29
Kontaktdaten:

Beitrag von mexoticom » 10. Dez 2007, 03:05

Hallo spezi!
Danke für deine Antwort.
In einem anderen Thread gabst du den Tipp anstatt der DVD-Version von Antivir lieber die von der Homepage zu nehmen.
Habe nun die "Linux/FreeBSD/OpenBSD/Solaris"-Version runtergeladen und habe aber keine Ahnung, wie ich die installieren soll.
Kannst du mir da bitte weiterhelfen?
OpenSuse 10.3 Kernel 2.6.22.17-0.1-default i686 KDE 4.0.1 (KDE 4.0.x >=20080201) "release 12.4"
Jeder so wie er es verdient

Benutzeravatar
spezi
Hacker
Hacker
Beiträge: 769
Registriert: 19. Mai 2004, 12:24
Wohnort: die Stadt im Wald

Beitrag von spezi » 10. Dez 2007, 05:10

Guten Morgen,
die runtergeladene Datei in einen Ordner Deiner Wahl entpacken. Als root auf der Konsole in diesen Ordner wechseln und dort ./install ausführen und die Fragen zur Konfiguration beantworten. Meistens [y], Vorgaben für Pfade und Key in eckigen Klammern kannst Du direkt übernehmen.
Nach der Installation musst Du noch den/ die entspechenden User, der durch die Installation angelegten Gruppe, antivir zuordnen.
Solltest Du aber apparmor laufen haben, musst Du entscheiden was Dir lieber ist. Das verträgt sich nicht mit dazuko.

mfg
spezi
Intel Pentium G2020 - MSI H61I-E35 B3, LG-32MP58, Samsung RV720, BR MFC-J4420DW, FRITZ!Box 7490, Syynology DS215j, oS 42.3, Raucher

mexoticom
Member
Member
Beiträge: 65
Registriert: 2. Dez 2007, 14:29
Kontaktdaten:

Beitrag von mexoticom » 10. Dez 2007, 13:55

Vielen Dank.
AntiVir ist installiert, der Guard läuft auch.
Gibt es denn eine Möglichkeit die AntiVir-GUI auch ohne Konsole zu starten?
Wollte AntiVir so einstellen, dass es bei einem Fund die Datei sofort löscht,
funktioniert es, wenn ich den Müll-Pfad angebe?
Wenn ja, wie ist der Pfad des Mülls :?:
OpenSuse 10.3 Kernel 2.6.22.17-0.1-default i686 KDE 4.0.1 (KDE 4.0.x >=20080201) "release 12.4"
Jeder so wie er es verdient

Benutzeravatar
spezi
Hacker
Hacker
Beiträge: 769
Registriert: 19. Mai 2004, 12:24
Wohnort: die Stadt im Wald

Beitrag von spezi » 10. Dez 2007, 15:08

Hallo,
Verknüpfung auf dem Desktop oder Eintrag ins Menü. Mit dem löschen bin ich mir nicht so ganz sicher: konnte man das in der conf einstellen? Wenn nicht, schiebe die betroffenen Dateien nach /tmp und lass den mit /etc/sysconfig/cron bearbeiten. Das ist nur ein Vorschlag, darüber hab ich bisher noch keinen Kopf gemacht.

mfg
spezi
Intel Pentium G2020 - MSI H61I-E35 B3, LG-32MP58, Samsung RV720, BR MFC-J4420DW, FRITZ!Box 7490, Syynology DS215j, oS 42.3, Raucher

mexoticom
Member
Member
Beiträge: 65
Registriert: 2. Dez 2007, 14:29
Kontaktdaten:

Beitrag von mexoticom » 10. Dez 2007, 15:43

Hallo,
ich habe weder eine Verknüpfung auf dem Desktop, noch einen AntiVir-Eintrag im Menü.
Wie kann ich eine Verknüpfung auf dem Desktop erstellen?
Welche Datei muss ich dazu benutzen?
OpenSuse 10.3 Kernel 2.6.22.17-0.1-default i686 KDE 4.0.1 (KDE 4.0.x >=20080201) "release 12.4"
Jeder so wie er es verdient

Benutzeravatar
spezi
Hacker
Hacker
Beiträge: 769
Registriert: 19. Mai 2004, 12:24
Wohnort: die Stadt im Wald

Beitrag von spezi » 10. Dez 2007, 17:02

Hallo,
ich kenne mich mit gnome nicht so aus. Bei kde auf dem Destop -> rechte Maustaste -> Neu erstellen -> Link to Application -> Program antivir-gui eingeben. Bei gnome gibt sowas in der Art sicher auch.

mfg
spezi
Intel Pentium G2020 - MSI H61I-E35 B3, LG-32MP58, Samsung RV720, BR MFC-J4420DW, FRITZ!Box 7490, Syynology DS215j, oS 42.3, Raucher

mexoticom
Member
Member
Beiträge: 65
Registriert: 2. Dez 2007, 14:29
Kontaktdaten:

Beitrag von mexoticom » 11. Dez 2007, 17:07

Hallo!
Mit der Verknüpfung auf dem Desktop hat wie du es beschrieben
hast geklappt.
Doch beim GUI-Start bleibt er bei
"Lade lokales Objekt: Guard Local..."
stehen.
Auch von der Konsole aus ist es dasselbe.
An was kann das liegen?
OpenSuse 10.3 Kernel 2.6.22.17-0.1-default i686 KDE 4.0.1 (KDE 4.0.x >=20080201) "release 12.4"
Jeder so wie er es verdient

Benutzeravatar
spezi
Hacker
Hacker
Beiträge: 769
Registriert: 19. Mai 2004, 12:24
Wohnort: die Stadt im Wald

Beitrag von spezi » 12. Dez 2007, 14:49

Hallo,
gibt es auf der Konsole weitere Fehlermeldungen? Starte mal mit antivir-gui &. Ist der Benutzer in der Gruppe antivir ?
Ansonsten auch mal in den log Dateien nachschauen.

mfg
spezi
Intel Pentium G2020 - MSI H61I-E35 B3, LG-32MP58, Samsung RV720, BR MFC-J4420DW, FRITZ!Box 7490, Syynology DS215j, oS 42.3, Raucher

mexoticom
Member
Member
Beiträge: 65
Registriert: 2. Dez 2007, 14:29
Kontaktdaten:

Beitrag von mexoticom » 12. Dez 2007, 16:13

Die Konsole gibt mir die Fehlermeldung aus:
libxcd: WARNING! Program tries to unlock a connection without having acquired
a lock first, which indicates a programming error.
libxcd: WARNING! Programm tries to lock an already locked connection,
which indicates a programming error.
There will be no further warnings about this issue.

Was kann ich da machen?
OpenSuse 10.3 Kernel 2.6.22.17-0.1-default i686 KDE 4.0.1 (KDE 4.0.x >=20080201) "release 12.4"
Jeder so wie er es verdient

Benutzeravatar
spezi
Hacker
Hacker
Beiträge: 769
Registriert: 19. Mai 2004, 12:24
Wohnort: die Stadt im Wald

Beitrag von spezi » 12. Dez 2007, 18:37

Hallo,
da kann ich Dir auch nicht weiterhelfen. Ich habe mal danach gegoogelt, aber eine relevante Aussage dazu habe ich nicht bekommen.
Aber das hat, soweit ich das erkennen kann, nichts mit antivir direkt zu tun. Mir ist das noch nicht untergekommen. Diese libxcd ist auf meinem System auch nicht vorhanden. Ich bin also wirklich überfragt. :(

mfg
spezi
Intel Pentium G2020 - MSI H61I-E35 B3, LG-32MP58, Samsung RV720, BR MFC-J4420DW, FRITZ!Box 7490, Syynology DS215j, oS 42.3, Raucher

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast