mini HowTo für Hylafax

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Benutzeravatar
Kurt M
Hacker
Hacker
Beiträge: 407
Registriert: 24. Sep 2004, 12:39
Wohnort: Bayrischer Wald
Kontaktdaten:

Beitrag von Kurt M » 24. Feb 2005, 19:56

Bonsai hat geschrieben:
Faxe direkt auf Drucker ausgeben:

Drucker mit Cups einrichten und dann einfach am Ende der Datei

Code: Alles auswählen

/var/spool/fax/bin/faxrcvd
die Zeile

Code: Alles auswählen

/usr/bin/fax2ps $1 | lp
einfügen.
das funktioniert ja recht gut.
Nur nach jedem Update von Hylafax sind alle Einstellungen wieder weg. Nicht nur die obige Zeile, auch meine Fax-Passwörter sind weg.

Wie macht man einen Hylafax Update richtig, damit man nicht nochmal alles neu einrichten muß ?

Werbung:
Red_13
Newbie
Newbie
Beiträge: 1
Registriert: 21. Jun 2005, 10:23

Hi Bonsai !

Beitrag von Red_13 » 21. Jun 2005, 10:37

Erst mal Danke für das ausführliche und gut zu verstehende HowTo
über den Hylafaxserver.

Habe den Server jetzt eingerichtet ( SuSe 9.2 & AVM-B1 direkt an einem NTBA ) und bin bis jetzt sehr zufrieden. Versand per WHFC und auch der Empfang ( allerdings nur an den Faxmaster )funktionieren tadellos.
Würde nun gerne noch einen Schritt weitergehen und DDI verwenden um jedem meiner User eine eigene Faxnummer zu geben. Stelle mir das so vor, das Hylafax die eingehenden Faxe
entgegennimmt und dann per Mail als PDF oder Tiff an die einzelnen
User weiterleitet.
Habe mich bereits durch etliche Foren und Beiträge gelesen, überall
steht zu lesen das Hylafax das kann, nur eine verständliche Anleitung zur Einrichtung konnte ich nirgends entdecken. Kannst Du
auch hier mit einem HowTo weiterhelfen ?

Gruß, Red_13

mathew05
Newbie
Newbie
Beiträge: 41
Registriert: 16. Nov 2005, 17:06

raus faxen geht nicht

Beitrag von mathew05 » 21. Nov 2005, 14:14

hallo ich habe da ein poblem mit dem raus faxen. die aufträge bleiben in der warteschlange und nix passiert außer die meldung

Nov 21 14:09:49 testserver HylaFAX[8236]: Filesystem has SysV-style file creation semantics.
Nov 21 14:09:49 testserver FaxQueuer[8191]: SUBMIT JOB 4
ov 21 14:13:55 msitserver init: Id "fr" respawning too fast: disabled for 5 minutes

weiß jemand wo mein problem liegt?

ich habe mittlerweile suse10 mit eine avm fritzcard pci drin.

gruß
matthias

dsimons
Newbie
Newbie
Beiträge: 4
Registriert: 17. Apr 2004, 12:44
Wohnort: Neuss
Kontaktdaten:

Beitrag von dsimons » 24. Nov 2005, 09:18

Hallo mathew05,

ich hatte das gleiche Problem auf einem Dell PowerEdge 2850. Dort ist SuSE 10 in der 64Bit Version installiert.

Nachdem ich von Hand mit rpm -Uvh Paketname_x86_64.rpm die 64Bit Versionen der Pakete neu installiert und konfiguriert habe, funktionierte der Faxversand endlich.

Die Ausgabe mit faxstat war ebenfalls endlich korrekt.

Folgende Pakete habe ich neu installiert:
-Alles was mit CAPI, ISDN und AVM zu tun hatte
-Hylafax Server

Vielleicht hilft es auch bei Dir.

Viele Grüsse
Dietmar
Simons IT-Service
Dietmar Simons
Matthiasstr. 18a
41468 Neuss

Phone +49 2131 15 34 98
Fax +49 2131 15 34 99
Mobil +49 172 253 05 23
Email: dietmar.simons@simons-it-service.de
Internet: http://www.simons-it-service.de/

mathew05
Newbie
Newbie
Beiträge: 41
Registriert: 16. Nov 2005, 17:06

Beitrag von mathew05 » 24. Nov 2005, 09:51

ja, bei mir hat es dann gefunzt.

das einzige problem das ich noch hab ist das die faxe die ankommen irgendwie in die länge gezogen sind.

weiß vielleicht auch jemand einen grafischen hylafaxclient für linux bei dem vielleicht auch ein sendeprotokoll ersichtlich ist oder so?

danke

rethus
Advanced Hacker
Advanced Hacker
Beiträge: 1028
Registriert: 17. Sep 2004, 10:21
Wohnort: Kerpen
Kontaktdaten:

Beitrag von rethus » 17. Jan 2008, 21:26

Bonsai hat geschrieben: @Kalunke
hast Du das als Fax Class1 Modem konfiguriert?

Auch wenn root die Anwendung startet? Ich denke, ein entsprechender chmod auf den Ordner sollte das lösen.
Ich habe das gleiche Problem. Welchen Ordner meint Ihr, von wegen "Rechte ändern" ?

rethus
Advanced Hacker
Advanced Hacker
Beiträge: 1028
Registriert: 17. Sep 2004, 10:21
Wohnort: Kerpen
Kontaktdaten:

Beitrag von rethus » 17. Jan 2008, 21:44

Ok, die angekommenen Faxe kann ich jetzt ansehen /ein chmod 777 für den Ordner /var/spool/fax/recvq brachte die Lösung.

Aber oben geschildertes Problem mit KDEprintFax besteht immer noch, obwohl ich jetzt schon den gesamten ordner /var/spool/fax auf 777 gesetzt hab.

Im Protokoll steht:
Übermittlung an Fax mittels: /usr/bin/capisuitefax -d '01234554321' '/tmp/kde-xyz/kdeprintfax_tVVVX2bB'
can't write to queue dir

rethus
Advanced Hacker
Advanced Hacker
Beiträge: 1028
Registriert: 17. Sep 2004, 10:21
Wohnort: Kerpen
Kontaktdaten:

Beitrag von rethus » 14. Feb 2008, 20:24

Ich habe nun einen anderen String dort eingetragen, anhand dessen das Faxe-Versenden funktioniert:

Code: Alles auswählen

/usr/bin/sendfax -n -h %server %res -x %enterprise -c %comment -f %email -d %name@%number %files

coogor
Hacker
Hacker
Beiträge: 639
Registriert: 21. Dez 2005, 12:10
Wohnort: Düsseldorf

Beitrag von coogor » 19. Feb 2008, 23:01

rethus hat geschrieben: Im Protokoll steht:
Übermittlung an Fax mittels: /usr/bin/capisuitefax -d '01234554321' '/tmp/kde-xyz/kdeprintfax_tVVVX2bB'
can't write to queue dir
..Das wäre dann wohl /var/spool/fax/sendq (oder so ähnlich, hab gerade kein hfax hier...)
V8: More smile per mile

Favorite Toy: ThinkPad T520, Core i7-2640M, 8G RAM, 1600x900, openSUSE Tumbleweed
Member of openSUSE.org

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 2 Gäste