Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

Fragen zum kostenlosen CVS download von WINEX

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Antworten
frodoooo
Member
Member
Beiträge: 197
Registriert: 4. Dez 2005, 12:43
Wohnort: sachichauchnet
Kontaktdaten:

Fragen zum kostenlosen CVS download von WINEX

Beitrag von frodoooo » 23. Dez 2005, 11:44

Downloaden von WINEX auf die kostenlose Art, wie folgt.
Duncan Mac Leod

WineX gibts HIER: http://www.transgaming.com/license.php?source=1

Lizenz-Bestimmungen akzeptieren und Du erhaelst Password fuer CVS

dann einloggen:

cvs -d:pserver:cvs@cvs.transgaming.org:/cvsroot login

dann passwd eingeben und dann downloaden:

cvs -z3 -d:pserver:cvs@cvs.transgaming.org:/cvsroot co -r winex-3-3 winex

ins verzeichnis wechseln und compilieren - am besten nach /opt mit:

./configure --prefix=/opt/winex --enable-opengl --enable-pthreads
<output deleted>
make depend && make
cd programs/regapi
make
cd ../..
make install
Hallo Duncan Mac Leod, danke für diesen excellenten Beitrag.
Ich habe den jetzt einfach mal aus dem anderen Thread raus kopiert und einen neuen aufgemacht, weil in dem anderen mittlerweile soviel Blah drin steht dass man da gar nicht mehr richtig durchfindet :wink:

OK, soweit habe ich alles hinbekommen
WineX gibts HIER: http://www.transgaming.com/license.php?source=1

Lizenz-Bestimmungen akzeptieren und Du erhaelst Password fuer CVS

dann einloggen:

cvs -d:pserver:cvs@cvs.transgaming.org:/cvsroot login

dann passwd eingeben .....................[ERROR]
nur leider ist nach der Eingabe des Passwortes bei mir Feierabend !

Hier Frage 1: Wieso muss man hier nur ein Passwort eingeben ? Was ist mit einem Username oder Email Adresse ?

Frage 2: Bekomme immer eine Fehlermeldung "PAM irgendwas" (werde ich von zu Hause noch einmal posten, sitze im Moment nicht an meinem PC) kann es sein dass mir eine Software fehlt für die Authentifizierung ? Muss mein Linux Anmelde Name gleich dem Namen sein mit dem ich mich bei www.transgaming.com registriert habe ?

Danke schon mal für weitere Info's (werde nachher noch die GENAUE Fehlermeldung eintragen und diesen Beitrag dementsprechen abändern, bitte trotzdem schon antworten falls jemand ne ahnung hat :wink: )
Bis dann

Frodoooo

..:: http://www.myspace.com/michel_hesse ::..

Bild

Werbung:
traffic
Guru
Guru
Beiträge: 2750
Registriert: 13. Feb 2005, 05:50

Re: Fragen zum kostenlosen CVS download von WINEX

Beitrag von traffic » 23. Dez 2005, 12:21

frodoooo hat geschrieben:nur leider ist nach der Eingabe des Passwortes bei mir Feierabend !

Hier Frage 1: Wieso muss man hier nur ein Passwort eingeben ? Was ist mit einem Username oder Email Adresse ?
Wie wäre es denn mal mit einem Minumum(!) an Eigeninitiative?
To checkout a new CVS respository:

1. cvs -d:pserver:cvs@cvs.transgaming.org:/cvsroot login
2. When prompted for the password enter "cvs"
3. cvs -z3 -d:pserver:cvs@cvs.transgaming.org:/cvsroot co winex
Quelle: http://www.transgaming.com/sources.php

Cookies müssten akzeptiert werden, sonst endet die Lizenzabfrage in einer Endlosschleife.

frodoooo
Member
Member
Beiträge: 197
Registriert: 4. Dez 2005, 12:43
Wohnort: sachichauchnet
Kontaktdaten:

Beitrag von frodoooo » 23. Dez 2005, 12:34

Ich habe das
cvs -d:pserver:cvs@cvs.transgaming.org:/cvsroot login

dann passwd eingeben und dann downloaden:
so verstanden als ob ich das Passwort eingeben müsste das ich mir selbst beim erstellen des Transgaming Accounts gegeben habe.
Wie wäre es denn mal mit einem Minumum(!) an Eigeninitiative?
Lasst doch einfach mal diese überheblichen posts, und schreibt einfach nur zur Sache.
Ich habe 3 Tage Eigeninitiative gezeigt und alles mögliche mit meinen bescheidenen Mitteln ( weil ich bin Linux Neuling ) ausprobiert, nur irgendwann ist dann halt mal ende und man bitte hier um HILFE und nicht um DUMME SPRÜCHE !

Ok also versuche ich es heute noch einmal mit dem Passwort "CVS"

Danke für den Hinweis.
Bis dann

Frodoooo

..:: http://www.myspace.com/michel_hesse ::..

Bild

frodoooo
Member
Member
Beiträge: 197
Registriert: 4. Dez 2005, 12:43
Wohnort: sachichauchnet
Kontaktdaten:

Beitrag von frodoooo » 23. Dez 2005, 17:35

hat geklappt, danke.
Starte jetzt mit der Initiative "Installation" !
Bis dann

Frodoooo

..:: http://www.myspace.com/michel_hesse ::..

Bild

frodoooo
Member
Member
Beiträge: 197
Registriert: 4. Dez 2005, 12:43
Wohnort: sachichauchnet
Kontaktdaten:

Beitrag von frodoooo » 23. Dez 2005, 17:49

schade nachdem ich noch einige fehlende Dev. Pakete nachinstalliert hatte, und mich dann dem MAKE gewidmet hatte kam diese Meldung.
newstruc.c: In function ‘handle_ani_list’:
newstruc.c:740: error: invalid lvalue in increment
newstruc.c: In function ‘new_ani_curico’:
newstruc.c:851: error: invalid lvalue in increment
make[2]: *** [newstruc.o] Fehler 1
make[2]: Leaving directory `/home/hesse/winex/tools/wrc'
make[1]: *** [wrc] Fehler 2
make[1]: Leaving directory `/home/hesse/winex/tools'
make: *** [tools] Fehler 2
Hat einer ne Ahnung was das heissen soll und was ich dagegen machen kann ? Oder besser, wie kriege ich das zum durchlaufen :wink:
Bis dann

Frodoooo

..:: http://www.myspace.com/michel_hesse ::..

Bild

marcl
Newbie
Newbie
Beiträge: 8
Registriert: 2. Aug 2005, 17:34

Beitrag von marcl » 3. Jan 2006, 18:56

hallo zusammen und frohes neues,
ich hab leider beim verwenden es winecvs scripts genau diesselben probleme wie frodo :(

google hat mich hier hin gelotst.
EDIT: gcc-3.3 is no go. use 3.4 only.
Cool - thanks. I got gcc 3.4 and it *seems* to be running okay now Its got onto make install and no problems yet... fingers crossed
Nun per apt komme ich an kein anderes gcc ausser der neuesten.

also habe ich das mit den "umgebungsvariablen" ausprobiert.

Code: Alles auswählen

export CC=gcc3.4
export CCX=gcc3.4
so oder so ähnlich waren die befehle; finde grad die seite nicht mehr.
die eingabe führt zu keiner rückmeldung.

aber wenn ich dann wieder das script starte kriege ich wieder diesselbe fehlermeldung.

ja was soll ich sagen, ich kriegs nich hin und weder dieses forum noch google scheinen die lösung zu haben. also vielleicht kommt ihr jetzt nach den feiertagen wieder zurück und habt eine erleuchtung für frodo % mich

Also wie kriege gcc 3.4 installiert und wie sag ich dem script dass es bitte schön mit dem gcc 3.4 installieren soll; dazu hab ich hier im forum auch keine befriedegende lösung gefunden.
HW: A7n8x-x, Geforce ti 4400
SW: OS 10.0 - KDE 3.4

frodoooo
Member
Member
Beiträge: 197
Registriert: 4. Dez 2005, 12:43
Wohnort: sachichauchnet
Kontaktdaten:

Beitrag von frodoooo » 21. Mai 2006, 12:04

ich hänge immer noch bei dieser Fehlermeldung

nachdem ich 'make depend && make' eingebe.
newstruc.c: In function ‘handle_ani_list’:
newstruc.c:740: error: invalid lvalue in increment
newstruc.c: In function ‘new_ani_curico’:
newstruc.c:851: error: invalid lvalue in increment
make[2]: *** [newstruc.o] Error 1
make[2]: Leaving directory `/opt/winex/tools/wrc'
make[1]: *** [wrc] Error 2
make[1]: Leaving directory `/opt/winex/tools'
make: *** [tools] Error 2
linuxpc:/opt/winex # make install
make[1]: Entering directory `/opt/winex/unicode'
make[1]: `libwine_unicode.so' is up to date.
make[1]: Leaving directory `/opt/winex/unicode'
make[1]: Entering directory `/opt/winex/tools'
make[2]: Entering directory `/opt/winex/tools/winebuild'
make[2]: Nothing to be done for `all'.
make[2]: Leaving directory `/opt/winex/tools/winebuild'
make[2]: Entering directory `/opt/winex/tools/winedump'
make[2]: Nothing to be done for `all'.
make[2]: Leaving directory `/opt/winex/tools/winedump'
make[2]: Entering directory `/opt/winex/tools/wmc'
make[2]: Nothing to be done for `all'.
make[2]: Leaving directory `/opt/winex/tools/wmc'
make[2]: Entering directory `/opt/winex/tools/wrc'
gcc -c -I. -I. -I../../include -I../../include -g -O2 -Wall -mpreferred-stack-boundary=2 -fno-keep-static-consts -D__const=const -fno-strict-aliasing -D__int8=char -D__int16=short -D__int32=int "-D__int64=long long" -D__WINE__ -D_REENTRANT -I/usr/X11R6/include -o newstruc.o newstruc.c
newstruc.c: In function ‘handle_ani_list’:
newstruc.c:740: error: invalid lvalue in increment
newstruc.c: In function ‘new_ani_curico’:
newstruc.c:851: error: invalid lvalue in increment
make[2]: *** [newstruc.o] Error 1
make[2]: Leaving directory `/opt/winex/tools/wrc'
make[1]: *** [wrc] Error 2
make[1]: Leaving directory `/opt/winex/tools'
make: *** [tools] Error 2
Bis dann

Frodoooo

..:: http://www.myspace.com/michel_hesse ::..

Bild

diggital
Newbie
Newbie
Beiträge: 3
Registriert: 3. Jun 2006, 20:58

Frage zur Installation

Beitrag von diggital » 4. Jun 2006, 17:23

Ein Dankeschön und ein Hallo @All

Ich habe alles so gemacht wie du beschrieben hast und habe aber den downloadlink gemöss Beschrieb auf der besagten Seite genommen.

Hatt alles geklappt. Bin in das Verzeichniss gegangen und habe dein Instlink übernommen.
Dabei kam folgendes raus. Welchen Fehler habe ich gemacht.
dolphinwireless:~ # cd winex
dolphinwireless:~/winex # ./configure --prefix=/opt/winex --enable-opengl --enab
le-pthreads
checking build system type... i686-pc-linux-gnu
checking host system type... i686-pc-linux-gnu
checking target system type... i686-pc-linux-gnu
checking whether make sets $(MAKE)... yes
checking for gcc... gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ANSI C... none needed
checking how to run the C preprocessor... gcc -E
checking for X... libraries /usr/X11R6/lib, headers /usr/X11R6/include
checking for gethostbyname... yes
checking for connect... yes
checking for remove... yes
checking for shmat... yes
checking for IceConnectionNumber in -lICE... yes
checking for bison... no
checking for byacc... no
checking for flex... flex
checking for yywrap in -lfl... yes
checking lex output file root... lex.yy
checking whether yytext is a pointer... yes
checking for yacc... no
checking for bison... no
checking for yacc... no
configure: error: no suitable bison/yacc found. Please install the 'bison' packa ge.
dolphinwireless:~/winex # <output deleted>
-bash: syntax error near unexpected token `newline'
dolphinwireless:~/winex # make depend && make
make: *** No rule to make target `depend'. Stop.
dolphinwireless:~/winex # cd programs/regapi
dolphinwireless:~/winex/programs/regapi # make
make: *** No targets specified and no makefile found. Stop.
dolphinwireless:~/winex/programs/regapi # cd ../..
dolphinwireless:~/winex # make install
make: *** No rule to make target `install'. Stop.
dolphinwireless:~/winex #
Ich versuche diese Programm in Suse 10 zu Installieren.
Da ich im Linux noch kein Profi bin hänge ich ein wenig.

Gruss Diggital

legine
Newbie
Newbie
Beiträge: 33
Registriert: 1. Aug 2005, 13:23

Beitrag von legine » 1. Aug 2006, 16:51

Diggital instalier einfach mal das packet 'bison' (such in Yast und probiers nochmal.
Dies bversucht dir die Zeile:
configure: error: no suitable bison/yacc found. Please install the 'bison' packa ge.
zu sagen ;)

So und nun warum wollt ihr unbedingt transgameings winex haben?

Gruß
Legine

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast