Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

Meine SATA-Festplatte kann nicht gemountet werden

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Antworten
maru
Newbie
Newbie
Beiträge: 37
Registriert: 19. Jul 2005, 12:13

Meine SATA-Festplatte kann nicht gemountet werden

Beitrag von maru » 21. Dez 2005, 23:58

ich bin vor kurzem von suse auf debian umgestiegen. bin grundsätzlich erstmal begeistert von der schnelligkeit. mein suse-system hat den rechner wohl etwas überlasten.

aber nun zu meinem problem: ich habe zwei festplatten, eine ide, eine sata. letztere wurde zwar bei der installation erkannt und auch in die fstab eingetragen. beim booten kommt allerdings die fehlermeldung, das die partitionen nicht gemountet werden können. was kann ich tun?

maru

Werbung:
towo
Moderator
Moderator
Beiträge: 3710
Registriert: 15. Feb 2004, 16:42
Wohnort: Nimritz
Kontaktdaten:

Beitrag von towo » 22. Dez 2005, 00:00

was kann ich tun?
Erstmal Groß- und Kleinschreibung anwenden, dann den genauen Wortlaut der Fehlermeldung posten und hilfreich wären noch die Ausgaben von

cat /etc/fstab
fdisk -l
Signatur nach Diktat spazieren gegangen

Bild

maru
Newbie
Newbie
Beiträge: 37
Registriert: 19. Jul 2005, 12:13

Beitrag von maru » 22. Dez 2005, 00:11

Alles klar. Hier die Fehlermeldung beim Bootvorgang:

Checking all filesystems ...
fsck 1.37
Failed to open the device /dev/sda2: No such file or directory
Failed to open the device /dev/sda1: No such file or directory


Dann kann ich den Bootvorgang mit Ctr + D fortsetzen.
Weiterhin:

maru@deb:~$ cat /etc/fstab
# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
/dev/hdc1 / reiserfs notail 0 1
/dev/sda2 /data reiserfs defaults 0 2
/dev/sda1 /home reiserfs defaults 0 2
/dev/hdc2 none swap sw 0 0
/dev/hda /media/cdrom0 iso9660 ro,user,noauto 0 0
/dev/fd0 /media/floppy0 auto rw,user,noauto 0 0

und

deb:~# fdisk -l

Disk /dev/hdc: 13.6 GB, 13613064192 bytes
16 heads, 63 sectors/track, 26377 cylinders
Units = cylinders of 1008 * 512 = 516096 bytes

Device Boot Start End Blocks Id System
/dev/hdc1 1 12484 6291904+ 83 Linux
/dev/hdc2 12485 14565 1048824 82 Linux swap / Solaris
/dev/hdc3 * 14566 26377 5953248 c W95 FAT32 (LBA)

Disk /dev/sda: 160.0 GB, 160041885696 bytes
255 heads, 63 sectors/track, 19457 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Device Boot Start End Blocks Id System
/dev/sda1 1 9007 72348696 83 Linux
/dev/sda2 9008 12924 31463302+ 83 Linux
/dev/sda3 12925 19456 52468290 c W95 FAT32 (LBA)

Ich hoffe, das hilft weiter.
maru

towo
Moderator
Moderator
Beiträge: 3710
Registriert: 15. Feb 2004, 16:42
Wohnort: Nimritz
Kontaktdaten:

Beitrag von towo » 22. Dez 2005, 09:18

Da fsck die Meldung bringt, nehme ich mal an, das zu dem Zeitpunkt der sata-Treiber noch nicht geladen ist, ergo die Platte noch nicht existiert.

ein

Code: Alles auswählen

/dev/sda2 /data reiserfs defaults 0 0
/dev/sda1 /home reiserfs defaults 0 0 
schafft hier zwar Abhilfe, nur wird das FS dann auch nicht mehr automatisch auf Fehler geprüft.
Signatur nach Diktat spazieren gegangen

Bild

maru
Newbie
Newbie
Beiträge: 37
Registriert: 19. Jul 2005, 12:13

Beitrag von maru » 22. Dez 2005, 11:34

kann ich denn die platten nicht nachträglich nochmal auf fehler überprüfen?

maru

towo
Moderator
Moderator
Beiträge: 3710
Registriert: 15. Feb 2004, 16:42
Wohnort: Nimritz
Kontaktdaten:

Beitrag von towo » 22. Dez 2005, 11:36

JA, nachträglich geht auch, aber eben nicht automatisch.
Signatur nach Diktat spazieren gegangen

Bild

maru
Newbie
Newbie
Beiträge: 37
Registriert: 19. Jul 2005, 12:13

Beitrag von maru » 22. Dez 2005, 13:06

ok. die fehlermeldung beim start ist jetzt weg. allerdings werden /data und /home immer noch nicht richtig eingebunden. auch später kann ich sie nur als root einbinden, nicht als user. muss ich das "defaults" durch "user" ersetzen?

maru

towo
Moderator
Moderator
Beiträge: 3710
Registriert: 15. Feb 2004, 16:42
Wohnort: Nimritz
Kontaktdaten:

Beitrag von towo » 22. Dez 2005, 13:31

maru hat geschrieben:ok. die fehlermeldung beim start ist jetzt weg. allerdings werden /data und /home immer noch nicht richtig eingebunden. auch später kann ich sie nur als root einbinden, nicht als user. muss ich das "defaults" durch "user" ersetzen?

maru
Was heisst, nicht richtig eingebunden?
Entweder sie werden gemountet oder eben nicht, was nun?
Wenn der user die mounten dürfen soll, dann muß users dazu.
Signatur nach Diktat spazieren gegangen

Bild

maru
Newbie
Newbie
Beiträge: 37
Registriert: 19. Jul 2005, 12:13

Beitrag von maru » 22. Dez 2005, 14:11

Danke. Ich kann die Festplatten jetzt als User mounten (muss ich ja, wenn die home-Verzeichnisse auf der Platte liegen).
Aber: Die Platten werden nicht automatisch gemountet. Wie kommt das?

towo
Moderator
Moderator
Beiträge: 3710
Registriert: 15. Feb 2004, 16:42
Wohnort: Nimritz
Kontaktdaten:

Beitrag von towo » 22. Dez 2005, 17:37

schreib halt noch 'auto' als Option dazu.
Signatur nach Diktat spazieren gegangen

Bild

maru
Newbie
Newbie
Beiträge: 37
Registriert: 19. Jul 2005, 12:13

Beitrag von maru » 22. Dez 2005, 18:59

Ne. Leider tut sich da gar nichts. Habe dasselbe Problem wie vorher.
maru

maru
Newbie
Newbie
Beiträge: 37
Registriert: 19. Jul 2005, 12:13

Beitrag von maru » 27. Dez 2005, 14:34

weiß niemand eine antwort??

Antworten