Amule will einfach nicht?

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Antworten
Treamman
Newbie
Newbie
Beiträge: 7
Registriert: 26. Nov 2005, 19:20

Amule will einfach nicht?

Beitrag von Treamman » 26. Nov 2005, 19:45

Hi

habe jetzt versucht Amule zu installieren aber ich bekomms einfach nicht hin :/
wenn ich amule starten will kommt:
19:42:30: Error: Unable to initialize gtk, is DISPLAY set properly?

kann ich amule nicht nur in der console starten ohne grafische oberfläche?


Gruß,
Treamman

Werbung:
traffic
Guru
Guru
Beiträge: 2750
Registriert: 13. Feb 2005, 05:50

Re: Amule will einfach nicht?

Beitrag von traffic » 26. Nov 2005, 19:58

Treamman hat geschrieben:kann ich amule nicht nur in der console starten ohne grafische oberfläche?
Nein, kannst Du nicht. aMule ist eine GUI-Anwendung. Wenn Du keine grafische Oberfläche willst, beschäftige Dich mit dem aMule-Daemon.

Treamman
Newbie
Newbie
Beiträge: 7
Registriert: 26. Nov 2005, 19:20

Beitrag von Treamman » 26. Nov 2005, 21:57

so jetzt hab ich es als Deamon installiert.
jetzt kommt dieser fehler:
amule: error while loading shared libraries: libwx_gtk2_xrc-2.6.so.0: cannot open shared object file: No such file or directory

traffic
Guru
Guru
Beiträge: 2750
Registriert: 13. Feb 2005, 05:50

Beitrag von traffic » 26. Nov 2005, 22:30

Sorry, ohne die Angaben,

- welche Distribution und welche Version dieser Distribution Du benutzt,
- welche Pakete Du installiert hast und woher diese kommen,

kann ich Dir da leider nicht helfen.

Mach mal folgendes:

Code: Alles auswählen

rpm -qa | grep -i amule
rpm -qa | grep -i wx
cat /etc/*-release
Und kopier die Angaben ins Forum.

Treamman
Newbie
Newbie
Beiträge: 7
Registriert: 26. Nov 2005, 19:20

Beitrag von Treamman » 27. Nov 2005, 08:37

ja sorry ohne infos gehts schlecht ;)

aMule-2.0.3
wxBase-2.4.2-1

SUSE LINUX 10.0 (i586)
VERSION = 10.0
LSB_VERSION="core-2.0-noarch:core-3.0-noarch:core-2.0-ia32:core-3.0-ia32"

IhmSelbst
Member
Member
Beiträge: 53
Registriert: 28. Okt 2003, 01:03
Wohnort: 26349 Jade, nds, adw
Kontaktdaten:

Beitrag von IhmSelbst » 28. Nov 2005, 08:18

libwx_gtk2_xrc-2.6.so.0 wird von wxGTK-compat-2.6.1.0-4.i586.rpm bereitgestellt.

von dem uralt-wxBase-2.4.2-1 sollte man sich trennen.

wilder
Member
Member
Beiträge: 104
Registriert: 12. Sep 2006, 17:26

Beitrag von wilder » 11. Sep 2007, 18:07

ja, amule... :roll:

bei mir kommt beim start von amule folgende fehlermeldung:
(amule:5574): GLib-WARNING **: getpwuid_r(): failed due to: Die Operation ist nicht erlaubt.
Gtk-Message: Failed to load module "gail": /opt/gnome/lib/gtk-2.0/modules/libgail.so: Kann die Shared-Object-Datei nicht öffnen: Die Operation ist nicht erlaubt
Gtk-Message: Failed to load module "atk-bridge": /opt/gnome/lib/gtk-2.0/modules/libatk-bridge.so: Kann die Shared-Object-Datei nicht öffnen: Die Operation ist nicht erlaubt
_X11TransSocketINETConnect() can't get address for localhost:6000: Der Name oder der Dienst ist nicht bekannt
Error: Unable to initialize gtk, is DISPLAY set properly?
habe:
aMule-CVS-20070608-0.pm.1

wxGTK-compat-2.6.3.3-30
wxWidgets-2.8.4-0.pm.2
wxGTK-gl-2.6.3.3-30
wxGTK-2.6.3.3-30
python-wxGTK-2.6.3.3-30

LSB_VERSION="core-2.0-noarch:core-3.0-noarch:core-2.0-ia32:core-3.0-ia32"
openSUSE 10.2 (i586)
VERSION = 10.2

lösungen für das problem? ist gtk nicht korrekt installiert?

danke w.
Mein System: kernel 2.6.22.18-0.2-default, openSUSE 10.3 (32bit), Gnome 2.20.0

wilder
Member
Member
Beiträge: 104
Registriert: 12. Sep 2006, 17:26

Beitrag von wilder » 13. Sep 2007, 16:33

hallo,

und als root kommt folgende fehlermeldung in der konsole:

Code: Alles auswählen

(amule:5724): GLib-WARNING **: getpwuid_r(): failed due to: Operation not permitted.
_X11TransSocketINETConnect() can't get address for localhost:6000: Name or service not known
Error: Unable to initialize gtk, is DISPLAY set properly?
1. wie kann ich erreichen, dass die rechte für amule korrekt gesetzt sind (s.o., will amule als standard-nutzer starten)?

2. wie löse ich das problem mit "localhost:6000" und gtk?

danke, w.
Mein System: kernel 2.6.22.18-0.2-default, openSUSE 10.3 (32bit), Gnome 2.20.0

wilder
Member
Member
Beiträge: 104
Registriert: 12. Sep 2006, 17:26

Beitrag von wilder » 27. Nov 2007, 12:34

mit dem standard-nutzer erhalte ich jetzt folgende fehlermeldung beim start von amule:

Code: Alles auswählen

(amule:4893): GLib-WARNING **: getpwuid_r(): failed due to: Die Operation ist nicht erlaubt.
_X11TransSocketINETConnect() can't get address for localhost:6000: Der Name oder der Dienst ist nicht bekannt
Error: Unable to initialize gtk, is DISPLAY set properly?
habe aMule-CVS per YaST deinstalliert und aMuleAdu-CVS installiert. brachte keine besserung. als root kommt folgende fehlermeldung:

Code: Alles auswählen

(amule:6604): GLib-WARNING **: getpwuid_r(): failed due to: Operation not permitted.
AdunanzA says: bye bye!
Error: Unable to initialize gtk, is DISPLAY set properly?
Mein System: kernel 2.6.22.18-0.2-default, openSUSE 10.3 (32bit), Gnome 2.20.0

Benutzeravatar
Becksta
Hacker
Hacker
Beiträge: 425
Registriert: 6. Jun 2006, 01:25
Wohnort: Westerwald
Kontaktdaten:

Beitrag von Becksta » 27. Nov 2007, 12:40

Hm....

ganz komisches Zeug, das du da bekommst...
Um den Esel im Deamon Modus, also nicht graphisch zu starten,
Gib einfach mal als User auf der Konsole "amuled -f" ein.
Das -f bewirkt, dass du die Konsole auch wieder schließen kannst, die Anwendung wird in den Hintergrund "geforked".... :o)
So lasse ich das immer auf meinem Server mitlaufen. Über den http://localhost:4711 komme ich dann immer auf den Webserver...
Das muss allerdings erstmal in der /home/user/.aMule/amule.conf aktiviert werden....

Das was du da bekommst kann ich überhaupt nicht nachvollziehen.... ;o)

Greetz
Becksta
Mein System:
Intel Core 2 Duo E6400 2,13 Ghz
Asus P5b
MSI GeForce 7600 Gs
2048MB Arbeitsspeicher

Betriebssysteme:
OpenSuse 11.2 Linux 2.6.31
Gnome
Windows 7 Professional

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 2 Gäste