[gelöst] Benutzer an bestimmten Terminal binden

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Gesperrt
Benutzeravatar
Marc
Newbie
Newbie
Beiträge: 28
Registriert: 2. Sep 2003, 12:07
Wohnort: Kleve

[gelöst] Benutzer an bestimmten Terminal binden

Beitrag von Marc » 31. Mär 2004, 22:41

Hallo Listenleser,

ich möchte einen Benutzer an ein bestimmtes Terminal binden - nicht wörtlich gemeint ;-)
Und zwar sollen nur bestimmte Terminals (, die der Bücherei) kein Login benötigen.
Ich bin mir nicht sicher, ob es ausreicht, der Anleitung >>Autologin with KDM<< in Zusammenhang mit festen IPs bzw. MAC-Adressen zu folgen.

Unsicher bin ich auch bei der Reduzierung auf KDM. Ist der WindowManager da egal?

Für Hilfe wie immer dankbar.

Marc

Werbung:
schweer
Hacker
Hacker
Beiträge: 268
Registriert: 2. Jan 2004, 23:40
Wohnort: Bochum

Re: Benutzer an bestimmten Terminal binden

Beitrag von schweer » 1. Apr 2004, 17:28

Marc hat geschrieben:Und zwar sollen nur bestimmte Terminals (, die der Bücherei) kein Login benötigen.
Ich bin mir nicht sicher, ob es ausreicht, der Anleitung >>Autologin with KDM<< in Zusammenhang mit festen IPs bzw. MAC-Adressen zu folgen.

Unsicher bin ich auch bei der Reduzierung auf KDM. Ist der WindowManager da egal?
Der Windowmanager sollte egal sein.

Probiere es mal wie in diesem Beispiel (Datei kdmrc):

Code: Alles auswählen

[X-Terminal001:0-Core]
AutoLoginEnable=true
AutoLoginUser=testuser
 
[X-Terminal001:0-Greeter]
GreetString=Terminalserver:%h Terminal:X-Terminal001
ShowUsers=Selected
Users=testuser
wolfgang

Benutzeravatar
Marc
Newbie
Newbie
Beiträge: 28
Registriert: 2. Sep 2003, 12:07
Wohnort: Kleve

Rund 8 Monate später .... auto-login-Problem nicht gelöst

Beitrag von Marc » 12. Dez 2004, 12:25

Hallo Wolfgang, hallo Listenleser,

leider funktioniert dein Vorschlag zur Bindung bestimmter User an eine Maschine nicht bei mir.

Ich habe nun für unsere Schule einen neuen Server mit SuSE 9.2 und LTSP4.1 aufgesetzt. Lief bisher alles problemlos, lediglich bei den letzten Modifikationen habe ich Probleme.

Ich habe deine obigen Zeilen in
/etc/opt/kde3/share/config/kdm/kdmrc eingefügt.
Ich bin mir nicht sicher, an welcher Stelle sie stehen müssen.
Daher habe ich die Zeilen zunächst ans Ende gestellt.
In einem zweiten Versuch habe ich die
[X-:0-Core]
und [X-:0-Greeter] - Zeilen auskommentiert.
Beides half nicht.

lapmarc = ist mein Laptop, welches auch so in der host eingetragen ist.
Die Anmeldung funktioniert ansonsten tadellos.
Natürlich funtioniert auch der Vorschlag von McQuillan (auto-login) nicht, da er vom Prinzip genauso vorgeht.
http://ltsp.org/contrib/autologin_kdm.html

[EDIT]
Mal ne Frage: In der lts.conf habe ich SCREEN_01 = startx einstellen müssen, damit der Terminal(laptop) ein Bild produziert.
Hat das ggf. Auswirkungen auf die Einstellungen [X-:0-Core]???
[/EDIT]



Kann mir jemand dabei helfen?

Vielen Dank im Voraus.
Ich wünsche einen schönen dritten Advent.

Gruß
Marc




[General]
AuthDir=/var/lib/xdm/authdir/authfiles/
ConfigVersion=2.0
ExportList=LANG
PidFile=/var/run/kdm.pid
Xservers=/etc/X11/xdm/Xservers

[Shutdown]
HaltCmd=/sbin/halt
LiloCmd=/sbin/lilo
LiloMap=/boot/map
RebootCmd=/sbin/reboot
UseLilo=false

[X-*-Core]
AllowNullPasswd=true
AllowRootLogin=true
AllowShutdown=Root
AuthNames=XDM-AUTHORIZATION-1,MIT-MAGIC-COOKIE-1
AutoReLogin=false
Reset=/etc/X11/xdm/Xreset
Resources=/etc/X11/xdm/Xresources
Session=/etc/X11/xdm/Xsession
Setup=/etc/X11/xdm/Xsetup
Startup=/etc/X11/xdm/Xstartup
TerminateServer=true

[X-*-Greeter]
AdminSession=YaSTadminSession
AntiAliasing=true
BackgroundCfg=/etc/opt/kde3/share/config/kdm/backgroundrc
ColorScheme=SuSE
DefaultUser=Bookworm1
EchoMode=OneStar
FaceSource=AdminOnly
FailFont=Sans Serif,12,-1,5,74,0,0,0,0,0
FocusPasswd=false
GUIStyle=
GreetFont=Sans Serif,17,-1,5,48,0,0,0,0,0
GreetString=Willkommen auf (%h)
GreeterPos=50,50
HiddenUsers=root,nobody,@teachers
Language=de
LogoArea=Clock
LogoPixmap=
MaxShowUID=65000
MinShowUID=500
PreselectUser=None
SelectedUsers=
ShowUsers=NotHidden
SortUsers=true
StdFont=Sans Serif,12,-1,5,48,0,0,0,0,0
UseBackground=true
UserCompletion=false
UserList=true

[X-:*-Core]
AllowNullPasswd=true
AllowRootLogin=true
AllowShutdown=All
NoPassEnable=false
NoPassUsers=

[X-:*-Greeter]
AdminSession=YaSTadminSession

[X-:0-Core]
AutoLoginEnable=false
AutoLoginUser=Bookworm1
NoPassEnable=false
NoPassUsers=

[X-:0-Greeter]
AdminSession=
LogSource=/dev/xconsole

[Xdmcp]
Enable=true
Willing=/etc/X11/xdm/Xwilling
Xaccess=/etc/X11/xdm/Xaccess

[X-lapmarc:0-Core]
AutoLoginEnable=true
AutoLoginUser=Bookworm1

[X-lapmarc:0-Greeter]
GreetingString=Terminalserver:%h Terminal:X-lapmarc
ShowUsers=Selected
Users=Bookworm1

tomtom
Newbie
Newbie
Beiträge: 10
Registriert: 18. Nov 2004, 23:55

Vorschlag

Beitrag von tomtom » 13. Dez 2004, 19:25

Hi,

1. Has ja schon mal die richtige Datei erwischt *smile*

2. sichere Deine aktuelle kdmrc und check nochmal /etc/hosts

3. lösche die Zeilen

[X-:0-Core]
AutoLoginEnable=false
AutoLoginUser=Bookworm1
NoPassEnable=false
NoPassUsers=

*und zum Test (fehlt nämlich in meiner Datei)*

[X-lapmarc:0-Greeter]
GreetingString=Terminalserver:%h Terminal:X-lapmarc
ShowUsers=Selected
Users=Bookworm1

4. ändere

[X-lapmarc:0-Core]
AutoLoginEnable=true
AutoLoginUser=Bookworm1

*in*

[X-lapmarc.deine.domain:0-Core]
AutoLoginEnable=true
AutoLoginUser=Bookworm1

5. gib Laut, auch wenns funzt :wink:
(wenn Du sonst nichts geändert hast wird es das :D )

Benutzeravatar
Marc
Newbie
Newbie
Beiträge: 28
Registriert: 2. Sep 2003, 12:07
Wohnort: Kleve

Funzt! - glaube ich!

Beitrag von Marc » 17. Dez 2004, 20:44

Hallo TomTom,

sorry, hatte die Woche über viel zu tun, so dass ich deinen Tipp erst heute ausprobieren konnte!

Zwar weiß ich nicht, ob die gemachten Einstellungen nur für mein Laptop (lapmarc) oder für alle Terminal funktioniert, aber zumindest wird kein Login mehr benötigt und die Maschine "bootet" direkt in den Windowmanager.

Das ist zumindest ein Teilerfolg!

Danke TomTom!
Warst eine echte Hilfe!

Gruß aus Kleve
Marc

Gesperrt

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 2 Gäste