Noch einmal ACPI und Kernel (SuSE 10.0)

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Antworten
norberth
Newbie
Newbie
Beiträge: 11
Registriert: 5. Nov 2005, 16:36

Noch einmal ACPI und Kernel (SuSE 10.0)

Beitrag von norberth » 5. Nov 2005, 23:25

Ich habe ein ähnliches Problem wie vorhin von wem anderen gepostet: Ich habe (weil ich dachte, das sei nötig) SuSE 10.0 ohne ACPI installiert (die Option gibt's ja auf der DVD). Nun habe ich aber festgestellt, dass ACPI nicht die Ursache des inzwischen gelösten Problems war (welches spielt hier keine Rolle), und jetzt frage ich mich, ob ich ACPI nachinstallieren kann, ohne das ganze OS nochmals zu installieren.
Bin aber ein blutiger Anfänger, zumindest was das Thema Kernel betrifft und weiß auch nichts über Kompilieren, Programmieren, C+ usw. Würde aber gern was lernen, und wenn mir jemand sagt, was ich lesen muss, um meine Frage selbst zu beantworten, freu ich mich auch.
Danke, Norbert

Werbung:
Benutzeravatar
onkelchentobi
Guru
Guru
Beiträge: 1899
Registriert: 11. Feb 2005, 15:54
Wohnort: BW - Stuttgart
Kontaktdaten:

Re: Noch einmal ACPI und Kernel (SuSE 10.0)

Beitrag von onkelchentobi » 5. Nov 2005, 23:52

Was soll das heißen, du hast ACPI nicht installiert ?

ACPI ist standartmäßig im Kernel aktiviert, hast du dieses im Kernel deaktiviert ?

Wenn nicht, dann kannst du natürlich die ACPI Pakete von den SuSE CD's bzw. den DVD's nachträglich nachinstallieren.
GNU/Debian Linux - Testing 32 Bit / Kernel 2.6.30.2 Vanilla / Ion3 - 20090110 / i2p

*** NO E-PATENTS ***

norberth
Newbie
Newbie
Beiträge: 11
Registriert: 5. Nov 2005, 16:36

Beitrag von norberth » 6. Nov 2005, 01:27

Das soll genau das heißen, was ich geschrieben habe. Es gibt bei der Installation von der SuSE 10.0-DVD die Option "Installation ohne ACPI". Meinem laienhaften Verständnis nach heißt das, dass da ein Kernel installiert wird, der ACPI eben NICHT unterstützt, und das sagt das OS beim Booten auch.
Somit hilft mir Deine Antwort nicht, denn es dreht sich offenbar doch um den Kernel.

Benutzeravatar
onkelchentobi
Guru
Guru
Beiträge: 1899
Registriert: 11. Feb 2005, 15:54
Wohnort: BW - Stuttgart
Kontaktdaten:

Beitrag von onkelchentobi » 6. Nov 2005, 11:03

Wenn es bei der Installation diese Option gibt das man einen Kernel ohne ACPI Unterstützung installieren kann ( was ich nicht weiß da ich keine SuSE 10.0 nutze ). Dann installiere von den SuSE CD's bzw. DVD's einen anderen Kernel einfach nach und Boote deinen Rechner neu. Sollte es hierbei Probleme geben, kann man auch ein der /boot/grub/menu.lst das ACPI deaktivieren wenn man "NOAPCI" oder "APCI=OFF" in die Zeile hinzufügt.
GNU/Debian Linux - Testing 32 Bit / Kernel 2.6.30.2 Vanilla / Ion3 - 20090110 / i2p

*** NO E-PATENTS ***

Benutzeravatar
Appleonkel
Hacker
Hacker
Beiträge: 794
Registriert: 30. Apr 2004, 12:02
Wohnort: Köln
Kontaktdaten:

Beitrag von Appleonkel » 6. Nov 2005, 14:46

So weit ich weiss hat SuSE keine Kernel ohne ACPI, weder SuSE 9.1 noch 10.0, bei den 2.4er Kernel weiss ich das nicht. Um sicher zu gehen das du ACPI im Kernel hast, einfach mal

Code: Alles auswählen

zcat /proc/config.gz | grep ACPI
ausführen, dann siehst du was im laufendem Kernel an ACPI aktiviert ist.
kann man auch ein der /boot/grub/menu.lst das ACPI deaktivieren wenn makann man auch ein der /boot/grub/menu.lst das ACPI deaktivieren wenn man "NOAPCI" oder "APCI=OFF" in die Zeile hinzufügt.
ACPI=OFF kann man bei boot vom Installmedium angeben, falls es damit Probleme gibt. Ich denke mal wenn man bei der Installation. Kein ACPI angibt, wird es auch bloss in die /etc/grub/menu.lst eingetragen. Um das wieder zu aktivieren einfach ACPI=OFF aus der Zeile entfernen, dann wird mit ACPI gebootet.

mfg Appleonkel
"Es gibt anscheinend keine Möglichkeit der Sonde zu antworten." – "Ja, es ist schwierig zu antworten, wenn man die Frage nicht versteht." Star Trek 4

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 2 Gäste