keine neue Hardware (Drucker, Parallelport) mit c't-Version?

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Antworten
DrMartinus

keine neue Hardware (Drucker, Parallelport) mit c't-Version?

Beitrag von DrMartinus » 29. Okt 2005, 17:39

Ich habe jetzt schon einige Software installiert mit meiner VMWare-c't-Version 4.5.2 unter OpenSuSE 10.0. Eine will nun unbedingt auch den Drucker haben, und so wollte ich die Treiber installieren, die dann aber den angeschlossenen Drucker nicht erkannten (Parallel-Port). Ein Blick in die Doks bei VMWare offenbarten, dass ich einfach eine neue Hardware (eben den Parallel-Port, den es auch tatsächlich nicht in der VM gibt) zufügen sollte mit dem Hardware-Assistenten. Nur: die Buttons "Add" und "Remove" in VM/Settings sind ausgegraut, ich kann also nichts hinzufügen (und auch nicht entfernen).
Ist das mein Fehler, oder sollte das eine dann doch gravierende Einschränkung der "lauffähigen Vollversion" (O-Ton c't) sein? Wie sieht das bei Euch aus? Was könnte die Ursache für meine Situation sein, wenn es bei anderen geht?
Und ich bitte vielmals um Verzeihung, wenn das Thema hier doch schon verhandelt wurde. Ich habe nach "VMWare" und "Drucker" gesucht und nichts relevantes gefunden.

Werbung:
Benutzeravatar
Martin Breidenbach
Ultimate Guru
Ultimate Guru
Beiträge: 5632
Registriert: 26. Mai 2004, 21:33
Wohnort: N 50.17599° E 8.73367°

Beitrag von Martin Breidenbach » 29. Okt 2005, 17:40

Versuchst Du das bei laufender VM ? Das geht nicht.
Nicht Böse sein ! Der Onkel macht doch nur Spaß !

DrMartinus

Beitrag von DrMartinus » 29. Okt 2005, 17:46

Sorry, mein Fehler, habe gerade gelesen, dass die VM abgeschaltet sein muss. ... und Deine Antwort nicht gesehen.

DrMartinus

Beitrag von DrMartinus » 29. Okt 2005, 17:53

Ok, so weit, so gut. Ich kriege jetzt diese Meldung:

Code: Alles auswählen

Parallel port "/dev/parport0" is used by another program (such as another instance of VMware Workstation) or driver (such as lp).
Device parallel0 will start disconnected.
Ich setze turboprint ein, da ich sonst keinen brauchbaren Treiber für meinen Drucker Canon i560 bekomme. Kann das das Problem sein? Und wie gehe ich jetzt damit um? Ich will turboprint nicht aufgeben...

towo
Moderator
Moderator
Beiträge: 3704
Registriert: 15. Feb 2004, 16:42
Wohnort: Nimritz
Kontaktdaten:

Beitrag von towo » 29. Okt 2005, 17:56

DrMartinus hat geschrieben:Ok, so weit, so gut. Ich kriege jetzt diese Meldung:

Code: Alles auswählen

Parallel port "/dev/parport0" is used by another program (such as another instance of VMware Workstation) or driver (such as lp).
Device parallel0 will start disconnected.
Ich setze turboprint ein, da ich sonst keinen brauchbaren Treiber für meinen Drucker Canon i560 bekomme. Kann das das Problem sein? Und wie gehe ich jetzt damit um? Ich will turboprint nicht aufgeben...
http://portal.suse.com/sdb/de/2002/01/v ... ional.html
Signatur nach Diktat spazieren gegangen

Bild

DrMartinus

Beitrag von DrMartinus » 29. Okt 2005, 18:17

Hilft mir nicht viel weiter. "rclpd" wird nicht erkannt. Und ich will ja von beiden Systemen drucken können. Vielleicht verstehe ich das Ganze auch nur nicht richtig?
[/quote]

towo
Moderator
Moderator
Beiträge: 3704
Registriert: 15. Feb 2004, 16:42
Wohnort: Nimritz
Kontaktdaten:

Beitrag von towo » 29. Okt 2005, 18:22

und ich will ja von beiden Systemen drucken können.
Das geht aber nicht gleichzeitig, da Du unter Linux die Schnittstelle freigeben mußt, damit VMWare diese benutzen kann!
Du könntest natürlich per SMB aus der VM drucken, dazu muß der Drucker mit Samba freigegeben werden. Je nach OS in der VM kannste auch direkt über Cups auf dem Drucker drucken.
Signatur nach Diktat spazieren gegangen

Bild

DrMartinus

Beitrag von DrMartinus » 31. Okt 2005, 06:10

towo2099 hat geschrieben:Das geht aber nicht gleichzeitig, da Du unter Linux die Schnittstelle freigeben mußt, damit VMWare diese benutzen kann!
Du könntest natürlich per SMB aus der VM drucken, dazu muß der Drucker mit Samba freigegeben werden. Je nach OS in der VM kannste auch direkt über Cups auf dem Drucker drucken.
Dass das nicht gleichzeitig geht, ist mir schon klar, aber ich muss doch ohne große Probleme und ohne Porteinstellungen zu ändern oder gar Treiber zu (de)installieren von VMWare und von Linux aus drucken können.
Gibt es irgendwo ein HOWTO, wie man einen Samba-Drucker in VMWare einrichtet? Ich sehe nichts dergleichen in den Möglichkeiten, eine neue Hardware einzurichten. Oder über CUPS - wie weiß ich, dass der Drucker über CUPS eingerichtet ist? Wenn ich das Web-Interface von CUPS aufrufe, will es mein root-Passwort nicht akzeptieren.
Der Drucker ist aber eingerichtet, soweit ich das sehen kann, Schnittstelle /dev/lp0. Ich kann vom Web-Interface aus eine Testseite drucken lassen.
Aber auch hier die Frage: wie mache ich das dann mit VMWare?
Die Hilfe in VMWare kann ich nicht aufrufen (vielleicht steht da ja alles drin?), es moniert immer das Fehlen des Browsers in der config-Datei, dabei habe ich den Browser dort eingetragen...

Benutzeravatar
Martin Breidenbach
Ultimate Guru
Ultimate Guru
Beiträge: 5632
Registriert: 26. Mai 2004, 21:33
Wohnort: N 50.17599° E 8.73367°

Beitrag von Martin Breidenbach » 31. Okt 2005, 14:00

DrMartinus hat geschrieben:Gibt es irgendwo ein HOWTO, wie man einen Samba-Drucker in VMWare einrichtet?
Dabei ist es unerheblich ob das unter VMware läuft oder nicht - das geht halt über's Netz.
Nicht Böse sein ! Der Onkel macht doch nur Spaß !

DrMartinus

Beitrag von DrMartinus » 31. Okt 2005, 18:07

Ja, an solche simplen Dinge denkt man manchmal nicht. Herzlichen Dank für den Hinweis, jetzt klappt's!

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 4 Gäste