Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

DBDesigner 4 und MySQL

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

carcophan
Newbie
Newbie
Beiträge: 14
Registriert: 21. Okt 2005, 08:13

DBDesigner 4 und MySQL

Beitrag von carcophan » 21. Okt 2005, 08:41

Hallo,

Ich habe vor kurzen DBDesigner 4 (freeware tool zur Datenbank modellierung für MySQL) auf meinem OpenSuSE 10.0 System installiert. Ausserdem läuft bei mir der MySQL Server 4.1.14 mit MySQL Administrator und Query Browser. Die Datenbank läuft wunderbar ohne Probleme und DBDesigner 4 ebenfalls.

Problem ist nur wenn ich versuche mit dem DBDesigner auf meine MySQL Datenbank zu verbinden. Denn dann kommt die Fehlermeldung:
unable to load libmysqlclient.so
Ich habe nachgescheut und die og. so Datei existiert und ist scheinbar auch korrekt gelinkt.
Installiert habe ich den Designer mit Yast und habe das DBDesigner4-0.5.4-0.i586.rpm package verwendet. Starten tue ich mit "startdbd".
Die Symbolischen Links zu den .so Bibliotheken die DBDesigner benötigt scheinen alle korrekt zu sein (sonst wurde ja der Designer auch nicht starten).

Dennoch die Fehlermeldung wenn ich mit MySQL verbinden möchte.

Kann mir jemand einen Tip geben, was man da anstellen könnte damit es funktioniert?

Werbung:

carcophan
Newbie
Newbie
Beiträge: 14
Registriert: 21. Okt 2005, 08:13

Beitrag von carcophan » 21. Okt 2005, 10:13

whois hat geschrieben:Hi

Siehe Link

SUCH ERGEBNIS
wenn Google alles wüsste, gäbs keine Foren 8)

Es scheint wohl ein Bug von DBDesigner zu sein, denn egal welche versionen von dem libmysqlclient ich verwende (10 / 12 / 14) er kann sie nicht öffnen. Jedesmal lass ich die libraries korrekt verlinken.
Ich habs auch schon mit ODBC treibern versucht. An MySQL kanns nicht liegen da ich problemlos mit JDBC connectors von Java progs aus drauf zugreifen kann.


wäre dankbar für jede Hilfe zum Thema: DBDesigner mit MySQL verbinden.

Benutzeravatar
whois
Administrator
Administrator
Beiträge: 16603
Registriert: 11. Okt 2004, 08:50
Wohnort: Aachen
Kontaktdaten:

Beitrag von whois » 21. Okt 2005, 10:22

Und wer zu faul zum Suchen und lesen ist darf keine grosse Antwort erwarten.

Nochwas welches libs hast du gebraucht.

Eventuell sind die Libraries zu alt.
Zuletzt geändert von whois am 21. Okt 2005, 10:31, insgesamt 1-mal geändert.

carcophan
Newbie
Newbie
Beiträge: 14
Registriert: 21. Okt 2005, 08:13

Beitrag von carcophan » 21. Okt 2005, 10:30

Du bist ganz schön dreist mit deiner behauptung!
Woher willst Du wissen, dass ich nicht bereits gegoogelt habe oder diverse andere Foren durchsucht habe?

Googeln kann wirklich jeder dulli! aber hast du mal nachgeschaut was da in anderen FOren zu genau diesem Thema geschrieben wird? nichts als unhilfreiche tips.

Also als kleiner Tip für Deine nächsten Google Links: schau doch mal nach ob Google vernüntige Treffer liefert und nicht einfach Forenbeiträge anderer User die ihre Fragen ebenfalls nicht vernünftig gelöst bekommen.

:evil:

Benutzeravatar
whois
Administrator
Administrator
Beiträge: 16603
Registriert: 11. Okt 2004, 08:50
Wohnort: Aachen
Kontaktdaten:

Beitrag von whois » 21. Okt 2005, 10:32

OK

Beantworte bitte die Frage.

Und sag mir wo du das Programm geladen hast.

carcophan
Newbie
Newbie
Beiträge: 14
Registriert: 21. Okt 2005, 08:13

Beitrag von carcophan » 21. Okt 2005, 10:47

an zu alten libs kanns glaube ich nicht liegen, ich habe die neuesten installiert:

/usr/lib/libmysqlclient.so.14
/usr/lib/libmysqlclient.so.14.0.0
/usr/lib/libmysqlclient_r.so.14
/usr/lib/libmysqlclient_r.so.14.0.0
/usr/lib/mysql/libmysqlclient.so.14
/usr/lib/mysql/libmysqlclient.so.14.0.0
/usr/lib/mysql/libmysqlclient_r.so.14
/usr/lib/mysql/libmysqlclient_r.so.14.0.0

(mysql-shared-4.1.10a-3.i586.rpm)

ich habe sie ausprobiert und mit libmysqlclient.so verlinkt in das DBDesigner library verzeichnis wo vorher die version .so.10 war.

Jedes mal kommt die Fehlermeldung, dass DBDesigner nicht verbinden kann da die libmysqlclient.so nicht geladen werden kann.

Hast du den DBDesigner bei dir laufen? wenn ja kannst du verbinden?
die FAQ der DBDesigner Seite sagt es unterstütze MySQL versionen 3 und 4 und falls es nicht funktioniert soll man die ODBC Treiber versuchen.

Ich habs auch mit den ODBC treibern von MySQL getestet und einfach mal ganz naiv genauso verlinkt (symolisch) wie mit den libmysqlclient libraries. Geht natürlich auch nicht :-(

Benutzeravatar
whois
Administrator
Administrator
Beiträge: 16603
Registriert: 11. Okt 2004, 08:50
Wohnort: Aachen
Kontaktdaten:

Beitrag von whois » 21. Okt 2005, 10:52

Hmm

Sorry bin im Büro und habe leider auch DBDesigner nicht.

Du hast nun eine andere Fehlermeldung.

Ich seh mich im Net um eventuell finde ich eine Lösung. :wink:

carcophan
Newbie
Newbie
Beiträge: 14
Registriert: 21. Okt 2005, 08:13

Beitrag von carcophan » 21. Okt 2005, 11:35

whois hat geschrieben: Du hast nun eine andere Fehlermeldung.
???

----------

thx würde mich sehr freuen falls Du was rausbekommst.

Benutzeravatar
whois
Administrator
Administrator
Beiträge: 16603
Registriert: 11. Okt 2004, 08:50
Wohnort: Aachen
Kontaktdaten:

Beitrag von whois » 21. Okt 2005, 11:37

Hi

Freudsche Fehlleistung :wink: Vergiss es :roll:

Ich arbeite dran :wink:

Benutzeravatar
whois
Administrator
Administrator
Beiträge: 16603
Registriert: 11. Okt 2004, 08:50
Wohnort: Aachen
Kontaktdaten:

Beitrag von whois » 21. Okt 2005, 11:53

Wo hast du das Paket her?

Eventuell kann ich über die Quelle mehr erfahren.

cu



/EDIT:OK ich hab es schon.

Selbst die Doku weisst nicht auf das Problem hin.

http://www.fabforce.net/dbdesigner4/doc/index.html

Benutzeravatar
whois
Administrator
Administrator
Beiträge: 16603
Registriert: 11. Okt 2004, 08:50
Wohnort: Aachen
Kontaktdaten:

Beitrag von whois » 21. Okt 2005, 12:36

So Ich habe mich gerade zu Mittag mit einem Kumpel (Datenbank Programmierer)getroffen.

Er sagt mit M$ läuft das ohne Probleme, mit Linux arbeitet er nur wenig,hat allerding vor einiger Zeit die gleichen Probleme gehabt..

Leider ungelöst.

carcophan
Newbie
Newbie
Beiträge: 14
Registriert: 21. Okt 2005, 08:13

Beitrag von carcophan » 21. Okt 2005, 20:16

vielen Dank für Deine Mühe!

Scheint wohl irgendwie ein bug zu sein der sich nicht mit irgendwelchen Treibern aufheben lässt.

Hoffentlich gibt es bald MySQL Workbench auch für Linux.

Falls noch irgendjemand Erfahrungen mit DBDesigner 4 hat, und eine Idee wie man das zum laufen bringen könnte wäre ich sehr dankbar.

Benutzeravatar
whois
Administrator
Administrator
Beiträge: 16603
Registriert: 11. Okt 2004, 08:50
Wohnort: Aachen
Kontaktdaten:

Beitrag von whois » 22. Okt 2005, 08:59

Hi

Sorry tut mir Leid.

Scheint tatsächlich ein Bug zu sein.

Benutzeravatar
whois
Administrator
Administrator
Beiträge: 16603
Registriert: 11. Okt 2004, 08:50
Wohnort: Aachen
Kontaktdaten:

Beitrag von whois » 22. Okt 2005, 14:49

Hi

So ich habe mich auf der Mailingliste zum Produkt umgehört.

Das ist ein Bug der allerdings mit der Neuerscheinung weg ist.

Warte etwas

carcophan
Newbie
Newbie
Beiträge: 14
Registriert: 21. Okt 2005, 08:13

Beitrag von carcophan » 28. Okt 2005, 08:38

weist du auch zufällig, ob es sich bei der neuerscheinung um eine neue DBDesigner version handelt, oder ob das ganze dann MySQL Workbench heissen soll?

Benutzeravatar
whois
Administrator
Administrator
Beiträge: 16603
Registriert: 11. Okt 2004, 08:50
Wohnort: Aachen
Kontaktdaten:

Beitrag von whois » 28. Okt 2005, 08:40

Hi

Da stand nichts von drin auf der Mailingliste.

Wenn irgendwas kommt schreibe ich es in diesen Thread und schick dir eine PN

useher
Member
Member
Beiträge: 138
Registriert: 2. Nov 2005, 14:55

Beitrag von useher » 3. Nov 2005, 14:00

carcophan hat geschrieben:weist du auch zufällig, ob es sich bei der neuerscheinung um eine neue DBDesigner version handelt, oder ob das ganze dann MySQL Workbench heissen soll?
AFAIK wurde der DBDesigner bei 4.05.xx (leider) eingestellt zu Gunsten der Workbench (die auf sich warten lässt).

CU Uwe

Heart
Hacker
Hacker
Beiträge: 449
Registriert: 10. Jul 2004, 14:37

Re: DBDesigner 4 und MySQL

Beitrag von Heart » 7. Apr 2006, 21:06

carcophan hat geschrieben:Problem ist nur wenn ich versuche mit dem DBDesigner auf meine MySQL Datenbank zu verbinden. Denn dann kommt die Fehlermeldung:
unable to load libmysqlclient.so
Gibt es hierzu mittlerweile schon eine Lösung :? ?
Desktop 10/2012

ukuarcor
Newbie
Newbie
Beiträge: 32
Registriert: 10. Mai 2006, 12:40

Beitrag von ukuarcor » 10. Mai 2006, 13:04

Hallo zusammen,

auch ich bin seit kurzem mit diesem Thema am kämpfen.

Die Voraussetzungen: SUSE 10.0
MySql 4.1
DBDesigner4

Fehler: unable to load libmysqlclient.so => das ist ja nix neues

Bisher durchgeführte Schritte:
Gemäß MySql-Doku (über Google...) die libmysqlclient.so nach /usr/lib kopiert (ohne symb. Link) und die LD_RUN_PATH auf diesen Pfad gesetzt.
Auch das setzen der PATH-Variablen auf den Installationspfad hat kein Ergebnis gebracht

Zur Sicherheit mysqlclient_test laufen lassen, man kann ja nie wissen. Ergebnis: Alles bestens :lol:

In verschiedenen Dokus finden sich Hinweise darauf, daß das Problem darauf zurückzuführen sein kann, dass die Pakete (PHP versus mysql) mit unterschiedlichen Kompilerversionen hergestellt wurden und dies zu dem beschriebenen Systemverhalten führt.

Hat jemand eine Idee, was man noch unternehmen kann?

Ich habe mir die aktuelle mysql-Workbench installiert, bekomme jedoch schon beim Start einen "Segmentation Fault" aus dem Startskript "mysql-workbench" 8)
Erfolgreich kann man das auch nicht wirklich nennen.

Freue mich über jegliches Feedback

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast