wine + aspi + dvdshrink

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

enricoj
Newbie
Newbie
Beiträge: 8
Registriert: 22. Mär 2004, 13:40
Kontaktdaten:

wine + aspi + dvdshrink

Beitrag von enricoj » 22. Mär 2004, 13:57

servus @all,

mein problem bei dieser konstelation ist, dass mir wine immer wenn ich die dvd öffnen möchte, mit einen aspi fehler abschmiert. starten von shrink funzt super. hat jemand einen tip für mich? gibt es etwas aspi ähnliches für wine?

ich nutze suse 9 mit der dazu gehörigen wine version... nummer weiss ich jetzt nicht. dvdshrink hab ich in der version 3.1.6
im meinem rechner werkelt 1 ide dvd laufwerke und 1 ide dvd brenner von nec.

für antworten bin ich dankbar...

greetz

Werbung:
Fish
Newbie
Newbie
Beiträge: 44
Registriert: 7. Feb 2004, 11:01

Beitrag von Fish » 22. Mär 2004, 22:43

Ich hab zwar keine Antwort, aber geile Idee mit DVD Shrink :)

edit: Ich meine den Shrink unter Suse zu verwenden anstatt fieberhaft nach einem Linux Prog zu suchen :D

enricoj
Newbie
Newbie
Beiträge: 8
Registriert: 22. Mär 2004, 13:40
Kontaktdaten:

Beitrag von enricoj » 23. Mär 2004, 07:37

naja wenn es funzen würde wäre es mir lieber. hat keiner ne idee wie ich das prob beheben kann? ist nämlich das erste mal das ich wine benutze.

greetz

Benutzeravatar
makemyday
Newbie
Newbie
Beiträge: 19
Registriert: 6. Mär 2004, 11:43
Wohnort: 52°17' n.B 8°55'ö.L
Kontaktdaten:

Beitrag von makemyday » 24. Mär 2004, 19:04

Ich hab echt keine Ahnung,

aber gib wine doch mal nen aspi treiber is auch ne .exe!

Is nur ne blöde Idee :?
Lernen, ohne zu denken, ist eitel.
Denken, ohne zu lernen, gefährlich.

Benutzeravatar
wake
Newbie
Newbie
Beiträge: 10
Registriert: 23. Mär 2004, 08:22
Wohnort: LL

Beitrag von wake » 26. Mär 2004, 14:29

hallo zusammen,

habt ihr für das problem ne lösung gefunden ??

stehe nämlich vor dem selbigen :)

grüsse
wake

enricoj
Newbie
Newbie
Beiträge: 8
Registriert: 22. Mär 2004, 13:40
Kontaktdaten:

Beitrag von enricoj » 27. Mär 2004, 20:07

bin noch nicht weiter. es funzt auch nicht mit einer älteren version von dvdshrink.

greetz

Benutzeravatar
wake
Newbie
Newbie
Beiträge: 10
Registriert: 23. Mär 2004, 08:22
Wohnort: LL

Beitrag von wake » 29. Mär 2004, 08:34

schade schade,,bei einer lösung bitte posten..bin auch am basteln

grüsse
wake

gh

Beitrag von gh » 4. Apr 2004, 19:13

Hallo,

Habe wine-20040309-0.i586.rpm installiert.

Gebe ich in der Datei ~/.wine/config im Abschnitt
[Version]
"Windows" = "win2k"
ein, dann funct zumindest die Analyse der DVD.
Leider stürzt DVDShrink danach ab.

Wahrscheinlich nur ein Prob mit der Festplattenkonfiguration unter wine.

Ist jemand schon weiter?

Viele Grüße gh

gh

Nachtrag

Beitrag von gh » 4. Apr 2004, 19:29

Bei mir funktioniert es jetzt.

In der Datei
~/.wine/config müssen folgende Einträge drinnen sein:

Beispiel für konfigurierte Festplatten (muss natürlich gemountet sein):
[Drive D]
"Path" = "/media/daten"
"Type" = "hd"
"Label" = "/media/daten"

Im Abschnitt [wine] müssen unter
[wine]
"Path" = "C:\\Windows;C:\\Windows\\System;D:\\;E:\\;F:\\;G:\\;X:\\;Y:\\"
alle Laufwerke auftauchen, auf die zugegriffen werden können soll.

und wie gesagt unter
[Version]
; Windows version to imitate
"Windows" = "win2k" oder "Windows" = "winxp"
eintragen und Semikolons davor entfernen, damit kein ASPI-Treiber
verlangt wird.

Viel Glück, :D
gh

enricoj
Newbie
Newbie
Beiträge: 8
Registriert: 22. Mär 2004, 13:40
Kontaktdaten:

gute idee mit dem update von wine

Beitrag von enricoj » 5. Apr 2004, 20:27

auf die sache mit dem wine update hätte ich auch kommen können. hab nur die shrink vers. up und downgegraded. aber mit dem neuen wine scheint es zu klappen, zumindest klappt schon mal die analyse der dvd ohne probs.

greetz

Grond

klappt noch nicht

Beitrag von Grond » 6. Apr 2004, 19:24

Hallo!

Also ich habe auch wine-version 20040309 und habe auch die Einträge in der Konfig-Datei angepasst wie von gh beschrieben. Allerdings bekomme ich immer noch die ASPI-Fehlermeldung. Könnte mal jemand bei dem dvdshrink jetzt prblemlos mit wine läuft seine Konfig-Datei hier posten?

Danke schonmal, Grond

enricoj
Newbie
Newbie
Beiträge: 8
Registriert: 22. Mär 2004, 13:40
Kontaktdaten:

Beitrag von enricoj » 6. Apr 2004, 19:55

hast du auch dvdshrink mit wine installiert? oder hast du nur das verzeichnis von windows übernommen? nach der installation mit wine war bei mir dieser fehler weg.

hier mal meine wine-config:

hoffentlich hilft es ;-)

--------------------------------------------------------------------------------------------------

WINE REGISTRY Version 2
;; All keys relative to \\Machine\\Software\\Wine\\Wine\\Config

;; If you think it is necessary to show others your complete config for a
;; bug report, filter out empty lines and comments with
;; grep -v "^;" ~/.wine/config | grep '.'
;;
;; MS-DOS drives configuration
;;
;; Each section has the following format:
;; [Drive X]
;; "Path"="xxx" (Unix path for drive root)
;; "Type"="xxx" (supported types are 'floppy', 'hd', 'cdrom' and 'network')
;; "Label"="xxx" (drive label, at most 11 characters)
;; "Serial"="xxx" (serial number, 8 characters hexadecimal number)
;; "Filesystem"="xxx" (supported types are 'msdos'/'dos'/'fat', 'win95'/'vfat', 'unix')
;; This is the FS Wine is supposed to emulate on a certain
;; directory structure.
;; Recommended:
;; - "win95" for ext2fs, VFAT and FAT32
;; - "msdos" for FAT16 (ugly, upgrading to VFAT driver strongly recommended)
;; DON'T use "unix" unless you intend to port programs using Winelib !
;; "Device"="/dev/xx" (only if you want to allow raw device access)
;;
[Drive C]
"Path" = "%HOME%/.wine/fake_windows"
"Type" = "hd"
"Label" = "fake_windows"
"Filesystem" = "win95"

;[Drive D]
;"Type" = "hd"
;"Path" = "/mnt/dvd"
;"Label" = "dvd"
;"FS" = ""
;"Device" = "/dev/hdd"

[Drive D]
"Path" = "/mnt/dvd"
"Type" = "cdrom"
"Label" = "DVD-R"
"Filesystem" = "win95"
"Device" = "/dev/hdd"

[Drive X]
"Type" = "hd"
"Path" = "/root/.wine/.tmp"
"Label" = "Tmp Drive"
;"FS" = "win95"

[Drive Y]
"Type" = "network"
"Path" = "%HOME%"
"Label" = "Home"
"FS" = "win95"

[Drive Z]
"Type" = "network"
"Path" = "/"
"Label" = "Root"
"FS" = "win95"

[wine]
"Windows" = "C:\\Windows"
"System" = "C:\\Windows\\System"
"Temp" = "C:\\Windows\\Temp"
"Path" = "C:\\Windows;C:\\Windows\\System;X:\\;Y:\\"
"Profile" = "c:\\windows\\Profiles\\Administrator"
"GraphicsDriver" = "x11drv"
;"ShowDirSymlinks" = "1"
;"ShowDotFiles" = "1"
"ShellLinker" = "wineshelllink"

# <wineconf>

[Version]
; Windows version to imitate (win95,win98,winme,nt351,nt40,win2k,winxp,win20,win30,win31)
"Windows" = "winxp"

; Be careful here, wrong DllOverrides settings have the potential
; to pretty much kill your setup.
[DllOverrides]
"msvcrt" = "native,builtin"
"msi" = "native,builtin"
; default for all other dlls
"*" = "builtin, native"

[x11drv]
; Number of colors to allocate from the system palette
"AllocSystemColors" = "100"
; Use a private color map
"PrivateColorMap" = "N"
; Favor correctness over speed in some graphics operations
"PerfectGraphics" = "N"
; Color depth to use on multi-depth screens
;;"ScreenDepth" = "16"
; Name of X11 display to use
;;"Display" = ":0.0"
; Allow the window manager to manage created windows
"Managed" = "Y"
; Use a desktop window of 640x480 for Wine
;"Desktop" = "640x480"
; Use XFree86 DGA extension if present
; (make sure /dev/mem is accessible by you !)
"UseDGA" = "Y"
; Use XShm extension if present
"UseXShm" = "Y"
; Use XVidMode extension if present
"UseXVidMode" = "Y"
; Use the take focus protocol
"UseTakeFocus" = "Y"
; Enable DirectX mouse grab
"DXGrab" = "N"
; Create the desktop window with a double-buffered visual
; (useful to play OpenGL games)
"DesktopDoubleBuffered" = "N"
; Use this if you have more than one port for video on your setup
; (Wine uses for now the first 'input image' it finds).
;; "XVideoPort" = "43"
; Run in synchronous mode (useful for debugging X11 problems)
;"Synchronous" = "Y"
;
; Use the Render extension to render client side fonts (default "Y")
;;"ClientSideWithRender" = "Y"
; Fallback on X core requests to render client side fonts (default "Y")
;;"ClientSideWithCore" = "Y"
; Set both of the previous two to "N" in order to force X11 server side fonts
;
; Anti-alias fonts if using the Render extension (default "Y")
;;"ClientSideAntiAliasWithRender" = "Y"
; Anti-alias fonts if using core requests fallback (default "Y")
;;"ClientSideAntiAliasWithCore" = "Y"
;

[fonts]
;Read the Fonts topic in the Wine User Guide before adding aliases
;See a couple of examples for russian users below
"Resolution" = "96"
"Default" = "-adobe-helvetica-"
"DefaultFixed" = "fixed"
"DefaultSerif" = "-adobe-times-"
"DefaultSansSerif" = "-adobe-helvetica-"

;; default TrueType fonts with russian koi8-r encoding
;"Default" = "-monotype-arial-*-*-*--*-*-*-*-*-*-koi8-r"
;"DefaultFixed" = "-monotype-courier new-*-*-*--*-*-*-*-*-*-koi8-r"
;"DefaultSerif" = "-monotype-times new roman-*-*-*--*-*-*-*-*-*-koi8-r"
;"DefaultSansSerif" = "-monotype-arial-*-*-*--*-*-*-*-*-*-koi8-r"
;; default cyrillic bitmap X fonts
;"Default" = "-cronyx-helvetica-"
;"DefaultFixed" = "fixed"
;"DefaultSerif" = "-cronyx-times-"
;"DefaultSansSerif" = "-cronyx-helvetica-"

; the TrueType font dirs you want to make accessible to wine
[FontDirs]
"dir1" = "/usr/X11R6/lib/X11/fonts/truetype"
"dir2" = "/usr/X11R6/lib/X11/fonts/TrueType"
"dir3" = "/usr/X11R6/lib/X11/fonts/TT"

[serialports]
"Com1" = "/dev/ttyS0"
"Com2" = "/dev/ttyS1"
"Com3" = "/dev/ttyS2"
"Com4" = "/dev/modem"

[parallelports]
"Lpt1" = "/dev/lp0"

[ppdev]
;; key: io-base of the emulated port
;; value : parport-device{,timeout}
;; timeout for auto closing an open device ( not yet implemented)
;"378" = "/dev/parport0"
;"278" = "/dev/parport1"
;"3bc" = "/dev/parport2"

[spooler]
"FILE:" = "tmp.ps"
"LPT1:" = "|lpr"
"LPT2:" = "|gs -sDEVICE=bj200 -sOutputFile=/tmp/fred -q -"
"LPT3:" = "/dev/lp3"

[ports]
;"read" = "0x779,0x379,0x280-0x2a0"
; "write" = "0x779,0x379,0x280-0x2a0"

[Debug]
"RelayExclude" = "RtlLeaveCriticalSection;RtlEnterCriticalSection;TlsGetValue;_EnterSysLevel;_LeaveSysLevel;RtlAllocateHeap;RtlFreeHeap;RtlReAllocateHeap;LOCAL_Lock;LOCAL_Unlock"
;"RelayInclude" = "user32.CreateWindowA"
;"RelayFromExclude" = "user32;x11drv"
;"RelayFromInclude" = "sol.exe"
;"SnoopExclude" = "RtlEnterCriticalSection;RtlLeaveCriticalSection"
;"SpyExclude" = "WM_SIZE;WM_TIMER;"

[registry]
;These are all booleans. Y/y/T/t/1 are true, N/n/F/f/0 are false.
;Defaults are read all, write to Home
; Where to find the global registries
;"GlobalRegistryDir" = "/etc";
; Global registries (stored in /etc)
"LoadGlobalRegistryFiles" = "Y"
; Home registries (stored in ~user/.wine/)
"LoadHomeRegistryFiles" = "Y"
; Load Windows registries from the Windows directory
"LoadWindowsRegistryFiles" = "Y"
; TRY to write all changes to home registries
"WritetoHomeRegistryFiles" = "Y"
; Registry periodic save timeout in seconds
; "PeriodicSave" = "600"
; Save only modified keys
"SaveOnlyUpdatedKeys" = "Y"

[Tweak.Layout]
;; supported styles are 'Win31'(default), 'Win95', 'Win98'
;; this has *nothing* to do with the windows version Wine returns:
;; set the "Windows" value in the [Version] section if you want that.
"WineLook" = "Win95"

[Clipboard]
"ClearAllSelections" = "0"
"PersistentSelection" = "1"

; List of all directories directly contain .AFM files
[afmdirs]
"1" = "/usr/share/ghostscript/fonts"
"2" = "/usr/share/enscript/afm"
"3" = "/usr/X11R6/lib/X11/fonts/Type1"
"4" = "/usr/lib/wine/afm"

[WinMM]
; Uncomment the "Drivers" line matching your sound setting.

"Drivers" = "wineoss.drv" ; default for most common configurations
;"Drivers" = "winearts.drv" ; for KDE
;"Drivers" = "winealsa.drv" ; for ALSA users
;"Drivers" = "winejack.drv" ; for Jack sound server
;"Drivers" = "winenas.drv" ; for NAS sound system
;"Drivers" = "wineaudioio.drv" ; for Solaris machines
;"Drivers" = "" ; to disable sound
"WaveMapper" = "msacm.drv"
"MidiMapper" = "midimap.drv"

[dsound]
;; HEL only: Number of waveOut fragments ahead to mix in new buffers.
;"HELmargin" = "5"
;; HEL only: Number of waveOut fragments ahead to queue to driver.
;"HELqueue" = "5"
;; Max number of fragments to prebuffer
;"SndQueueMax" = "28"
;; Min number of fragments to prebuffer
;"SndQueueMin" = "12"
;; Forces emulation mode (using wave api)
;"HardwareAcceleration" = "Emulation"
;; Sets default playback device (0 - number of devices - 1)
;"DefaultPlayback" = "0" ; use first device (/dev/dsp)
;"DefaultPlayback" = "1" ; use second device (/dev/dsp1)
;"DefaultPlayback" = "2" ; use third device (/dev/dsp2)
;; Sets default capture device (0 - number of devices - 1)
;"DefaultCapture" = "0" ; use first device (/dev/dsp)
;"DefaultCapture" = "1" ; use second device (/dev/dsp1)
;"DefaultCapture" = "2" ; use third device (/dev/dsp2)

[Network]
;; Use the DNS (Unix) host name always as NetBIOS "ComputerName" (boolean, default "Y").
;; Set to N if you need a persistent NetBIOS ComputerName that possibly differs
;; from the Unix host name. You'll need to set ComputerName in
;; HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\ComputerName\ComputerName, too.
;"UseDnsComputerName" = "N"

[ppd]
"generic" = "/usr/lib/wine/ppd/generic.ppd"

# </wineconf>

#########################################
# Application dependent sections follow #
#########################################

; 3 InstallShield versions who like to put their full screen window in front,
; without any chance to switch to another X11 application.
; So just catch them in a desktop window.

[AppDefaults\\_INS0432._MP\\x11drv]
"Desktop" = "640x480"

[AppDefaults\\_INS0466._MP\\x11drv]
"Desktop" = "640x480"

[AppDefaults\\_INS0576._MP\\x11drv]
"Desktop" = "640x480"

[AppDefaults\\_INS5176._MP\\x11drv]
"Desktop" = "640x480"

[AppDefaults\\_INS5576._MP\\x11drv]
"Desktop" = "640x480"

[AppDefaults\\nlnotes.exe\\x11drv]
;"Desktop" = "800x600"
"Synchronous" = "Y"

[AppDefaults\\notes.exe\\DllOverrides]
"msvcrt" = "native"
"msvcrt40" = "native"
"crtdll" = "native"
"imagehlp" = "native"
"rnaph" = "native"

[AppDefaults\\nlnotes.exe\\DllOverrides]
"msvcrt" = "native"
"msvcrt40" = "native"
"crtdll" = "native"
"imagehlp" = "native"
"rnaph" = "native"

[AppDefaults\\nhldaemn.exe\\DllOverrides]
"msvcrt" = "native"
"msvcrt40" = "native"
"crtdll" = "native"
"imagehlp" = "native"
"rnaph" = "native"

War_vorher_gh

My Computer ei Open Files

Beitrag von War_vorher_gh » 8. Apr 2004, 10:45

Ich habe doch noch ein Problem.

Das das Öffnen und schrumpfen von DVDs funktioniert zwar.

Wenn ich aber vorhandene Dateien schrumpfen will (Der Knopf rechts neben "Open DVD"), dann öffnet sich aber ein FileOpen-Dialog, in dem mir nur "Desktop" mit einem
"+" davor angezeigt wird,
"My Computer" fehlt aber, so dass ich keine Dateien oder Verzeichnisse öffnen kann.
Klicke ich auf "Re-Author" dann gibt es "My Computer" aber.
Und in anderen Programmen, z.B CDex geht es auch.

Hat jemand hierzu eine Idee?

vitesse

"My Computer" Fehler

Beitrag von vitesse » 19. Apr 2004, 02:11

Ich habe das gleiche Problem mit Wine (version 20040408), aber mit Crossover Office 2.1.0 ist alles OK. (Leider muss man für CXOffice bezahlen.)

Jetzt habe ich noch ein Problem: Es gibt eine "Slider"-Kontrolle unter "Compression Settings." Wenn ich "Custom Ratio" wähle, kann ich die Kontrolle nur bis etwa 90% bewegen. Aber mit Windows, kann ich die Kontrolle bis 40% oder 50% bewegen.

Hat jemand eine Lösung?

frufo

"My Computer" fehlt

Beitrag von frufo » 22. Apr 2004, 08:56

Benutze Debian wine version: 20040309, habe auch das Problem, das der "My Computer"-Eintrag neuerdings fehlt. Bei der Version die ich davor hatte funktionierte es noch. Hat jemand eine Idee wie man das analysieren kann, wenn es keine Fehlermeldung gibt?

Gast

"MY Computer" fehlt

Beitrag von Gast » 22. Apr 2004, 21:17

So habe jetzt wieder die alten Debian pakete mit der wine version vom
20040121 installliert, da gibt es einen Fehler beim starten in der Datei
UXTHEME.DLL.so, wenn ich die aus der Wine Version vom 2004030, nehme, funktrioniert es wieder, vielleicht kommt ihr ja auch an ältere Suse-Pakete.

Gruß
Frufo

Gast

Beitrag von Gast » 24. Apr 2004, 15:25

ich habe bei mir DVDshrink3.1.7 in folgender Umgebung getestet:
SuSE 9.0
KDE 3.2.2
wine 20040408

und es läuft einwandfrei bis zum fertigen auslesen der DVD und meldet
auch das erfolgreiche auslesen.
Danach allerdings verabschiedet es sich unweigerlich.

Weiss jemand Rat ?

Benutzeravatar
moe
Member
Member
Beiträge: 114
Registriert: 20. Apr 2004, 21:07
Wohnort: Tuxtown
Kontaktdaten:

Beitrag von moe » 24. Apr 2004, 15:26

sorry war nicht eingeloggt ... letzer post war von: moe

fishy
Newbie
Newbie
Beiträge: 8
Registriert: 14. Apr 2004, 00:26

Beitrag von fishy » 1. Mai 2004, 22:20

Hat jemand dvdshrink unter CrossOffice zum laufen gekriegt ? Hab des Aspi-Problem find nur nicht das richtige config-file

need help please !!!

grüßli vom fishy

Gast

Beitrag von Gast » 1. Mai 2004, 23:32

so habs gefunden und hab alles so eingetragen jetzt hab ich allerdings ein neues Problem DVDShrink meldet mir immer : "DVD Shrink ecountered an error and connot continue. Failed to read file "N:\" Invalid handle "

Hat das jemand schon mal jemand gehabt ? liegt des irgendwie am mounten ?

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast