MySQL Installation auf Suse Linux 8 ?

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren


Werbung:
hausi18
Newbie
Newbie
Beiträge: 25
Registriert: 28. Sep 2005, 16:02

Beitrag von hausi18 » 29. Sep 2005, 13:14

Linux x86 RPM downloads -> Server

hab darunter gerade gesehen mit: Server (glibc 2.3)
brauch ich die??

Benutzeravatar
whois
Administrator
Administrator
Beiträge: 16598
Registriert: 11. Okt 2004, 08:50
Wohnort: Aachen
Kontaktdaten:

Beitrag von whois » 29. Sep 2005, 13:18

hmm

Hast du die MDK Checksum geprüft ?

Ja nimm mal die andere !

hausi18
Newbie
Newbie
Beiträge: 25
Registriert: 28. Sep 2005, 16:02

Beitrag von hausi18 » 29. Sep 2005, 13:23

ja hab mir mit der checksumme die rausgesucht die runtergeladen wurde!
lad gerade die andere herunter, ich probiers mal aus!
danke auf jeden fall.

bin mir aber fast sicher, dass wieder ein fehler kommt ;-)

hausi18
Newbie
Newbie
Beiträge: 25
Registriert: 28. Sep 2005, 16:02

Beitrag von hausi18 » 29. Sep 2005, 13:41

wie ichs mir gedacht hab - noch mehr fehler.
und zwar möchte er perl sachen? keine ahnung warum!

was kann ich jetzt noch machen?

Benutzeravatar
whois
Administrator
Administrator
Beiträge: 16598
Registriert: 11. Okt 2004, 08:50
Wohnort: Aachen
Kontaktdaten:

Beitrag von whois » 29. Sep 2005, 13:47

Puh

Er sind ja SLES9 Downloads da nur keine für 8.

Meines Erachtens hängt da das Problem.

Ich werde mich weiter informieren habe aber für Suse 8 Perse keine Lösung in Peto.

Google gibt auch nichts her.

traffic
Guru
Guru
Beiträge: 2750
Registriert: 13. Feb 2005, 05:50

Beitrag von traffic » 29. Sep 2005, 13:55

Die Version, die Du da hast, kannst Du vergessen. Die wird nicht laufen, weil Deine glibc zu alt ist.

Probier stattdessen die Version "glibc-2.2, static" oder auf jeden Fall irgendwas, wo nicht "glibc-2.3" dabei steht.

hausi18
Newbie
Newbie
Beiträge: 25
Registriert: 28. Sep 2005, 16:02

Beitrag von hausi18 » 29. Sep 2005, 13:59

welche version die ich hab meinst du - linux oder mysql?

Benutzeravatar
whois
Administrator
Administrator
Beiträge: 16598
Registriert: 11. Okt 2004, 08:50
Wohnort: Aachen
Kontaktdaten:

Beitrag von whois » 29. Sep 2005, 14:58

mysql !

hausi18
Newbie
Newbie
Beiträge: 25
Registriert: 28. Sep 2005, 16:02

Beitrag von hausi18 » 30. Sep 2005, 10:51

so, habs jetzt geschafft, dass ich die datebank installiere. habs nicht mit dem rpm gemacht sondern mitn .tar.gz

jetzt brauch ich noch myodbc, hab mir die version 3.51 schon heruntergeladen und entpackt. auf der anleitungsseite von mysql steht man soll die instruktionen laut INSTALL-BINARY file ausführen. ich hab aber dieses file nirgends wo.
weiß jemand wo ich das finde bzw. was für befehle ich noch ausführen muss.

hätt schon probiert unter /bin den MYODBCInstaller auszuführen, bekam aber die fehlermeldung, dass libltdl.so.3 nicht gefunden wurde!

kann mir bitte jemand weiterhelfen?!
danke

Benutzeravatar
whois
Administrator
Administrator
Beiträge: 16598
Registriert: 11. Okt 2004, 08:50
Wohnort: Aachen
Kontaktdaten:

Beitrag von whois » 30. Sep 2005, 11:03

HI

Da ist doch mit Sicherheit ein readme File dabei.

Steht da was von

Code: Alles auswählen

configure - make - makeinstall
Du hast einen Server da musst du das doch Umsetzen können.

hausi18
Newbie
Newbie
Beiträge: 25
Registriert: 28. Sep 2005, 16:02

Beitrag von hausi18 » 30. Sep 2005, 11:27

es ist ein file install.html dabei. da steht drinnen:

This release of Connector/ODBC v5 has been built on kubuntu with latest updates (x86-32bit) using unixODBC and should work on same or similar. Installing this release involves:

unpacking the files

registering the driver

optionally creating a DSN

Please refer to unixODBC documentation for more about using ODBC on Linux.

Benutzeravatar
whois
Administrator
Administrator
Beiträge: 16598
Registriert: 11. Okt 2004, 08:50
Wohnort: Aachen
Kontaktdaten:

Beitrag von whois » 30. Sep 2005, 12:12

hausi18 hat geschrieben:
Please refer to unixODBC documentation for more about using ODBC on Linux.
http://www.linux-club.de/viewtopic.php?t=41204

hausi18
Newbie
Newbie
Beiträge: 25
Registriert: 28. Sep 2005, 16:02

Beitrag von hausi18 » 30. Sep 2005, 12:41

ich hab ja schon ein problem mit der installation, ich brauchs auch nicht für php.
hab jetzt ne andere version ausprobiert, da hab ich auch das install file dabei.

wenn ich ./configure mache checked er ein paar sachen durch und sagt dann missing ...
make und make install gehen gar nicht.
was muss ich da noch machen jetzt, damit ich odbc.ini bekomme?


hausi18
Newbie
Newbie
Beiträge: 25
Registriert: 28. Sep 2005, 16:02

Beitrag von hausi18 » 3. Okt 2005, 10:19

so, bin schon weiter gekommen in der zwischenzeit!
hab jetzt myodbc 3.51 drauf und unixodbc 2.2.2

hab die einstellungen laut mysql handbuch gemacht, auch die umgebungsvariablen zu ODBCINI und ODBCSYSINI passen.

beim test mit isql logging -v bekomm ich aber den fehler:

Data Source Name not found, and no default driver specified

in der odbc.ini hab ich die einstellungen auch laut handbuch gemacht. diese sieht so aus für meinen dsn:

[logging]
Driver = /usr/local/lib/libmyodbc3.so
Description = MySQL ODBC 3.51 Driver DSN for DB Logging
SERVER = localhost
PORT = 3306
USER = root
Password =
Database = Logging
OPTION = 3
SOCKET =

in der odbcinst.ini ist allerdings gar nichts drinnen gestanden! hab ein wenig gegoogelt und bin auf das gekommen:

[MySQL]
Description = ODBC for MySQL
Driver = /usr/local/lib/libmyodbc3.so
Setup = /usr/local/lib/libodbcmyS.so.1
FileUsage = 1

das problem ist, dass ich die datei libodbcmyS.so.1 nicht habe.

meine frage jetzt: passen meine einstellungen soweit?
was gehört in die odbcinst.ini datei?

lg

EDIT:
die libodbcmyS.so.1 hab ich jetzt unter /usr/lib/unixODBC gefunden. den link in der odbcinst.ini hab ich dorthin ausgetauscht bei Setup.

beim test bekomm ich aber trotzdem noch den oben genannten fehler. warum findet er den dsn nicht??


hausi18
Newbie
Newbie
Beiträge: 25
Registriert: 28. Sep 2005, 16:02

Beitrag von hausi18 » 3. Okt 2005, 11:33

mach ich ja schon stundenlang!!!
aber vielleicht gibts ja noch wo eine kleinigkeit die ich einstellen muss, und die wer weiß!

bin für jede hilfe auf jeden fall dankbar.

hausi18
Newbie
Newbie
Beiträge: 25
Registriert: 28. Sep 2005, 16:02

Beitrag von hausi18 » 3. Okt 2005, 11:44

hab ich oben schon mal hingeschrieben. hier nochmal:

[logging]
Description = ODBC for MySQL
Driver = /usr/local/lib/libmyodbc3.so
Setup = /usr/lib/unixODBC/libodbcmyS.so.1
FileUsage = 1

die dateien befinden sich auch in diesen angegebenen verzeichnissen!

thx

Benutzeravatar
whois
Administrator
Administrator
Beiträge: 16598
Registriert: 11. Okt 2004, 08:50
Wohnort: Aachen
Kontaktdaten:

Beitrag von whois » 3. Okt 2005, 11:47

OK Danke

Ich werde das mit meiner eigenen mal vergleichen.

Gesperrt

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 2 Gäste