[gelöst] ED2K-GUI findet ED2K-CLC auf dem Server nicht

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Gesperrt
Benutzeravatar
mtom
Member
Member
Beiträge: 57
Registriert: 9. Jun 2005, 11:21
Wohnort: Hamburg
Kontaktdaten:

[gelöst] ED2K-GUI findet ED2K-CLC auf dem Server nicht

Beitrag von mtom » 14. Sep 2005, 19:20

Moin!

Ich hatte bei mir eine Weile lang edonkey2000 auf meinem Server laufen. Das funktionierte soweit auch ganz gut, aber nur unter der KDE. Mit nur 196 MB RAM ist es auch nicht unbedingt ein Vergnügen mit der KDE zu Arbeiten. Außerdem hängt an dem Server ein 640x480 sw Monitor und der Server steht im Keller in der hintersten Ecke.

Daher habe ich jetzt den edonkey-clc installiert. Der lässt sich einwandfrei starten und auf den Port 4700 als Admin Port einstellen. Admin Username und Passwort habe ich auch eingestellt. Gestartet habe ich edonkeyclc mit der Option "-", so wie es auch in der Doku zu lesen ist.

Aber ich komme ums verrecken nicht mit der GUI auf den CLC. :evil:

Der Firewall auf dem Server ist aus und auf dem Router habe ich den Port 4700 auch noch freigegeben. Alles ohne Wirkung.

Die GUI habe ich unter Windows und unter Suse 9.3 probiert.

Muss ich auf dem Server noch einstellen, auf welchen Port da gelauscht werden soll?

Hat einer von Euch eine Idee was ich noch so Versuchen kann? Ich habe die GUI (oder das GUI?) versucht auf dem selben Rechner laufen zu lassen, aber bei der Installation habe ich was zerschossen, so dass ich jetzt weder Yast noch Yast2 mehr habe ...

Grüße aus Hamburg

Thomax

Werbung:
Benutzeravatar
mtom
Member
Member
Beiträge: 57
Registriert: 9. Jun 2005, 11:21
Wohnort: Hamburg
Kontaktdaten:

Gelöst - nicht sauber, aber ohne Probleme

Beitrag von mtom » 26. Sep 2005, 19:51

Moin!

Weil mir keiner von Euch helfen konnte habe ich mir eben selbst geholfen. OK, eigentlich bin ich zufällig auf die Lösung gestoßen.

Server
Hier starte ich den edonkeyclc mit der Option c, damit er sich automatisch verbindet.
Die Verzeihnisse habe ich so eingestellt:
in /filebase/ed2k/in
temp /filebase/ed2k/temp

Die beiden Verzeichnisse habe ich für Windows mit Samaba und für Linux mit NFS freigegeben. So kann ich von Windows und von Linux aus auf die Verzeichnisse zugreifen.

Client
Auf dem Client (eDonkey2000) habe ich die in und temp Verzeichnisse auch auf /filebase/ed2k/.. bzw. auf X:\filebase\ed2k\... eingestellt. Upload und Download habe ich auf jeweils 1 KB/s begrenzt. Die Begrenzung macht an dieser Stelle nichts, da ich vom Client aus nur steuern und keine Downloads machen möchte.

Nach dem Neustart von eDonkey2000 auf dem Client sehe ich jetzt die angefangenen Downloads vom edonkeyclc! Über die eingebaute Suchfunktion oder jeden beliebigen Browser kann ich jetzt Downloads zufügen.

Wenn ich fertig bin mit dem hinzufügen von Downloads schließe ich auf dem Client eDonkey2000.

Auf dem Server schließe ich edonkeyclc und starte ich neu.
Die neu gestarteten Downloads werden jetzt von edonkeyclc mit vd angezeigt.

Ich hoffe es kann noch jemand so seine Probleme lösen )


Grüße aus Hamburg

Thomas

Gesperrt

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 3 Gäste