Wine: L"c:windows" is not accessible.

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Antworten
Palantir
Newbie
Newbie
Beiträge: 9
Registriert: 22. Aug 2005, 15:06

Wine: L"c:windows" is not accessible.

Beitrag von Palantir » 26. Aug 2005, 09:51

Hallo!
Wenn ich versuche Wine zu starten kommt immer folgende Fehlermeldun:
moritz@linux:~> wine --help
Warning: the specified Windows directory L"c:windows" is not accessible.
Warning: the specified System directory L"c:windowssystem" is not accessible.
Warning: could not find DOS drive for current working directory '/home/moritz', starting in the Windows directory.
Wine 20050211
Usage: wine PROGRAM [ARGUMENTS...] Run the specified program
wine --help Display this help and exit
wine --version Output version information and exit
moritz@linux:~>
Ich versuche das durch die /home/../.wine/conf Datei zu regeln, aber ich kann da reinschreiben soviel ich will, der verändert nichts (selbst wenn ich sinnloses reinschreibe) - nicht mal ander der Fehlerausgabe, die immer die selbse bleibt, auch bei Verädnerung der Pfade.

Habe Wine von der Suse 9.3 DVD mitinstalliert. Gibt es da woanders die conf Datei? Hat jemand Erfahrung?

ANHANG

conf Datei von wine in /home/.../.wine (Wine soll unter /home/winec seine "C" einrichten - alle nötigen Ordner nach Anleitung (www.holarse.de) dort erstellt)
WINE REGISTRY Version 2
...

[Drive A]
"Path" = "/mnt/floppy"
"Type" = "floppy"
"Label" = "Floppy"
"Serial" = "87654321"
"Device" = "/dev/fd0"

[Drive C]
"Path" = "/home/winec"
"Type" = "hd"
"Label" = "MS-DOS"
"Filesystem" = "win95"

[Drive D]
"Path" = "/mnt/dvd"
"Type" = "cdrom"
"Label" = "CD-Rom"
"Filesystem" = "win95"
; make sure that device is correct and has proper permissions !

[Drive E]
"Path" = "/tmp"
"Type" = "hd"
"Label" = "Tmp Drive"
"Filesystem" = "win95"

[Drive F]
"Path" = "${HOME}"
"Type" = "network"
"Label" = "Home"
"Filesystem" = "win95"

[wine]
"Windows" = "c:windows"
"System" = "c:windowssystem"
"Temp" = "e:"
"Path" = "c:windows;c:windowssystem;e:;e:test;f:"
"Profile" = "c:windowsProfilesAdministrator"
"GraphicsDriver" = "x11drv"
;"ShowDirSymlinks" = "1"
;"ShowDotFiles" = "1"

# [wineconf]
...

Werbung:
geopin
Newbie
Newbie
Beiträge: 17
Registriert: 3. Aug 2005, 15:07

Beitrag von geopin » 29. Aug 2005, 07:40

hiho ;)

hast du schon einmal die wineconfig ausgeführt? ich weiss zwar nicht,
was das problem beheben könnte, aber in der wineconfig kannst du
auch ein fakewindows erstellen, was dann auch grad in der conf-datei
angepasst wird.

Palantir
Newbie
Newbie
Beiträge: 9
Registriert: 22. Aug 2005, 15:06

Danke

Beitrag von Palantir » 29. Aug 2005, 15:04

Hallo!
Habe es mit Winecfg probiert, der hat mir auch alle meine in der config eingerichteten Laufwerke angezeigt - hat dann aber trotzdem nicht funktioniert.
hab dann aus lauter Frust .wine komplett gelöscht und wine nochmal ausgeführt
Jetzt klappt's - zwar nicht in den ordner, in denen ich es gern hätte aber es macht keine Fehlermeldung mehr.

Palantir

Danke

Benutzeravatar
little tux
Member
Member
Beiträge: 71
Registriert: 4. Sep 2005, 23:48

Beitrag von little tux » 14. Okt 2005, 21:25

Ich hab leider genau den gleichen Fehler...
Mit einem Unterschied: Nach einer Neuinstallation von Wine wurde es nicht besser! Bitte um Hilfe!

Wenn ich mit winecfg bei Laufwerke auf Automatisch klicke erscheinen meine Partitionen richtig, wenn ich aber auf Anwenden klicke werden die Fehlermeldungen

Code: Alles auswählen

err:winecfg:apply_drive_changes   unable to define devicename of 'C:', targetpath of '/'
err:winecfg:apply_drive_changes   unable to define devicename of 'D:', targetpath of '/windows/C'
err:winecfg:apply_drive_changes   unable to define devicename of 'E:', targetpath of '/windows/E'
err:winecfg:apply_drive_changes   unable to define devicename of 'F:', targetpath of '/windows/F'
err:winecfg:apply_drive_changes   unable to define devicename of 'G:', targetpath of '/proc/bus/usb'
err:winecfg:apply_drive_changes   unable to define devicename of 'H:', targetpath of '/media/dvd'
err:winecfg:apply_drive_changes   unable to define devicename of 'I:', targetpath of '/media/cdrecorder'
err:winecfg:apply_drive_changes   unable to define devicename of 'J:', targetpath of '/subdomain'
err:winecfg:apply_drive_changes   unable to define devicename of 'K:', targetpath of '/home/little_tux'
ausgegeben.

geopin
Newbie
Newbie
Beiträge: 17
Registriert: 3. Aug 2005, 15:07

Beitrag von geopin » 18. Okt 2005, 07:47

greift ihr auf eine windows partition zu?

oder auf ein fake windows von wine?

[edit] kleine frage: habt ihr zufällig ein "dosdevices"-verzeichnis in
eurem ~/.wine-verzeichnis?

Benutzeravatar
little tux
Member
Member
Beiträge: 71
Registriert: 4. Sep 2005, 23:48

Beitrag von little tux » 2. Nov 2005, 18:19

Ich würde gerne auf eine Windows Partition zugreifen.

In meinem ~/.wine Verzeichnis befindet sich kein dosdevices Verzeichnis.
Dort befindet sich außer der System.reg und der User.reg gar nichts.

Benutzeravatar
little tux
Member
Member
Beiträge: 71
Registriert: 4. Sep 2005, 23:48

Beitrag von little tux » 2. Nov 2005, 22:20

OK, sorry. Es wurde mal wieder bewiesen, dass es durchaus sinnvoll ist, die Hinweise genau zu befolgen, die bereits vorhanden sind und dann rumzuheulen. :D

Als ich das ~/.wine Verzeichnis gelöscht habe und dann Wine wieder gestartet habe gings! Wine hat es neu angelegt und das Problem war beseitigt. Ich dachte durch eine deinstallation wird der auch mitgelöscht, aber das war wohl nicht so. Auf jeden Fall vielen Dank an Palantir für den entscheidenden Hinweis und an geopin für die Bemühungen!

geopin
Newbie
Newbie
Beiträge: 17
Registriert: 3. Aug 2005, 15:07

Beitrag von geopin » 6. Nov 2005, 17:50

ah, ok :)

mist, hätte mich doch wundergenommen, ob das mit den dos-devices und dessen symlinks das problem behoben hätte.

gruss, geopin

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast