GTA San Andreas!

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Antworten
Benutzeravatar
Coolzero
Advanced Hacker
Advanced Hacker
Beiträge: 1087
Registriert: 7. Mär 2004, 14:45

GTA San Andreas!

Beitrag von Coolzero » 19. Aug 2005, 11:12

Hallo, hab gta sA instaliert, nur spiele klappt leider nicht!
Nutze die neueste cedega version 4.4.1-1 und das neuester Point to Play!
Bekomme folgende Fehlermeldung:
cedega gta_sa.exe
mmtime pid=8936 tid=8962
wine: Unhandled exception, starting debugger...
WineDbg starting on pid 1
No debug information in ELF '/usr/lib/transgaming_cedega//winex/bin/wine' (0x00000000)
Breakpoint 1 at 0x4000db70
No debug information in ELF '/usr/lib/transgaming_cedega//winex/pthread_lib/libntdll.so' (0x40019000)
No debug information in ELF '/usr/lib/transgaming_cedega//winex/pthread_lib/libwine.so' (0x4011d000)
No debug information in ELF '/usr/lib/transgaming_cedega//winex/lib/libwine_unicode.so' (0x40132000)
No debug information in ELF '/usr/lib/transgaming_cedega//winex/lib/libwine_port.so' (0x401f9000)
No debug information in ELF '/lib/tls/libm.so.6' (0x40223000)
No debug information in ELF '/lib/tls/libc.so.6' (0x40246000)
No debug information in ELF '/lib/tls/libpthread.so.0' (0x40360000)
No debug information in ELF '/lib/libdl.so.2' (0x40372000)
No debug information in ELF '/lib/ld-linux.so.2' (0x40000000)
No debug information in ELF '/usr/lib/transgaming_cedega//winex/lib/libwinmm.so' (0x40803000)
No debug information in ELF '/usr/lib/transgaming_cedega//winex/lib/libuser32.so' (0x40859000)
No debug information in ELF '/usr/lib/transgaming_cedega//winex/lib/libgdi32.so' (0x40981000)
No debug information in ELF '/usr/lib/transgaming_cedega//winex/lib/libkernel32.so' (0x409f8000)
No debug information in ELF '/usr/lib/transgaming_cedega//winex/lib/libadvapi32.so' (0x40a79000)
No debug information in ELF '/usr/lib/transgaming_cedega//winex/lib/libws2_32.so' (0x40bb1000)
No debug information in ELF '/usr/lib/transgaming_cedega//winex/lib/libiphlpapi.so' (0x40bc9000)
No debug information in ELF '/usr/lib/transgaming_cedega//winex/lib/libole32.so' (0x40c08000)
No debug information in ELF '/usr/lib/transgaming_cedega//winex/lib/librpcrt4.so' (0x40c6d000)
No debug information in ELF '/usr/lib/transgaming_cedega//winex/lib/libwineserver.so' (0x40cb3000)
No debug information in ELF '/usr/lib/libfreetype.so.6' (0x40d1c000)
No debug information in ELF '/usr/lib/transgaming_cedega//winex/lib/libx11drv.so' (0x40d8b000)
No debug information in ELF '/usr/lib/transgaming_cedega//winex/lib/libwine_tsx11.so' (0x40e0b000)
No debug information in ELF '/usr/X11R6/lib/libSM.so.6' (0x40e44000)
No debug information in ELF '/usr/X11R6/lib/libICE.so.6' (0x40e4c000)
No debug information in ELF '/usr/lib/libGL.so.1' (0x40e64000)
No debug information in ELF '/usr/lib/transgaming_cedega//winex/lib/libGLU.so.1' (0x40ee3000)
No debug information in ELF '/usr/X11R6/lib/libXext.so.6' (0x40f9e000)
No debug information in ELF '/usr/X11R6/lib/libX11.so.6' (0x40fac000)
No debug information in ELF '/usr/lib/libGLcore.so.1' (0x410a8000)
No debug information in ELF '/usr/lib/tls/libnvidia-tls.so.1' (0x41811000)
No debug information in ELF '/usr/X11R6/lib/X11/locale/lib/common/xlcUTF8Load.so.2' (0x40e1f000)
No debug information in ELF '/usr/X11R6/lib/X11/locale/lib/common/ximcp.so.2' (0x40e21000)
No debug information in ELF '/usr/X11R6/lib/libXcursor.so.1' (0x418e5000)
No debug information in ELF '/usr/X11R6/lib/libXrender.so.1' (0x418ee000)
No debug information in ELF '/usr/lib/transgaming_cedega//winex/lib/libwineoss.drv.so' (0x41a70000)
No debug information in ELF '/usr/lib/transgaming_cedega//winex/lib/libmsacm32.so' (0x41a89000)
No debug information in ELF '/usr/lib/transgaming_cedega//winex/lib/libmsacm.drv.so' (0x41bb0000)
No debug information in ELF '/usr/lib/transgaming_cedega//winex/lib/libmidimap.drv.so' (0x41bb8000)
No debug information in ELF '/usr/lib/transgaming_cedega//winex/lib/libddraw.so' (0x42c45000)
No debug information in ELF '/usr/lib/transgaming_cedega//winex/lib/libd3dgl.so' (0x42da0000)
No debug information in ELF '/usr/lib/transgaming_cedega//winex/lib/libd3d8.so' (0x430f5000)
No debug information in ELF '/usr/lib/transgaming_cedega//winex/lib/libdpnhpast.so' (0x447a0000)
No debug information in ELF '/usr/lib/transgaming_cedega//winex/lib/libd3d9.so' (0x447a5000)
No debug information in ELF '/usr/lib/transgaming_cedega//winex/lib/libdsound.so' (0x44a00000)
No debug information in ELF '/usr/lib/transgaming_cedega//winex/lib/libdinput8.so' (0x42c8a000)
No debug information in ELF '/usr/lib/transgaming_cedega//winex/lib/libdinput.so' (0x4311c000)
No debug information in ELF '/usr/lib/transgaming_cedega//winex/lib/libjoystick.drv.so' (0x43140000)
No debug information in ELF '/lib/libgcc_s.so.1' (0x43181000)
No debug information in ELF '/usr/lib/transgaming_cedega//winex/lib/libquartz.so' (0x44a23000)
No debug information in ELF '/usr/lib/libjpeg.so.62' (0x44c18000)
No debug information in ELF '/usr/lib/transgaming_cedega//winex/lib/liboleaut32.so' (0x44c37000)
No debug information in ELF '/usr/lib/transgaming_cedega//winex/lib/libmsvfw32.so' (0x44bf1000)
No debug information in ELF '/usr/lib/transgaming_cedega//winex/lib/libcomctl32.so' (0x44c9c000)
No debug information in ELF '/usr/lib/transgaming_cedega//winex/lib/libversion.so' (0x44d21000)
No debug information in ELF '/usr/lib/transgaming_cedega//winex/lib/liblz32.so' (0x44d2b000)
wine: Unhandled exception, starting debugger...
WineDbg starting on pid c
No debug information in ELF '/usr/lib/transgaming_cedega//winex/bin/wine' (0x00000000)
Breakpoint 1 at 0x4000db70
No debug information in ELF '/usr/lib/transgaming_cedega//winex/pthread_lib/libntdll.so' (0x40019000)
No debug information in ELF '/usr/lib/transgaming_cedega//winex/pthread_lib/libwine.so' (0x4011d000)
No debug information in ELF '/usr/lib/transgaming_cedega//winex/lib/libwine_unicode.so' (0x40132000)
No debug information in ELF '/usr/lib/transgaming_cedega//winex/lib/libwine_port.so' (0x401f9000)
No debug information in ELF '/lib/tls/libm.so.6' (0x40223000)
No debug information in ELF '/lib/tls/libc.so.6' (0x40246000)
No debug information in ELF '/lib/tls/libpthread.so.0' (0x40360000)
No debug information in ELF '/lib/libdl.so.2' (0x40372000)
No debug information in ELF '/lib/ld-linux.so.2' (0x40000000)
No debug information in ELF '/usr/lib/transgaming_cedega/winex/bin/winedbg.so' (0x404d1000)
No debug information in ELF '/usr/lib/transgaming_cedega//winex/lib/libadvapi32.so' (0x40743000)
No debug information in ELF '/usr/lib/transgaming_cedega//winex/lib/libkernel32.so' (0x4076a000)
No debug information in ELF '/usr/lib/transgaming_cedega//winex/lib/libwineserver.so' (0x407eb000)
No debug information in 32bit DLL '/usr/lib/transgaming_cedega/winex/bin/winedbg' (0x404d9000)
No debug information in 32bit DLL 'NTDLL.DLL' (0x40057000)
No debug information in 32bit DLL 'KERNEL32.DLL' (0x4079d000)
No debug information in 32bit DLL 'ADVAPI32.DLL' (0x40755000)
Unhandled exception: page fault on read access to 0x41986374 in 32-bit code (0x404e93cf).
In 32-bit mode.
Register dump:
CS:0073 SS:007b DS:007b ES:007b FS:003b GS:0033
EIP:404e93cf ESP:40731e98 EBP:40731ea0 EFLAGS:00210246( R- 00 I Z- -P1 )
EAX:41986368 EBX:405048f8 ECX:00000000 EDX:00000003
ESI:00000000 EDI:7800cd18
Stack dump:
0x40731e98 (/usr/lib/transgaming_cedega/winex/bin/winedbg..data+0x256e98): 24924925 7800cd18 40731ef4 404e97a1
0x40731ea8 (/usr/lib/transgaming_cedega/winex/bin/winedbg..data+0x256ea8): 7800cd18 40830000 41986368 00000001
0x40731eb8 (/usr/lib/transgaming_cedega/winex/bin/winedbg..data+0x256eb8): 0000001c 4050445c 40830000 00000001
0x40731ec8 (/usr/lib/transgaming_cedega/winex/bin/winedbg..data+0x256ec8): 7800cf68 40732000 00000003 00000080
0x40731ed8 (/usr/lib/transgaming_cedega/winex/bin/winedbg..data+0x256ed8): 0000000b 7800cda8 00000000 00000000
0x40731ee8 (/usr/lib/transgaming_cedega/winex/bin/winedbg..data+0x256ee8): 405048f8 00400308 00000330 40732064
0x40731ef8 (/usr/lib/transgaming_cedega/winex/bin/winedbg..data+0x256ef8):

Backtrace:
=>0 0x404e93cf (/usr/lib/transgaming_cedega/winex/bin/winedbg..data+0xe3cf in winedbg.so) (ebp=40731ea0)
1 0x404e97a1 (/usr/lib/transgaming_cedega/winex/bin/winedbg..data+0xe7a1 in winedbg.so) (ebp=40731ef4)
2 0x404e65a1 (/usr/lib/transgaming_cedega/winex/bin/winedbg..data+0xb5a1 in winedbg.so) (ebp=40732064)
3 0x404f09f8 (/usr/lib/transgaming_cedega/winex/bin/winedbg..data+0x159f8 in winedbg.so) (ebp=40732188)
4 0x404f0dc2 (/usr/lib/transgaming_cedega/winex/bin/winedbg..data+0x15dc2 in winedbg.so) (ebp=407321fc)
5 0x404f127a (/usr/lib/transgaming_cedega/winex/bin/winedbg..data+0x1627a in winedbg.so) (ebp=40732230)
6 0x404da3d5 (/usr/lib/transgaming_cedega/winex/bin/winedbg.EntryPoint+0x2d in winedbg) (ebp=4073224c)
7 0x400cb400 (NTDLL.DLL.wine_server_call+0x1e74 in libntdll.so) (ebp=407322f4)
8 0x400cb513 (NTDLL.DLL.wine_server_call+0x1f87 in libntdll.so) (ebp=40732428)
9 0x40365aa7 (NTDLL.DLL.memcpy+0xb6af7 in libpthread.so.0) (ebp=407324b8)
10 0x402ffc2e (NTDLL.DLL.memcpy+0x50c7e in libc.so.6) (ebp=00000000)

0x404e93cf (/usr/lib/transgaming_cedega/winex/bin/winedbg..data+0xe3cf in winedbg.so): cmpl $8,0xc(%eax,%ecx,1)
Modules:
Address Module Name
0x40057000-40059000 (PE) NTDLL.DLL
0x404d9000-404db000 (PE) /usr/lib/transgaming_cedega/winex/bin/winedbg
0x40755000-40757000 (PE) ADVAPI32.DLL
0x4079d000-4079f000 (PE) KERNEL32.DLL
Threads:
process tid prio
0000000c (D) /usr/lib/transgaming_cedega/winex/bin/winedbg
0000000d 0 <==
00000001
0000000b 0
0000000a 0
00000008 0
00000007 0
00000006 0
00000005 0
00000003 0
00000002 0
WineDbg terminated on pid c
Cannot close *fd* 12
Cannot close *fd* 13
Cannot close *fd* 11
Cannot close *fd* 14


Aber das soll doch angeblich lkaufen unter cedega!?

Werbung:
geopin
Newbie
Newbie
Beiträge: 17
Registriert: 3. Aug 2005, 15:07

Beitrag von geopin » 19. Aug 2005, 15:29

Huhu :)

kleines frägchen *g* hast du cadega über CVS gezogen und selber
kompiliert? wahrscheinlich nicht, oder?
was hast du für eine distribution?

Benutzeravatar
zero0109
Hacker
Hacker
Beiträge: 367
Registriert: 21. Apr 2004, 13:50
Wohnort: Regensburg
Kontaktdaten:

Beitrag von zero0109 » 19. Aug 2005, 22:10

Gta San Andreas wird von Transgaming noch nicht unterstützt. Es lässt sich zwar nach Anpassung diverser Einstellungen starten, allerdings kommt es dabei zu massiven Grafikfehlern. Ich würde dir anraten, dich noch ein wenig zu gedulden, bis Transgaming sich der Sache angenommen hat.

Benutzeravatar
Coolzero
Advanced Hacker
Advanced Hacker
Beiträge: 1087
Registriert: 7. Mär 2004, 14:45

re

Beitrag von Coolzero » 20. Aug 2005, 19:04

Nein hab mir nicht die source gezogen, sondern die fertigen binarys von transgaming!Wäre es besser selbst zu compelieren?
Benutze Suse 9.3
geopin hat geschrieben:Huhu :)

kleines frägchen *g* hast du cadega über CVS gezogen und selber
kompiliert? wahrscheinlich nicht, oder?
was hast du für eine distribution?

Benutzeravatar
Gimpel
Guru
Guru
Beiträge: 1983
Registriert: 11. Feb 2004, 13:58
Wohnort: Mjunik .... "no a hoibe, resi!"
Kontaktdaten:

Re: re

Beitrag von Gimpel » 20. Aug 2005, 19:06

Coolzero hat geschrieben:Nein hab mir nicht die source gezogen, sondern die fertigen binarys von transgaming!Wäre es besser selbst zu compelieren?
Benutze Suse 9.3
nein, weil dabei der directX support flöten geht!

siehe zero0109
Bild on AMD Athlon64 X2 5600+|64bit|6GB DDR2 800MHz|nVidia GF 8500GT|2.6.29-rc1-moo1|BTRFS|KDE-4.2 SVN trunk + Compiz++|M-Audio Audiophile 2496
----
Bild

Benutzeravatar
Coolzero
Advanced Hacker
Advanced Hacker
Beiträge: 1087
Registriert: 7. Mär 2004, 14:45

re

Beitrag von Coolzero » 20. Aug 2005, 19:09

zero0109 hat geschrieben:Gta San Andreas wird von Transgaming noch nicht unterstützt. Es lässt sich zwar nach Anpassung diverser Einstellungen starten, allerdings kommt es dabei zu massiven Grafikfehlern. Ich würde dir anraten, dich noch ein wenig zu gedulden, bis Transgaming sich der Sache angenommen hat.

http://transgaming.org/gamesdb/

Benutzeravatar
zero0109
Hacker
Hacker
Beiträge: 367
Registriert: 21. Apr 2004, 13:50
Wohnort: Regensburg
Kontaktdaten:

Beitrag von zero0109 » 20. Aug 2005, 20:29

Das ist die Games Database der Community-Seite, dort ist so gut wie jedes bisher erschienene Spiel verzeichnet. Mit der Kompatibilität zu Cedega hat dies nichts zu tun. Dort tragen sich vor allem viele Leute ein, um zu erreichen, dass Transgaming sich daran macht das Spiel zu unterstützen.

Benutzeravatar
Coolzero
Advanced Hacker
Advanced Hacker
Beiträge: 1087
Registriert: 7. Mär 2004, 14:45

re

Beitrag von Coolzero » 21. Aug 2005, 17:42

gibts denn jetzt garkeine möglichkeit!?
bei einigen läufts doch

geopin
Newbie
Newbie
Beiträge: 17
Registriert: 3. Aug 2005, 15:07

Beitrag von geopin » 22. Aug 2005, 09:08

Hallo :)

Schau mal, was piratec zu einer Problemstellung mit GTA San Andreas
geschrieben hat (zweitletzter Beitrag):

Hier klicken

Er verwies z.B. auf den "-opengl"-Parameter, bastelt an der config rum
und behauptet, dass das Spiel nur mit NVIDIA Grafikkarten laufen
würde. Aber les dir den Beitrag
mal durch, anscheinend gibts auch Probleme mit den Intros vom Spiel.

Benutzeravatar
Coolzero
Advanced Hacker
Advanced Hacker
Beiträge: 1087
Registriert: 7. Mär 2004, 14:45

re

Beitrag von Coolzero » 22. Aug 2005, 21:47

Danke für den tip, damit läufts, mußte nur den Ordner Movies umbenennen!
Komm zwar nicht ins Grafik Menü, dann stürzt er ab, aber die Grafik sieht in der Grundeionstellung sehr gut aus, und läuft flüssig!
Das einzige Problem welches ich jetzt noch hab ist das das die Sprache englisch ist und ich deutsch auch nicht auswählen kann!
Unter Windowes funzt das aber!

Benutzeravatar
Coolzero
Advanced Hacker
Advanced Hacker
Beiträge: 1087
Registriert: 7. Mär 2004, 14:45

re

Beitrag von Coolzero » 22. Aug 2005, 22:09

Hab mal neu gestartet und dann wars in deutsch wieso auch immer!
Aber hab festgestellt das es ab und an eineige Polygon Fehler gibt und anscheinend wird kein AA und sowas genutzt, also die kantenglättung, sind doch heftige Treppchen effekte!
Kann man die noch irgendwie beheben?

geopin
Newbie
Newbie
Beiträge: 17
Registriert: 3. Aug 2005, 15:07

Beitrag von geopin » 23. Aug 2005, 07:41

hallo :)

hast du schon einmal den "-opengl"-Parameter verwendet, damit
das spiel mit OpenGL anstatt DirectX läuft?

vielleicht hilft es, vielleicht startet das spiel auch gar nicht mehr *g*,
indemfall sorry ;)

Benutzeravatar
zero0109
Hacker
Hacker
Beiträge: 367
Registriert: 21. Apr 2004, 13:50
Wohnort: Regensburg
Kontaktdaten:

Beitrag von zero0109 » 1. Sep 2005, 13:55

gibts denn jetzt garkeine möglichkeit!?
bei einigen läufts doch
Aber hab festgestellt das es ab und an eineige Polygon Fehler gibt und anscheinend wird kein AA und sowas genutzt, also die kantenglättung, sind doch heftige Treppchen effekte!
Jo, wie ich schon oben geschrieben hab, es ist zum Laufen zu bringen, alllerdings nur mit Grafikfehlern. Mir persönlich ist bis jetzt noch keiner begegnet, bei dem es fehlerfrei lief.

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast