Tftp Error - File not found :(

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Antworten
Sveniboy1984
Newbie
Newbie
Beiträge: 37
Registriert: 8. Aug 2005, 14:12
Wohnort: Schleswig
Kontaktdaten:

Tftp Error - File not found :(

Beitrag von Sveniboy1984 » 17. Aug 2005, 09:38

Moin Moin Jungs,

ich hab mal wieder ein Problem.

Ich hab meinen Ltsp Server eingerichtet (ltsp.org, Version 4.1) und der Dhcp läuft auch.

Beim Booten der PXE-fähigen Clients, finden die Clients auch eine Ip, Metzmaske usw. Das geht ja.

Aber dann meckert er rum:

PXE-T01: File not found
PXE-E3B: TFTP Error - File Not found

Ich geh davon aus, das er im Verzeichniss tftpboot den Kernel nicht findet.

Mein Verzeichnis sieht aus aus:
/tftpboot/lts

2.4.26-ltsp-3
/2.4.26-ltsp-3/pxelinux.cfg
/2.4.26-ltsp-3/pxelinux.cfg/default
/2.4.26-ltsp-3/bzImage-2.4.26-ltsp-3
/2.4.26-ltsp-3/initrd-2.4.26-ltsp-3.gz
/2.4.26-ltsp-3/pxelinux.0

2.6.9-ltsp-3
/2.6.9-ltsp-3/pxelinux.cfg
/2.6.9-ltsp-3/pxelinux.cfg/default
/2.6.9-ltsp-3/bzImage-2.6.9-ltsp-3
/2.6.9-ltsp-3/initrd-2.6.9-ltsp-3.gz
/2.6.9-ltsp-3/pxelinux.0

vmlinuz-2.4.26-ltsp-3
vmlinuz-2.6.9-ltsp-3

Nur welche Datei nehm ich?
Muss ich noch was entpacken?

Meine Dhcpd.conf:

default-lease-time 604800;
max-lease-time 691200;

option subnet-mask 255.255.255.0;
option broadcast-address 192.168.84.255;
option domain-name "ltsp";
option domain-name-servers 192.168.1.254;
option routers 192.168.84.1;
ddns-update-style none;

option root-path "192.168.84.1:/opt/ltsp/i386";
filename "192.168.84.1:/lts/2.4.26-ltsp-3/pxelinux.cfg/default";

subnet 192.168.84.0 netmask 255.255.255.0 {
range 192.168.84.10 192.168.84.20;
default-lease-time 604800;
max-lease-time 691200;
}

Bin für jeder Hilfe dankbar :)
Zuletzt geändert von Sveniboy1984 am 17. Aug 2005, 10:29, insgesamt 1-mal geändert.

Werbung:
rolle
Guru
Guru
Beiträge: 3721
Registriert: 4. Mai 2004, 21:50
Kontaktdaten:

Beitrag von rolle » 17. Aug 2005, 10:12

Wissen tue ich es nicht, aber
option root-path "192.168.84.1:/opt/ltsp/i386";
klingt so, als ob damit das Wurzelverzeichnis für den Client festgelegt wird. Dann wird wahrscheinlich
filename "192.168.84.1:/lts/2.4.26-ltsp-3/pxelinux.cfg/default";
als Unterpfad davon gesucht.
Du hast aber geschrieben, dieses Verzeichnis sehe so aus:
/tftpboot/ltsfile:

2.4.26-ltsp-3
/2.4.26-ltsp-3/pxelinux.cfg
/2.4.26-ltsp-3/pxelinux.cfg/default
/2.4.26-ltsp-3/bzImage-2.4.26-ltsp-3
/2.4.26-ltsp-3/initrd-2.4.26-ltsp-3.gz
/2.4.26-ltsp-3/pxelinux.0
Nach Deinen Angaben liegt es also nicht in dem virtuellen Wurzelverzeichnis und ist eventuell deshalb nicht auffindbar.
Horrido, Roland

Für meine Postings gilt außer bei Zitaten hier im Linux-Club die Creative Commons.

Sveniboy1984
Newbie
Newbie
Beiträge: 37
Registriert: 8. Aug 2005, 14:12
Wohnort: Schleswig
Kontaktdaten:

Beitrag von Sveniboy1984 » 17. Aug 2005, 10:45

/tftpboot/ltsfile:
Ohh, sorry da hat sich der Fehlerteufel eingeschlichen :(

Heißt natürlich /tftpboot/lts

Muss ich noch irgendwelche Dienste starten damit er den Kernel lädt?
Muss ich den Kernel (gz datei) entpacken?

Wieso sind da den 2 Ordner drinne (2.4.26-ltsp-3 und 2.6.9-ltsp-3)
Welchen soll ich nehmen?

Ich poste mal meine IP-Daten:

Client IP: 192.168.84.20
Mask: 255.255.255.0
Dhcp IP: 192.168.84.1
Gateway Ip: 192.168.84.1

Hab meine dhcpd.conf jetzt geändert in:
default-lease-time 604800;
max-lease-time 691200;

option subnet-mask 255.255.255.0;
option broadcast-address 192.168.84.255;
option domain-name "ltsp";
option domain-name-servers 192.168.1.254;
option routers 192.168.84.1;
ddns-update-style none;

subnet 192.168.84.0 netmask 255.255.255.0 {
range 192.168.84.10 192.168.84.20;
default-lease-time 604800;
max-lease-time 691200;

if substring (option vendor-class-identifier,0,9)="PXEClient"
{
filename "/lts/2.4.26-ltsp-3/pxelinux.0";
}
else
{
filename "/lts/vmlinuz-2.4.26-ltsp-3";
}

}

gustavk
Newbie
Newbie
Beiträge: 1
Registriert: 6. Dez 2003, 20:40

Beitrag von gustavk » 5. Sep 2005, 12:42

Hallo,

ein kleiner Hinweis, den ich glaube auf ltsp.org gelesen zu haben.

Wenn in der /etc/inetd.conf hinter tftpd ein '-s' steht kannst du in der /etc/dhcpd.conf bei filename das "/tftpboot" weglassen. Somit geht es gleich mit dem Verzeichnis "ltsp" los.

Gruß
Gustav

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 3 Gäste