neues kniffel: vnc mit https ohne putty (ssh)

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Antworten
narvik
Newbie
Newbie
Beiträge: 10
Registriert: 21. Jul 2005, 13:35

neues kniffel: vnc mit https ohne putty (ssh)

Beitrag von narvik » 28. Jul 2005, 14:49

neue kleine denksportaufgabe für linux-vnc-cracks:

vorhandene umgebung:
server1 in intranet, per vnc erreichbar.

dieser server1 soll nun über das internet (also von außen, eine firewall ist dazwischen, die die ports 580x und 590x forwarded) per vnc - aber secure, also https - erreicht werden.

es ist, wie gesagt, kein putty oder dergleichen nutzbar/verfügbar, sondern nur http/https.

es gibt also nur eine dynamische ip, sagen wir mal über dyndns zu erreichen.

so, nun mal frisch ans werk... bin schon auf eure lösungsansätze gespannt.

Werbung:
rolle
Guru
Guru
Beiträge: 3721
Registriert: 4. Mai 2004, 21:50
Kontaktdaten:

Beitrag von rolle » 28. Jul 2005, 15:00

Für so etwas nehme ich FreeNX, da ist die Verschlüsselung schon mit drin.
Horrido, Roland

Für meine Postings gilt außer bei Zitaten hier im Linux-Club die Creative Commons.

narvik
Newbie
Newbie
Beiträge: 10
Registriert: 21. Jul 2005, 13:35

Beitrag von narvik » 28. Jul 2005, 15:42

kann man mit einem vnc-client auch auf einen freenx-server zugreifen?

rolle
Guru
Guru
Beiträge: 3721
Registriert: 4. Mai 2004, 21:50
Kontaktdaten:

Beitrag von rolle » 28. Jul 2005, 22:24

Nein, dazu benutzt man einen NX-Client. den gibt es aber (wie ich überflogen habe) sogar als Plugin für Browser und ansonst auch kostenfrei.
Horrido, Roland

Für meine Postings gilt außer bei Zitaten hier im Linux-Club die Creative Commons.

narvik
Newbie
Newbie
Beiträge: 10
Registriert: 21. Jul 2005, 13:35

Beitrag von narvik » 31. Jul 2005, 10:57

ok, freeNX mal probeweise installiert.
läßt sich leider nicht starten.

...
nxserver --start
NX> 500 Error: Function -- not implemented yet.
NX> 999 Bye

Leider finde ich selbst über google keine Erklärung.

schweer
Hacker
Hacker
Beiträge: 268
Registriert: 2. Jan 2004, 23:40
Wohnort: Bochum

Beitrag von schweer » 31. Jul 2005, 19:01

narvik hat geschrieben:nxserver --start
NX> 500 Error: Function -- not implemented yet.
NX> 999 Bye
Leider finde ich selbst über google keine Erklärung.
Einfache Erklärung:
Du hast nxserver -- start eingegeben.
Mit nxserver --start wird es funktionieren.

wolfgang

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 4 Gäste