Wine geht nur unter Root

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Antworten
Dr. Glastonbury
Advanced Hacker
Advanced Hacker
Beiträge: 1149
Registriert: 20. Aug 2004, 12:27
Wohnort: München
Kontaktdaten:

Wine geht nur unter Root

Beitrag von Dr. Glastonbury » 14. Jul 2005, 22:27

Hiho - ich mal wieder...
Und diesmal mit einem seltsamen Problem:
Ich hab Wine wie schon so oft vorher wunderbar kompillieren und installieren können. Danach hab ich auch gleich mal als root getestet - weil ich noch vom make install als root in der Konsole eingelogt war.

Tjo, hat wunderbar funktioniert!

Dann hab ich mir gedacht, mach ichs doch als user und was kommt:

Code: Alles auswählen

moritz@Lamer:/windows/e/MOHAA> wine MOHAA.exe
wine: exists lstat socket : No such file or directory
moritz@Lamer:/windows/e/MOHAA> wineserver
Line 8: Malformed key '[wine]'
Line 8: Error creating key '[wine]'
Line 9: Value without key '"Windows" = "c:\\windows"'
Line 10: Value without key '"GraphicsDriver" = "x11drv"'
Line 16: Malformed key '[Version]'
Line 16: Error creating key '[Version]'
Line 18: Value without key '"Windows" = "win98"'
Line 20: Value without key '"DOS" = "6.22"'
Line 24: Malformed key '[DllOverrides]'
Line 24: Error creating key '[DllOverrides]'
Line 26: Value without key '"oleaut32"     = "builtin, native"'
Line 27: Value without key '"ole32"        = "builtin, native"'
Line 28: Value without key '"comdlg32"     = "builtin, native"'
Line 29: Value without key '"shell32"      = "builtin, native"'
Line 30: Value without key '"shfolder"     = "builtin, native"'
Line 31: Value without key '"shlwapi"      = "builtin, native"'
Line 32: Value without key '"shdocvw"      = "builtin, native"'
Line 33: Value without key '"advapi32"     = "builtin, native"'
Line 34: Value without key '"msvcrt"       = "native, builtin"'
Line 35: Value without key '"mciavi.drv"   = "native, builtin"'
Line 36: Value without key '"mcianim.drv"  = "native, builtin"'
Line 37: Value without key '"d3drm"        = "native, builtin"'
Line 38: Value without key '"d3dxof"       = "native, builtin"'
Line 39: Value without key '"dpnhpast"     = "native, builtin"'
Line 46: Value without key '"*" = "builtin, native"'
Line 48: Malformed key '[x11drv]'
Line 48: Error creating key '[x11drv]'
Line 50: Value without key '"AllocSystemColors" = "100"'
Line 52: Value without key '"PrivateColorMap" = "N"'
Line 54: Value without key '"PerfectGraphics" = "N"'
Line 58: Value without key '"Managed" = "Y"'
Line 63: Value without key '"UseDGA" = "Y"'
Line 65: Value without key '"UseXVidMode" = "Y"'
Line 67: Value without key '"UseXRandR" = "Y"'
Line 69: Value without key '"UseTakeFocus" = "Y"'
Line 71: Value without key '"DXGrab" = "N"'
Line 74: Value without key '"DesktopDoubleBuffered" = "N"'
Line 90: Malformed key '[fonts]'
Line 90: Error creating key '[fonts]'
Line 93: Value without key '"Default" = "-adobe-helvetica-"'
Line 94: Value without key '"DefaultFixed" = "fixed"'
Line 95: Value without key '"DefaultSerif" = "-adobe-times-"'
Line 96: Value without key '"DefaultSansSerif" = "-adobe-helvetica-"'
Line 110: Malformed key '[FontDirs]'
Line 110: Error creating key '[FontDirs]'
Line 111: Value without key '"dir1" = "/usr/X11R6/lib/X11/fonts/truetype"'
Line 112: Value without key '"dir2" = "/usr/X11R6/lib/X11/fonts/TrueType"'
Line 113: Value without key '"dir3" = "/usr/X11R6/lib/X11/fonts/TT"'
Line 115: Malformed key '[ppdev]'
Line 115: Error creating key '[ppdev]'
Line 123: Malformed key '[spooler]'
Line 123: Error creating key '[spooler]'
Line 124: Value without key '"FILE:" = "tmp.ps"'
Line 125: Value without key '"LPT1:" = "|lpr"'
Line 126: Value without key '"LPT2:" = "|gs -sDEVICE=bj200 -sOutputFile=/tmp/fred -q -"'
Line 127: Value without key '"LPT3:" = "/dev/lp3"'
Line 129: Malformed key '[ports]'
Line 129: Error creating key '[ports]'
Line 133: Malformed key '[Debug]'
Line 133: Error creating key '[Debug]'
Line 141: Malformed key '[registry]'
Line 141: Error creating key '[registry]'
Line 147: Value without key '"LoadGlobalRegistryFiles" = "Y"'
Line 149: Value without key '"LoadWindowsRegistryFiles" = "Y"'
Line 153: Value without key '"SaveOnlyUpdatedKeys" = "Y"'
Line 155: Malformed key '[Clipboard]'
Line 155: Error creating key '[Clipboard]'
Line 156: Value without key '"UsePrimary" = "0"'
Line 159: Malformed key '[afmdirs]'
Line 159: Error creating key '[afmdirs]'
Line 160: Value without key '"1" = "/usr/share/ghostscript/fonts"'
Line 161: Value without key '"2" = "/usr/share/a2ps/afm"'
Line 162: Value without key '"3" = "/usr/share/enscript"'
Line 163: Value without key '"4" = "/usr/X11R6/lib/X11/fonts/Type1"'
Line 165: Malformed key '[WinMM]'
Line 165: Error creating key '[WinMM]'
Line 168: Value without key '"Drivers" = "wineoss.drv"      ; default for most common configurations'
Line 175: Value without key '"WaveMapper" = "msacm.drv"'
Line 176: Value without key '"MidiMapper" = "midimap.drv"'
Line 178: Malformed key '[dsound]'
Line 178: Error creating key '[dsound]'
Line 198: Malformed key '[Network]'
Line 198: Error creating key '[Network]'
Line 205: Malformed key '[ppd]'
Line 205: Error creating key '[ppd]'
Line 206: Value without key '"generic" = "/usr/share/wine/generic.ppd"'
Ok denk ich mir, versuch ichs mit winecfg - macht er alles wunderbar, aber in dem Moment, wo ich versuche das ganze zu starten erhalte ich exakt die gleiche Fehlermeldung...

Also such ich im Inet und finde eigentlich nichts --- hmpf...
Nochmal die configs neu machen und jetzt kommt das:

Code: Alles auswählen

moritz@Lamer:/windows/e/MOHAA> wine MOHAA.exe
Warning: no valid DOS drive found, check your configuration file.
Warning: could not find wine config [Drive x] entry for current working directory /windows/E/MOHAA; starting in windows directory.
Invalid path 'c:\windows\system' for system directory: does not exist
Perhaps you have not properly edited or created your Wine configuration file.
This is (supposed to be) '/home/moritz/.wine/config'
Ok, denk ich mir schon wieder; mach ich eben n winecfg, damit da die Laufwerke eingetragen werden können und so schließt sich mein Teufelskreislauf........nämlich mit der selben Fehlermeldung, die ich eingangs bereits beschrieben hatte..... :(

Also hat wer ne Idee, was da faul sein könnte? Ich bin mit meinem Latein am (Note 6^^)

Denn schon mal vielen Dank im Vorraus ;)
Das Leben: hasse oder ignoriere es, lieben kannst du es nicht.

Werbung:
luchsn
Newbie
Newbie
Beiträge: 4
Registriert: 7. Aug 2005, 18:04
Wohnort: Erding
Kontaktdaten:

Beitrag von luchsn » 7. Aug 2005, 18:11

ich hab das selbe problem an meinem rechner in der firma. soweit ich weiss, liegt es daran, dass du als su bzw. root compiliert hast.

Dr. Glastonbury
Advanced Hacker
Advanced Hacker
Beiträge: 1149
Registriert: 20. Aug 2004, 12:27
Wohnort: München
Kontaktdaten:

Beitrag von Dr. Glastonbury » 12. Aug 2005, 16:15

luchsn hat geschrieben:ich hab das selbe problem an meinem rechner in der firma. soweit ich weiss, liegt es daran, dass du als su bzw. root compiliert hast.
Hmmmm - klingt zumindest plausibel..... Nja, dann werd ich wohl nochmal mit meinem User probieren, ob ichs hinbekomm.

Schon mal Danke ;)
Das Leben: hasse oder ignoriere es, lieben kannst du es nicht.

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 3 Gäste