ESD + SuSE 9.3 + LTSP 4.1.1

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Antworten
gamefreaktegel
Newbie
Newbie
Beiträge: 45
Registriert: 25. Jun 2004, 23:54
Wohnort: Berlin
Kontaktdaten:

ESD + SuSE 9.3 + LTSP 4.1.1

Beitrag von gamefreaktegel » 19. Jun 2005, 17:11

Hi Leutz,

ich versuche gerade den Sound an meinen Igel-Terminals (AC-97 Soundchip) zu aktivieren. Erstmal meine Konfiguration:
/etc/esd.conf

Code: Alles auswählen

[esd]
auto_spawn=1
spawn_options=-terminate -nobeeps -as 2
spawn_wait_ms=100
# default options are used in spawned and non-spawned mode
default_options=-as 2
/etc/sysconfig/esound

Code: Alles auswählen

# Beeps on daemon start?
#
ESD_BEEPS="no"

## Type:        yesno
## Default:     yes
#
# Open TCP socket?
#
ESD_TCP="yes"

## Type:        yesno
## Default:     yes
#
# Public access to server (from other host than localhost)?
# Note that you must either enable public access or set bind address
# to be able to access esound remotelly.
#
ESD_PUBLIC="yes"

## Type:        string
## Default:     ""
#
# TCP/IP bind address.
# You can also specify "$HOSTNAME", this will be replaced by your
# canonical host name.
# Note that you must either enable public access or set bind address
# to be able to access esound remotelly.
#
ESD_BIND=""

## Type:        yesno
## Default:     no
#
# Open UNIX socket?
#
ESD_UNIX="no"

## Type:        integer
## Default:     2
#
# Timeout to release sound device if daemon is not active (auto-spawn)
# Set to -1 for no timeout.
#
ESD_AS=2

## Type:        string
## Default:     ""
#
# Other esound options:
#  -d DEVICE
#        force esd to use sound device DEVICE
#  -b
#        run server in 8 bit sound mode
#  -r RATE
#        run server at sample rate of RATE
#  -port PORT
#        listen for connections at PORT (only for tcp/ip)
#  -promiscuous
#        start unlocked and owned (disable authenticaton)
#        NOT RECOMMENDED
#  -trust
#        start esd even if use of /tmp/.esd can be insecure
#        NOT RECOMMENDED
#  -terminate
#        DO NOT USE
#
ESD_OPTIONS=""
Ist das so in Ordnung? (Habe nichts verändert...)


/opt/ltsp/i386/etc/lts.conf

Code: Alles auswählen

[Default]
        SERVER             = 192.168.0.1
        XSERVER            = auto
        X_MOUSE_PROTOCOL   = "PS/2"
        X_MOUSE_DEVICE     = "/dev/psaux"
        X_MOUSE_RESOLUTION = 400
        X_MOUSE_BUTTONS    = 3
        USE_XFS            = N
        XkbModel           = pc104
        XkbLayout          = de
        SOUND              = Y
        SOUND_DAEMON       = esd

[client10]
        XSERVER          = sis
        LOCAL_APPS         = N
        USE_XFS         = Y
        USE_NFS_SWAP    = N
        SWAPFILE_SIZE   = 48m
        SOUND           = Y
        SOUND_DAEMON    = esd
        VOLUME          = 100
        MIC_VOLUME      = 100
        X_VIDEORAM      = 8192
        RAMDISK_SIZE    = 10240

Bei den KDE-Einstellungen habe ich die Netzwerkunterstützung aktiviert und den Buffer ganz runter gesetzt. Bloß was gebe ich als Sounddevice an. Bisher stand da was mit automatischer Erkennung. ESound taucht in der Liste nicht auf... nur ALSA, OSS usw.

Ich habe aber den Verdacht, dass der Server zwar richtig sendet, aber die Clients es nicht annehmen. Wenn ich vom Server aus einen Portscan mit nmap durchführe, dann müsste doch der ESD-Port zu sehen sein oder?
Was mache ich falsch?

Danke im Voraus

Werbung:
markus_aus_do
Newbie
Newbie
Beiträge: 15
Registriert: 13. Okt 2005, 12:31
Wohnort: Ruhrstadt

Re: ESD + SuSE 9.3 + LTSP 4.1.1 + Sound

Beitrag von markus_aus_do » 13. Okt 2005, 13:00

hast du schonmal die informationen aus folgender quelle probiert:
http://wiki.ltsp.org/twiki/bin/view/Lts ... _97_Sounds

dann ist mir noch aufgefallen, dass du kein sound-module lädst:
SMODULE_01 = "sb io=0x220 irq=5 dma1"
diese zeile steht bei mir hinter dem sound-daemon.

bei mir wird dann ein soundserver gestartet, der auf port 16001 auf anfragen wartet.
allerdings startet aktuell dann kde nicht. nach dem anmeldebildschirm, wo normalerweise der login-sound erscheint, erscheint nach anmeldung unmittelbar wieder der anmeldebildschirm. hier habe ich auch noch keine lösung.

gruss
markus_aus_do

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 3 Gäste