crossover-office startet nicht

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Antworten
saturn
Newbie
Newbie
Beiträge: 25
Registriert: 2. Jan 2005, 15:55
Wohnort: Erfurt / Thüringen

crossover-office startet nicht

Beitrag von saturn » 2. Jun 2005, 13:58

Ich gruesse Euch

Folgendes Problem,ich habe mir bei LinuxLand CrossoverOffice Standart gekauft.

Ich fuerte ,nach dem es in home gelandet ist,folgendes aus

mike@linux:~> su
Password:
linux:/home/mike # sh install-crossover-office.sh
Verifying archive integrity...OK
Uncompressing CrossOver Office Standard..........................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................
Xlib: connection to ":0.0" refused by server
Xlib: No protocol specified


Setup requires an X display to run. There is a display variable set, however
you have no permissions to access the X server (:0.0) it points to.
Try running xhost +localhost before su'ing to root.

linux:/home/mike #

und erhielt diese Meldung.
Warum startet es nicht,oder wo liegt hier der Fehler.


Nen schoenen Tag noch.



Suse 9.2

Werbung:
Benutzeravatar
zero0109
Hacker
Hacker
Beiträge: 367
Registriert: 21. Apr 2004, 13:50
Wohnort: Regensburg
Kontaktdaten:

Beitrag von zero0109 » 2. Jun 2005, 14:14

Bevor du su machst, tipp xhost + ein.
Du musst aber Crossover nicht als root installieren.

saturn
Newbie
Newbie
Beiträge: 25
Registriert: 2. Jan 2005, 15:55
Wohnort: Erfurt / Thüringen

Beitrag von saturn » 2. Jun 2005, 14:42

Na das ging aber schnell,Danke.
Ich habe folgendes ausgefuert


mike@linux:~> xhost
access control enabled, only authorized clients can connect
mike@linux:~> xhost+
bash: xhost+: command not found
mike@linux:~> xhost+sh install-crossover-office.sh
bash: xhost+sh: command not found
mike@linux:~> xhost sh install-crossover-office.sh
xhost: bad hostname "sh"
xhost: bad hostname "install-crossover-office.sh"
mike@linux:~>

mehr ist nicht passiert.

Reagieren auf Hilfe kann ich heute nicht mehr ,ich mss jetzt zur Arbeit

renate

Beitrag von renate » 2. Jun 2005, 14:51

Hi,
Syntax:

Code: Alles auswählen

xhost leerzeichen +
access control disabled, clients can connect from any host
su Passwort
sh ./install-crossover-office.sh

Dann gehts.

taki
Advanced Hacker
Advanced Hacker
Beiträge: 974
Registriert: 30. Apr 2004, 17:40
Wohnort: Berlin
Kontaktdaten:

Also denn für heute abend...

Beitrag von taki » 2. Jun 2005, 14:54

xhost +NEUE ZEILE
su -c 'sh install-crossover-office.sh'
Passwort
Das Installationsscript will ein Fenster auf die Oberfläche zaubern.
Da Du das Script als root starten möchtest, hat es keinen Zugriff auf die grafische Oberfläche (X), da diese ja dem Benutzer mike gehört.
Mit xhost+ erlaubt mike allen anderen Usern (und damit auch root) Zugriff auf den X-Server (die grafische Oberfläche).

Anschließend kann root dann das Script starten.

Allerdings kam weiter oben schon mal der berechtigte Hinweis, dass Du Crossover Office eigentlich nicht als Root installieren solltest.

P.S.: Schon wieder war ich zu langsam... Hallo Renate :wink:
Ausserdem hatte ich das su vergessen :oops:
SuSE 12.3 kernel 3.7.10-1.16-desktop, K Desktop Environment Version 4.10.5 r1 - Medion Titanium Aldi v. 03/2009

saturn
Newbie
Newbie
Beiträge: 25
Registriert: 2. Jan 2005, 15:55
Wohnort: Erfurt / Thüringen

Beitrag von saturn » 4. Jun 2005, 12:59

Ich gruesse Euch

Ein dickes Lob den Helfern in der Not.
Crossover-Office läuft(ohne root),ich muss jetzt nur noch mein Astrologie-Programm
zum laufen bringen.

Einen schoenen Tag noch.

Mike

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 2 Gäste