rdesktop 1.4.1 und OpenSSL

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Antworten
hubivo
Newbie
Newbie
Beiträge: 6
Registriert: 20. Aug 2004, 23:18

rdesktop 1.4.1 und OpenSSL

Beitrag von hubivo » 2. Jun 2005, 11:39

Hallo NG,

habe einen Laptop unter SuseLinux 9.1 installiert (hinterher auch das Online-Update gemacht).
Ich möchte mit rdesktop nun auf Windows-Kisten zugreifen (über XP-Clients funktioniert das schon).
Habe mir dazu die akt. Version von rdesktop gezogen und will diese nun installieren. Bei ./configure bringt er mir aber immer die Fehlermeldung "Couldn`t find your OpenSSL libary installation dir...."
Daraufhin hab ich mal mit dem Filemanager nach OpenSSL-Ordnern und -Dateien gesucht und nur unter /usr/bin eine ausführbare Datei openssl und unter /usr/share/doc/packages einen Ordner openssl gefunden. Habe mit ./configure --with-openssl=...... die Pfade einmal angegeben, aber ohne Erfolg. Bricht mit der selben Fehlermeldung wieder ab. Habe auch über Yast das Packet openssl nocheinmal aktualisiert, aber hat auch nicht geholfen (war schon installiert).

Was kann ich denn jetzt machen ?

thx in advance & best regards
hubivo

Werbung:
Benutzeravatar
Frankie777
Advanced Hacker
Advanced Hacker
Beiträge: 916
Registriert: 30. Apr 2005, 23:22

Beitrag von Frankie777 » 2. Jun 2005, 12:12

Hallo,

Du mußt auch das devel Paket installiert haben.

openssl-devel-0.9.7d-25.1
openssl-doc-0.9.7d-25.1
openssl-0.9.7d-25.1

hubivo
Newbie
Newbie
Beiträge: 6
Registriert: 20. Aug 2004, 23:18

Beitrag von hubivo » 2. Jun 2005, 13:05

Ja, die hatte ich noch nicht installiert. Jetzt hat`s funktioniert, zumindest bis ich dann make ausführen wollte. *g* make und die Kernel-Sources musste ich auch noch installieren.
Wenn ich jetzt aber make ausführe, kommen etliche error- u. warning-Meldungen von xwin.c und bricht dann mit der Meldung "make: *** [xwin.o] Fehler 1" ab.

Habe jetzt über Yast-Installation xwin gesucht, aber da gibt es nichts, was auch nur so ähnlich heisst. Was fehlt da denn jetzt noch ?

regards
hubivo

Benutzeravatar
Frankie777
Advanced Hacker
Advanced Hacker
Beiträge: 916
Registriert: 30. Apr 2005, 23:22

Beitrag von Frankie777 » 2. Jun 2005, 14:33

Kam nach configure die Meldung creating Makefile?
configure: creating ./config.status
config.status: creating Makefile

xwin.c ist Teil der rdesktop Sources und .o das erzeugte Object File.
In xwin.c wird unter anderem Bezug genommen auf Xlib.h, welches ich damals auch erst installieren mußte....

hubivo
Newbie
Newbie
Beiträge: 6
Registriert: 20. Aug 2004, 23:18

Beitrag von hubivo » 3. Jun 2005, 09:15

Also "configure: creating ./config.status" bringt er.
Leider kann ich nichts finden, was dem Xlib oder Xwin entspricht. Also es gibt keine Pakete zum installieren unter Yast. Bei Google find ich nur Problembeschreibungen, leider keine Downloads :cry:

regards
hubivo

Benutzeravatar
Frankie777
Advanced Hacker
Advanced Hacker
Beiträge: 916
Registriert: 30. Apr 2005, 23:22

Beitrag von Frankie777 » 3. Jun 2005, 12:14

Hallo,

nochmal, bringt er auch " config.status: creating Makefile"?
Wenn nein, dann kann make nicht gehen.

Nun, xwin.c muß in den Source-Files von redesktop enthalten sein, sonst geht es nicht zu kompilieren und die Sources sind unvollständig.

Ich mußte damals noch unter anderem xlib.h bereitstellen. xlib.h ist im Paket xorg-x11-devel enthalten und sollte auch über Yast zu installieren sein.

Tip: Files findet man am besten mit locate (vorher updatedb machen). locate xwin.c sollte Dir ganz schnell das File im Ordner rdesktop anzeigen. Ebenso kannst Du mit locate xlib.h ganz schnell prüfen ob das File auf Deinem Rechner vorhanden ist.

hubivo
Newbie
Newbie
Beiträge: 6
Registriert: 20. Aug 2004, 23:18

Beitrag von hubivo » 8. Jun 2005, 08:40

creating makefile bringt er auch.

Das File xwin.c ist in den Sourcefiles drinn.

Das Paket xorg oder ähnliches gibt es im Yast nicht :( und die Datei xlib.h ist auch nicht auf dem Rechner.
Gibt es noch andere Quellen, wo man das Paket von xorg-x11-devel erhalten kann ?

Vielen Dank für die Mühe!

regards
hubivo

Benutzeravatar
Frankie777
Advanced Hacker
Advanced Hacker
Beiträge: 916
Registriert: 30. Apr 2005, 23:22

Beitrag von Frankie777 » 8. Jun 2005, 09:24

OK, wenn xlib.h fehlt dann kann es nicht gehen...

xorg-x11-devel_6.8.2-35.1_i586.rpm enthält xlib.h und andere Files, die Du brauchst.
für Suse 9.2 gibt es das hier:
ftp://ftp.gwdg.de/pub/suse/i386/9.2/suse/i586/

hubivo
Newbie
Newbie
Beiträge: 6
Registriert: 20. Aug 2004, 23:18

Beitrag von hubivo » 8. Jun 2005, 10:05

Tausend Dank Frankie !!!! Es funzt :D .

best regards
hubivo

hubivo
Newbie
Newbie
Beiträge: 6
Registriert: 20. Aug 2004, 23:18

Beitrag von hubivo » 8. Jun 2005, 10:15

Wie ist es da eigentlich mit der Lizenzierung ? Unter Windows bekomme ich da ja immer eine temporäre Lizenz für den Terminalserver. Wenn die ausläuft, lösch ich immer einfach den Registry-Key dafür und ich bekomme eine neue.

regards
hubivo

Benutzeravatar
Frankie777
Advanced Hacker
Advanced Hacker
Beiträge: 916
Registriert: 30. Apr 2005, 23:22

Beitrag von Frankie777 » 8. Jun 2005, 15:26

wenn Win2003 Server unter pro User läuft prüft MS die Lizenzierung nicht, Win2k hatte ich nie als TerminalServer in Betrieb

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast