[gelöst] Probleme beim start von amule als user

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Gesperrt
necromancer
Newbie
Newbie
Beiträge: 26
Registriert: 23. Jul 2004, 21:11

[gelöst] Probleme beim start von amule als user

Beitrag von necromancer » 19. Mai 2005, 18:18

Ich habe die Version von Packman installiert, aber ich kann amule als user nicht starten.
Als Fehlermeldung kommt:

Code: Alles auswählen

Initialising aMule
Checking if there is an instance already running...

(amule:15809): Gtk-CRITICAL **: file gtkaccellabel.c: line 214 (gtk_accel_label_new): assertion `string != NULL' failed

(amule:15809): Gtk-CRITICAL **: file gtkmisc.c: line 211 (gtk_misc_set_alignment): assertion `GTK_IS_MISC (misc)' failed

(amule:15809): Gtk-CRITICAL **: file gtkcontainer.c: line 949 (gtk_container_add): assertion `GTK_IS_WIDGET (widget)' failed

(amule:15809): Gtk-CRITICAL **: file gtkaccellabel.c: line 400 (gtk_accel_label_set_accel_widget): assertion `GTK_IS_ACCEL_LABEL (accel_label)' failed

--------------------------------------------------------------------------------
A fatal error has occurred and aMule has crashed.
Please assist us in fixing this problem by posting the backtrace below in our
'aMule Crashes' forum and include as much information as possible regarding the
circumstances of this crash. The forum is located here:
    http://forum.amule.org/board.php?boardid=67
If possible, please try to generate a real backtrace of this crash:
    http://www.amule.org/wiki/index.php/Backtraces

----------------------------=| BACKTRACE FOLLOWS: |=----------------------------
Current version is: aMule 2.0.1 using wxGTK2 v2.5.2
Running on: Linux 2.6.8.1 i686

[2] wxFatalSignalHandler in /usr/lib/libwx_base-2.5.so.2[0x405e23f6]
[3] ?? in [0xffffe420]
[4] gtk_menu_item_new_with_label in /opt/gnome/lib/libgtk-x11-2.0.so.0[0x409d765a]
[5] wxChoice::GtkAddHelper(_GtkWidget*, int, wxString const&) in /usr/lib/libwx_gtk2_core-2.5.so.2[0x40304475]
[6] wxChoice::DoAppend(wxString const&) in /usr/lib/libwx_gtk2_core-2.5.so.2[0x403049b9]
[7] ?? in amule [0x81d5d98]
[8] ?? in amule [0x807f822]
[9] ?? in amule [0x807865f]
[10] ?? in amule [0x80786e7]
[11] ?? in amule [0x8071f3c]
[12] ?? in amule [0x807829f]
[13] wxAppConsole::CallOnInit() in amule[0x8074271]
[14] wxEntry(int&, char**) in /usr/lib/libwx_base-2.5.so.2[0x405860e5]
[15] ?? in amule [0x8078ade]
[16] __libc_start_main in /lib/tls/libc.so.6[0x407b4b10]
[17] wxTextCtrl::GetSelection(long*, long*) const in amule[0x8065241]

--------------------------------------------------------------------------------
Abgebrochen

In einem Fenster erscheint als Fehlermeldung noch

Code: Alles auswählen

Deine locale wurde wegen einer Konfigurations-
Änderung auf Systemstandard geändert. Sorry.
Es scheint wohl ein Problem der wxgtk zu sein. Ich habe nicht die version von amule.org, sondern eine von SuSE (über apt geholt, wie amule).
Als root geht es jedoch. (mit kdesu amule getestet)
Ich habe auch schon den .aMule in meinem home-Verzeichnis umbenannt, hat auch nichts gebracht.

Schonmal danke für jede Hilfe. :)
Zuletzt geändert von necromancer am 20. Mai 2005, 23:25, insgesamt 1-mal geändert.
SuSE 10.0
KDE 3.5 Level "a"
Kernel: 2.6.13-15-default
-------------------------------------

Bild

Werbung:
deltaHF
Newbie
Newbie
Beiträge: 13
Registriert: 4. Nov 2003, 19:31
Kontaktdaten:

Beitrag von deltaHF » 19. Mai 2005, 23:19

hi,

leider geben wir auf die versionen von packman keinen support da es auf wxgtk von SuSE basiert. wxgtk von suse = jede menge bugs.
Es scheint wohl ein Problem der wxgtk zu sein. Ich habe nicht die version von amule.org, sondern eine von SuSE (über apt geholt, wie amule).
das mit wxgtk hast du richtig erkannt.. ;)

nicht böse sein, aber wir können bei problemen die bei suse selbst auftreten nicht auch noch helfen.

grüsse
admin & dev of the aMule project
multiplatform eMule for Linux/*BSD/MacOSX/Solaris/Windows

.. the game of life is hard to play ..

necromancer
Newbie
Newbie
Beiträge: 26
Registriert: 23. Jul 2004, 21:11

Beitrag von necromancer » 20. Mai 2005, 19:58

Schon klar dass du nicht der Support für alles sein kannst ;)

Es hätte ja auch ein bekanntes Problem sein können und die Lösung auch schon bekannt.

Was mich dabei verwundert ist, dass es als root funktioniert, deswegen hab ich gedacht, dass es vielleicht auch an Zugriffsrechten entweder von wxgtk oder amule liegt.

Aber trotzdem danke für die schnelle Antwort.
Werde aber wohl noch etwas warten vielleicht hat ja ein anderer user noch einen Tip oder gar eine Lösung dafür.
Falls nicht, hol ichs mir halt von amule.org und versuchs damit zu laufen zu bekommen.

Mein Esel soll ja nicht krank im Stall liegen, sondern fröhlich durch die Welt springen ;)
SuSE 10.0
KDE 3.5 Level "a"
Kernel: 2.6.13-15-default
-------------------------------------

Bild

traffic
Guru
Guru
Beiträge: 2750
Registriert: 13. Feb 2005, 05:50

Beitrag von traffic » 20. Mai 2005, 20:05

aMule 2.0.1 von PackMan läuft definitiv unter SuSE 9.2 mit SuSEs wxGTK.

Code: Alles auswählen

user@linux:~> amule
Initialising aMule
Checking if there is an instance already running...
Loading temp files from /home/user/.aMule/Temp.
Loading PartFile 15 of 15
All PartFiles Loaded.
ListenSocket: Ok.
 
External connections disabled in config file
*** Server UDP socket (TCP+3) at 0.0.0.0:4665
*** TCP socket (TCP) listening on 0.0.0.0:4662
*** Client UDP socket (extended eMule) at 0.0.0.0:4672
Adding file /home/user/.aMule/Temp/015.part.met to shares
Adding file /home/user/.aMule/Temp/019.part.met to shares
Adding file /home/user/.aMule/Temp/030.part.met to shares
Adding file /home/user/.aMule/Temp/031.part.met to shares
Adding file /home/user/.aMule/Temp/032.part.met to shares
Empty dir /home/user/.aMule/Incoming/ shared
Servers: Trying to connect
Servers: Trying to connect
Servers: Connected
Und wenn es als anderer Benutzer läuft, dann liegt die Ursache sicherlich woanders.
openSUSE Factory - GNOME 2.32.1

IhmSelbst
Member
Member
Beiträge: 53
Registriert: 28. Okt 2003, 01:03
Wohnort: 26349 Jade, nds, adw
Kontaktdaten:

Beitrag von IhmSelbst » 20. Mai 2005, 23:24

traffic hat geschrieben:aMule 2.0.1 von PackMan läuft definitiv unter SuSE 9.2 mit SuSEs wxGTK.
kann ich leider _so_ nicht bestätigen. - eigentlich wollt´ ich mich ja wegen der nichtunterstützten packmanrpms, und auch, weil hier kein SuSE9.2 mehr läuft, gar nicht mehr großartig dazu äußern, aber die o.a. rpms neigten zumindest auch hier seinerzeit, also unter SuSE9.2, sehr zur instabilität, und sind zumindest immer schön regelmäßig bei jedweder art von veränderungs-, bzw. einstellungsversuchen abgestürzt.

necromancer
Newbie
Newbie
Beiträge: 26
Registriert: 23. Jul 2004, 21:11

Beitrag von necromancer » 20. Mai 2005, 23:24

So hab nun etwas rumprobiert und siehe da! Nun gehts! :)

Es kam mit der alten amule.conf (diese stammte noch von 2.0.0 RC8 und ältere Versionen) wohl nicht zurecht.

Hab nun einfach in ~/.aMule/ die amule.conf gelöscht und beim erneuten start hat amule eine neue erstellt.

Damit gehts nun endlich wieder :)
SuSE 10.0
KDE 3.5 Level "a"
Kernel: 2.6.13-15-default
-------------------------------------

Bild

traffic
Guru
Guru
Beiträge: 2750
Registriert: 13. Feb 2005, 05:50

Beitrag von traffic » 20. Mai 2005, 23:48

IhmSelbst hat geschrieben:kann ich leider _so_ nicht bestätigen. - eigentlich wollt´ ich mich ja wegen der nichtunterstützten packmanrpms, und auch, weil hier kein SuSE9.2 mehr läuft, gar nicht mehr großartig dazu äußern, [...]
Die sind von Dir nicht unterstützt, es gibt aber auch andere Leser in diesem Forum, die an der Stelle gerne einspringen. Außerdem ist es sowieso wurscht, weil jeder Benutzer das nimmt, was bei ihm gut läuft.
openSUSE Factory - GNOME 2.32.1

IhmSelbst
Member
Member
Beiträge: 53
Registriert: 28. Okt 2003, 01:03
Wohnort: 26349 Jade, nds, adw
Kontaktdaten:

@traffic

Beitrag von IhmSelbst » 21. Mai 2005, 00:30

moin traffic
traffic hat geschrieben:...
Die sind von Dir nicht unterstützt, es gibt aber auch andere Leser in diesem Forum, die an der Stelle gerne einspringen. Außerdem ist es sowieso wurscht, weil jeder Benutzer das nimmt, was bei ihm gut läuft.
aus _dem_ grunde hab ich mich ja auch bekanntlich hier zuvor nie zu den packmanrpms ausgelassen, sondern hab mich dahingehend bewußt neutral verhalten. bin im gegenteil auch dankbar für jedwede unterstützung usw... - allerdings konnte ich die aussage
traffic hat geschrieben:...aMule 2.0.1 von PackMan läuft definitiv unter SuSE 9.2 mit SuSEs wxGTK.
...
verständlicherweise beim besten willen eben aufgrund anderweitiger erfahrungen natürlich _so_ allerdings auch nicht stehenlassen.


cuagn

Gesperrt

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 2 Gäste