Probleme bei der Erstellung der "initrd"

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Antworten
R@dH@t
Newbie
Newbie
Beiträge: 2
Registriert: 26. Apr 2005, 14:39
Wohnort: Augsburg
Kontaktdaten:

Probleme bei der Erstellung der "initrd"

Beitrag von R@dH@t » 26. Apr 2005, 15:14

hi
folgende situation.

mein System:
DAC 960 Raid Controller
kernel: 2.4.21-27
OS: RedHat ES 3

Ich muss den Kernel 2.4.21-15.EL installieren:

dazu habe ich ich heruntergeladen. Entpackt.
dann make menuconfig ausgefüht, jedoch nichts darin verändert
dann folgende Befehle ausgeführt:
make dep
make clean
make bzImgae
make modules --> traten Fehler auf "[_modinst_] Fehler1"
"[_modinst_cipe] Fehler2"
"[_modinst_addon] Fehler2"
"[_modinst_drivers] Fehler2"
make modules_install --> hier traten dann auch Fehler auf

wenn ich nun mir eine initrd bauen möchte kommt dies:
mein befehl:
mkinitrd /boot/initrd-2.4.21-15.EL 2.4.21-15.EL

no module DAC960 found for kernel 2.4.21-15, aborting

lief da schon was bei dem "make modules" schief?
muss ich noch irgendwie module vom alten kernel in den neuen einbinden?
oder gibt es da spezielle module von dem Raid controller für diese Kernelversion???

Ich bedanke mich jetzt schon mal für eure Hilfe!

wenn ihr noch Infos braucht über mein System um mir helfen zu können dann schreibt es mir.

Vielen Dank!
mfg

Werbung:
Benutzeravatar
Gimpel
Guru
Guru
Beiträge: 1983
Registriert: 11. Feb 2004, 13:58
Wohnort: Mjunik .... "no a hoibe, resi!"
Kontaktdaten:

Beitrag von Gimpel » 27. Apr 2005, 16:25

hi!
make modules --> traten Fehler auf "[_modinst_] Fehler1"
"[_modinst_cipe] Fehler2"
"[_modinst_addon] Fehler2"
"[_modinst_drivers] Fehler2"
hmm, stand da was genaueres?
make modules_install --> hier traten dann auch Fehler auf
bringt dann nichts, da ja module überhaupt kompilieren schon fehl geschlagen ist.
Bild on AMD Athlon64 X2 5600+|64bit|6GB DDR2 800MHz|nVidia GF 8500GT|2.6.29-rc1-moo1|BTRFS|KDE-4.2 SVN trunk + Compiz++|M-Audio Audiophile 2496
----
Bild

R@dH@t
Newbie
Newbie
Beiträge: 2
Registriert: 26. Apr 2005, 14:39
Wohnort: Augsburg
Kontaktdaten:

Beitrag von R@dH@t » 9. Mai 2005, 13:31

sorry ich hab da nicht alle pakete installiert
darum konnte die initrd nicht erzeugt werden
anfängerfehler

trotzdem danke für die hilfe

mfg R@dH@t

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 3 Gäste