Suse 9.2 Pro - Wine - kriegs nicht hin

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Antworten
Q.ru
Newbie
Newbie
Beiträge: 2
Registriert: 10. Apr 2005, 16:22

Suse 9.2 Pro - Wine - kriegs nicht hin

Beitrag von Q.ru » 12. Apr 2005, 21:01

hi, habe folgendes problem:

wenn ich über Suse wine ein programm starte will erscheint folgendes:
linux777:/windows/C/Games/Black Isle/BGII - SvA # wine BG
BGConfig.exe BGMain.exe
linux777:/windows/C/Games/Black Isle/BGII - SvA # wine BGMain.exe
Xlib: connection to ":0.0" refused by server
Xlib: No protocol specified

wine: Could not load graphics driver 'x11drv'.
Make sure that your X server is running and that $DISPLAY is set correctly.
linux777:/windows/C/Games/Black Isle/BGII - SvA #
was mache ich falsch? was ist ein X server?
oder kann es sein, dass es nicht geht, weil ich die programme von der windows partition starten will?
ich hatte nie mit wine davor zu tun, bin auch ein linux - n00b. ich habe nur von der Suse cd dieses wine installiert. nichts mehr gemacht damit. Muss ich irgendwelche Bibos aus Windows holen??

bitte um hilfe, danke im voraus

Werbung:
traffic
Guru
Guru
Beiträge: 2750
Registriert: 13. Feb 2005, 05:50

Beitrag von traffic » 12. Apr 2005, 21:18

Du versuchst die Programme aus der Konsole als root zu starten. Das funktioniert nicht. Um grafische Programme aus der Konsole eines anderen Benutzers heraus als root starten zu können, muss der Benutzer, dessen X-Session gerade läuft, dies separat erlauben.

Das brauchst Du aber gar nicht zu tun. Öffne einfach eine andere Konsole als der Benutzer, dessen X-Session gerade läuft. Dann kannst Du auch grafische Programme normal starten. ;)

Q.ru
Newbie
Newbie
Beiträge: 2
Registriert: 10. Apr 2005, 16:22

Beitrag von Q.ru » 13. Apr 2005, 01:19

komisch.. ist es normal, dass ich trotzdem kein programm starten kann (CS, HL, Baldurs gate)? es kommen ständig irgendwelche DialogFehlermeldugen :(

HL startet zwar aber ich sehe nur Hintergrund und nichts zum anklicken. (obwohl es blind geht, und irgendwelche menüs erscheinen, wo ebenfalls nur hintergrund zu sehen ist)
liegts an der verflixten SiS m760 grafikkarte, bei der 3d hardwarebeschleunigung unter linux nicht erkannt wird??

traffic
Guru
Guru
Beiträge: 2750
Registriert: 13. Feb 2005, 05:50

Beitrag von traffic » 13. Apr 2005, 03:06

Ich habe jetzt leider keine Vorstellung, was für Fehlermeldungen das sein können, aber sagen wir es mal so: Ja, es ist normal, dass man viele Programme nicht starten kann. WINE ist Software im Alpha-Stadium, an der Hardware wird es eher nicht liegen.

Manches ist zum Laufen zu bringen, indem man DLLs aus der Windows-Partition rüberkopiert, manches läuft sofort und ohne einen Finger krumm zu machen und manches läuft nie. Bei Spielen wirst Du mit dem Standard-WINE nicht besonders weit kommen, dafür gibt es WineX und Cedega, dazu gibt es hier schon einige Threads.

Versuch doch erstmal einfachere Programme zu starten, zum Beispiel das Notepad oder das Wordpad von Deiner Windows-Partition, die sind beide im Windows-Ordner. Oder so Sachen wie IrfanView laufen auch ganz gut, aber bei Spielen bin ich eher pessimistisch.

Benutzeravatar
BdMdesigN
Member
Member
Beiträge: 188
Registriert: 6. Mai 2005, 13:00
Kontaktdaten:

Beitrag von BdMdesigN » 7. Mai 2005, 09:30

:twisted:


Bei mir läuft fast garnichts ob wine oder winex ,cedega schon gar nicht.
Bei bestimmten wine versionen kann ich Spiele installieren das wars dann auch schon.
Bei dem Spiel Microsoft Combat Flight Simulator kommt das Startbild und nichts weiter.
Unter SuSE 8.2 liefen mehr Spiele als unter 9.1 und unter 9.2 noch garnichts
Selbst das Lorio Skat läuft nicht ( unter 9.1 lief es) Unter 8.2 lief selbst Panzergeneral 3 D.
Gieb es irgend wo Portirungs Proggies? Ich habe 2 Tage unter Google gesucht nichts gefunden.Ich habe das Wine problem schon 2 Jahre.
Habe erst seit kurzen wieder Internet aber alles hat sich geändert seit 2001.
Bitte um hilfe .
Bin echt schon bischen genervt
Ich liebäugel schon wieder mit RedHat will mich aber nicht so schnell von SuSE trennen und da ich kein Platten platz über habe geschweige denn noch mals Windows aufzuspielen <------- Das auch net mehr geht !
System: OpenSuSE 13.1 Kernel 3.13.2-6-default
Bild
Anfangs-Systeme: Commodore VC 20, C64, Amiga Workbench 1.3 (A500 & A4000), RedHat 5.0.2 & SuSE 7.2

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast