kdm autologin

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Antworten
Blaubär
Newbie
Newbie
Beiträge: 24
Registriert: 28. Mär 2005, 19:14

kdm autologin

Beitrag von Blaubär » 9. Apr 2005, 19:06

Hallo Forum,

ich möchte an einem Terminal per autologin so ne Art Kiosksurfstation betreiben. Ich habe kdm auch soweit eingerichtet, dass er an ws005 den Benutzer surfkiosk automatisch startet. Die Vorgehensweise habe ich hier im Forum gefunden. kdm meldet dann auch brav: kdm: ws005.hrsberge:0[4139]: pam_unix2: session started for user surfkiosk, service xdm-np . Nur auf dem Monitor bleibt das Kreuz vom x-server stehen und der Hintergrund von kdm, obwohl KDE als standard windowmanager eingestellt ist. Hier nochmal meine kdmrc:

General]
AuthDir=/var/lib/xdm/authdir/authfiles/
ConfigVersion=2.0
ExportList=LANG
PidFile=/var/run/kdm.pid
Xservers=/etc/X11/xdm/Xservers

[Shutdown]
HaltCmd=/sbin/halt
LiloCmd=/sbin/lilo
LiloMap=/boot/map
RebootCmd=/sbin/reboot
UseLilo=false

[X-*-Core]
AllowNullPasswd=true
AllowRootLogin=true
AllowShutdown=Root
AuthNames=XDM-AUTHORIZATION-1,MIT-MAGIC-COOKIE-1
AutoReLogin=false
Reset=/etc/X11/xdm/Xreset
Resources=/etc/X11/xdm/Xresources
Session=/etc/X11/xdm/Xsession
Setup=/etc/X11/xdm/Xsetup
Startup=/etc/X11/xdm/Xstartup
TerminateServer=true

[X-*-Greeter]
AdminSession=YaSTadminSession
AntiAliasing=true
BackgroundCfg=/etc/opt/kde3/share/config/kdm/backgroundrc
ColorScheme=SuSE
DefaultUser=surfkiosk
EchoMode=OneStar
FaceSource=AdminOnly
FailFont=Sans Serif,12,-1,5,74,0,0,0,0,0
FocusPasswd=false
GUIStyle=
GreetFont=Sans Serif,17,-1,5,48,0,0,0,0,0
GreetString=Willkommen auf (%h)
GreeterPos=50,50
HiddenUsers=root,nobody, surfkiosk
Language=de
LogoArea=Clock
LogoPixmap=
MaxShowUID=65000
MinShowUID=500
PreselectUser=None
SelectedUsers=
ShowUsers=NotHidden
SortUsers=true
StdFont=Sans Serif,12,-1,5,48,0,0,0,0,0
UseBackground=true
UserCompletion=false
UserList=true

[X-:*-Core]
AllowNullPasswd=true
AllowRootLogin=true
AllowShutdown=All
NoPassEnable=true
NoPassUsers=surfkiosk

[X-:*-Greeter]
AdminSession=YaSTadminSession

[X-:0-Core]
AutoLoginEnable=false
AutoLoginUser=surfkiosk

[X-:0-Greeter]
AdminSession=
LogSource=/dev/xconsole

[X-ws005.hrsberge:0-Core]
NoPassEnable=true
NoPassUsers=surfkiosk
AutoLoginEnable=true
AutoLoginUser=surfkiosk

[X-ws005:0-Greeter]
GreetString=Terminalserver:%h Terminal:X-ws005
ShowUsers=Selected

[Xdmcp]
Enable=true
Willing=/etc/X11/xdm/Xwilling
Xaccess=/etc/X11/xdm/Xaccess

Ach ja: suse 9.2 und LTSP 4.1
Weiß jemand Rat?

Viele Grüße
Der Blaubär

Werbung:
Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast