Kann mich nicht auf der postgres konsole einloggen

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Antworten
marcusx
Newbie
Newbie
Beiträge: 3
Registriert: 6. Apr 2005, 14:09

Kann mich nicht auf der postgres konsole einloggen

Beitrag von marcusx » 6. Apr 2005, 14:32

Hallo Leute!

Ich versuche grade opengroupware zu installieren und hab dazu postgreSQL 8.0 unter Suse 9.2 installiert. RPM's mit Yast.

Webmin hat den Server auch gleich erkannt ich kann User und Sonstiges problemlos anlegen. Der Postgres Befehl CREATEDB, CREATEUSER auf der Konsole hat auch funktioniert.

Jetzt würde ich mich gerne auf der Postgres Adminconsole einloggen um die Anweisungen auf:

http://opengroupware.org/en/install/postgresql.html (Load Databse Scheme) auszuführen und da beist jetzt aus.

Code: Alles auswählen

psql -h localhost OGo OGo
Bringt die Meldung

Code: Alles auswählen

psql: FATAL:  Ident-Authentifizierung für Benutzer »OGo« fehlgeschlagen
Ich hab in der pg_hba.conf schon alles unter local auf TRUST gesetzt hat nichts gebracht. Was muss ich da noch einstellen? Mit dem postgres user ist es übrigens dasselbe. Der User und die DB sind korrekt angelegt, zumindest sehe ich ihn beides in der Webmin Oberfläche und kann sie editieren.
Es spielt auch keine Rolle ob ich root oder postgres bin

Danke!
marcus

Werbung:
marcusx
Newbie
Newbie
Beiträge: 3
Registriert: 6. Apr 2005, 14:09

Zusatzinfo

Beitrag von marcusx » 6. Apr 2005, 14:48

Ich hab grad noch folgendes gefunden:

http://www.lx-office.org/forum/board_en ... escasc=ASC

Hier steht das es wohl ein Problem mit den Berechtigungen und Speicherorten der Suse installation ist. Ich hab im Verzeichnis file:/var/lib/pgsql/data jetzt mal alles für jeden lesbar gestellt. Bei mir bringt das aber nix - immer noch das selbe Lied. Irgendwelchen Ideen?

marcusx
Newbie
Newbie
Beiträge: 3
Registriert: 6. Apr 2005, 14:09

[solved]

Beitrag von marcusx » 6. Apr 2005, 16:18

Hi!

Ich habs jetzt hinbekommen.

Hab in der pg_hba.conf noch folgendes geändert:

host ... ident sameuser rausgeschmissen und auch für OGo auf Trust gesetzt siehe unten.

Vielen Dank an Stephan Schulz und sein Open X-Change HowTo für Suse 9.2 da stand des so drin.

http://www.ox-server.de/de/tutorial/ox_suse92.php

Code: Alles auswählen

# TYPE  DATABASE    USER        CIDR-ADDRESS          METHOD

# "local" is for Unix domain socket connections only
local   all         all                               trust
# IPv4 local connections:
  host    all        all          127.0.0.1   255.255.255.255 trust
# default version: (funzt nicht)
#host    all         all         127.0.0.1/32          ident sameuser
# geaendert wie in www.ox-server.de/de/tutorial/ox_suse92.php beschrieben
# IPv6 local connections:
# host    all         all         ::1/128               ident sameuser
host  OGo    OGo    127.0.0.1    255.255.255.255      trust

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 2 Gäste