ELSTER 2004/2005 mit Wine unter SuSE 9.2

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Antworten
Archilles
Newbie
Newbie
Beiträge: 27
Registriert: 21. Jun 2004, 14:34

ELSTER 2004/2005 mit Wine unter SuSE 9.2

Beitrag von Archilles » 31. Jan 2005, 20:43

Hi,

ich benötige für meine Umsatzsteuervoranmeldung ELSTER und für einiges Anderes mehr auch.

Wenn ich das Installationsprogramm mit wine starte, erhalte folgende Fehlermeldungen:

Code: Alles auswählen

wine ElsterFormular2004.exe


fixme:ole:RegisterTypeLib Registering non-oleautomation interface!
fixme:ole:RegisterTypeLib Registering non-oleautomation interface!
fixme:ole:RegisterTypeLib Registering non-oleautomation interface!
fixme:ole:RegisterTypeLib Registering non-oleautomation interface!
fixme:ole:RegisterTypeLib Registering non-oleautomation interface!
fixme:ole:RegisterTypeLib Registering non-oleautomation interface!
fixme:ole:RegisterTypeLib Registering non-oleautomation interface!
fixme:ole:RegisterTypeLib Registering non-oleautomation interface!
fixme:ole:RegisterTypeLib Registering non-oleautomation interface!
fixme:ole:RegisterTypeLib Registering non-oleautomation interface!
fixme:ole:StdMarshalImpl_UnmarshalInterface Calling back to ourselves for {3d8b6331-d8b1-11d2-80c5-00104b1f6cea}!
fixme:ole:_copy_arg Should not use VariantChangeType here. (conversion from 0x4003 -> 0xb) 4036ffff
fixme:ole:_copy_arg Should not use VariantChangeType here. (conversion from 0x4003 -> 0xb) 4036ffff
fixme:ole:_copy_arg Should not use VariantChangeType here. (conversion from 0x4003 -> 0xb) 4036ffff
fixme:ole:_copy_arg Should not use VariantChangeType here. (conversion from 0x4003 -> 0xb) 4036ffff
fixme:ole:_copy_arg Should not use VariantChangeType here. (conversion from 0x4003 -> 0xb) 4036ffff
fixme:ole:_copy_arg Should not use VariantChangeType here. (conversion from 0x4003 -> 0xb) 4036ffff
fixme:ole:_copy_arg Should not use VariantChangeType here. (conversion from 0x4003 -> 0xb) 4036ffff
fixme:ole:_copy_arg Should not use VariantChangeType here. (conversion from 0x4003 -> 0xb) 4036ffff
fixme:ole:_copy_arg Should not use VariantChangeType here. (conversion from 0x4003 -> 0xb) 4036ffff
fixme:ole:_copy_arg Should not use VariantChangeType here. (conversion from 0x4003 -> 0xb) 4036ffff
fixme:ole:_copy_arg Should not use VariantChangeType here. (conversion from 0x4003 -> 0xb) 4036ffff
fixme:ole:_copy_arg Should not use VariantChangeType here. (conversion from 0x4003 -> 0xb) 4036ffff
fixme:ole:_copy_arg Should not use VariantChangeType here. (conversion from 0x4003 -> 0xb) 4036ffff
fixme:ole:_copy_arg Should not use VariantChangeType here. (conversion from 0x4003 -> 0xb) 4036ffff
fixme:ole:_copy_arg Should not use VariantChangeType here. (conversion from 0x4003 -> 0xb) 4036ffff
fixme:ole:_copy_arg Should not use VariantChangeType here. (conversion from 0x4003 -> 0xb) 4036ffff
fixme:ole:_copy_arg Should not use VariantChangeType here. (conversion from 0x4003 -> 0xb) 4036ffff
fixme:ole:_copy_arg Should not use VariantChangeType here. (conversion from 0x4003 -> 0xb) 4036ffff
fixme:ole:_copy_arg Should not use VariantChangeType here. (conversion from 0x4003 -> 0xb) 4036ffff


Und das Programm hängt sich auch, will nicht weiter.

Meine config-Datei unter .wine sieht so aus:

Code: Alles auswählen

[Drive A]
"Type" = "floppy"
"Path" = "/media/floppy"
"Label" = "/media/floppy"
"Device" = "/dev/fd0"

[Drive C]
"Path" = "/home/andreas/windowsC"
"Type" = "hd"
"Label" = "MS-DOS"
"Filesystem" = "win95"


[Drive Z]
"Type" = "network"
"Path" = "/"
"Label" = "Root"
"FS" = "win95"

[wine]
"Windows" = "C:\\Windows"
"System" = "C:\\Windows\\System"
"Temp" = "C:\\Windows\\Temp"
"Path" = "C:\\Windows;C:\\Windows\\System;X:\\;Y:\\"
"Profile" = "c:\\windows\\Profiles\\Administrator"
"GraphicsDriver" = "x11drv"
;"ShowDirSymlinks" = "1"
;"ShowDotFiles" = "1"
"ShellLinker" = "wineshelllink"

# <wineconf>

[Version]
; Windows version to imitate (win95,win98,winme,nt351,nt40,win2k,winxp,win20,win30,win31)
;"Windows" = "win98"
; DOS version to imitate
;"DOS" = "6.22"


Kann mir jemand sagen, warum Wine nicht will?


Kann mir jemand sagen, warum Wine nicht will?


MFG

Archilles

Werbung:
Xware
Newbie
Newbie
Beiträge: 29
Registriert: 10. Jan 2005, 23:52

Beitrag von Xware » 12. Feb 2005, 07:43

Hallo,

da Du ja überhaupt nich keine Antwort bekommen hast, hier mal ein Tipp wie Du deine UstVa zum Finanzamt bekommst:

1. mit "Winston" (läuft unter Wine, es kommt aber eine native Linuxversion, die Testversion steht schon bereit) von www.felfri.de (kostenlos)
2. mit "T@x 2005 linux" von Buhldata (www.buhl-data.de ) (ca. 20€)
...

MfG, Frank.

Archilles
Newbie
Newbie
Beiträge: 27
Registriert: 21. Jun 2004, 14:34

Beitrag von Archilles » 12. Feb 2005, 11:43

Hi Frank,

besten Dank für das Mitleid, das aber nicht notwendig ist. Daran, wie schnell und gut in einem Forum gut geantwortet wird, sehe ich eigentlich die Qualität eines Forums.
Sehr gut schneidet hier http://www.linuxforen.de ab.

Als eingefleischter OSS'ler halte ich von T@x2005linux, weils eben Schrott ist, der unnötig Geld kostet, rein gar nischts.

Und desweiteren löst das keinesweg das Problem. Dazu haben wir aber ein Forum. Auch wenn du nur Teillösungen bekommst, mit denen du dann aber Bausteine für die eigentliche Problemlösung hast.

Ich habe ergo über Linuxforen.de eben so eine Teillösung gefunden und somit über Google folgendes HowTo:

http://mitglied.lycos.de/markusmaerz/elster.html

Somit ist mein Problem lösbar ohne dem Problem durch Alternativen aus dem Weg gehen zu müssen.

Ich danke Dir und verbleibe

MfG

Archilles

Benutzeravatar
Kurt M
Hacker
Hacker
Beiträge: 407
Registriert: 24. Sep 2004, 12:39
Wohnort: Bayrischer Wald
Kontaktdaten:

Beitrag von Kurt M » 21. Feb 2005, 23:35

die Beschreibung auf
http://mitglied.lycos.de/markusmaerz/elster.html
ist zwar korrekt aber unnötig mühsam.
Besorge dir die winetools, die machen das gleiche fast automatisch und Elster läuft.

Archilles
Newbie
Newbie
Beiträge: 27
Registriert: 21. Jun 2004, 14:34

Beitrag von Archilles » 22. Feb 2005, 09:24

Danke,

für den Hinweis. Auf dieses Website bin ich auch schon gestoßen. Hat leider auch nichts geholfen.
Grund:

Es sind einfach zu viele Wine-Versionen im Umlauf. Fakt ist, daß einzig wine-20041019 laut Aussage der Entwickler mit ELSTER läuft und sich vorab dieser Scheiß-IE6 installieren läßt. Was ja für MDAC Grundvoraussetzung ist.

Fakt, ELSTER läuft jetzt. Ich schreibe hierzu noch eine Doku und setze sie bei mir auf die Websites.

MfG

Archilles

tom-lawyer
Newbie
Newbie
Beiträge: 4
Registriert: 8. Mär 2005, 07:44

Beitrag von tom-lawyer » 8. Mär 2005, 09:13

Hallo,

ich will mal noch was zu dem Thema sagen: Es ist eine absolute Frechheit der Finanzverwaltung, von Gewerbetreibenden die Abgabe der Umsatzsteuervoranmeldungen per Internet erzwingen zu wollen. Ich habe mich unter den Hinweis auf Linux und Inkompatibilität der ELSTER-Software erst mal geweigert und bin bis zum 31.12.2005 befreit.
Außerdem vertrete ich einige Gewerbetreibende, die gar keinen Internetanschluß haben und die nun gezwungen werden sollen, sich einen anzuschaffen. Das ist eine bodenlose Frechheit des Gesetzgebers die nur dazu dient, noch mehr Personal einzusparen. Auf die Risiken (hackbare Ports, keine Sicherheitsvorkehrungen etc. bei der Finanzverwaltung) gehen die gar nicht ein.
Wer wie ich das auch nicht hinnehmen will, kann mir gerne eine PN schreiben, ich setze mich dann in Kontakt!

Benutzeravatar
PC-Ulf
Member
Member
Beiträge: 180
Registriert: 1. Okt 2004, 17:30
Wohnort: Köln
Kontaktdaten:

zu Tax 2005 unter Linux

Beitrag von PC-Ulf » 8. Mär 2005, 12:43

zu Tax 2005: ich habe es mir gekauft. Auf meinem alten Rechner lief es sehr lahm. Jetzt habe ich mir extra einen neuen Rechner angeschafft (allein 2GB Arbeitsspeicher). Tax läuft trotzdem nicht wirklich besser.

Dazu habe ich es bis heute nicht hinbekommen Erklärungen zu versenden.

Ust.-Erklärung Januar 2005 wurde noch aus Buchungen berechnet. Für Februar muß ich die Buchungen per Hand berechnen und einfügen (bei automatisch aus Buchungen berechnen erscheint immer 0,00 Euro). Trotzdem kann ich plötzlich nicht mehr drucken (der Drucker kriegt Daten, kann diese aber nicht verarbeiten). Also wieder per PDF verarbeitet.

Was ich sagen will: TAX ist wirklich sein Geld nicht wert.

Der Support meldet sich trotz mehrfachen Anfragen auch nicht mehr bei mir.

Arnd
Member
Member
Beiträge: 207
Registriert: 27. Aug 2004, 15:12
Wohnort: /home/arnd ( NRW )

Beitrag von Arnd » 9. Mär 2005, 08:01

Hey @ all,

ich habe ein wenig gesucht und mir dann Winetools installiert.

Damit habe ich die Basic settings gemacht und die Systemconfiguration alles in Deutsch installierten lassen über dieses Tool.

Nun wollte ich Elster über Winetools sowie über die CD die ich habe installieren aber leider kommt bei beiden diese Fehlermeldung

Bild

klicke ich auf das ok ist die Insall am Ende.

Habt Ihr ne Idee wie ich das machen kann.

Danke
Arnd
Dies Forum ist das Beste was ich je im Netz gesehen habe ... DANKE ...
PC: AMD 2.5 : Suse 10.2 : KDE 3.5 : Firefox/Thunderbird
Notebook: Dell I6000 : Suse 10.2 KDE 3.5 Firefox/Thunderbird

Antworten

Wer ist online?

Mitglieder in diesem Forum: Bing [Bot] und 3 Gäste