Ltsp 4.1 konfigurieren

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Mikesch
Member
Member
Beiträge: 77
Registriert: 11. Jan 2005, 19:25

Beitrag von Mikesch » 10. Feb 2005, 16:36

So nun es funktioniert danke. Jetzt kommt das beste wenn ich meinen Client das 1. mal starte Meldet er Das mit dem root-path aber wenn ich ihn ausschalte und ihn sofort nochmal versuchen lasse f'hrt er ohne wenn und aber hinauf. An was k;nnte dieser fehler noch liegen am P4 funktioniert es garnicht aber ich bin froh das es wenigstens mal auf einem geht.
Also besten Dank fuer deine Bemuehungen alleine haette ich das nie geschaft.

Werbung:
Mikesch
Member
Member
Beiträge: 77
Registriert: 11. Jan 2005, 19:25

Beitrag von Mikesch » 11. Feb 2005, 10:26

Juhu der 2. Client geht jetzt auch ich habe eine andere Karte rein gebaut und jetzt geht er auch ich denke da stimt am Bootrom was nicht.

Sveniboy1984
Newbie
Newbie
Beiträge: 37
Registriert: 8. Aug 2005, 14:12
Wohnort: Schleswig
Kontaktdaten:

Beitrag von Sveniboy1984 » 17. Aug 2005, 15:30

Hey, ich hab das selbe Problem:

TFTP.
PXE-T01: File not found
PXE-E3B: TFTP Error-File not found
PXE-M0F: Exiting PXEROM

Hier meine dhcpd.conf:

default-lease-time 604800;
max-lease-time 691200;

option subnet-mask 255.255.255.0;
option broadcast-address 192.168.84.255;
option domain-name "ltsp";
option domain-name-servers 192.168.1.254;
option routers 192.168.84.1;
ddns-update-style none;

subnet 192.168.84.0 netmask 255.255.255.0 {
range 192.168.84.10 192.168.84.20;
default-lease-time 604800;
max-lease-time 691200;
option root-path "192.168.84.1:/opt/ltsp/i386";

if substring (option vendor-class-identifier,0,9)="PXEClient"
{
filename "192.168.84.1:/tftpboot/lts/2.4.26-ltsp-3/pxelinux.0";
}
else
{
filename "192.168.84.1:/tftpboot/lts/vmlinuz-2.4.26-ltsp-3";
}

}

mechanicus
Hacker
Hacker
Beiträge: 299
Registriert: 14. Jan 2005, 22:26

Beitrag von mechanicus » 19. Aug 2005, 21:33

Sveniboy1984 hat geschrieben:Hey, ich hab das selbe Problem:

TFTP.
PXE-T01: File not found
PXE-E3B: TFTP Error-File not found
PXE-M0F: Exiting PXEROM
(...)
if substring (option vendor-class-identifier,0,9)="PXEClient"
{
filename "192.168.84.1:/tftpboot/lts/2.4.26-ltsp-3/pxelinux.0";
}
else
{
filename "192.168.84.1:/tftpboot/lts/vmlinuz-2.4.26-ltsp-3";
}
Kann er ja auch nicht finden, weil das angegebene Verzeichnis nicht da ist. Der Dateiname muß relativ zu /tftpboot angegeben werden!

D.h. z.B.

Code: Alles auswählen

filename "192.168.84.1:/lts/2.4.26-ltsp-3/pxelinux.0";
da er sonst die Datei im Verzeichnis /tftpboot/tftpboot/lts/2.4.26-ltsp-3/ sucht.

M.f.G. Anton

Sveniboy1984
Newbie
Newbie
Beiträge: 37
Registriert: 8. Aug 2005, 14:12
Wohnort: Schleswig
Kontaktdaten:

Beitrag von Sveniboy1984 » 22. Aug 2005, 09:12

Hallo Anton,

erstmal danke für deine vorrige Hilfe.

Hier mein geändertes dhcpd.conf:

default-lease-time 604800;
max-lease-time 691200;

option subnet-mask 255.255.255.0;
option broadcast-address 192.168.84.255;
option domain-name "ltsp";
option domain-name-servers 192.168.1.254;
option routers 192.168.84.1;
ddns-update-style none;

subnet 192.168.84.0 netmask 255.255.255.0 {
range 192.168.84.10 192.168.84.20;
default-lease-time 604800;
max-lease-time 691200;
option root-path "192.168.84.1:/opt/ltsp/i386";

if substring (option vendor-class-identifier,0,9)="PXEClient"
{
filename "192.168.84.1:/lts/2.6.9-ltsp-3/pxelinux.0";
}
else
{

Muss ich bei option root-path auch die Ip mit angeben?

Mein Tftp Server hat ein s flag, heißt das nicht das ich den /tftpboot order in filename mitangeben muss?

Mein Subnet ist 192.168.84.0.
Mein Dhcp Server ist 192.168.84.1.
Was genau heißt das Subnet denn da?

mechanicus
Hacker
Hacker
Beiträge: 299
Registriert: 14. Jan 2005, 22:26

Beitrag von mechanicus » 22. Aug 2005, 09:39

Sveniboy1984 hat geschrieben:Mein Tftp Server hat ein s flag, heißt das nicht das ich den /tftpboot order in filename mitangeben muss?
Nein, der Eintrag lautet

Code: Alles auswählen

	server_args		= -s /tftpboot
tftp ist ein relativ unsicheres Protokoll. Ohne diesen Eintrag wäre ein Angreifer sofort im root-Verzeichnis.
Sveniboy1984 hat geschrieben:Was genau heißt das Subnet denn da?
Nur in dem deklarierten Subnetz gelten die dafür aufgestellten Regeln.

M.f.G. Anton

Sveniboy1984
Newbie
Newbie
Beiträge: 37
Registriert: 8. Aug 2005, 14:12
Wohnort: Schleswig
Kontaktdaten:

Beitrag von Sveniboy1984 » 22. Aug 2005, 09:44

Ja, ok...

Aber ich weiß nicht was ich machen soll...

Er findet die Files beim booten nicht.
Hab schon so oft die dhcpd.conf geändert...

Meine pxelinux.0 ist auch leer :(
Weiß nicht mit welchen Programm ich die öffne...

mechanicus
Hacker
Hacker
Beiträge: 299
Registriert: 14. Jan 2005, 22:26

Beitrag von mechanicus » 22. Aug 2005, 10:27

Sveniboy1984 hat geschrieben:Er findet die Files beim booten nicht.
Meine pxelinux.0 ist auch leer :(
Weiß nicht mit welchen Programm ich die öffne...
Die brauchst Du nicht zu öffnen, die ist binär.
Wenn die Datei leer ist, dann ist nicht richtig installiert worden.

M.f.G. Anton

Sveniboy1984
Newbie
Newbie
Beiträge: 37
Registriert: 8. Aug 2005, 14:12
Wohnort: Schleswig
Kontaktdaten:

Beitrag von Sveniboy1984 » 22. Aug 2005, 10:53

Ich weiß ja nicht ob sie leer ist :(
Kann sie ja nicht öffnen...

Was is überhaupt in /pxelinux.cfg/default ?
Da stehen Daten drinne...

mechanicus
Hacker
Hacker
Beiträge: 299
Registriert: 14. Jan 2005, 22:26

Beitrag von mechanicus » 22. Aug 2005, 13:56

Sveniboy1984 hat geschrieben:Ich weiß ja nicht ob sie leer ist :(
Kann sie ja nicht öffnen...
Brauchst Du auch nicht. Bootet denn nun der Client über pxe oder etherboot?

M.f.G. Anton

Sveniboy1984
Newbie
Newbie
Beiträge: 37
Registriert: 8. Aug 2005, 14:12
Wohnort: Schleswig
Kontaktdaten:

Beitrag von Sveniboy1984 » 22. Aug 2005, 14:50

PXE!
Ist eine D-Link Karte.

mechanicus
Hacker
Hacker
Beiträge: 299
Registriert: 14. Jan 2005, 22:26

Beitrag von mechanicus » 22. Aug 2005, 15:12

Sveniboy1984 hat geschrieben:PXE!
Ist eine D-Link Karte.
Dann konntrolliere nochmal genau und peniebel den Pfad zur Datei. Am 17.8. lag er in 2.4.26-ltsp-3, am 22.8. in 2.6.9-ltsp-3??? Was ist denn nun installiert?

M.f.G. Anton

Sveniboy1984
Newbie
Newbie
Beiträge: 37
Registriert: 8. Aug 2005, 14:12
Wohnort: Schleswig
Kontaktdaten:

Beitrag von Sveniboy1984 » 22. Aug 2005, 15:39

Hab beide installiert :)

Dachte ich nimm 2.6.9 weil das ja der neuste Kernel sein muss

Es wird irgendwo ein kleiner Fehler sein.

Oder muss ich nich irgendwelche Dienste für die Tftp Übertragung starten?

mechanicus
Hacker
Hacker
Beiträge: 299
Registriert: 14. Jan 2005, 22:26

Beitrag von mechanicus » 22. Aug 2005, 16:21

192.168.84.1 ist die Adresse des Terminalservers? Dann nimm doch mal die Adresse raus und schreib

Code: Alles auswählen

filename "/lts/2.6.9-ltsp-3/pxelinux.0";
Ich erwähnte schon, daß die fileangaben relativ zu /tftpboot sein müssen. In Deiner Schreibweise sucht er unter /tftpboot/192.168.84.1:/ ...

M.f.G. Anton

Sveniboy1984
Newbie
Newbie
Beiträge: 37
Registriert: 8. Aug 2005, 14:12
Wohnort: Schleswig
Kontaktdaten:

Beitrag von Sveniboy1984 » 23. Aug 2005, 08:49

Ja, 192.168.84.1 ist der Terminal und Dhcp Server!

Das Script hab ich shcon oft genung geändert, aber ich komm auf keine Lösung :x

So hab meine Config mal wieder geändert:

default-lease-time 604800;
max-lease-time 691200;

option subnet-mask 255.255.255.0;
option broadcast-address 192.168.84.255;
option domain-name "ltsp";
option domain-name-servers 192.168.1.254;
option routers 192.168.84.1;
ddns-update-style none;

subnet 192.168.84.0 netmask 255.255.255.0 {
range dynamic-bootp 192.168.84.10 192.168.84.20;
default-lease-time 604800;
max-lease-time 691200;
option root-path "/opt/ltsp/i386";
filename "/lts/2.6.9-ltsp-3/pxelinux.0";
}

Nur wo gebe ich an der Terminalserver 192.168.84.1 ist?

Ich les oft vom den Kernel in einer bzimage datei.
Muss ich diese DAtei noch irgendwie entpacken oder lass ich die Datei so, wie sie an Anfang entpackt wurde?

Egal was ich mache, er findet das drecksding nicht :(
Ob ich bei filename /tftboot oder die Ip vorher schreibe, er findet es nicht...
So langsam glaub ich das der Fehler woanders liegen muss.

Kann man nicht irgendwo unter /Var die Fehler nachlesen?

mechanicus
Hacker
Hacker
Beiträge: 299
Registriert: 14. Jan 2005, 22:26

Beitrag von mechanicus » 23. Aug 2005, 10:19

Sveniboy1984 hat geschrieben:Nur wo gebe ich an der Terminalserver 192.168.84.1 ist?
In der /opt/ltsp/i386/etc/lts.conf:

Code: Alles auswählen

[Default]
        SERVER			= 192.168.84.1
Ist das oben Deine komplette dhcpd.conf oder nur ein Auszug?

M.f.G. Anton

Sveniboy1984
Newbie
Newbie
Beiträge: 37
Registriert: 8. Aug 2005, 14:12
Wohnort: Schleswig
Kontaktdaten:

Beitrag von Sveniboy1984 » 23. Aug 2005, 10:22

Gut in der lts.conf steht der Server schon von Anfang an drinne!

Ich les oft vom den Kernel in einer bzimage datei.
Muss ich diese DAtei noch irgendwie entpacken oder lass ich die Datei so, wie sie an Anfang entpackt wurde?

Auf welche Datei muss ich im Filename verweisen?
Dreh hier bald druch....

Ist bestimmt ein kleiner Fehler der alles versaut.

Meine komplette Dhcpd.conf:

default-lease-time 604800;
max-lease-time 691200;

option subnet-mask 255.255.255.0;
option broadcast-address 192.168.84.255;
option domain-name "ltsp";
option domain-name-servers 192.168.1.254;
option routers 192.168.84.1;
ddns-update-style none;
option root-path "/opt/ltsp/i386";

subnet 192.168.84.0 netmask 255.255.255.0 {
range dynamic-bootp 192.168.84.10 192.168.84.20;
default-lease-time 604800;
max-lease-time 691200;
filename "/tftpboot/lts/2.6.9-ltsp-3/pxelinux.0";
}

Das /tftpboot muss ich doch mit reinnehmen (les ich immer), da meine tftp server ein s flag hat.

Anton hast du Icq oder so?
Das wäre effiktiver zu bereden.

mechanicus
Hacker
Hacker
Beiträge: 299
Registriert: 14. Jan 2005, 22:26

Beitrag von mechanicus » 23. Aug 2005, 11:18

Sveniboy1984 hat geschrieben:Das /tftpboot muss ich doch mit reinnehmen (les ich immer), da meine tftp server ein s flag hat.
Also weißt Du...?
Ich habe Dir das weiter oben bereits gesagt und erläutert, wenn Du es nicht machen möchtest, ist das Dein Problem. Aber dann nerve bitte nicht rum, daß das file nicht gefunden wird.

Nur mal so als Hinweis: Unter http://www.gentoo.org/doc/de/ltsp.xml kannst Du klipp und klar folgendes nachlesen:
Das -s Flag gibt an, dass TFTP in einem sicheren chroot Modus (empfohlen) ausgeführt wird. Dies bedeutet, dass Sie den /tftpboot Pfad, z.B. in der DHCP Konfiguration, nicht mit einbeziehen müssen.
Anton

Sveniboy1984
Newbie
Newbie
Beiträge: 37
Registriert: 8. Aug 2005, 14:12
Wohnort: Schleswig
Kontaktdaten:

Beitrag von Sveniboy1984 » 23. Aug 2005, 11:21

Also weißt Du...?
Ich habe Dir das weiter oben bereits gesagt und erläutert, wenn Du es nicht machen möchtest, ist das Dein Problem. Aber dann nerve bitte nicht rum, daß das file nicht gefunden wird.
Ja, ok dann nimm ich das raus

Ändert aber leider nicht viel am jetzigen Problem.

Ich hab gerade den dhcp Server mit dhcpd restart neugestartet.

Er meldet den: Not configured to listen on any interfaces!

Obwohl in der /etc/sysconfig/dhcpd unter DHCPD_INTERFACES="eth0" eingetragen ist.
Wenn ich es auf beispielsweise "eth1" ädner, dann meckert er immer noch rumm das er nichts findet..

Sveniboy1984
Newbie
Newbie
Beiträge: 37
Registriert: 8. Aug 2005, 14:12
Wohnort: Schleswig
Kontaktdaten:

Beitrag von Sveniboy1984 » 23. Aug 2005, 13:21

Yuhuhu, es geht.

Es zieht sich jetzt die Daten vom Server :)

Fragt mich nicht, wieso aber es geht.

Naja, ich schätze mal das hing mit der 2. Netzwerkkarte irgendwie zusammen. Die hab ich deaktiviert und den Pc neugestartet und dann ging es.

Weil als ich dhcpd -d -f gemacht habe, mecktere er rum das eth1 (die 2. netzwerkkarte) kein netz hat. Naja, da die Karte aber mit den Konzept nichts zu tun hatte, hab ich die gekickt...

Mal gucken wann der nächste Fehler kommt ;)

ER lädt den Desktop!
Wunderbar, es läuft!


VIELEN DANK AN ALLE

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast