Ltsp 4.1 konfigurieren

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Mikesch
Member
Member
Beiträge: 77
Registriert: 11. Jan 2005, 19:25

Ltsp 4.1 konfigurieren

Beitrag von Mikesch » 14. Jan 2005, 14:41

Hallo,
ich habe Ltsp 4.1 über die .iso Datei installiert und dann über die Grafischeöberfläche konfiguriet allerdings wollen alle meine Rechner nicht mit machen sie finden keinen DHCP Obwohl der Konfiguriert ist. Was kann ich tun?
Danke

Werbung:
mechanicus
Hacker
Hacker
Beiträge: 299
Registriert: 14. Jan 2005, 22:26

Re: Ltsp 4.1 konfigurieren

Beitrag von mechanicus » 14. Jan 2005, 22:32

Mikesch hat geschrieben:... allerdings wollen alle meine Rechner nicht mit machen sie finden keinen DHCP Obwohl der Konfiguriert ist.
Welches Betriebsystem? Läuft der dhcp-Server? Was ist auf dem Bildschirm zuletzt zu sehen?

Mikesch
Member
Member
Beiträge: 77
Registriert: 11. Jan 2005, 19:25

Beitrag von Mikesch » 7. Feb 2005, 11:08

Es läuft Suse 9.2 der Dhcp funzt jetzt. Nur meldet der Client er findet keine Dateien um zu booten, darum meine Frage was muss in den ordner tftpboot, dass der Client etwas findet?

mechanicus
Hacker
Hacker
Beiträge: 299
Registriert: 14. Jan 2005, 22:26

Beitrag von mechanicus » 7. Feb 2005, 12:29

Mikesch hat geschrieben:was muss in den ordner tftpboot, dass der Client etwas findet?
Das sollte das Installationsscript erledigen. Ist Dein Ordner denn leer?
Bootest Du mit Etherboot oder mit PXE?

Anton

Mikesch
Member
Member
Beiträge: 77
Registriert: 11. Jan 2005, 19:25

Beitrag von Mikesch » 7. Feb 2005, 13:55

Ich boote mit PXE und der Ordner tftpboot ist leer.

mechanicus
Hacker
Hacker
Beiträge: 299
Registriert: 14. Jan 2005, 22:26

Beitrag von mechanicus » 7. Feb 2005, 15:52

Mikesch hat geschrieben: ... und der Ordner tftpboot ist leer.
Da haben wir doch die Ursache. Irgend etwas ist da bei der Installation schiefgelaufen.
Hier müßte ein Verzeichnis lts drin sein, welches den Kernel beinhaltet sowie ein Verzeichnis für PXE-Boot.
Laß doch bitte nochmal ltspcfg durchlaufen, insbesondere Punkt 4.

Anton

Mikesch
Member
Member
Beiträge: 77
Registriert: 11. Jan 2005, 19:25

Beitrag von Mikesch » 7. Feb 2005, 16:55

Ich habe es jetzt nochmals laufen lassen allerdings gibt es den ordner noch immer nicht. Noch was was muss ich mit dem NFS Server machen. Aber zuerst muss ich mal den TFTP hin bekommen

Mikesch
Member
Member
Beiträge: 77
Registriert: 11. Jan 2005, 19:25

Beitrag von Mikesch » 7. Feb 2005, 17:24

Könnte man diese Dateien eventuell per hand zur verfügung stellen? Außerdem habe ich alles nochmals neu installiert hat aber nichts gebracht.

mechanicus
Hacker
Hacker
Beiträge: 299
Registriert: 14. Jan 2005, 22:26

Beitrag von mechanicus » 7. Feb 2005, 17:25

Mikesch hat geschrieben:Ich habe es jetzt nochmals laufen lassen allerdings gibt es den ordner noch immer nicht. Noch was was muss ich mit dem NFS Server machen. Aber zuerst muss ich mal den TFTP hin bekommen
Ich vermute, daß da irgend was in der ISO-Datei nicht i.O. ist. Kannst Du nochmal normal installieren?
ltsp-utils installieren und dann ltspadmin ausführen, benötigte Pakete werden nun runtergeladen.
Schau auch mal in die Doku unter http://www.ltsp.org/documentation/index.php an.

Anton

Mikesch
Member
Member
Beiträge: 77
Registriert: 11. Jan 2005, 19:25

Beitrag von Mikesch » 7. Feb 2005, 17:47

Es funktioniert einfach nicht. Alles nochmals neu gemacht. Er schreibt nichts in den Ordner.

mechanicus
Hacker
Hacker
Beiträge: 299
Registriert: 14. Jan 2005, 22:26

Beitrag von mechanicus » 7. Feb 2005, 19:06

Mikesch hat geschrieben:Es funktioniert einfach nicht. Alles nochmals neu gemacht. Er schreibt nichts in den Ordner.
Hast Du übers Internet mit ltspadmin installiert? Ist der Ordner vielleicht schreibgeschützt? Überprüfe mal die Rechte.

Anton

Mikesch
Member
Member
Beiträge: 77
Registriert: 11. Jan 2005, 19:25

Beitrag von Mikesch » 8. Feb 2005, 14:19

Ich habe einfach die Iso die ich heruntergeladen habe nochmals neu geladen.

Mikesch
Member
Member
Beiträge: 77
Registriert: 11. Jan 2005, 19:25

Beitrag von Mikesch » 8. Feb 2005, 14:20

Noch was wie installiere ich das ganze vom Internet aus?

mechanicus
Hacker
Hacker
Beiträge: 299
Registriert: 14. Jan 2005, 22:26

Beitrag von mechanicus » 8. Feb 2005, 15:01

Mikesch hat geschrieben:Noch was wie installiere ich das ganze vom Internet aus?
Schau Dir bitte mal die Doku an, da steht es drin.

http://www.ltsp.org/documentation/ltsp- ... tml#AEN309

Anton

Mikesch
Member
Member
Beiträge: 77
Registriert: 11. Jan 2005, 19:25

Beitrag von Mikesch » 8. Feb 2005, 17:50

Wenn ich vom Internet installiere lädt er mir die Dateien herunter allerdings wenn ich wieder ltspadmin gehe sind die Dateien wieder nicht vorhanden.

Mikesch
Member
Member
Beiträge: 77
Registriert: 11. Jan 2005, 19:25

Beitrag von Mikesch » 8. Feb 2005, 18:29

Also jetzt habe ich es alles installiert und jetzt habe ich im Ordner tftpboot auch diese Dateien, aber mein Client den ich mit PXE boote meint er findet dort keine Dateien. Was kann ich nun tun

mechanicus
Hacker
Hacker
Beiträge: 299
Registriert: 14. Jan 2005, 22:26

Beitrag von mechanicus » 8. Feb 2005, 18:32

Mikesch hat geschrieben:... allerdings wenn ich wieder ltspadmin gehe sind die Dateien wieder nicht vorhanden.
Wer sagt Dir das, meckert ltspadmin? Wie lautet die Fehlermeldung?

Anton

mechanicus
Hacker
Hacker
Beiträge: 299
Registriert: 14. Jan 2005, 22:26

Beitrag von mechanicus » 8. Feb 2005, 18:34

Mikesch hat geschrieben:... aber mein Client den ich mit PXE boote meint er findet dort keine Dateien. Was kann ich nun tun
Welchen filename hast Du in der dhcpd.conf angegeben (bitte die komplette Zeile nennen)?

Anton

Mikesch
Member
Member
Beiträge: 77
Registriert: 11. Jan 2005, 19:25

Beitrag von Mikesch » 8. Feb 2005, 18:53

Dies ist meine Dhcp.conf:
option domain-name "WORKGROUP";
option domain-name-servers 192.168.69.6;
option routers 192.168.69.254;
option ntp-servers 192.168.69.6;
option lpr-servers 192.168.69.6;
ddns-update-style none;
default-lease-time 14400;
subnet 192.168.69.0 netmask 255.255.255.0 {
range 192.168.69.1 192.168.69.100;
default-lease-time 14400;
max-lease-time 172800;
}
if substring (option vendor-class-identifier,0,9)="PXEClient"
{
filename "/lts/2.4.24-ltsp-1/pxelinux.0";
}
else
{
filename "/lts/vmlinuz-2.4.24-ltsp-1";
}

mechanicus
Hacker
Hacker
Beiträge: 299
Registriert: 14. Jan 2005, 22:26

Beitrag von mechanicus » 8. Feb 2005, 19:15

Mikesch hat geschrieben:subnet 192.168.69.0 netmask 255.255.255.0 {
range 192.168.69.1 192.168.69.100;
default-lease-time 14400;
max-lease-time 172800;
}
Diese letzte Klammer bitte hier löschen ganz zum Schluß setzen, dann sollte es klappen.

Anton

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 4 Gäste