Faxversand: sendq wird nicht geleert

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Antworten
nojetlag
Newbie
Newbie
Beiträge: 2
Registriert: 15. Nov 2004, 23:39

Faxversand: sendq wird nicht geleert

Beitrag von nojetlag » 29. Dez 2004, 18:07

Hallo zusammen,

ich habe hylafax auf Suse 9.2 installiert und bis auf den faxversand scheint alles zu laufen
- KISDNwatch zeigt zwei freie leitungen, pppd isdn/avm baut eine verbindung auf
- ich kann faxe von außerhalb empfangen
- sendfax -d 12345678 /etc/groups erzeugt eine Postscript Datei und legt sie in /var/spool/fax/docq ordner hinein und erzeugt in ../sendq den entsprechenden queue eintrag. dieser bleibt aber bis zum st. nimmerleinstag dort drinnen stehen und wird nie abgearbeitet

meine /var/spool/fax/etc/config:
LogFacility: hylafax
CountryCode: 49
AreaCode: 89
LongDistancePrefix: 0
InternationalPrefix: 00
DialStringRules: "etc/dialrules"
ServerTracing: 527
SessionTracing: 527
ContCoverPage: etc/cover.tmpl
MaxSendPages: 30
# SendFaxCmd: /var/spool/fax/bin/faxsend
SendFaxCmd: /usr/bin/c2faxsend

meine /var/spool/fax/etc/config.c2fax:
LogFacility: hylafax
CountryCode: 49
AreaCode: 89
LongDistancePrefix: 0
InternationalPrefix: 00
DialStringRules: "etc/dialrules"
ServerTracing: 527
SessionTracing: 527
ContCoverPage: etc/cover.tmpl
MaxSendPages: 30
# SendFaxCmd: /var/spool/fax/bin/faxsend
SendFaxCmd: /usr/bin/c2faxsend


ps -aux | grep fax ergibt folgendes
fax 5060 0.0 0.7 4204 1684 ? Ss 17:24 0:00 /usr/sbin/faxq
fax 5063 0.0 0.6 3932 1408 ? Ss 17:24 0:00 /usr/lib/fax/hfaxd -i hylafax -o 4557 -s 444
fax 5171 0.0 0.6 20052 1352 ? Ssl 17:24 0:00 /usr/bin/c2faxrecv -q /var/spool/fax
root 5643 0.0 0.2 1732 636 pts/1 S+ 17:45 0:00 grep fax

vielleicht denke ich nur falsch, aber sollte da nicht ein c2faxsend laufen? oder wird das durch den faxq angestoßen, wenn es etwas zu versenden gibt? (nur interessehalber!)

das /tmp/capilog zeigt mir folgendes:
Dec 29 18:08:51.36: [ 5881]: CapiFaxSend - INFO: SESSION BEGIN 00000003 (null)
Dec 29 18:08:51.36: [ 5881]: CapiFaxSend - INFO: SEND FAX: JOB 3 DEST 069131214565 COMMID 00000023
Dec 29 18:08:51.36: [ 5881]: CapiFaxSend - INFO: Try to connect to fax number 069131214565 in Hylafax mode on controller 1.
Dec 29 18:08:51.36: [ 5881]: CapiFaxSend - INFO: Dial and starting transfer of TIFF-File docq/doc3.ps;30 with normal resolution.
Dec 29 18:08:51.36: [ 5881]: CapiFaxSend - INFO: Connection dropped with Reason 0x1009 (CAPI not installed).

was genau ist an CAPI nicht richtig installiert?

wäre schön, wenn mir jemand weiterhelfen könnte, ich habe nach ein paar stunden suchen und lesen hier im forum und auf hylafax.org mittlerweile ne echte denkblockade.

danke

stefan

Werbung:
nojetlag
Newbie
Newbie
Beiträge: 2
Registriert: 15. Nov 2004, 23:39

Beitrag von nojetlag » 31. Dez 2004, 00:18

eine fehlerursache scheint in den fehlenden berechtigungen für die /dev/capi20 zu liegen. ich habe diese gestern abend noch im brute force verfahren einfach auf rwx für alle gesetzt, inkl sticky bit - ganz frei nach dem motto: viel hilft viel - und siehe da, mit einem mal funktionierte es.

ABER: heute boote ich den rechner neu, und zwei effekte treten ein

1) die berechtigungen von /dev/capi20 sind wieder auf den ursprungszustand zurückgesetzt. kann mir das mal jemand erklären? (zugegeben, ich bin kein unix profi)

2) das program c2faxrecv startet nicht mehr. es ist in der inittab einwandfrei eingetragen (genau wie in der mini how to beschrieben), aber in /var/log/messages steht nach dem booten:

Code: Alles auswählen

 server init: ID "fr" respawning too fast: disabled for 5 minutes.

wenn ich ich die capifax.log reinschaue steht da

Code: Alles auswählen

c2faxrecvd - INFO:
no device is waiting for faxes so the program can terminate for now 
und das ganze gleich 5x hintereinander. wenn ich die timing angabe richtig verstehe im abstand von jeweils einer hundertstelsekunde, aber die einträge in der capifax.log werden auf alle fälle in derselben sekunde angelegt wie der eintrag in /var/log/messages. ich habe daher keine ahnung welcher eintrag zuerst erfolgt, aber ich vermute der in der capifax.log.
da dort ein fünfmaliges scheitern eingetragen wird, schätze ich, daß der init prozeß sagt, daß das ein fehlerhaftes program ist, und es deswegen auf disabled setzt - wie gesagt, ich kenne mich mit UNIX nicht so aus, ich versuchs halt mit denken und googlen ;-)

Ich bin für jede Hilfe dankbar. Wie mache ich dem c2faxrecv klar, welches device waiting for faxes ist, so daß er wieder läuft und wie setzte ich dauerhaft die permissions in der /dev/capi20?

danke

stefan

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 2 Gäste