Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

kompatibilitätsprobleme beim compilieren

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Antworten
hjoerg
Newbie
Newbie
Beiträge: 1
Registriert: 13. Jul 2004, 14:37

kompatibilitätsprobleme beim compilieren

Beitrag von hjoerg » 29. Dez 2004, 10:37

ich weiß nicht ob ich hier richtig bin, aber es ist meine letzte chance !

Ich habe mir die sources von isdn2sip von www.datacore.ch runtergeladen und wollte sie in mein system integrieren (suse 9.0).

./configure...und anschließendes make gab folgenede warnung.

depmode=gcc3 /bin/sh ../depcomp \
g++ -DHAVE_CONFIG_H -I. -I. -I.. -I../include/vovida/ -I../include/vovida/util/ -I../include/vovida/util/deprecated/ -I../include/vovida/util/io/ -I../include/vovida/util/logging/ -I../include/vovida/util/snmp/ -I../include/vovida/util/threads/ -I../include/vovida/util/transport/ -I../include/vovida/sipstack/ -I../include/vovida/sdp/ -I../include/vovida/rtp/ -I../include/vovida/rtp/codec/ -I../include/ -D_GNU_SOURCE -DVOCAL_USE_DEPRECATED -D_REENTRANT -DUSE_PTHREADS -DPERF_DEBUG -DVOCAL_USING_PENTIUM -Wall -O1 -g -c -o Log.o `test -f Log.cpp || echo './'`Log.cpp
Log.cpp:8:24: strstream.h: Datei oder Verzeichnis nicht gefunden
In file included from /usr/include/g++/backward/fstream.h:31,
from Log.h:17,
from Log.cpp:13:
/usr/include/g++/backward/backward_warning.h:32:2: Warnung: #warning This file includes at least one deprecated or antiquated header. Please consider using one of the 32 headers found in section 17.4.1.2 of the C++ standard. Examples include substituting the <X> header for the <X.h> header for C++ includes, or <sstream> instead of the deprecated header <strstream.h>. To disable this warning use -Wno-deprecated.
make[2]: *** [Log.o] Fehler 1
make[2]: Leaving directory `/tmp/isdn2sip-0.9.1/src'
make[1]: *** [all-recursive] Fehler 1
make[1]: Leaving directory `/tmp/isdn2sip-0.9.1'
make: *** [all] Fehler 2


aber wie kann ich diese kompatibilität herstellen ?

Werbung:
Antworten